bootet nur in APX modus

  • 127 Antworten
  • Neuester Beitrag
Diskutiere bootet nur in APX modus im Root / Hacking / Modding für HANNspree HANNSpad (SN10T1) im Bereich HANNspree HANNSpad (SN10T1) Forum.
H

Hanns

Neues Mitglied
Also die HannsPad_Restore.rar (müsste die sein die du meinst von MP2005) nochmal runtergeladen u. geflasht.Ohne Erfolg,immernoch APX. Vielleicht sollte ich nochmal kurz erklären wie ich in diese blöde Situation gekommen bin. Also hab mir Flashback 7.2 nach Anleitung geflasht.Hat alles auf Anhieb super funktioniert.Lief auch alles stabil und ohne Probleme.So nun wollte ich das Flashback 8.1 probieren.Ich wollte zuerst ein Backup machen und damit fingen meine Probleme an.Ich war so blöd und hab die falsche Datei ausgeführt.Und damit wäre ich wieder bei HannsPad_Restore.rar.Die habe ich,so glaub ich geflasht.Und nun bin ich im APX. Vielleicht hat ja jetzt noch einer ne Idee. @mikaole :Danke für dein Angebot, vielleicht komm ich darauf noch zurück .
 
G

gurkensalat

Ambitioniertes Mitglied
Also ich muß mich jetzt hier auch mal einklinken :tongue: Lade doch mal bitte das folgende Archiv: Multiupload.com - upload your files to multiple file hosting sites! runter und entpack es. Stöpsel dein Pad an den Rechner an, schalt es ein und führe die PartTabBack.bat aus. Dann wird im gleichen Ordner eine aktuell.cfg erstellt. Diese Datei bitte hochladen, denn dann kann ich mir die aktuelle Partitionstabelle ansehen. Ich denke das hier das Problem irgendwo liegt. Anscheinend kann man nicht einfach so ein Backup zurückspielen, das Backup muß wohl auch die gleiche Partitionstabelle haben. Man kann wohl nicht mal ein Backup ohne die richtige Partitionstabelle machen aber das weiß ich jetzt noch nicht sicher! Ich habe auch schon gesehen das es einen Befehl gibt mit dem man eine Bootpartition festlegen kann, vieleicht kommen wir irgendwie auf diesem Weg weiter.
 
H

Hanns

Neues Mitglied
Danke schon mal für die Hilfe.:thumbsup: Denke ich werde morgen Zeit haben deinen Vorschlag zu testen und dir die Datei mal hochladen.
 
H

Hanns

Neues Mitglied
gurkensalat schrieb:
Also ich muß mich jetzt hier auch mal einklinken :tongue: Lade doch mal bitte das folgende Archiv: Multiupload.com - upload your files to multiple file hosting sites! runter und entpack es. Stöpsel dein Pad an den Rechner an, schalt es ein und führe die PartTabBack.bat aus. Dann wird im gleichen Ordner eine aktuell.cfg erstellt. Diese Datei bitte hochladen, denn dann kann ich mir die aktuelle Partitionstabelle ansehen. Ich denke das hier das Problem irgendwo liegt. Anscheinend kann man nicht einfach so ein Backup zurückspielen, das Backup muß wohl auch die gleiche Partitionstabelle haben. Man kann wohl nicht mal ein Backup ohne die richtige Partitionstabelle machen aber das weiß ich jetzt noch nicht sicher! Ich habe auch schon gesehen das es einen Befehl gibt mit dem man eine Bootpartition festlegen kann, vieleicht kommen wir irgendwie auf diesem Weg weiter.
So hab die PartTabBack.bat mal ausgeführt.Die aktuell.cfg hab ich hochgeladen:MEGAUPLOAD - The leading online storage and file delivery service
Ich hoffe du kannst damit was anfangen und wir kommen damit irgendwie weiter.
 
G

gurkensalat

Ambitioniertes Mitglied
Also ich habe mir die Partitionstabelle mal angesehen. Das mein Backup und die anderen nicht funktionieren ist kein Wunder. Du hast zwei Partitionen weniger als mein Pad und die meisten anderen. Ich habe hier aber eine Partitionstabelle von einem anderen Pad mit fast der gleichen Partitionstabelle wie deines sie hat. Lediglich die letzte Parttion ist ein paar Sektoren größer. Die gute Nachricht ist, das andere Pad läuft mit dieser Partitonstabelle, die schlechte der Besitzer kann kein Backup von seinem Pad machen da dies fehlschlägt. Ich habe der Tage mit dem Befehl rawdeviceread vom nvflash experimentiert denn der hätte die Lösung sein können aber der funktioniert auf meinem Pad, das wunderbar funktioniert, auch nicht. Ich habe das ganz dumme Gefühl das wir die Situation durch das Rückspielen von falschen Backups nur verschlimmert haben. Mein CWM-Restore hätte niemals funktionieren dürfen, denn bei deiner Konfiguration ist Partition 9 die Recoverypartition, mein CWM-Restore überschrieb aber Partition 11. Warum es dann aber einmal funktioniert hat verstehe ich nicht. Lange Rede kurzer Sinn ich würde jetzt unglaublich gerne zwei Sachen ausprobieren. Die erste Sache ist die Partition 9 mit dem CWM-Restore neubeschreiben. Das sollte mit folgendem Archiv klappen: Multiupload.com - upload your files to multiple file hosting sites! Einfach entpacken und die CWM-Restore.bat ausführen. Mit etwas Glück sollte jetzt der CWM-Modus wieder funktionieren von dort aus könnte man dann auch wieder einen neuen Kernel bzw. ein neues Rom flaschen. Müßte man halt zur Not vorher per USB auf das Pad kopieren. Im CWM das Untermenü "mounts and storage" und dann "mount USB Storage". Falls du das schon kennst, vergiß mein Geschwätz :razz: Falls das nicht funktioniert mal die CWM-Set-Boot.bat ausprobieren. Das ist dann der zweite Anlauf um den CWM-Modus zu reaktivieren. Falls auch das nicht funktioniert kann ich dir auch mal noch ein komplettes Backup zusammenbasteln.
 
Zuletzt bearbeitet:
S

SHORTY-NR1

Erfahrenes Mitglied
gurkensalat schrieb:
Also ich habe mir die Partitionstabelle mal angesehen. Das mein Backup und die anderen nicht funktionieren ist kein Wunder. Du hast zwei Partitionen weniger als mein Pad und die meisten anderen. Ich habe hier aber eine Partitionstabelle von einem anderen Pad mit fast der gleichen Partitionstabelle wie deines sie hat. Lediglich die letzte Parttion ist ein paar Sektoren größer. Die gute Nachricht ist, das andere Pad läuft mit dieser Partitonstabelle, die schlechte der Besitzer kann kein Backup von seinem Pad machen da dies fehlschlägt. Ich habe der Tage mit dem Befehl rawdeviceread vom nvflash experimentiert denn der hätte die Lösung sein können aber der funktioniert auf meinem Pad, das wunderbar funktioniert, auch nicht. Ich habe das ganz dumme Gefühl das wir die Situation durch das Rückspielen von falschen Backups nur verschlimmert haben. Mein CWM-Restore hätte niemals funktionieren dürfen, denn bei deiner Konfiguration ist Partition 9 die Recoverypartition, mein CWM-Restore überschrieb aber Partition 11. Warum es dann aber einmal funktioniert hat verstehe ich nicht. Lange Rede kurzer Sinn ich würde jetzt unglaublich gerne zwei Sachen ausprobieren. Die erste Sache ist die Partition 9 mit dem CWM-Restore neubeschreiben. Das sollte mit folgendem Archiv klappen: Multiupload.com - upload your files to multiple file hosting sites! Einfach entpacken und die CWM-Restore.bat ausführen. Mit etwas Glück sollte jetzt der CWM-Modus wieder funktionieren von dort aus könnte man dann auch wieder einen neuen Kernel bzw. ein neues Rom flaschen. Müßte man halt zur Not vorher per USB auf das Pad kopieren. Im CWM das Untermenü "mounts and storage" und dann "mount USB Storage". Falls du das schon kennst, vergiß mein Geschwätz :razz: Falls das nicht funktioniert mal die CWM-Set-Boot.bat ausprobieren. Das ist dann der zweite Anlauf um den CWM-Modus zu reaktivieren. Falls auch das nicht funktioniert kann ich dir auch mal noch ein komplettes Backup zusammenbasteln.
Ich glaube das mit dem CWM-Restore.bat hat er schon von mir bekommen, und er ist auch nur einmal ins CWM reingekommen, aber konnte kein mount durchführen damit er die update.zip übertragen kann. Dann hat er wieder nur APX-Modus.
Gibt es nicht die Möglichkeit statt CWM, das Original Recovery (das mit der blauen schrift) zu wiederstellen. Dann könnte er von einer microsd karte aus flashen!!!!
 
G

gurkensalat

Ambitioniertes Mitglied
Ja aber das CWM-Restore hat wie gesagt Partition 11 neubeschrieben die neue Version beschreibt aber Partition 9!
 
S

SHORTY-NR1

Erfahrenes Mitglied
gurkensalat schrieb:
Ja aber das CWM-Restore hat wie gesagt Partition 11 neubeschrieben die neue Version beschreibt aber Partition 9!
Ich hab da keine Ahnung, aber kann man die Part 11 oder 9, nicht mit der von einer Original-Recovery ersetzen und mit NVFlash zurückspielen?
 
M

marcero

Erfahrenes Mitglied
Nvflash partitioniert doch zuerst und spielt dann erst die backups drauf. Jedenfalls sollte das so sein, soweit ich weiß.
Die Größen stellt man in der .cfg ein. Ich kann so meine Partitionen vergrößern.
Das ist auch der Grund warum die Größen der .img nicht zwangsweise mit der Größe der Partitionen in der .cfg übereinstimmen muss.
Warum es auf manchen Tabs nicht geht liegt meines Erachtens an was anderem, was ich mir bisher aber nicht erklären kann.
 
H

Hanns

Neues Mitglied
Danke euch erst mal für die Hilfe:thumbup: Werde jetzt mal den Vorschlag von gurkensalat testen und dann berichten.
 
H

Hanns

Neues Mitglied
Hat leider keinen Erfolg gebracht.Nach ausführen der CWM-Restore.bat kommt das Hanns-Logo und dann das TapnTap-Logo.Nach einiger Zeit bleibt dann das Display schwarz.Nach Neustart geht wieder nur APX,egal mit welcher Tastenkombi.Während die Logos angezeigt werden wird das Pad als Wechseldatenträger angezeigt.Ich kann aber nicht drauf zugreifen.Nach Reboot zeigt er mir keinen Wechseldatenträger mehr.
 
G

gurkensalat

Ambitioniertes Mitglied
Nvflash ist es vollkommen egal welches Recovery auf welcher Partition liegt. Nvflash braucht nichts außer dem Pad im APX-Modus und einem Bootloader der in unserem Fall schon mit dabei ist und mit --bl bootloader.bin auf das Pad geladen wird und dann mit --go ausgeführt wird. Ab dann schickt nvflash die Befehle an den Bootloader der jetzt auf dem Pad gestartet ist, sieht man auch schon an der Meldung auf dem Display des Pads. Eigentlich sollte man jetzt alles machen können unter anderem auch neupartitionieren. Aber genau das scheint nicht ordentlich zu funktionieren. Eingentlich müßte Hanns sonst ein Pad mit mehr als 12 Partitionen haben, zumindest das von mir hochgeladene Backup beinhaltet Partition 2-14. Ich glaube das Problem liegt am Bootloader, denn einige Befehle funktionieren einfach nicht richtig. So stürzt --rawdeviceread bei mir auch auf Partitionen ab die mit --read ausgelesen werden können. Ich habe auch schon andere Bootloader ausprobiert aber anstatt einer Fehlermeldung hängt sich nvflash dann einfach nur auf. Ich würde auch zu gerne wissen was mit Partition 1 ist, was da wohl drauf ist?
 
S

SHORTY-NR1

Erfahrenes Mitglied
Hanns schrieb:
Hat leider keinen Erfolg gebracht.Nach ausführen der CWM-Restore.bat kommt das Hanns-Logo und dann das TapnTap-Logo.Nach einiger Zeit bleibt dann das Display schwarz.Nach Neustart geht wieder nur APX,egal mit welcher Tastenkombi.Während die Logos angezeigt werden wird das Pad als Wechseldatenträger angezeigt.Ich kann aber nicht drauf zugreifen.Nach Reboot zeigt er mir keinen Wechseldatenträger mehr.
Ich hatte das schonmal geschrieben. Nach dem CWM-Flash das Pad nicht durchstarten, sonder versuchen gleich ins CWM zu kommen "mit + und Power Taste".
Hast du das schon probiert?
 
H

Hanns

Neues Mitglied
SHORTY-NR1 schrieb:
Ich hatte das schonmal geschrieben. Nach dem CWM-Flash das Pad nicht durchstarten, sonder versuchen gleich ins CWM zu kommen "mit + und Power Taste".
Hast du das schon probiert?
Habs eben nochmal probiert,geht auch nicht.
 
M

mikaole

Gast
das ist ja alles sehr merkwürdig. Also bei mir hat es, als ich nur noch APX hatte, 20 Anläufe mit dem selben Backup gebraucht, bis es endlich geklappt hat. Bin ich ja mal froh. Vielleicht hakt es ja auch an der Kommunikation zwischen PC und Hanns. habe ebn mal versucht ein Backup zu machen und siehe da. 6x bei 10 stehen geblieben und beim 7. mal durchgelaufen.

Hatte ja auch keine Probleme damit die Partitionen zu ändern für FB 7.

Das bringt mich zu der Frage, wie und ob es möglich ist die Partitionen zu vergrößern. Z.B. System auf 500Mb vergrößern.

und meine Partitionen sehen aber mal ganz anders aus
 

Anhänge

  • partition.txt
    1,3 KB Aufrufe: 92
Zuletzt bearbeitet von einem Moderator:
S

sebbo78

Neues Mitglied
hmmmmm....

wer mag mein pad selbst mit eigenen rechner und software probieren ??
(ich sende es zu mit rückschein ....)
sonst liegt das teil die nächsten paar wochen einfach rum :sad: bis ich wieder dazu zeit habe....


ich hatte bereits einiges probiert :
-verschiedene backup's
-verschiedene backup's die an meine partitionstabelle angepasst sind
-verschiedene betriebssysteme (XP, XP SP3, Win7 32bit, win7 64bit, linux)

:crying: will doch "nur" android 3....
 
G

gurkensalat

Ambitioniertes Mitglied
Also ich muss gestehen das es mich reizt diese Herausforderung anzunehmen. Ich muss aber dazu sagen das ich jetzt auch nicht der absolute Held bin und ich mit dem Hannspad eigentlich selbst Androideinsteiger bin!
 
M

mikaole

Gast
biete mich da gerne an, nur mitlerweile glaube ich, dass irgendetwas bei Dir nicht stimmt. Könnte es aber trotzdem gerne versuchen.
 
G

gurkensalat

Ambitioniertes Mitglied
Also gut einen habe ich noch :razz:Bei mir ließ sich bis gerade eben Partition 10 nicht auslesen. Jetzt habe ich mein Backup zurückgespielt und kann Partition 10 auslesen. Ich habe sowohl den Fehlschlag aus auch den Erfolg jeweils sechs mal hintereinander reproduzieren können, zu mehr war ich dann zu faul. Ich habe das CWM-Restore nochmal abgeändert jetzt wird auch noch die Partition davor formatiert! Hier das Archiv: Multiupload.com - upload your files to multiple file hosting sites!

http://www.multiupload.com/W5KEP0HFR3