Proximity Sensor defekt?

manuel-89

manuel-89

Ambitioniertes Mitglied
Threadstarter
Habe gestern telefoniert und der Proximity Sensor funktionierte noch.
Etwa 5min später bei dem nächsten Gespräch jedoch nicht mehr.
Das Handy ist noch nie am Boden geflogen oder sonstiges, und immer in der Htc Tasche versorgt.

Installiert war:
Android Revolution HD 1.9.3, Kernel Buzz OC/UV 1.51Ghz

Backup vom 13.12 durchgeführt (Android Revolution HD 1.9.2, Kernel Buzz OC/UV 1.51Ghz)

Sensor funktioniert noch immer nicht.
Hardreset hat nichts gebracht.
Factory/Data Reset und dann CyanogenMod-6.1 installiert, ebenfalls nichts gebracht.

Jemand eine Idee was ich noch versuchen könnte?
 
Finntroll82

Finntroll82

Experte
Den Stock Kernel einspielen, sehen das der Sensor nicht defekt ist und dann diesen Kernel behalten oder mit dem Fehler leben. Mein Display geht zwar aus beim telefonieren, aber danach nicht mehr an. Muss erst über den Powerbutton entsperren.
 
manuel-89

manuel-89

Ambitioniertes Mitglied
Threadstarter
Hast du vl einen download link zum stock kernel?

Wenn der Sensor nicht mehr funktioniert ist das doch ein Hardware Fehler und das noch während der Garantie?
 
K

Kiray1982

Lexikon
Er hat dir doch ne alternative erläutert.
Der Kernel regelt unter anderem auch den Proximity.
Viele Roms haben nen modifizierten Kernel, wo es dann zu Problemen kommen kann.
Teste den Stock-Kernel wie empfohlen.
Aber nur weil die Software nicht richtig funzt, hat das noch lang nix mit der Hardware zu tun oder jeglichen Anlass gleich nach Garantie zu schreien.
 
manuel-89

manuel-89

Ambitioniertes Mitglied
Threadstarter
Ist nur etwas komisch das er funktionierte und 5min später ohne etwas geändert zu haben auf einmal nicht mehr.

Finde den Stock Kernel nicht zum downloaden -.-
 
AndroidJunkie

AndroidJunkie

Experte
Ich hab ein ähnliches Phänomen... Teste mal folgendes:

- Telefonieren
- Gespräch vom Partner beenden lassen
- Wenn Display aus bleib, halte eine helle Lichtquelle über den Sensor
Anschliessend wird dein Display wieder angehen...

Ich habe derzeit das letzte offizielle WWE Radio + CM 6.1 nightly 14 + Buzz 1.1.4 Kernel (Buzz nutzt einen anderen Treiber für den Prox Sensor (vom HTC Glacier)).
Damit hab ich KEINE Probleme... Sobald ich aber das Orange Radio oder einen anderen Kernel verwende, geht der Sensor wieder nicht...

Teste es einfach mal ;)

EDIT: Ganz vergessen... Manchmal hilft es, wenn Du den Akku für ca 30 sek raus nimmst. Danach normal starten und einen Probeanruf machen. In den meisten Fällen geht es danach wieder (zumindest bei meiner Kombination ;))
 
Zuletzt bearbeitet:
manuel-89

manuel-89

Ambitioniertes Mitglied
Threadstarter
vielen dank finntroll, stock kernel funktioniert der sensor ;-)
bin schon etwas ins schwitzen gekommen^^
 
Jersey Devil

Jersey Devil

Stammgast
Tritt der Fehler nur beim 1,5 Ghz Buzz Kernel auf, oder auch beim 1,22, der ja standardmäßig beim Revolution HD dabei ist?
 
Jersey Devil

Jersey Devil

Stammgast
Das ist unschön.
Also lieber den Standard-Kernel flashen (wenn man sowieso kein OC will) ?

Edit:
Aber nur mit Radio S-OFF (also kein Eng hboot) kann man gar keinen anderen Kernel flashen oder?
 
Zuletzt bearbeitet:
T

Thyrus

Gast
Doch, aber eben nicht über den fastboot Befehl sondern als "update"
 
D

david2580

Erfahrenes Mitglied
@ jersey,

hats du ein gerät mit branding bekommen oder nicht? hab nämlich eins mit o2 branding bekommen, was ich eig nicht so toll finde.
 
Jersey Devil

Jersey Devil

Stammgast
Bin mir noch nicht 100%ig sicher, denke aber, dass es auch ein o2-Branding hat. Durfte es ja noch nicht auspacken, und die Seriennummer kann ich mir auch nicht anschauen.
Aber es klebt ja ein o2-Aufkleber drauf, von daher bin ich mir da ziemlich sicher.
Wenn man es nur mit der Goldcard debranden könnte, würde ich es zurückschicken, aber da das vollkommene debranden ja keine große Sache ist behalte ich es und spar mir den Stress ;)
 
Oben Unten