'< waiting for device >' während des Unlocken via htcdev.com

  • 10 Antworten
  • Neuster Beitrag
K

kleo-patra

Neues Mitglied
Threadstarter
Hallo Leute,
trotz mehrerer Tage Suchen finde ich für mein Problem keine Lösung und habe auch keine Idee mehr, wo ich noch suchen und was ich noch ausprobieren könnte.
Nachdem mir mein HTC Desire HD jahrelang treu gedient hatte, wollte ich jetzt mal eine aktuellere Android-Version aufspielen. Da ich keinen Windows-PC besitze, habe ich auf meinem MacBook mit VirtualBox eine Windows-VM installiert, weil ich irgendwie auch keine gute Beschreibung gefunden habe, wie ich das Handy mit dem Mac entsperre und roote und und und...
Genauso habe ich es auch mit meinem Wildfire S gemacht.
----
Im 1. Step habe ich die Schritte 1 bis 8 auf htcdev.com durchlaufen, hab den Token erstellen können und auch eine E-Mail mit dem Antwort-Token erhalten. Beim Versuch, diesen mit dem Kommando 'fastboot flash unlocktoken Unlock_code.bin' einzuspielen, bekomme ich jetzt auf einmal die Meldung
'< waiting for device >'

und weiter passiert nichts mehr. Das Handy wird im FASTBOOT-USB-Modus einfach nicht mehr gefunden.
Zwischenzeitlich habe ich schon alles Mögliche ausprobiert. Unter anderem auch...

  • VirtualBox-USB-Port-Einstellungen überprüft
  • Treiber de- und wieder installiert
  • Factory reset auf dem Handy ausgeführt
  • Akku rausgezogen und wieder reingesteckt
  • USB-Debugging-Einstellungen überprüft
  • das Wildfire S am gleichen Port mit dem gleichem Kabel im FASTBOOT-USB-Port angesteckt und ein fastboot-Kommando gestartet ('fastboot getvar all')

Auf dem Gerät befindet sich die T-gebrandete Android-Version 2.3.5.

Und hier sind die Informationen auf dem HBOOT-Startbildschirm:
***LOCKED (00W) ***
ACE PVT SHIP S-ON RL
HBOOT-2.00.0029
MICROP-0438
RADIO-26.14.04.28_M
eMMC-boot
Dec 22 2011, 14:28:19

Welche Informationen sind noch notwendig, um das Problem weiter einzugrenzen und - vielleicht auch - zu beseitigen?

Schon jetzt vielen Dank für Tipps und viele Grüße
Sabine
 
P

Phiber2000

Experte
1. Welches Windows läuft in deiner VM?
2. Was zeigt sich im Geräte-Manager deiner VM, wenn das DHD eingesteckt & im Fastboot-Modus ist??
3. Hat es mit deinem Wildfire funktioniert?

Phiber
 
K

kleo-patra

Neues Mitglied
Threadstarter
Hallo Phiber,
vielen Dank für Deine Rückfrage.
1. Ist eine W7-VM
2. Im Gerätemanager sehe ich das der USB-Port an die VM durchgereicht wird (Meintest Du das?)
3. Mit dem Wildfire hat es gut geklappt. Damals beim entsperren und jetzt auch bei Testen.
Hast Du irgendeine Idee, was es sein könnte?

Danke und Grüße
Sabine
 
P

Phiber2000

Experte
Gut - also ein Treiberproblem.
Wenn das DHD eingesteckt, im Fastboot-Modus & der Port durchgereicht ist müsstest du das Gerät im Geräte-Manager sehen - wahrscheinlich sogar als Fehler markiert.
Stelle das zunächst einmal sicher.

Gruß
Phiber
 
K

kleo-patra

Neues Mitglied
Threadstarter
Hi Phiber,
ja, stimmt: Im Windows-Gerätemanager sehe ich, das etwas nicht stimmt. Ersichtlich ist eine Kategorie 'Android USB Devices' mit dem Gerät 'My HTC' welches ein gelbes Ausrufezeichen hat. In den Geräteigenschaften sehe ich den Gerätestatus 'Das Gerät kann nicht gestartet werden. (Code 10)'.
Was bedeutet das? Ist der Port am Handy defekt?
Danke und Grüße
Sabine
 
P

Phiber2000

Experte
Das bedeutet in diesem Fall nur, dass dein USB-Chipsatz nicht zum HBoot des DHD kompatibel ist.
Du muss also auf einen anderen Rechner ausweichen.

Phiber
 
K

kleo-patra

Neues Mitglied
Threadstarter
Hallo Phiber,
leider verstehe ich das mit dem USB-Chipsatz nicht. Kannst Du mir das vielleicht näher erklären?
Kann ich da vielleicht irgendwo etwas einstellen? Habe ich da vielleicht etwas verstellt?
Wenn ich das Desire HD ins Betriebssystem hochfahre, dann wird der Treiber 'My HTC' richtig gestartet. Hat damit wohl nichts zu tun.

--
Jetzt habe ich mir ein altes Fujitsu Siemens Lifebook besorgt und Win7 aufgespielt.
Mit dem Wildfire wird der Treiber im fastboot-Modus und im Betriebssystem-Modus gestartet (ersichtlich im Windows-Geräte-Manager). Mit dem Desire ist im Gerätemanager gar nichts zu sehen. Es kommt auch keine Fehlermeldung.
Im Fastboot-Modus wird nocht nicht einmal angezeigt, das er mit dem USB-Port verbunden ist.
Ist vielleicht doch der Port defekt?

Der ursprüngliche Beitrag von 15:15 Uhr wurde um 16:40 Uhr ergänzt:

Nachtrag:
Ich habe einen alten Compaq-Rechner mit XP aus dem Keller gekramt. Der hat ein Problem mit dem Erkennen von Treibern für USB-Geräte, aber die HTC-Treiber konnte ich doch installieren. Mit dem Wildfire wieder alles prima und mit dem Desire leider nicht.
Im Android-Modus konnte ich die Treiber (per Hand) installieren und bekam auch eine positive Quittung. Wenn ich das Gerät jetzt wieder dranstecke, sehe ich den Gerätemanager neu laden, sehe aber das Gerät nicht. Es erscheint leider keine Fehlermeldung.
Im fastboot-Modus wird auf dem Handy der USB-Port erkannt, allerdings bekomme ich im Windows die Fehlermeldung "Ein an desen Computer angeschlossenes USB-Gerät funktioniert nicht richtig und wird nicht erkannt."
Da ist der Port wohl wirklich defekt. Kann ich das Gerät jetzt wegschmeissen oder gibt es einen anderen Weg?
Grüße
Sabine
Da ist wohl
 
P

Phiber2000

Experte
Wenn das Gerät unter Android über USB korrekt verwendbar ist, dürfte der USB-Port als Fehlerquelle eigentlich auszuschließen sein (Lifebook). Das DHD sollte im Fastboot-Modus unter Win7 mit Sicherheit darauf laufen!
Kontaktiere mich morgen in einer Woche noch einmal, dann würde ich einen kurzen Blick darauf werfen.

Gruß
Phiber
 
K

kleo-patra

Neues Mitglied
Threadstarter
Hallo Phiper,
ich sollte Dich nochmal kontaktieren...
Hast Du eine Idee, was mein Problem sein könnte?
Grüße
Sabine
 
P

Phiber2000

Experte
Du hast PM.

Phiber
 
K

kleo-patra

Neues Mitglied
Threadstarter
Nachdem Phiber2000 jetzt mal drübergeguckt hat, sieht es wohl doch sehr nach einem defekten Port aus (auch ein vorsichtiges Reinigen mit einer Stecknadel hat nicht geholfen).
Weiß jemand, ob man das reparieren kann?
Und - was vielleicht noch interessanter ist - ob sich das lohnt?
Danke und Grüße
Sabine
 
Oben Unten