[Gelöst] Recovery updaten

  • 13 Antworten
  • Neuster Beitrag
Status
Für weitere Antworten geschlossen.
B

bugbug

Gesperrt

Threadstarter
Ich wollte gerade das Recovery von v2.5.0.7 zu v3.0.0.5 aber es kommt nen error

"Error: Failed to get root. Is your firmware too new?

Aber ich habe auch mit den Tipps die ich so fand das ganze nicht beheben können

Ich habe folgendes versucht

- ältere Version von unrevoked (3.22)
- Factory Reset
- deinstallieren von Zysploit
- RUU Froyo installieren



Aber das half alles nix bzw die RUU von Froyo scheitert auch



Kann mir jmd helfen das ich möglichst noch Heute das neue Recovery drauf bekomme??
 
B

bugbug

Gesperrt

Threadstarter
Ok RUU ist nun drauf aich versuch neu zu rooten
 
B

bugbug

Gesperrt

Threadstarter
Neues Problem

Ich habe nun 3.0.0.5 drauf mit meinem Backup von IC 1.1.1.

aber ich bekomm das Radio nicht auf die 32.56.00.32U_5.17.05.23

finding update package…
opening update package…
installing update…
Amend scripting ( update-script ) is no longer supported.
Amend scripting was deprecated by Google in Android 1.5.
It was necassary to remove it when upgrading to the ClockWorkMod 3.0 Gingerbread based recovery.
Please switch to Edify scripting (update-script and update binary ) to create working update.zip packages.
Installation aborted
Was kann ich da machen??
 
Thyrion

Thyrion

Ehrenmitglied
Weißt du eigentlich, was du da tust?
Hast du schonmal ein Script für ein Recovery geschrieben/gelesen+nachvollzogen, was da passiert?

Wieso folgst du nicht einfach der von Schnello verlinkten Anleitung/Lösung des Problems?
 
B

bugbug

Gesperrt

Threadstarter
Thyrion schrieb:
Weißt du eigentlich, was du da tust?
Hast du schonmal ein Script für ein Recovery geschrieben/gelesen+nachvollzogen, was da passiert?

Wieso folgst du nicht einfach der von Schnello verlinkten Anleitung/Lösung des Problems?
Der war der brüller, den fand ich so gut das ich erstmal vom Stuhl fiel :flapper::flapper:

Hast du den Link mal angeklickt von schnello?? Denn dann würdest du sehen das sein verlinktes zu dem was ich geschrieben habe weiterverlinkt !!!

Ich habe mit diesem Tool das .zip "umgewandelt" aber es brachte nichts.

Ach weiste weis ich habe gestern einfach wieder 2.5.0.7 drauf gemacht und das bleibt nun drauf.

Aber bitte einfach vorher mal selbst lesen bevor man Leute dumm anmacht
 
Thyrion

Thyrion

Ehrenmitglied
bugbug schrieb:
Hast du den Link mal angeklickt von schnello??
Ich muss gestehen: Nein - Ich habe ihn mit einem anderen Thread/Beitrag aus dem Forum hier verwechselt - der Link geht aber auch in den falschen Bereich (Desire Z).

Aber hier wärst du fündig geworden.

Ach weiste weis ich habe gestern einfach wieder 2.5.0.7 drauf gemacht und das bleibt nun drauf.
Es ist dein Handy, mach damit, was du möchtest. Aber dann erwarte bitte auch keine Hilfe mehr zu Problemen die evtl. durch das veraltete Recovery verursacht werden.

Aber bitte einfach vorher mal selbst lesen bevor man Leute dumm anmacht
Wo habe ich dich denn dumm angemacht? Und das mit dem "selbst lesen" solltest du dir wohl eher zu Herzen nehmen, als ich - für jedes der bisher hier behandelten Probleme gibt es mehrere Threads inkl. Lösungen.
 
B

bugbug

Gesperrt

Threadstarter
Thyrion schrieb:
Ich muss gestehen: Nein - Ich habe ihn mit einem anderen Thread/Beitrag aus dem Forum hier verwechselt - der Link geht aber auch in den falschen Bereich (Desire Z).
Der Bereich wäre egal wenn der Fehler damit gelöst wäre :rolleyes2:

Thyrion schrieb:
Aber hier wärst du fündig geworden.
Den werde ich mir mal anschauen

Thyrion schrieb:
Es ist dein Handy, mach damit, was du möchtest. Aber dann erwarte bitte auch keine Hilfe mehr zu Problemen die evtl. durch das veraltete Recovery verursacht werden.
Die Frage ist doch eher warum im Rommanager oder unrevoked nicht die 3.x als Standard angeboten wird. Achja da war ja das Problem mit dem Flashen :rolleyes2: Somit scheint die 2.5.x immer noch problemlos zu laufen.

Thyrion schrieb:
Wo habe ich dich denn dumm angemacht
1. Satz, da stellst du mich als Dumm da, aber das ich den Beitrag von schnello gelsen habe und das dort beschriebene vesucht habe konntest du nicht prüfen (da selbst nicht gelesen)

Thyrion schrieb:
Und das mit dem "selbst lesen" solltest du dir wohl eher zu Herzen nehmen, als ich - für jedes der bisher hier behandelten Probleme gibt es mehrere Threads inkl. Lösungen.
Mehrere Threads inkl. Lösungen aber von diesen "Lösungen" haben viele versagt. Am Ende habe ich es ja selbst gelöst, was heißt das ich weitergesucht (gelesen) und getestet habe. :rolleyes2:


OK nun zu dem oben verlinkten
Step by Step

Recovery gehen ---> Apply update from Sdcard ( nicht Flash from SD Card ) --->Yes ---> Install / sdcard / update zip -- CWM spring um auf Grüne schrift ---> Install zip from SD Card ----> Radio auf SD Card wählen und Flashen
Das funktioniert daher, das wenn ich das update im recovery mache temporär die 2.5.0.7 bekomme oder?

Da ja das recovery nur permanent mit unrevoked bei S-ON geändert werden kann.

Sehe ich das richtig?
 
Thyrion

Thyrion

Ehrenmitglied
bugbug schrieb:
Die Frage ist doch eher warum im Rommanager oder unrevoked nicht die 3.x als Standard angeboten wird.
Dass der ROM-Manager nicht perfekt ist (um es mal milde auszudrücken) ist hier auch schon öfter geschrieben worden. Und der sagt dir immer noch, dass die 2.5.0.7 aktuell sei, obwohl es eine 4.x gibt.

Und was unrevoked als Paket mitliefert, liegt einzig an dem Team von Unrevoked. Aber das Tool ist auch schon etwas älter, da war das CWM eben sehr beliebt und aktuell.

Somit scheint die 2.5.x immer noch problemlos zu laufen.
Dann hoffe ich mal, dass du kein PVT4 Desire hast.

1. Satz, da stellst du mich als Dumm da
Nein, die Frage war ernst gemeint.
 
B

bugbug

Gesperrt

Threadstarter
1. habe ich mich zuvor darüber informiert welceh version ich habe PVT1
2. ist 2.5.0.7 immer noch wet verbreitet
3. warum ist das radio rom von HTC welches schon lange nicht mehr das "alte" update script haben sollte imme rnoch so? und wieso kann man ein Recovery nicht ubwärtskompatible machen?
4. ich weis was ich mache und was ich besser lasse

Und ich habe einen Beitrag gelsen der besagt in etwa

"CWM > 3 nur wirklich für CM7 und PVT4 zwingend sei und für A2SD und PVT != 4 CWM 2.5.07 ausreichend sei"
 
Thyrion

Thyrion

Ehrenmitglied
@2: Das ändert doch nichts daran, dass es a) mit dem neueren Gerät nicht mehr 100% funktioniert und es b) mittlerweile weiterentwickelte Recoverys gibt.

@3: HTC hat nie RADIO-Images einzeln ausgeliefert. Und es gibt durchaus Recoverys die sowohl Amend- als auch Edify-Skripte verstehen, wobei Amend seit Android 1.5 oder 1.6 überholt ist und damit (offiziell) auch nicht weiter supported wird.


EDIT: Aber lassen wir das - das führt am Thema vorbei.
 
B

bugbug

Gesperrt

Threadstarter
Thyrion schrieb:
@2: Das ändert doch nichts daran, dass es a) mit dem neueren Gerät nicht mehr 100% funktioniert und es b) mittlerweile weiterentwickelte Recoverys gibt.
zu a): Das ist ja mal wieder eine unnötige Aussage^100. Das Gerät ist nicht neu und wird es auch nie wieder
zu b): nicht alle Neuerungen sind immer gleich besser und wie sagt die Wirtschaft: "Never change a running System"

Thyrion schrieb:
@3: HTC hat nie RADIO-Images einzeln ausgeliefert. Und es gibt durchaus Recoverys die sowohl Amend- als auch Edify-Skripte verstehen, wobei Amend seit Android 1.5 oder 1.6 überholt ist und damit (offiziell) auch nicht weiter supported wird.
und soll ich dir mal was sagen welches so ein Recovery ist .... JA es ist das 2.5.0.7 udn soll ich dir auch sagen welche das nicht mehr sind .... JA aller ab 3.x also hat diese Begründung wieder mal NULL Aussagekraft.
Einzigst das nach Android 1.6 der Support eingestellt wurde wäre nen Grund aber der ist beim Desire auch eingestellt -> Desire direkt in den Müll (laut deiner Aussage)


Zurück zum eigentlichen Thema:
Ich habe nun nach weiteren Regerchen CWM 4.x + 32.56.00.32U_5.17.05.23 + IC 1.1.1. drauf


Also scheine ich ja doch zu wissen was ich mache :flapper::flapper:
 
Thyrion

Thyrion

Ehrenmitglied
bugbug schrieb:
zu a): Das ist ja mal wieder eine unnötige Aussage^100.
Wenn du dies als deinen privaten Thread ansiehst, den sonst keiner lesen wird, dann ja - aber das hat auch sein Gutes: Ich kann den Thread als gelöst nun schließen.

Das Gerät ist nicht neu und wird es auch nie wieder
Ich habe "neuere" geschrieben, nicht "neu" - da du kein PVT4-Gerät hast, betrifft dich das eben nicht, aber tausende andere.

zu b): nicht alle Neuerungen sind immer gleich besser und wie sagt die Wirtschaft: "Never change a running System"
Und prompt verstößt du selbst gegen diese "Regel", s. "Ich habe nun nach weiteren Regerchen CWM 4.x + 32.56.00.32U_5.17.05.23 + IC 1.1.1. drauf" (sic!).

und soll ich dir mal was sagen welches so ein Recovery ist .... JA es ist das 2.5.0.7 udn soll ich dir auch sagen welche das nicht mehr sind .... JA aller ab 3.x also hat diese Begründung wieder mal NULL Aussagekraft.
Diese Aussage ist falsch. Zunächst beziehst du dich nur auf ClockworkMod - es gibt aber noch mindestens 3 weitere Recoverys. Außerdem kann CWM 3.0 und 4.0 sehr wohl mit Amend-Skripten umgehen, nur vielleicht nicht mit dem gewohnten Menüpunkt (und etwas versteckter). Und das ändert auch nichts daran, dass CWM 2.5.0.7 veraltet und zu den weit verbreiteten PVT4-Desire inkompatibel ist. Ist doch schön, wenn du damit keine Probleme hast. Hier gibt es aber massig Threads, wo es genau um diese Probleme geht.

Desire direkt in den Müll (laut deiner Aussage)
Das habe ich überhaupt nicht gesagt. Und das Desire hat sehr wohl noch Support (die ersten Geräte laufen erst in ca. 6 Monaten aus diesem raus).
 
Status
Für weitere Antworten geschlossen.
Oben Unten