Ideos X3 erkennt mein Custom Recovery nicht

  • 1 Antworten
  • Neuester Beitrag
Diskutiere Ideos X3 erkennt mein Custom Recovery nicht im Root / Hacking / Modding für Huawei Ideos X3 im Bereich Huawei Ideos X3 (U8510) Forum.
R

RecMak

Neues Mitglied
Hallo allerseits,

nachdem ich mich durch dieses und andere Foren geforstet habe und keine Lösung für mein Problem gefunden habe, möchte ich euch um Hilfe bitten.


Daten:

Ideos X3
- gerootet
- CWM-Recovery
- Stock-Rom
- Android 2.3.5

Ich würde gern ein eigenes Recovery-Image erstellen, das ich dann auf das Ideos X3 flashe. Als Vorspiel habe ich dazu erstmal das CWM-Recovery entpackt und unverändert wieder neu gepackt, um zu schauen, dass ich alle Parameter richtig habe.


Ich habe es wie folgt gemacht:


1. Unpack Recovery-Images:


./split_bootimg.pl recovery.img

mkdir ramdisk
cd ramdisk
gzip -dc ../recovery.img-ramdisk.gz | cpio -i
cd ..

2. Re-Pack Recovery-Images:


./mkbootfs ./ramdisk | gzip > ramdisk-new.gz

./mkbootimg --kernel recovery.img-kernel --ramdisk recovery.img-ramdisk.gz --cmdline "console=ttyDCC0 androidboot.hardware=huawei" -o recovery.img --base 0x10200000

Das resultierende recovery.img habe ich dann mittels fastboot draufgeflasht:


fastboot erase recovery
fastboot flash recovery recovery.img
fastboot reboot

Es wird augenscheinlich erfolgreich geflasht und der Reboot scheint wohl auch zu erfolgen, aber dann hängt das X3 im Boot-Vorgang fest und kann nur durch Entfernen des Akkus wieder ausgeschaltet werden. Ein Booten in das Recovery funktioniert nicht. Es wird offenbar nicht als Recovery erkannt.

Nu hab ich schon ewig recherchiert und gegrübelt, wo mein Fehler liegen könnte und hab auch zumindest eine Menge über die notwendigen Parameter bei mkbootimg gelernt. Aber meiner Meinung nach müssten die Parameter jetzt so stimmen und trotzdem klappt es nicht.

Habt ihr Ideen, was ich übersehen habe?

Danke schon mal und
Gruß,
RecMak
 
Zuletzt bearbeitet:
R

RecMak

Neues Mitglied
Hallo,

des Rätsels Lösung war, dass das mkbootimg-Binary, dass ich irgendwo runtergeladen habe, offenbar keine für das X3 korrekten Images erstellen konnte. Darauf bin ich ewig nicht gekommen, weil die Recovery-Images, die ich für ein Samsung Galaxy S Plus gebaut habe, klaglos von diesem akzeptiert wurden.

Habe jetzt ein anderes mkbootimg und damit geht alles:thumbup:

Gruß,
RecMak (Anne)