Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

vulnerable_recovery lässt sich nicht flashen :(

  • 6 Antworten
  • Neuester Beitrag
Diskutiere vulnerable_recovery lässt sich nicht flashen :( im Root / Hacking / Modding für Motorola Milestone im Bereich Motorola Milestone Forum.
pibels94

pibels94

Neues Mitglied
Hey Leute,

hoffe ihr könnt mir bei folgendem Problem helfen:

will CM 7 auf mein Milestone machen, hab deswegen erstmal alle Firmware Einstellungen resetet etc.

Wenn ich jetzt das MS mit der "verwundbaren" Recovery flashen will, bleibt der Start Button immer grau :(

Sowohl im Standby als auch im Boatloader Modus :(

Firmware ist Android 2.2.1
Boatloader: 90.78

OS ist Win 7 64Bit, Adminrechte sind vorhanden.
 
TheSpiritof69

TheSpiritof69

Experte
Explizit als Admin ausgeführt via Rechtsklick?

Wirds Milestone wenigstens erkannt?
Standby bringt eh nix, musst explizit in den Bootloader booten mit DPAD-Up+Power
 
pibels94

pibels94

Neues Mitglied
das Milestone wird erkannt, ja :)

und ich hab in den Eigenschaften vom RSD festgelegt das es als Admin ausgeführt werden soll, wird es dann auch ^^

hab mir probeweise auch andere sbf's runter geladen, aber bei File Properties erschein nie etwas und der Start Button bleibt grau.
 
TheSpiritof69

TheSpiritof69

Experte
Die SBF mal umbenennen, einfach einen kurzen Namen (bspw. vuln.sbf) vergeben und unter C:\ ablegen, dann von dort auswählen.

Aus welchem Grund auch immer, RSDlite spackt da manchmal ein wenig.
 
pibels94

pibels94

Neues Mitglied
hat nix gebracht :(
 
-FuFu-

-FuFu-

Ikone
mögliche Lösungen:
ich führe nochmal alles auf, was ich im Kopf habe...

- neuste RSD Lite Version nutzen (http://droid-world.bplaced.net/load.php?file=download/tools/RSDLite_5.3.1.zip)
- Motorola Treiber installiert?
- RSD Lite als Administrator ausgeführt?
- die sbf in "recovery.sbf" umbenennen
- ist die sbf auch wirklich ne sbf oder noch ne zip? (entpacken eventuell nötig)
- Milestone befindet sich im Bootloader
- mal versuchen per Konsole zu flashen (CMD)
EDIT: Gregor901 hat mich darauf hingewiesen, das die Schritte fuer die Behebung des Fehlers mit den Admin Rechten nicht fuer alle User selbsterklaerend sein koennen in den vorher angebebenen Link ([TUT] Manuelles Update auf 2.0.1 mit Root und deutscher Tastatur)

Daher mein Versuch, das einfacher zu erklaeren:

Schritt 1:
Kopiert die zu flashende Datei in den Ordner, in dem auch RSD Lite installiert ist, und benennt diese in einen einfachen namen um (z.B dach21.sfb)

Schritt 2:
Nun sollt ihr die Applikation RSD Lite durch verwenden der Eingabeauforderung(command) erzwingen, das flashen im Admin Modus auszufuehren. Dieser Befehl sieht SO aus:

C:\{ORDNER, in dem RSD Lite installiert ist}\SDL.exe -f {NAMEDESZUFLASHENENFILES}.sbf -t 2

Als Beispiel fuer Win7, 64 Bit
(bei 32 bit heist der Ordner "Programme", Nicht "Programme (x86))

a) Rechte Maustaste auf Startmenu -> Eigenschaften -> Anpassen, dann den Hacken setzen bei "Befehl Ausführen"
b) Linksklink auf "Ausführen" im Startmenue
c) CMD eingeben (Das startet die Eingabeauforderung, in der man mit DOS befehlen wie "cd" (change directory), dir (zeige das Verzeichnis an) etc sich dann zu dem Odner navigieren muss, wo RSD standarmaessig installiert wird)
d) zum Installationsordner von RSD navigieren (z.b C:\Programme (x86)\Motorola\RDS Lite) mit CD (immer von ordner zu ordner hangeln, also cd Programme (x86), danach cd Motorola etc

nun sollte die Eingabeaufforderung (shell) an unserem Beispiel anzeigen:
c:\Programme (x86)\Motorola\RSD Lite

e) nun diesen befehl eingeben (an unserem beispiel)

SDL.exe -f dach21.sbf -t 2

(dach21 ist der von euch vorher vergebene Name, als ihr das .sbf file in den RSD ordner kopiert habt)
Wichtig sind die parameter (leerzeichen -f) nach der sdl.exe und (leerzeichen-t leerzeichen 2) nach dem namen des sbf-files

Nun sollte es funktionieren :)

PS: weitere Command Line commands und ein Manual kann man hier einsehen:
http://www.motorolafans.com/forums/a...ser-manual.pdf
Ich hoffe das eine Lösung dazwischen ist


p.s.
wenn man es per CMD unter Win7 versucht, die CMD als Administrator ausführen...
 
pibels94

pibels94

Neues Mitglied
hab ich alles :D

bis auf das Konsolenflashing, das versuch ich nacher mal :thumbsup: