Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

ADB klappt, Fastboot leider nicht

  • 14 Antworten
  • Neuester Beitrag
Diskutiere ADB klappt, Fastboot leider nicht im Root / Hacking / Modding für Motorola Xoom im Bereich Motorola Xoom Forum.
K

karostl

Ambitioniertes Mitglied
Hallo allerseits,

Habe die android-sdk_r12-linux_x86.tgz installiert und Zugriff auf das Xoom vermittels adb.

Der Befehl: adb devices listet das angeschlossene Xoom einwandfrei auf.


Habe mir ferner das binary fastboot von folgender Quelle besorgt:
HTC - Developer Center
Der Befehl fastboot devices findet das angeschlossene Xoom leider nicht.

Wie könnte man den Fehler noch weiter eingrenzen?

Gruß Robert
 
Fieser-Kardinal

Fieser-Kardinal

Experte
Sicher dass du auch im richtigen Pfad bist wo die fastboot.exe liegt? Beim Android SDK ist das getrennt und man muss es manuell kopieren. Vielleicht löst das dein Problem schon.

Andernfalls musst du die Xoom Treiber mal aktualisieren, die pfuschen da manchmal mit rein.
 
Zuletzt bearbeitet:
K

karostl

Ambitioniertes Mitglied
Hallo Kardinal,
Danke für die schnelle Antwort.

Da ich hier Linux nutze, habe ich nicht die fastboot.exe, sondern das Linux-Binary fastboot.
adb und fastboot liegen im gleichen Verzeichnis, ich rufe beide Befehle mit absoluter Pfadangabe auf, also so:
./adb devices
./fastboot devices

Wie gesagt, adb klappt, fastboot nicht.

Parallel dazu installiere ich mir das Ganze mal unter XP, vielleicht habe ich da mehr Glück.

Gruß Robert
 
GMoN

GMoN

Experte
Ich habe das gleiche Problem unter Mac OS. Fastboot erkennt nix. adb klappt.Ich muss es immer mit XP machen.
 
L

Lupus

Stammgast
du machst auch ein adb reboot bootloader bevor du fastboot verwendest oder? im laufenden system funktioniert fastboot nicht und findet auch keine devices
 
K

karostl

Ambitioniertes Mitglied
Hallo allerseits,

Habe das ganze jetzt auch unter XP probiert.
Das Verhalten ist dasselbe.

In folgendem Forum wird das von Lupus beschriebene nochmals bestätigt:
[Tutorial-Ubuntu] Android SDK/ADB/Fastboot - UPDATED - CyanogenMod Forum

Ich zitiere:
"Your device must in in FASTBOOT mode for fastboot command to work. adb only requires your device to be in USB Debug mode. So it can see your device after it fully booted."

Dank an alle.

Gruß
Robert
 
Z

Zipfelklatscher

Gast
Schon mal versucht, fastboot als Root zu starten?

sudo ./fastboot devices
 
M

McFiscH

Erfahrenes Mitglied
karostl schrieb:
Hallo allerseits,

Habe das ganze jetzt auch unter XP probiert.
Das Verhalten ist dasselbe.

In folgendem Forum wird das von Lupus beschriebene nochmals bestätigt:
[Tutorial-Ubuntu] Android SDK/ADB/Fastboot - UPDATED - CyanogenMod Forum

Ich zitiere:
"Your device must in in FASTBOOT mode for fastboot command to work. adb only requires your device to be in USB Debug mode. So it can see your device after it fully booted."

Dank an alle.

Gruß
Robert
Ich bin nicht sicher ob du das und ich dich richtig verstanden habe, daher:

Fastboot: Gerät muss im fastboot-Modus sein (wird beim Xoom dann im Display angezeigt, erfolgt anstelle des Ladens des normalen Android-Systems)

adb: Gerät muss normal hochgefahren sein und USB-Debugging aktiv haben

Den Fastboot-Modus erreicht man entweder per adb mittels
Code:
adb reboot-bootloader
oder indem man
Code:
beim Booten nach Erscheinen des roten Moto-Logos die VolUp-Taste drückt
Ist das Gerät im Fastboot-Modus, wird weiterhin das Moto-Logo angezeigt und links oben steht:
Code:
Starting Fastboot protocol support
Kommandos des jeweiligen Tools funktionieren nur, wenn das Gerät auch im jeweiligen Modus ist. Hast du nun das fastboot-Kommando im Fastboot-Modus ausgeführt oder nicht? :confused:

PS: aus Fastboot heraus kann man mittels
Code:
fastboot reboot-bootloader
auch nach einem Neustart direkt wieder in den Fastboot-Modus fahren.
 
K

karostl

Ambitioniertes Mitglied
Hallo MacFish,

Erstmal Danke für Deine Erläuterungen.

Ich habe das fastboot Kommando bisher nicht im Fastboot-Modus ausgeführt.

Bevor ich mein teures Xoom erstmalig in den Fastboot-Modus fahre, erlaube mir eine letzte triviale Frage:
"Wie beendet man einen laufenden Fastboot-Modus, damit das Gerät anschließend wieder normal bootet?"

Womöglich bin ich ja ein bisschen übervorsichtig, aber da man offenbar kein Full-Backup machen kann, frage ich lieber zweimal nach.


Gruß Robert
 
L

Lupus

Stammgast
mit
Code:
fastboot reboot
bootest du dein gerät wieder ganz normal
 
M

McFiscH

Erfahrenes Mitglied
Mit [VolUp]+[POWER] kannst du dein Xoom immer "kaltstarten", z.B. um aus einem Bootloop zurück ins Recovery oder Fastboot kommen. Das funktioniert auch aus dem laufenden normalen Android heraus.

Drückst du statt [VolUp] beim Booten die [VolDown]-Taste, kannst du durch die verschiedenen Boot-Modi wechseln (z.B. Normal, Fastboot, Recovery) und den gewählten Modus per [VolUp] starten.
 
Zuletzt bearbeitet:
K

karostl

Ambitioniertes Mitglied
Hallo allerseits,
Der Vollständigkeit halber:
Der fastboot Befehl klappt jetzt auch hier.
Voraussetzung ist, wie bereits erwähnt, dass das Xoom im fastboot-Modus sein muss.

Gruß
 
GMoN

GMoN

Experte
Bei mir klappt fastboot jetzt auch direkt auf dem iMac. Mein Fehler war, dass fastboot nicht mit root Rechten ausgeführt wurde. Beim Mac klappt su nicht so einfach im Terminal. Man muss root erst für den Benutzer und auch den Admin aktivieren.

root am Mac aktivieren

Und dann war dieses noch hilfreich.
 
O

ol2tmx

Neues Mitglied
Fastboot in der Linux Version hat bei seinen Upgrades intern die Syntax geändert. Die Windows-Versionen sind bei 1.4.3 - die aktuelle Linux Version ist bei 1.8.x. Sämtliche Scripte müssen dann leider entsprechend de reuen Syntax angepasst werden 😢
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Lexikon
Inwiefern hat sich denn die Syntax geändert? Hast du zufällig einen Link zu einem Changelog o.ä.?