Wie Magisk installieren

M

MarkF

Ambitioniertes Mitglied
7
Ich bin mit meinem Latein am Ende:
Seit vielen Stunden versuche ich, mit fastboot eine boot.img-Datei auf ein Samsung-Smartphone (GT-i9001) zu flashen - aber es geht nicht, weil fastboot das i9001 im download-mode nicht erkennt (adb ebenfalls nicht). Odin erkennt es aber! Wie ist das möglich?
Also: adb und fastboot sowie die Samsung-USB-Treiber (verschiedene Versionen getestet) installiert. Das i9001 hat TWRP 2.8.1.0 und lineageos 14.1 (7.1.2). Normal gebootet und (in den Entwickleroptionen) USB-debugging aktiviert und USB von "Laden" auf "Dateiübertragung" eingestellt wird das i9001 vom PC (Win7-32) als Mediengerät erkannt. Im Gerätemanager wird es als USB-Gerät und als tragbares Gerät angezeigt. Zugriff, Kopieren usw. ist möglich. Das funktioniert mit jedem USB-Kabel. In diesem Zustand erkennt auch adb ("adb devices") das Gerät, der Zugriff ist möglich). fastboot ("fastboot devices") erkennt das i9001 aber nicht.
Im Download-Modus (Volume- plus Home plus Power) erkennt Odin das i9001 zwar nicht mit allen USB-Kabeln, aber doch mit einigen (warum auch immer nicht alle Kabel funktionieren). Im Win7-Gerätemanager ist das i9001 dann (aber nur) als USB-Gerät eingetragen (mit den nicht funktionierenden USB-Kabeln dagegen als nicht erkanntes USB-Gerät, der Treiber wird dann auch nicht geladen), nicht mehr auch als tragbares Gerät. Aber: Weder fastboot noch adb erkennen so das i9001. "adb devices" bzw. "fastboot devices" zeigen keine Geräte.
Was ist da los, wie kann das sein? Wenn Odin das i9001im Download-Modus erkennt, dann muß das doch auch für adb/fastboot gelten Zumindest wird auf allen Seiten, in denen diese Problematik behandelt wird, als "Testkriterium" genannt, daß Odin das Gerät erkennt.
Andererseits wird (selten) darauf hingewiesen, daß das Gerät dann zwei mal im Gerätemanager auftauchen würde bzw. sollte (also vermutlich wie es im gebooteten Zustand der Fall ist).
Im Netz gibt es nicht allzu viel Fundstellen zu diesem Problem, und immer heißt es: USB-Kabel, USB-Ports - habe ich alles ausprobiert, egal welches Kabel, egal welcher Port, vor allem aber klappt es mit Odin.
In den Anleitungen klingt alles so einfach ...
Leider bin ich auf fastboot angewiesen, denn ich finde keine andere Möglichkeit, die boot.img an das i9001 zu schicken, mit Odin geht es nicht (-> nächstes post).
 
Folgende Situation: Ich versuche, Magisk in meinem Samsung GT-i9001 zu installieren. Auf dem Gerät ist TWRP 2.8.1.0 und lineageos 14.1 (Nougat 7.1.2). Das unmittelbare Flashen von Magisk via .zip-Datei über TWRP-Install funktioniert nicht - Fehler beim Flashen in der ZIP (mehrfach downgeloadet), vielleicht/vermutlich ist TWRP 2.8.1.0 zu alt (aber ich finde nirgends eine neuere Version). Also muß alternativ die stock-boot-image-Datei boot.img durch den Magisk-Manager gepatcht werden.
Hierzu habe ich zum einen die boot.img-Datei aus dem zu Beginn angefertigten TWRP-backup des stock-ROMs genommen und einfach in boot.img umbenannt. Angeblich -so heißt es im Netz - sei die unkomprimierte backup-Datei identisch mit boot.img, müsse also nur umbenannt werden. Zum anderen habe ich die boot.img aus einer stock-ROM-Datei aus dem Netz genommen. Mit beiden habe ich es ausprobiert.
Der Magisk-Manager patcht beide .img-Dateien ohne Fehlermeldung. Schon mal gut.
Da das Flashen mit fastboot nicht klappt (das i9001 wird von fastboot ums Verr... nicht erkannt, siehe vorheriges post) muß ich es über Odin machen. Odin flasht aber keine .img-Dateien sondern erwartet .tar-Archive. Im Netz gibt es einen .img->.tar-Konverter, angeblich speziell für diesen Zweck. Mit dieser .tar-Datei füttere ich Odin - aber es klappt nicht:
Bei diesem .img->.tar-Konverter ist eine ältere Odin-Version - 3.irgendwas - dabei. Sie erkennt zwar das angeschlossene i9001, mag auch die .tar-Datei, die ihr in/als AP bzw. PDA zugeführt wird - hängt aber nach "Start" schon bei dem Versuch, die Verbindung mit dem i9001 aufzunehmen. In
Samsung Galaxy S "Plus" i9001 - Flashen mit Odin - Root - Brick
wird behauptet, für das i9001 müsses es die Version Odin Multi Downloader 4.43 sein. Mit dieser Version hatte ich auch schon ganz am Anfang die beim Flashen des ersten Custom-ROM aufgetretene boot-loop durch Neuflashen des bootloaders durchbrechen können - funktioniert also mit dem i9001. Aber:
Diese Odin-Version mag die boot.tar-Datei bzw. die in dieser enthaltene boot.img-Datei nicht (egal welche). Sobald ich die .tar-Datei in/über PDA auswähle wird sie in Odin geladen und geprüft und Odin beschwert sich über ein ungültiges Image-File. Lade ich sie dagegen als bootlader oder eine der anderen Möglichkeiten in Odin, wird sie befremdlicherweise widerspruchslos akzeptiert. Andererseits müssen boot images aber mit/über AP bzw. PDA geladen und geflasht werden - so heißt es jedenfalls "überall", in jeder Anleitung. Die Ursache nicht auch nicht im Patch durch den Magisk-Manager, denn natürlich habe ich es auch mit der unverändeten boot.img aus dem TWRP-backup bzw. dem downgeloadeten Stock-ROM getestet, mit dem nämlichen Ergebnis.
Jetzt weiß ich nicht weiter. Was ist/mache ich falsch?
 
Zuletzt bearbeitet:

Ähnliche Themen

S
Antworten
9
Aufrufe
1.121
BOotnoOB
BOotnoOB
M
Antworten
4
Aufrufe
1.040
marcim6
M
N
Antworten
4
Aufrufe
3.552
Ourrewaeller
O
Zurück
Oben Unten