Magisk auf SGS2 i9100 installieren mit Fehlermeldung

  • 9 Antworten
  • Neuster Beitrag
vonharold

vonharold

Stammgast
Threadstarter
Hallo zusammen,

ich möchte zu Testzwecken Magisk 17.1.zip über TWRP (i9100/twrp-3.2.3-0-i9100.img) installieren.
Habe auch schon mit uninstall SuperSU deinstalliert.

Leider kommt zum Schluss die Fehlermeldung: Prozess Updater endete mit Fehler: !
Fehler beim installieren von ZIP "sdkart0/Download/Magisk-v17.1.zip"

Egal wo ich die Zip ablege kommt der Fehler mit dem Pfad der Zipdatei.

Magisk_Fehler.jpg

Über dem Magisk-Manager 6.0.1 habe ich es auch schon versucht

An was liegt der Fehler?

Hier der Log:
- Copying image to cache
- Device platform: armeabi-v7a
- Existing zip found
- Extracting files
boot_patch.sh[73]: can't create /proc/self/fd/: Is a directory
MagiskBoot v17.1(17100) (by topjohnwu) - Boot Image Modification Tool
Parsing boot image: [/data/user_de/0/com.topjohnwu.magisk/install/boot.img]
boot_patch.sh[91]: can't create /proc/self/fd/: Is a directory
boot_patch.sh[91]: can't create /proc/self/fd/: Is a directory
boot_patch.sh[91]: can't create /proc/self/fd/: Is a directory
! Installation failed
Vermutlich immer vor dem PC/Handy! :)
 
Zuletzt bearbeitet:
TramJens

TramJens

Stammgast
@vonharold
Hallo, liegt vielleicht an der Rom,welches Customrom hast Du drauf?
 
vonharold

vonharold

Stammgast
Threadstarter
Hallo TramJens,

aktuelle 14.1-LineageOS
 
TramJens

TramJens

Stammgast
@vonharold
Ich weiß nicht wirklich woran es liegt,es sollte funktionieren, sind nur ein paar Gedanken von mir.
TWRP 3.2.3 ist die neuste? Mit der hatte ich nur Probleme, vielleicht hilft es Magisk 16 oder 17.0 zu flashen.
 
vonharold

vonharold

Stammgast
Threadstarter
Hallo TramJens,

kein Problem, werde ich auch noch testen.
Hatte vorher das alte 3.1.0-0 TWRP drauf und ging auch nicht, deswegen das aktuelle TWRP benutzt.
 
vonharold

vonharold

Stammgast
Threadstarter
Hallo TramJens,
so habe mehrere Magiskversionen nach unten durchprobiert und immer der gleiche Fehler.
Habe sogar das Handy neu geflasht und immer noch das gleiche Problem.
Funktioniert scheinbar nicht mit dem alten S2.
Ist ja auch nur das Testhandy. Wollte mir einfach mal Magisk mal im Umgang anschauen und mich damit beschäftigen.
Apps ausprobieren, die ihren Dienst bei gerooteten Handy verweigern usw.

Falls noch jemand eine oder mehrere Lösungen hat, nur her damit.

Danke!
 
Pazuzu-13

Pazuzu-13

Stammgast
Magisk funktioniert auf meinem S2 problemlos!
Habe nur das Problem, wie viele Andere, daß LOS nich sehr flüssig darauf läuft.
 
Zuletzt bearbeitet:
TramJens

TramJens

Stammgast
Hallo vonharold,
Eine Lösung hab ich noch nicht,vielleicht verrät uns Pazuzu-13 seine.
Ich hab das auf meinem S2 durchprobiert,
CM12.1 mit CWM,
RR5.8.3, LOS 14.1,beide mit twrp, funktioniert bei mir auch nicht, immer der gleiche Fehler.
 
vonharold

vonharold

Stammgast
Threadstarter
Hallo TramJens,

habe das S2 bestimmt schon 5 mal komplett neu aufgesetzt und komme immer wieder zum gleichen Fehler.
Habe schon mit dem Magisk Manager 5.8.2 angefangen und mich von unten nach oben durch geupdatet.
Immer der gleiche Fehler.
Na mal schauen, ob noch andere konstruktive Vorschläge oder Lösungen kommen.
Die Hoffnung stirbt ja bekanntlich zuletzt.
 
Pazuzu-13

Pazuzu-13

Stammgast
Ihr habt vollkommen recht, Magisk funktioniert nich auf'm S2.
Hatte das S2 vor nem halben Jahr zum 'spielen' in Benutzung & wußte nich, daß ich es damals auch nich komplett installiert hatte - der Manager geht, nur Root eben nich.
Großes Sorry für die Falsch-Aussage!:1f615:
Der Akku vom S2 (meiner Schwester) is so dermaßen kaputt, daß ich kaum dran 'arbeiten' kann: 2x booten & das Ding zeigt 'leer'!
 
Oben Unten