HOW-TO Galaxy adb Treiber unter Vista/Win7 32+64bit

  • 15 Antworten
  • Neuester Beitrag
Diskutiere HOW-TO Galaxy adb Treiber unter Vista/Win7 32+64bit im Root / Hacking / Modding für Samsung Galaxy im Bereich Samsung Galaxy (I7500) Forum.
A

aslocum

Erfahrenes Mitglied
Meine Anleitung mal aus dem anderen Thread rauskopiert damit man es einfacher findet.. falls doch noch Fehler und/oder Unklarheiten drin sind einfach meckern :)

hier nun die anweisungen für vista/win7 32+64bit:

das galaxy bitte erst vom pc abstecken.
ich gehe davon aus das man das neueste android sdk (1.5 r3) heruntergeladen hat oder zumindest den tools ordner davon hat wegen adb und fastboot

also als allererstes würde ich alle samsung galaxy usb geräte weginstallieren: dazu am einfachsten USBDeview - View all installed/connected USB devices on your system runterladen (muss per rechtsklick als admin gestartet werden falls man uac an hat) in dem programm alle samsung geräte markieren und rechtsklick deinstallieren.

danach muss man leider das samsung nps installieren (falls nicht schon geschehen.) falls es unter win7 meckert beim installieren: rechstklick auf die New PC Studio 1.2.0.IF2_2.exe und Kompabilität Vista SP2 einstellen und programm als admin ausführen
danach die Samsung_USB_Driver_Installer.exe installieren.. auch ggf. über kompabilitätsmodus und admin (zumindest bei win7 64bit "erfolderlich" sonst kommen einige fehler)

jetzt mein gemoddetes treiberpaket herunterladen und entpacken: usb_driver_modded.zip

galaxy auf usb-debuging stellen und einstecken. die allermeisten treiber sollte er automatisch installieren bis auf einen.
im gerätemanager rechtsklick auf das unbekannte device: treiber aktualisieren: auf dem computer nach treibersoftware suchen: dort dann den pfad zum entpackten usb treiber von mir. er sollte dann das gerät erkennen und installieren.
FALLS nicht (kann passieren je nach firmware version) muss man etwas in der inf ändern in dem treiberpaket.. keine angst ist auch ganz einfach:
ihr solltet evtl. notepad++ oder ähnliches textprogramm haben.. notepad von windoof ist eher ungeignet.
bei 32bit die inf im x86 ordner ändern bei 64bit die im amd64 (ja auch bei intel 64bit ).
die jeweilige inf in einem texteditor öffnen und bisschen runterscrollen..dort stehen einige zeilen ähnlich dieser hier:

%USB\VID_04E8&PID_6640&MI_04.DeviceDescRelease%=an droidusb.Dev, USB\VID_04E8&PID_6640&MI_04

ich hab extra schon die mir bekannten MI_ eingetragen (hatte 1,3 und 4 je nach firmware bisher) aber es kann ja sein dsas ihr doch eine andere habt..das findet man so raus: im geräte manager rechtsklick auf das device.. eigentschaften-> details dort dann hardware-id's im pulldown menu wählen. jetzt seht ihr schon sowas in der art:

USB\VID_04E8&PID_6640&MI_04&blahblah

vergleicht die id mit denen in der inf. eigentlich sollte nur der MI_0X wert anders sein. diesen dann einfach in einer zeile in der ganzen inf anpassen (taucht paarmal auf der wert) oder neue zeilen dazumachen (copy+paste udn wert ändern)
auch ganz unten in der inf den MI_0X wert ändern!
also nochmal.. wenn ihr MI_02 habt könnt ihr z.b. alle MI_01 in der inf einfach durch MI_02 ersetzen.
danach das treiber install spielchen nochmal..sollte gehen!

das macht man dann noch paarmal für die jeweiligen modi..fastboot im speziellen. die beiden unteren tasten (power on und die auf der anderen seite..weiss den namen grade nicht) des galaxy halten zum starten bis fastboot im display erscheint. schnell usb kabel dran ..windows startet devicee erkennung. nach 15sec startet das galaxy automatisch weiter aber ist nicht schlimm das android 1.0 (glaub so hiess es) device ist trotzdem weiter im gerätemanager (kann sein das man ausgeblendete geräte anzeigen aktivieren muss)
dieses rechtsklicken... treiber aktualisieren..blah blah mein treiber auswählen fertig.

so sollte es eigentlich funktionieren.. tuts zumindest bei mir.. hoffe hab nix vergessen zu erwähnen
 
T

the-offspring1

Neues Mitglied
Hallo,

ich habe versucht deine Anleitung zu befolgen, weil ich meinen USB treiber auch nicht installieren kann.

Ich kann mein handy nicht auf Debug umstellen, da es sich nach dem zurücksetzten auf Fabrikzustand nicht mehr booten lässt.
Die letzte Version lässt er sich auch nicht aufspielen, und deinen gemoddeten kann ich nicht installieren, weil ich nicht sehe welche firmware drauf ist, da dort nur USB:Unknown da steht...

man man man ich wünschte irgendjemand hätte da einen guten Rat für mich.
 
T

Trumpf

Fortgeschrittenes Mitglied
Woran kann es liegen das der Debug-Modus einfach nicht funktioniert?
Er ist auf meinem Galaxy (GAOSP 10292010) eingeschaltet, aber beim Befolgen dieser Anleitung unter Windows Vista passiert gar nix wenn ich den Debug-Modus aktiviere. Auch ein "adb devices" findet nichts.

Mein Haupt-System ist Linux. Auch dort wird mit "adb devices" absolut gar nichts gefunden.

Hat jemand eine Idee woran das liegen könnte?


EDIT am 07.11.2010 um 08:50:

Also, jetzt funktioniert adb. Aber erst nachdem ich ein Restore zurück zu GALAXO gemacht habe. Dort funktionierte adb sofort nachdem ich den Debug-Modus eingeschalten habe.
Dann mit aktiviertem Debug-Modus ein Restore zurück zu GAOSP. Jetzt funktioniert es auch unter GAOSP.

Ich schliesse daraus das das einschalten des Debug-Modus unter GAOSP schlichtweg nicht funktioniert. Die Mehrheit hier hat unter GAOSP kein Problem eine adb Verbindung zustande zu bekommen, da ihr den Debug-Modus schon unter GALAXO aktiviert hattet.

Kann das sein? Kann das jemand bestätigen oder widerlegen?
Ich kann es mir einfach nicht anders erklären.
 
Zuletzt bearbeitet von einem Moderator:
T

the-offspring1

Neues Mitglied
Hallo,

ich habe nun mal wieder versucht mein handy mit meinem PC zu verbinden...

aber leider funktioniert garnix...

ich weiß garnicht mehr was ich noch versuchen soll...

entweder es lässt sich der treiber schon nicht installieren, oder das handy wird beim anstecken nicht erkannt, und aktuell sei der treiber aber trotzdem...

hilfe?!
 
T

the-offspring1

Neues Mitglied
Sooooo ich denke ich bin doch nach ein paar stunden weiter gekommen...

ich bin nun auf einen xp rechner gewechselt, nun kann ich dein kit aber nicht soweit modden, weil ich nicht rausfinden kann welchen "MI_0x" benötige, da ich nicht rausfinde was ich brauche.

ich weiß zwar, das ich eine 1.6er firmware habe, allerdings im dropdown menü über die hardware Id kann ich kein MI ausmachen ...

kannst du mir da einen Tip geben?

Weil ich auf dem xp rechner mit dem üblichen treiber auch nicht auskam, habe ich es jetzt einfach so probiert, oder soll ich da wieder was anderes machen?

ich hoffe bald folgt eine Antwort :cool2:
 
C

Coxeroni

Stammgast
Also ich weiß nicht warum, aber bei mir weder unter Windows 7 32 bit noch 64 bit so ein Aufriss nötig.

Mein Vorgehen war folgendes:

NPS installiert, SDK installiert, den win7 Treiber von inFect aus dem Galaxo-Guide geladen, Galaxy eingesteckt, im Gerätemanager das fehlerhafte ADB per "Treiber aktualisieren" und navigieren zum entpackten Treiber (Ordner "SDK1.6_USB_Galaxy") installiert, und fertig war die Laube.

Vielleicht klappt's ja auch bei euch ;)
 
C

Coxeroni

Stammgast
Trumpf schrieb:
Woran kann es liegen das der Debug-Modus einfach nicht funktioniert ?
Er ist auf meinem Galaxy (GAOSP 10292010) eingeschaltet, aber beim Befolgen dieser Anleitung unter Windows Vista passiert gar nix wenn ich den Debug-Modus aktiviere. Auch ein "adb devices" findet nichts.

Mein Haupt-System ist Linux. Auch dort wird mit "adb devices" absolut gar nichts gefunden.

Hat jemand eine Idee woran das liegen könnte ?
Hilft dir das vielleicht?

Workaround for adb when it's not working after flashing a rom¶
You need to disable USB Debugging (in Settings --> Applications --> Development), unplug the USB cable, then reenable USB Debugging and plug in your USB cable.
 
T

Trumpf

Fortgeschrittenes Mitglied
Coxeroni schrieb:
Hilft dir das vielleicht?
123.000 Mal gemacht.
Das einzige was bei mir geholfen hat dass das Galaxy im Debug Modus mit adb erkannt wurde war ein Restore eines Backup von Galaxo zu machen. Dort bei Galaxo USB Debugging einzuschalten und dann wieder ein Restore zu Gaosp.
Erst dann ging es. Vorher hab ich alles probiert was man hier im Forum dazu finden kann..
 
F

Falkentavio

Neues Mitglied
Hallo Galaxy-User
ich versuche jetzt seit etwa 2 Stunden mein Galaxy zu flashen. Ich schaffe es auch das recovery zu flashen und das handy im recovery mode zu starten. aber dort zeigt er mir an, dass die datei rectools.tar.gz fehlt. nach einigem Suchen hab ich dann herausgefunden, dass die datei auf die interne SD Karte muss, nicht auf die externe. Und hier kommen wir zu meinem Problem:
Ich habe alle Treiber erfolgreich installiert (auch den adb), jedoch registriert Windows die Datenträger nicht. Ich erhalte Laufwerk E und F, aber es sind angeblich keine Medien enthalten und somit kann ich auch keine daten auf die interne SD Karte ablegen. Währe toll, wenn jemand dafür eine Lösung hat.

Mein System: Windows 7 Pro 64 bit
Galaxy GT I7500 mit Android 1.6
 
D

Dirkkro

Erfahrenes Mitglied
Hi,

du must ggf. den Datenträger bereitstellen, kommt auf Dein System an! Bei GASOP auf das USB Symbol klicken. Das 1.6 hatte ich nie, Beim 1.5er mußte man irgenwo in den Einstellungen freigeben. Ggf. gehts auch mit Recovery.

Gruß dirk
 
F

Falkentavio

Neues Mitglied
Das Galaxy Handy wurde frei gekauft und ist von Anfang an ein Android 1.6 gewesen und noch das selbe System wie beim Kauf. Eine Einstellung zum Freigeben des Datenträgers finde ich nicht. Ich habe es mit dem Massenspeichermodus versucht und mit dem USB-Debbuging Modus, beides mit dem selben Ergebnis. Auch habe ich versucht die SD Karten unter "SD Karten & Speicher" zu entnehmen, auch das hat nichts gebracht.
Das Recovery kann ich nicht starten, weil ich die rectools.tar.gz nicht auf die interne SD Karte speichern kann. Das ist ja mein Problem :sad:
Gibt es womöglich einen Weg die rectools von der externen SD Karte auf die interne zu verschieben, sodass ich das recovery starten kann?

EDIT: grade habe ich mir das Handy nochmal genau angesehen und das USB Symbol entdeckt und dadurch auch die Bereitstellungsoption. Nun geht alles!

Vielen Dank für die Hilfe!
 
Zuletzt bearbeitet:
lev17

lev17

Stammgast
Drecksanleitung macht es so wie er will
Wie sollen wir Noobs das verstehen mit deinem FACHCHINESISCH


Bei mir musste ich nur den Pfad zu AMD64 angeben und er hat den Treiber aktualisiert!
Wo muss ich jetzt weiter machen?
auch diese MI_0X da ändern? oder wo?
(kann passieren je nach firmware version) muss man etwas in der inf ändern in dem treiberpaket.. keine angst ist auch ganz einfach:
ihr solltet evtl. notepad++ oder ähnliches textprogramm haben.. notepad von windoof ist eher ungeignet.
bei 32bit die inf im x86 ordner ändern bei 64bit die im amd64 (ja auch bei intel 64bit ).
die jeweilige inf in einem texteditor öffnen und bisschen runterscrollen..dort stehen einige zeilen ähnlich dieser hier:

%USB\VID_04E8&PID_6640&MI_04.DeviceDescRelease%=an droidusb.Dev, USB\VID_04E8&PID_6640&MI_04

ich hab extra schon die mir bekannten MI_ eingetragen (hatte 1,3 und 4 je nach firmware bisher) aber es kann ja sein dsas ihr doch eine andere habt..das findet man so raus: im geräte manager rechtsklick auf das device.. eigentschaften-> details dort dann hardware-id's im pulldown menu wählen. jetzt seht ihr schon sowas in der art:

USB\VID_04E8&PID_6640&MI_04&blahblah

vergleicht die id mit denen in der inf. eigentlich sollte nur der MI_0X wert anders sein. diesen dann einfach in einer zeile in der ganzen inf anpassen (taucht paarmal auf der wert) oder neue zeilen dazumachen (copy+paste udn wert ändern)
auch ganz unten in der inf den MI_0X wert ändern!
also nochmal.. wenn ihr MI_02 habt könnt ihr z.b. alle MI_01 in der inf einfach durch MI_02 ersetzen.
danach das treiber install spielchen nochmal..sollte gehen!


das macht man dann noch paarmal für die jeweiligen modi..fastboot im speziellen. die beiden unteren tasten (power on und die auf der anderen seite..weiss den namen grade nicht)[ "was solln das jetzt? ]
des galaxy halten zum starten bis fastboot im display erscheint. [ Von Fastboot habe ich nichts gelesen? erkläre deutlicher] schnell usb kabel dran ..windows startet devicee erkennung. nach 15sec startet das galaxy automatisch weiter aber ist nicht schlimm das android 1.0 (glaub so hiess es) device ist trotzdem weiter im gerätemanager (kann sein das man ausgeblendete geräte anzeigen aktivieren muss)
dieses rechtsklicken... treiber aktualisieren..blah blah mein treiber auswählen fertig.

so sollte es eigentlich funktionieren.. tuts zumindest bei mir.. hoffe hab nix vergessen zu erwähnen
 
C

Coxeroni

Stammgast
lev17 schrieb:
Drecksanleitung macht es so wie er will
Wie sollen wir Noobs das verstehen mit deinem FACHCHINESISCH
Beschwerst du dich auf, dass du keinen Düsenjet fliegen kannst weil die Anleitung zu schwierig ist? Manche Sachen muss man nicht verstehen.
 
C

caiga

Fortgeschrittenes Mitglied
alles gemacht...laut anleitung....das ding is nur das win 7 prof alles automatisch instaliert und ich auch im nachhinein nichts mehr ändern kann....
es ist auch im geräte manager nichts gelb markiert...komisch.

kanns eventuell daran liegen dass ich die aktuellste nps software nutze? die läuft ohne probs unter win 7.
 
R

rilazo

Neues Mitglied
Vielen Dank für die Anleitung!

Bei mir klappte es anfangs nicht, weil ich den x86 Driver installieren wollte. Da ich einen Intel Rechner habe, hat mich AMD64 in die Irre geführt. Beim editieren der .inf ist mir das dann aufgefallen. AMD64 installiert und ohne Modifikation funktionierte es einwandfrei.
 
M

Methedrin

Neues Mitglied
Der Thread ist zwar schon etwas älter sollte aber vom Prinzip her immernoch das gleiche sein, nur funktioniert es bei mir leider nicht:

Ich habe alles nach Anleitung gemacht bzw. versucht. Sobald ich den letzten Treiber im Gerätemanager installieren will, geht es einfach nicht, da es einfach nur meldet, dass die aktuelle Treibersoftware bereits installiert ist. Die richtigen Pfade sind auch angegeben. Angezeigt wirds immernoch mit gelbem Ausrufezeichen und als Unknown Device. USB-Debugging ist aktiviert ;)
Falls es eine Rolle spielt: Ich habe Win 7 Ultimate 64 Bit.

PS: Kann es sein das es eine Rolle spielt welches Datenkabel ich verwende? Ich verwende nämlich zum verbinden ein Nokia CA 101-Kabel, was aber soweit kompatibel sein sollte.
 
Zuletzt bearbeitet: