Hardwaretastatur länger leuchten lassen?

Lenoid

Lenoid

Enthusiast
1.018
Die Tastatur des XP ist ja absolut genial. Allerdings nervt es mich etwas dass die Beleuchtung bei Denkpausen während des Schreibens immer so schnell ausgeht. Gerade im Dunkeln.

Kennt jemand eine Möglichkeit dass man die Tastatur länger leuchten lassen kann wenn sie ausgeklappt ist? Habe Stockrom GB69, rooted.


EDIT: Problem gelöst: Post #12 brachte die Erkenntnis. :thumbup:
 
Zuletzt bearbeitet:
Je nach ROM hängt das mit etwas anderem zusammen.

Ist es bei dir nicht so, dass sobald das Display abdunkelt, die HW-Tastatur aufhört zu leuchten? Auf jeden Fall würde ich mal die Einstellungen unter Display anschauen.
 
Hi, die Beleuchtung geht unabhängig vom einstellten Display-Timeout (bei mir 1 Minute) nach 5 Sekunden aus. Das Display selbst verdunkelt sich erst kurz bevor es ausgeht (also nach ca. 55 Sekunden).

Ich habe zusätzlich eine App namens "Brightness Level" installiert, allerdings scheint diese keinen Einfluss darauf zu haben (habe sie temporär per Titanium Backup deaktiviert).
 
Geh mit Root Rechten unter system/etc und öffne dann die Datei hw_config.sh.

Bearbeite sie dann am richtigen Ort und alles geht, bearbeite sie am falschen Ort und es geht gar nichts mehr :)
 
Wenn ich nur wüsste welchen Wert ich verändern müsste...
Ich habs mal mit dem probiert:
echo 38000 > $dev/keyboard-backlight/max_current
Hat leider nichts gebracht (Neustart gemacht).

Ich habe bei XDA 2 Threads gefunden:
[MOD][01|09|2012] ALS hack <flashable zip>
[Q] How to increase light duration for hardware keyboard for Mini Pro

Beim ersten weiß ich nicht was er beheben soll (jedenfalls nix mit der Tastatur) und der Workaround vom zweiten ist schon sehr umständlich.
Kann vielleicht jemand was mit dem Code anfangen?
 
Lade dir das herunter => disable_als_by_trapacska.zip
Und installiere es, wie du eine ROM installieren würdest. (Über das CMW)

Der ursprüngliche Beitrag von 23:03 Uhr wurde um 23:04 Uhr ergänzt:

Aber 8-tung:
Das ist nicht für das Pro, es kann sein, dass es nachher gar nicht mehr geht.
 
Ich habe folgenden Abschnitt jetzt in meine hw_config.sh kopiert:
# ALS Settings by trapacska, disabled ALS
dev=/sys/devices/i2c-0/0-0040/leds
echo 255,255,255,255,255,255,255 > /sys/devices/i2c-0/0-0040/leds/lcd-backlight/als/curve # ALS curve for group1
echo 2,127,1,130,130,2,2 > $dev/button-backlight/als/curve # ALS curve for group2
echo 2,127,1,130,130,2,2 > $dev/keyboard-backlight/als/curve # ALS curve for group2
echo 3,0,2,0 > $dev/lcd-backlight/als/params #[gain],[filter_up],[filter_down],[offset]
echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h
echo 1 > $dev/button-backlight/als/enable #Sensor on/off. 1 = on, reg 90h
echo 1 > $dev/keyboard-backlight/als/enable #Sensor on/off. 1 = on, reg 90h
echo 500 > $dev/button-backlight/max_current
echo 5000 > $dev/keyboard-backlight/max_current
echo 1 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h
echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h

Hat nichts gebracht.
 
Ersetze das Script um dieses:
Code:
# Audio jack configuration
dev=/sys/devices/platform/simple_remote.0
echo 0,201,1600 > $dev/accessory_min_vals  # default = 0,200,1600
echo 200,1599  > $dev/accessory_max_vals  # default = 200,1600
echo 0,100,280,500,700 > $dev/button_min_vals  # default = 0,100,300,600,700
echo 99,199,399,699,5000  > $dev/button_max_vals  # default = 99,199,399,699,5000
echo 512   > $dev/btn_trig_period_freq  # Button Period Freq(Hz) default = 512
echo 16  > $dev/btn_trig_period_time  # Button Period Time(cycle) default = 16
echo 512   > $dev/btn_trig_hyst_freq    # Button Hysteresis Freq(Hz) default = 512
echo 16  > $dev/btn_trig_hyst_time   # Button Hysteresis Time(Cycle) default = 16
echo 500 > $dev/btn_trig_level  # default = 500

# Proximity sensor configuration
dev=/sys/bus/i2c/devices/0-0054/
val_cycle=2
val_nburst=0
val_freq=2
val_threshold=5
val_filter=0

nv_param_loader 60240 prox_cal
val_calibrated=$?
case $val_calibrated in
 1)
  nv_param_loader 60240 threshold
  val_threshold=$?
  nv_param_loader 60240 rfilter
  val_filter=$?
  ;;
esac

echo $val_cycle > $dev/cycle    # Duration Cycle. Valid range is 0 - 3.
echo $val_nburst > $dev/nburst  # Number of pulses in burst. Valid range is 0 - 15.
echo $val_freq > $dev/freq      # Burst frequency. Valid range is 0 - 3.
echo $val_threshold > $dev/threshold # sensor threshold. Valid range is 0 - 15 (0.12V - 0.87V)
echo $val_filter > $dev/filter  # RFilter. Valid range is 0 - 3.

# ALS Settings by trapacska, disabled ALS
dev=/sys/devices/i2c-0/0-0040/leds
echo 255,255,255,255,255,255,255 > /sys/devices/i2c-0/0-0040/leds/lcd-backlight/als/curve  # ALS curve for group1
echo 2,127,1,130,130,2,2 > $dev/button-backlight/als/curve  # ALS curve for group2
echo 2,127,1,130,130,2,2 > $dev/keyboard-backlight/als/curve  # ALS curve for group2
echo 3,0,2,0 > $dev/lcd-backlight/als/params  #[gain],[filter_up],[filter_down],[offset]
echo 0 > $dev/lcd-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
echo 1 > $dev/button-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
echo 1 > $dev/keyboard-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
echo 500 > $dev/button-backlight/max_current
echo 5000 > $dev/keyboard-backlight/max_current
echo 1 > $dev/lcd-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
echo 0 > $dev/lcd-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h

dev=/sys/devices/platform/spi_qsd.0/spi0.0
app_id=`cat  $dev/appid`
case "$app_id" in
    "0x0603")
        fw=touch_mango_seiko.hex
        ;;
    "0x0103")
        fw=touch_mango_sony_type1.hex
        ;;
    "0x0113")
        fw=touch_mango_sony_type2.hex
        ;;
    "0x0203")
        fw=touch_mango_hitachi.hex
        ;;
    *)
        fw=touch_mango_sony_type1.hex
        ;;
esac
cyttsp_fwloader -dev $dev -fw /system/etc/firmware/$fw

# TI BQ275xx firmware loader
bq275xx_fwloader
 
Hat nichts gebracht. Nur die Tastatur leuchtet kaum noch. hab wieder das alte drauf.
 
Wie gesagt; Du müsstest es für dein Gerät anpassen...
 
Wie gesagt: es bringt nichts. :sad:
 
Vielen Dank!!! Habe die App gerade unter GB69 ausprobiert. Scheint einwandfrei zu funktionieren.

Ich kann die App jedem empfehlen. Sie bietet einen echten Mehrwert für das Pro!
 
Kann mich nur anschließen. Vielen Dank :thumbup:
Funktioniert bei mir unter 2.3.4 auch tadellos.

Da schaut man täglich bei XDA rein, aber manchmal übersieht man schon mal etwas :)

VG
Hardy

Gesendet von einem Sony Handy mit Hardwaretastatur :)
 

Ähnliche Themen

V
Antworten
7
Aufrufe
2.151
noob_fl
noob_fl
R
Antworten
0
Aufrufe
1.204
ralf4u
R
Touhy
Antworten
16
Aufrufe
13.221
siyman
S
Zurück
Oben Unten