1. dk99, 29.10.2012 #1
    dk99

    dk99 Threadstarter Neues Mitglied

    Hallo,

    ich besitze ein Sony Ericsson Xperia X10 und möchte versuchen darauf Cyanogenmod 9, genauer FXP 142, zu installieren.

    Habe schon einiges zum Thema Custom Rom flashen gelesen.

    Ich muß ja den Bootloader entsperren um CM 9 zu flashen.
    Sollte mit dem Flashtool 0.9.8.0 auch kein Problem sein.

    Nur verliere ich, wie ich das verstanden habe, beim Entsperren des Bootloaders die DRM Rechte.
    Wie genau wirkt sich das aus?
    Welche Apps funktionieren danach nicht mehr?

    Es soll ja auch eine Testpointmethode geben, um den Bootloader zu entsperren, bei der die DRM Rechte erhalten bleiben. Funktioniert dies auch beim X10?

    Bisher habe ich keine Infos dazu gefunden, zumindest nicht für das X10.

    Vielleicht kann mir ja jemand meine Fragen beantworten.

    Danke schonmal.
     
  2. dk99, 30.10.2012 #2
    dk99

    dk99 Threadstarter Neues Mitglied

    Hab gesehen dass mein Beitrag wohl besser in den Bereich "Root / Hacking / Modding für Sony Ericsson Xperia X10" passt.
    Vielleicht wäre jemand so nett und könnte den verschieben.

    Danke :smile:
     
  3. noob_fl, 30.10.2012 #3
    noob_fl

    noob_fl Experte

    apps funktionieren alle

    DRM - Digital Rights Management ist ein Sicherheitsfeature dass verhindert, dass Musik und Filme auf mehrere geräte kopiert werden kann. In Anbetracht der Tatsache, das, gerade bei Musik, die meisten Anbieter davon abstand genommen haben, DRM geschützen Content anzubieten (AMAZON, itunes, Musicload usw.) ist DRM sowieso eher vernachlssigbar..

    wies mit dem epub Format bei büchern aussieht, weis ich nicht genau - also ob die übe die DRM Keys des gerätes oder durch andere keys gebunden werden
     
    dk99 bedankt sich.
  4. dk99, 30.10.2012 #4
    dk99

    dk99 Threadstarter Neues Mitglied

    Vielen Dank für deine Antwort.

    E-Books lese ich keine, daher ist mir das Epub Format egal ;)
    Und wenn alle Apps danach noch funktionieren, dann werd ich mich gleich mal ranmachen und versuchen CM9 zu flashen.

    Gruß dk99
     
  5. dk99, 31.10.2012 #5
    dk99

    dk99 Threadstarter Neues Mitglied

    So, hat leider nicht funktioniert Cm 9.1(FXP 142) zu flashen.
    Die heruntergeladene Datei enthält keine ftf Datei.
    Hab die Datei von hier: FXP142_CM9.1

    Könnte mir jemand sagen, wo ich die ftf Datei für Cm 9.1 bekomme?

    Danach hab ich Cm 7.2(FXP130) installiert. Das klappte ohne Probleme.
    Hier war auch eine ftf Datei vorhanden.
    Nur funktioniert hier der Kamera Zoom nicht. Ansonsten find ich die Cyanogenmod wirklich gut :thumbsup:
     
  6. Das-Ich, 01.11.2012 #6
    Das-Ich

    Das-Ich Experte

    Hi

    du entpackst die kernel.sin und erstellst mit dem FlashTool ein sogenanntes Bundle, dieses enthält dann den Kernel, welchen du dann mit dem FlahToll installieren kannst.

    MfG
     
    dk99 bedankt sich.
  7. dk99, 02.11.2012 #7
    dk99

    dk99 Threadstarter Neues Mitglied

    Hi,

    danke für die Info. Damit hats geklappt.
    Würde ja den Danke Button klicken, geht aber noch nicht. ;)

    CM 9.1 ist jetzt installiert und läuft auch, hab aber jetzt Probleme mit dem Internet. Und zwar mit W-Lan und normaler Datenverbindung.

    W-Lan wurde erst zwar aktiviert, hat sich aber nicht verbunden.
    Hab dann die FXP142 nochmals aufgespielt(natürlich vorher einen wipe des dalvik cache, der cache partition und data/factory reset).

    Jetzt wird das W-Lan gar nicht mehr aktiviert.
    Das mobile Internet funktioniert zwar, nur kommt es mir erherblich langsamer vor, als mit der Stock Rom.

    Und noch etwas: Sobald ich USB-Debugging aktiviere, wird mein X10 nicht mehr am PC erkannt. Erst nach einem Neustart gehts dann wieder.

    Keine Ahnung woran das liegt, bei der Installation habe ich, soweit ich weiß, keinen Fehler gemacht.

    Vielleicht weiß ja jemand von euch, was ich da machen könnte.

    Gruß dk99
     
  8. Das-Ich, 03.11.2012 #8
    Das-Ich

    Das-Ich Experte

    Zuletzt bearbeitet: 03.11.2012
    dk99 bedankt sich.
  9. dk99, 04.11.2012 #9
    dk99

    dk99 Threadstarter Neues Mitglied

    Hi,

    hab die Baseband Version 2.1.71. Soweit ich weiß, die aktuellste.

    W-Lan und mobiles Internet funktionieren allerdings jetzt. Keine Ahnung, warum. Habe eigentlich nichts geändert.

    Einzig der W-Lan Scan scheint nicht zu funktionieren. Ich muss die Daten manuell eingeben, dann gehts.

    Das Problem, dass mein X10 nicht am PC erkannt wird, besteht allerdings weiterhin. Jetzt aber gar nicht mehr, also nicht nur mit eingeschaltetem USB-Debugging.
    Fehlermeldung im Gerätemanager: Unknown Device, Dieses Gerät wurde angehalten, weil es Fehler gemeldet hat. (Code 43)
    Hatte aber auch schon andere Fehlermeldungen(weiß aber nicht mehr genau welche).

    Und noch eine Frage: Ist es sinnvoll, nach dem flashen einer neuen Rom, die Battery Stats zu wipen?
    Die Meinungen gehen da doch etwas auseinander. Laut Mythos geklärt: Wipe der Battery Stats ist nicht sinnvoll - Android Profis solls nichts bringen.

    Gruß dk99
     
  10. Das-Ich, 04.11.2012 #10
    Das-Ich

    Das-Ich Experte

    Hi

    das wipen der BatStats bringt nichts, es ist normal das nach dem Flash einer neuen Rom der Akku etwas schneller lehr wird, liegt meiner Meinung, am Medienscanner der erst alles an Fotos und Multimediadateien in seine Datenbanken laden muss, das kostet eben etwas mehr Akku und dauert etwas bis es sich eingespielt hat.

    Zu deinem PC, ich würde dir erstmal empfehlen alle alten Treiber zu löschen, google mal nach nicht mehr benötigte Treiber deinstallieren, da muss man im Gerätemanager was umstellen und dann kann man alle Treiber die man nicht mehr benötigt vom System runterschmeissen.
    Wenn du das erledigst hast installierst du dir alle aktuelle Treiber die du bekommen kannst für's x10.

    Als letztes kannste dann auch mal einen anderen USB-Port versuchen.

    MfG
     
    dk99 bedankt sich.
  11. dk99, 28.11.2012 #11
    dk99

    dk99 Threadstarter Neues Mitglied

    Hallo,

    bräuchte bitte dringend eure Hilfe.

    Nachdem ich mit CM 9.1 fürs X10 nicht wirklich zufrieden war(Lags, Freezes, USB Debugging hat nicht mehr funktioniert) wollte ich wieder auf CM 7.2 zurück.

    Hab zuerst in der CWM Recovery einen wipe des dalvik cache, der cache partition und ein data/factory reset durchgeführt.
    Soweit, sogut.

    Danach wollte ich die FXP 130 über CWM aufspielen. Funktionierte nicht da dies eine 7zip Datei war und nicht erkannt wurde.

    Ok, blieb nur mehr das Flashtool. Firmware entpackt und geflasht.
    Flash war erfolgreich, keine Fehlermeldung.

    Nur jetzt hängt das X10 beim Free Xperia Logo und macht keinen Mucks mehr. :scared:

    Ich kann auch nichts mehr machen, da es vom Flashtool zwar kurz erkannt wird, aber nur bis "Decive Connected with USB Debugging off".
    Das wars. Mehr kommt dann nicht mehr.

    Und in die CWM komm ich ebenfalls nicht mehr rein.

    Im Moment hab ich keine Ahnung was ich noch machen könnte. :confused:

    Ich hoff nur ich hab das Phone nicht gebrickt. :eek:

    Vielleicht wisst ihr ja was ich noch machen kann.

    Gruß dk99
     
  12. Das-Ich, 28.11.2012 #12
    Das-Ich

    Das-Ich Experte

    Hi

    nein haste nicht, du musst erst noch den CM7-Kernel flashen, mit dem Flashtool. Dazu nimmst du das Kernel-Paket, entpackst es, startest das enthaltene FlashTool, bringst dein Handy in den Flashzustand und dann drauf mit dem Kernel. Danach sollte dein Handy auch booten.

    Am besten nimmst du einfach den Akku raus, stöpselt das Handy an, nachdem du den Flashvorgang eingeleitet hast, Akku wieder rein, die Zurücktaste gedrückt halten und schauen was passiert, wenn das nicht klappt, nach dem Akku rein noch die Powertaste drücken, sollte aber unnötig sein.

    MfG
     
    dk99 bedankt sich.
  13. dk99, 29.11.2012 #13
    dk99

    dk99 Threadstarter Neues Mitglied

    Hallo,

    erstmal danke für deine Antwort.

    Ich dachte immer der Kernel wird mit der ROM mitgeflasht.
    Bei FXP 130 ist der Kernel auf jeden Fall dabei. Die kernel.sin war in der Firmware vorhanden und sollte eigentlich auch geflasht worden sein.

    Auf jeden Fall hat es nicht funktioniert. Ich kann im Flashtool nur den Flash Mode auswählen, aber nicht den Kernel Installer.

    Hab dann vesucht nochmal im Flashmode die Stock Rom zu flashen, die beim Flashtool dabei ist, ging wieder durch, ohne Fehlermeldung.

    Jetzt hängt das X10 beim Sony Ericsson Logo. :confused:

    Der letzte Versuch mit dem Flashtool wurde mit folgender Fehlermeldung abgebrochen:
    ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ERR_DYNAMIC="SIN header verification failed"

    Ich glaub mit aufspielen der Stock ROM wurde der Bootloader wieder gesperrt.
    Nur krieg ich den nicht mehr entsperrt, zumindest nicht mit dem Flashtool, da das Phone ja nicht richtig erkannt wird und alle Optionen bis auf Flash ausgegraut und nicht verfügbar sind.

    Gibts noch etwas das ich machen könnte?

    Gruß dk99
     
  14. Das-Ich, 30.11.2012 #14
    Das-Ich

    Das-Ich Experte

    Hi

    der Kernel ist zwar im Paket, als Kernel.sin, wird aber nicht mitgeflasht, dies muss seperat passieren, entweder man läd sich das Kernelpaket herunter, oder entpackt die Kernel.sin und baut mit dem Flashtool erstmal ein Bundle und flasht dieses.

    So wenn du einen Kernel flashen willst, dann musst du eine .ftf Datei nutzen, die findet man meist im FlashTool-Ordner unter firmwares. Sind diese vorhanden einfach das FlashTool starten, dann auf den Blitz und Flashmode auswählen. Dann werden alle Flashbaren Firmwares, respektive Kernels aufgelistet, dort wählst du das zu flashende aus und klickst Ok, danach machst du einfach das was das FlashTool sagt, und schon sollte der Kernel, oder was auch immer geflasht sein.

    Wenn du jetzt den CM-Kernel geflasht hast, bootet dein Handy nur, wenn auch CM7 drauf ist.

    Sollte dein Bootlaoder wieder gesperrt sein, dann kann man doch mit dem FlashTool dies auch ganz einfach per Klick erledigen, da ich Linux nutze gibt es diese Funktion leider nicht, und ich kann auch nicht mehr dazu sagen.

    Soviel zu CM.

    Meines Wissens kannste aber erstmal einen anderen Kernel flashen, wie Doom, der auch gesperrte Bootloader unterstützt, musst nur die Richtige Version herunterladen.

    MfG
     
    dk99 bedankt sich.
  15. dk99, 30.11.2012 #15
    dk99

    dk99 Threadstarter Neues Mitglied

    Hallo,

    habe ich doch gemacht. Die bei FXP130 enthaltene .ftf Datei mit kernel.sin geflasht.
    Hatte ja auch schon CM 7.2 und 9.1 ohne Probleme installiert, daher verstehe ich nicht warum es diesmal nicht funktioniert hat.

    Den Bootloader kann ich nicht mehr per Flashtool entsperren, da das X10 nur mehr bis zum Sony Ericsson Logo lädt und daher auch vom Flashtool nicht erkannt wird bzw. erkannt werden kann.
    Wie schon erwähnt ist das Plugin zum Entsperren des Bootloaders daher nicht verfügbar.

    Edit: Hat sich erledigt. Mit SEUS die Software neuinstalliert und mein X10 läuft wieder. :biggrin:
    Dachte zwar SEUS funktioniert nicht bei gerootetem Gerät, aber scheinbar doch.
    Danke für deine Hilfe nochmal.

    Gruß dk99
     
    Zuletzt bearbeitet: 30.11.2012
  16. Das-Ich, 30.11.2012 #16
    Das-Ich

    Das-Ich Experte

    Hi

    vielleicht haste nur die Kernel vertauscht, da der von CM7 nicht mit CM9 läuft und umgekehrt. Wenn du aber dein Handy ausmachst und dann, wie am FLashTool beschrieben, das Phone in den Flashmodus bringst, dann sollte es auch gehen, wenn du nur das Sony-Logo siehst.

    Es freut mich das dein Phone ansich erstmal wieder läuft.

    MfG
     
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.