[Howto] Root mit Goldcard Lösung

  • 609 Antworten
  • Neuester Beitrag
Diskutiere [Howto] Root mit Goldcard Lösung im Root / Hacking / Modding für T-Mobile G1 im Bereich T-Mobile G1 Forum.

Hat euch diese Anleitung gefallen / geholfen?

  • Ja

    Stimmen: 93 76,9%
  • Nein

    Stimmen: 9 7,4%
  • Bin noch am überlegen

    Stimmen: 19 15,7%

  • Anzahl der Umfrageteilnehmer
    121
manuel-89

manuel-89

Ambitioniertes Mitglied
Komme auch nicht weiter...

Bin folgendermaßen vorgegangen:


  1. G1 mit orig. SD Card über Usb kabel angeschlossen.
  2. SD Card Fat 32 unter Windows xp formatiert.
  3. Über Astro CID ausgelesen, qmat gesteratet etc, goldcard.img per mail schicken lassen
  4. Update.zip, goldcard.img, DREAIMG.zip, recovery.img auf externe festplatte kopiert.
  5. Über ubuntu das ganze mit Terminal gemacht, goldcard.img wurde erfolgreich kopiert.
  6. DREAIMG.zip auf sd card kopiert und dort entpackt, danach recovery.img und update.zip auf die sd card kopiert.
  7. usb kabel vom g1 abgezogen, g1 ausgeschaltet.
  8. mit kamera taste und ausschalttaste gestartet und hier kommt dann der regenbogenmodus, wobei hier dann für einen ganz kurzen moment der text file not fount oder so steht was aber nur sehr sehr kurz dasteht, danach sieht man nur den regenbogen modus.
Habe die dateien in keine extra ordner oder sonst etwas auf der sd card liegen..
 
B

bexorn

Fortgeschrittenes Mitglied
fat 32, dreaimg.zip auf sd karte, dreaimg.zip entpackt auf sd karte.
recovery.img und update.zip auch auf sd-karte.

wenn ich den regenbogenmodus starte kommt erst der regenbogen, dann für ne halbe sek weißer bildschirm wo was blaues geschrieben steht, glaube "no image", kann das sein das ich doch keine goldcard habe? also das unter ubunto "xxx bytes kopiert" nicht richtig war?


...gleichschnell mit Manuel-89
 
manuel-89

manuel-89

Ambitioniertes Mitglied
seltsam, unter windows xp nochmal auf die sd card nachgesehen und da war die dreaimg datei was ich unter ubuntu entpackt habe mit 0kb, habe die jetzt über windows einfach nochmal entpackt, jetzt kommt nach dem regenbogen nach loading, checking und dann not allow und ein paar zahlen, vl falsche goldcard.img datei?
 
McLin

McLin

Erfahrenes Mitglied
Ja Ihr solltet die CID umkehren mit qmat... Not allowed bedeutet dass ihr keine Goldcard habt...

DREAMIMG.nbh
 
manuel-89

manuel-89

Ambitioniertes Mitglied
McLin schrieb:
Ja Ihr solltet die CID umkehren mit qmat... Not allowed bedeutet dass ihr keine Goldcard habt...

DREAMIMG.nbh
also auf dem bild ist die endung großgeschrieben also .NBH
entpackt ist es kleingeschrieben, keine ahnung ob das von bedeutung ist, also hab das mit qmat gemacht und meine CID umgekehrt, aber werde den schritt einfach nochmal versuchen.
 
manuel-89

manuel-89

Ambitioniertes Mitglied
Habe mir jetzt Terminal Emulator Installiert.
cat /sys/class/mmc_host/mmc1/mmc1:*/cid > /sdcard/serial.txteingegeben und folgende cid erhalten:
0353445355303247804126905d008be4

qmat -> crypto toolbox -> htc ausgewählt -> code reinkopiert -> reverse string:
e48b005d902641804732305553445303

auf der seite Free G1 goldcard generation !
mail adresse und darunter bei cid e48b005d902641804732305553445303 reinkopiert.

goldcard.img mit 394byte per mail erhalten.

dateien auf externe festplatte kopiert, sd card fat32 formatiert.
werde jetzt das ganze wieder unter ubuntu machen..
 
manuel-89

manuel-89

Ambitioniertes Mitglied
Unter ubuntu:
goldcard.img von externe festplatte auf desktop kopiert.
terminal gestartet, mount eingegeben, folgendes erhalten:
/dev/sdc1 on /media/G1 type vfat (rw,nosuid,nodev,uhelper=hal,shortname=mixed,uid=1000,utf8,umask=077,flush)
danach folgendes eingegeben:
cd Desktop
dd if=goldcard.img of=/dev/sdc1
Hier folgende meldung bekommen:
0+1 Datensätze ein
0+1 Datensätze aus
384 Bytes (384B) kopiert, .........

Danach DREAIMG.zip auf sd card, hier entpacken.
danach recovery.img und update.zip kopiert.
usb kabel vom g1 raus, g1 ausgeschaltet, mit kameraknopf und ausschalttaste gestartet und wieder funktioniert es nicht =(
 
McLin

McLin

Erfahrenes Mitglied
OHNE DIE 1!!!! /dev/sdc
 
manuel-89

manuel-89

Ambitioniertes Mitglied
McLin schrieb:
OHNE DIE 1!!!! /dev/sdc
omg..mein fehler...., steht sogar extra in der anleitung..
ok nochmal das ganze, thx fürs nerven bewahren ;)

edit: update in progress...

so gefällts mir schon besser, thx nochmal ;-)
 
Zuletzt bearbeitet:
B

bexorn

Fortgeschrittenes Mitglied
mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
cd sdcard
flash_image recovery recovery.img
cat recovery.img > /system/recovery.img

<--- hierbei bin ich gerade, doch verstehe ich nicht ob ich das alles hintereinander eingeben soll?
hab Telnet auf dem Handy installiert und tippe darüber ein, soll ich alles hintereinander oder wenn ein "," gezeigt wird, Enter drücken?
Sry für die vielen neuen grauen Haare ;)
 
McLin

McLin

Erfahrenes Mitglied
Für telnet brauchst du nen client egal ob handy oder windows, aber nur der Server wird auf dem Homescreen gestartet...

telnetd auf dem Homescreen <enter>
und dann client runterladen oder von windows starten wie auf den Bildern...
 
B

bexorn

Fortgeschrittenes Mitglied
"telnetd" eingetippt, Telnet auf dem Handy gestartet, "connect to local host"

mount -o rw (enter)
remount -t yaffs2 /dev/block/mtdblock3 /system (enter)
flash_image recovery recovery.img (enter)
cat recovery.img > /system/recovery.img (enter)

dann kommt: "cannot write recovery.img. read only"
 
McLin

McLin

Erfahrenes Mitglied
Bei dem mount befehl fehlt noch einiges;)

mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
 
B

bexorn

Fortgeschrittenes Mitglied
weiter kommt folgender fehler:
cannot create /system/recovery.img: read-only file system


habe folgendes eingegeben:

mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system (enter)

cd sdcard (enter)
flash_image recovery recovery.img (enter)
cat recovery.img > /system/recovery.img (enter)

hab auch
flash_image recovery recovery.img
cat recovery.img > /system/recovery.img (enter)

eingegeben
 
Zuletzt bearbeitet:
McLin

McLin

Erfahrenes Mitglied
Dass ist eine Zeile das ist dir klar?

Es darf keine Meldung kommen alles bleibt stumm kommt bei dir eine nach dem enter drücken je Befehl?
 
B

bexorn

Fortgeschrittenes Mitglied
hmm irgendwie ging eben gar nichts mehr, konnte nichtmal die sd carte mounten... hab aus spaß handy neugestartet und bin in den update screen gegangen, kommte das update dort installieren, scheint also zu gehen, lade grad das rc8 und dann mal schaun :)
 
B

bexorn

Fortgeschrittenes Mitglied
hmm jetzt häng das Handy jedesmal wenn ich es starte und home lange drücke...

ich sehe dieses Dreieck mit Ausrufezeichen drin und darunter das Handysymbol, doch da passiert nichts mehr... bleibt einfach auf dem Modus
 
McLin

McLin

Erfahrenes Mitglied
mach trotzdem weiter...

@bexorn

wenn das Bild da ist, Tastatur ausfahren ALT+l und dann ALT+W drücken...