Nach flash von rec170.img ist das G1 komisch

  • 2 Antworten
  • Neuester Beitrag
Diskutiere Nach flash von rec170.img ist das G1 komisch im Root / Hacking / Modding für T-Mobile G1 im Bereich T-Mobile G1 Forum.
BlutAxt74

BlutAxt74

Fortgeschrittenes Mitglied
Hi, habe heute nach der Anleitung von Android-faq mein G1 gerootet und geflasht.

Eigentlich hat alles gut geklappt, bis zu dem punkt wo ich das Recovery Image RA Dream 170 geflasht habe.

Seit dem bekomme ich nicht mehr ins Recovery Menü rein und das G1 stellt sich echt zickig beim booten an. Meistens bleibt es beim G1 Screen hängen.

Dann muss ich den Akku , SD Karte und USB Kabel entnehmen (mehrmals) und es neu starten.
Auch der Reset mit annehmen, Menü und auflegen klappt nicht immer, meistens nicht.

Habe jetzt mit dem Rom Manager schon das Recovery 2.5.0.7 wieder installiert (mehrmals) aber ich komme trotzdem nicht rein.

Ich kann ja leider nicht das ROM neu flashen, weil ich ja nicht in Recovery Menü komme.

irgendwie weiß ich jetzt nicht mehr weiter, weil die Hilfe zu dem Thema hilft irgendwie nicht.
 
W

winne

Android-Guru
Liest sich seltsam. Du kommst also mit gedrückter Hometaste nicht ins recovery, aber es bootet temporär mal ins OS durch.
Die Daten aus dem HBoot-Menü hätte ich gerne mal gesehen, wie schon geschrieben.

Danach gehts weiter.
 
W

wakkaluba

Neues Mitglied
Bei mir sieht es ähnlich aus ...
ich habe ein G1 von einem Kollegen bekommen, das er schon mal geflashed hatte.
Ich habe es mit der ursprünglich ausgelieferten Software bespielt, weil das geflashte Geräte so rund lief, wie ein Sack Nüsse.
Er musste unbedingt the latest and greatest aufspielen, was darin resultiert hat, das selbst ein Menü öffnen 5-10 Sekunde gedauert hat.

Soweit ich mich entsinne hatte ich auch das ursprüngliche recovery image eingespielt, das auch lief, wenn ich nicht verkehrt liege... Es hat zwischenzeitlich ein 3/4 Jahr rumgelegen, weil ich in der Zeit ein neues Handy bekam.

Nun benötige ich es aber und wollte es aktualisieren.
TelnetD angeschmissen, telnet installiert und auf localhost eingeloggt.
mtdblock3 auf System mit Lese-/Schreibrechten gemountet und per flash_image das recovery image eingespielt und in system/recovery.img reingestreamed.

Als Image hatte ich auch Amon Ra's 1.70 recovery aufgepsielt.
Das Handy startet normal und alle Hardkey Kombinationen beim Bootup gehen...AUSSER der Homekey. Wieso wundert mich das bloß nicht :rolleyes2:
Beim starten in das Recoverymenü bleibt das Handy im G1 Screen auf Ewig hängen.

Ich habe es auch mit anderen Ansätzen versucht in Ordnung zu bringen:

  • dem CM recovery Image
  • ältere Versionen
  • mit MRU-0.3.1 eingespielt, um es mit einer anderen Methode als Telnet zu nutzen
  • modifizierten Recover Image
  • Soft- und Hardreset
  • Wipen vom Betriebssystem, wie auch dem HBoot aus (Home und Back Taste beim Starten gedrückt halten und halten, bis das Regenbogenmenü durchlauft und die Manufacturer Wipe Option erscheint)
Egal was ich mache, immer der selbe Mist.
Ist da vielleicht ein vermurkster Loader drauf?
Wenn ja, kann ich den irgendwie ersetzen?


Im Regenbogenmenü, sieht man folgendes:
DREA110 PVT 32B
HBOOT-0.95.0000
CPLD-4
Radio-1.22.12.29


In der Info des OS:
Baseband 62.33.20.08U_1.22.12.29
Build Number kila_uk-user 1.0 TC5-RC7 112931
Kernel 2.6.25.01843.gfea26b0


Das Gerät funktioniert, aber das veraltete Betriebssystem macht mich kirre.
Achja... was nicht funktioniert sind Programme die mit der SU oder Datei Funktion hantieren.
Ein stinknormaler File Manager, wie auch einer mit SU funktion schmiert ab.
Androot ebenso. Selbst Tools, mit denen man nur abfragt, ob Root Rechte aktiv sind, schmieren weg.


Gruß
Jan

HAH!
Danke an android-newreco :)
Mit diesem Image http://android-newreco.googlecode.com/files/nr-recovery-v0.7.5G.img geht es wieder
 
Zuletzt bearbeitet: