T-Mobile Pulse: Root, Android 2.2 - final Edition

  • 936 Antworten
  • Neuster Beitrag
D

DerGraue

Ambitioniertes Mitglied
So, melde mich aus diesem Teil des Forums mehr oder weniger ab. Habe wie in einem meiner älteren Posts erwähnt die Ultimative Lösung für ein flottes Smartphone gefunden: In den Laden gehen und eine I9000 kaufen. Super Fix und macht echt Spaß. Werde nun das Pulse wieder von 2.2 auf Original downgraden und dann abstoßen. Falls jemand interesse hat, PN an mich. Ansonsten landet es in der Bucht.
Gruß
DerGraue
PS: Bin weiterhin immer mal im I9000 Forum unterwegs und schau auch immer mal wieder hier rein, das gebastel hatte ja schon ne Menge Spaß gemacht ;-).
 
S

SirNuton

Ambitioniertes Mitglied
Ich hab mal für einen Benutzer hier eine einfache Anleitung getippt, wie man das Pulse ganz ohne Bootloader, im Prinzip sogar ohne USB auf einen (beliebig) neuen Stand bringen kann. Weil ich die immer mal wieder verschickt hat und bis jetzt jeder recht glücklich damit war schreibe ich sie einfach mal hier rein.

Wichtig: Die Schritte sind knapp gefasst. Ihr solltet nichts tun, was ihr nicht versteht. Außer ihr vertraut mir vollkommen. Und ihr solltet mir nicht vollkommen vertrauen. Also: Alles auf eigene Gefahr

Pulse von 1.5 auf 2.2 Flashen am Beispiel von AIO (veraltetes System, aber auf alle Custom-ROMs übertragbar)

0) Sichern aller wichtiger Daten.

1) Installieren des offiziellen britischen 2.1 Updates

- Download dieser Datei: http://support.t-mobile.co.uk/librar...0Android21.zip
- ZIP-Datei entpacken, den enthaltenene dload-Ordner auf die SD-Karte des Handys verschieben (wichtig: NICHT in einen Unterordner)
- Handy ausschalten
- Diese Tasten drücken und halten: Power + Rot + Volume Up = Anschalten + Auflegen + Lauter
- Handy fragt ob Update durchgeführt werden soll. Bestätigen. Erster Boot (erstes Hochfahren) kann über 5 Minuten dauern. Wenn sich nichts mehr tut. Akku raus, wieder rein, dann klappts. Und keien Angst, so fürchterlich langsam bleibt es ganz und gar nicht ;)

2) Rooten (=Administratorrechte erlangen)

- App "z4root" aus dem Market installieren
- z4root ist selbst erklärend, einfach auf "Root", der Rest verläuft automatisch
- Handy startet neu

3) Recovery

- App "ROM-Manager" aus dem Market installieren
- ROM-Manager fragt, ob es ClockworkMod-Recovery installieren darf. Erlauben. Neustart abwarten.

(3.1, wenn Swap und A2SD noch nicht eingerichtet)
- Im ROM-Manager Partition SD-Card auswählen
- Werte (von mir geschätzt):
Code:
    SD    Class 4        |    Class 6
    -----------------------------------------
    Swap    16 MB        |    32/64 MB
    ext        256/512 MB, je nach Größe
4) 2.2 AIO

- Diese beiden Dateien downloaden. NICHT entpacken, nur auf die SD-Karte verschieben (Alternative Downloads: https://www.dropbox.com/s/092f1dgu5gt5epu)
https://weblappark.hu/~cvk/pulse/ind...20AIO%20v7.zip
http://dl.dropbox.com/u/19036985/M0D...Richard%29.zip
- Handy ausschalten
- Diese Tasten drücken und halten: Power + Red+ Menu = Anschalten + Auflegen + Menu
- Handy startet in Recovery-Modus
- "Flash ZIP from SD-Card" auswählen, dann zur ROM_cm6_AIO_v7.zip [oder alternatives ROM] navigieren, bestätigen
- "Flash ZIP from SD-Card" auswählen, dann zur Gapps_FIXED_Hopefully_copied_from_Richard.zip [oder alternative Gapps.zip] navigieren, bestätigen
[- wenn vorhanden und gewollt: A2SD.zip installieren]
- Reboot auswählen
 
Helix

Helix

Experte
Threadstarter
Ja, mein How2 ist veraltet, ich weiß...


Ich nehme deinen Post am Wochenende mal komplett auf, das alte System ist echt für die Tonne mittlerweile. Ich würde mal gerne wissen, wie viele User dem Pulse noch treu geblieben sind, es ist jetzt ja echt schon in seine Jahre gekommen...
 
B

BlinkyBob

Fortgeschrittenes Mitglied
Also ich hab meins noch^^ läuft allerdings nur mit nem FLB 1.6 rom, da dieses bei mir am stabilsten läuft.
Aber wahrscheinlich wird das Pulse in nächsten halben jahr weichen müssen...
 
C

Christian72D

Stammgast
Nachdem mein NAND wohl platt war habe ich das Handy am Mittwoch bei T-Mobile abgegeben und Freitag ein Austauschgerät zurück bekommen.

Es war wieder die Original 1.5 drauf, also bin ich die komplette Anleitung Punkt für Punkt durchgegangen, und beim letzten Punkt (Flashen des neuen ROMs) dann tritt dann wieder der (bei mir bekannte) Fehler auf: https://www.android-hilfe.de/forum/root-hacking-modding-fuer-t-mobile-pulse.48/pulse-defekt.132088.html

Kann ICH denn irgendwas komplett falsch machen daß es doch wieder genauso aussieht?
 
S

SirNuton

Ambitioniertes Mitglied
Guck mal hier ein paar Beiträge oben drüber, da hab ich mal eine alternative Variante gepostet, die neuer und einfacher durchzuführen ist. Schau einfach mal obs nach der läuft.
 
C

Christian72D

Stammgast
Mhhh, ich finde "z4root" aber nicht im Market, auch nicht wenn ich am PC danach suche.
 
C

Christian72D

Stammgast
Auch gefunden, es kommt die Meldung daß es nicht installiert werden kann. Fehler beim Parsen.

Kann es sein daß die aktuelle Version nicht mehr mit unserem Gerät kompatibel ist?
 
S

SirNuton

Ambitioniertes Mitglied
Bist du sicher, dass du genau nach Anleitung vorgegangen bist?

Vielleicht hat jemand hier im Forum noch eine alte Version von z4root, ich befürchte ich hab keine mehr.

EDIT: Ohne jegliche Garantie. Die Tiefen des Internets bringen die 1.0.1er Version hervor: http://megaupload.com/?d=21OODNFO Keine Ahnung ob das klappt, keine Ahnung ob die richtig ist, keine Ahnung ob du dir was zerschießt. Ich denke eigentlich es sollte nix schiefgehen ;) Deine Entscheidung!
 
Zuletzt bearbeitet:
C

Christian72D

Stammgast
Was kann ich denn bisher falsch gemacht haben?
Also ich konnte das Tool weder direkt von xda runterladen noch per QR Code und selbst als ich es mir per Mail rübergeschickt hatte ging es nicht.

Und auch bei der alten Version bekomme ich einen Parsingfehler! :(
 
B

balu62

Neues Mitglied
So, jetzt wird seit langem hier auch mal wieder geschrieben.
Hallo!
Ich bin ja ein absoluter Android-Neuling, nutze selbst 2 Samsung i8910HD, also Symbian FW.
Die sind allerding auch von mir geflasht worden.

Jetzt hab ich mal mit Android angefangen.
Das neue Handy meiner Tochter, ein Ideos X3 hab ich erfolgreich gerootet und auch den aktuellsten Cyanogen-Mod draufgeflasht.
Läuft super!

Dafür bekam ich ihr Pulse, welches ich ja dann nun auch flashen wollte.
Bis zum Android 2.1 hat das ja noch alles wunderbar funktioniert,
aber dann kam das Android 2.2.........

Irgendwas muß ich falsch gemacht haben.
Hab jetzt das ganze Pulse Forum durch und auch das gemacht, was andere auch bei diesem Problem machten, also ziemlich viele Hilfen.
Finde ich echt klasse hier.

Nun zu meinem Problem:
Nach dem Flashen wollte ich das Pulse neu starten, aber da hatte sich nicht mehr getan, es blieb mehrfach entweder beim Android Schriftzug stehen uder es ging noch kurz weiter zu T-Mobile (mit "Kringel"), aber das war es dann auch.
Hab dann direkt nach "VitaminC's Anleitung verucht, es zum laufen zu bringen, aber da geschah nichts.
Hab dann nach und nach das Pulse Forum durchgelesen und viele andere Ratschläge befolgt, aber da ist bisher nur Eins passiert:
Es bleibt beim booten bei dem Android Schriftzug hängen, aber nicht beim dem Schriftzug den ich bisher kannte, sondern bei einem solch kleinem, daß man fast ne Brille dafür braucht (zumindest ich, in meinem Alter).
Wenn ich den Boot-Recovery starte, steht unten:
Build: RA-pulse-v1.2.3
E.Can't find MISC:
E:Can't mount CACHE:recovery/command
E:Can't find MISC:
E:Can't mount CACHE:recovery/log
E:Can't open CACHE:recovery/log
E:Can't find MISC:

Das nun mal die ersten Infos.

Bedanke mich jetzt schon für eure Hilfe!
 
D

der_peter

Fortgeschrittenes Mitglied
Hattest du nen Wipe gemacht?
 
B

balu62

Neues Mitglied
Hi!
Ja, Wipe hatte ich gemacht, so, wie in der Anleitung beschrieben.
Was mir am meißten zu denken gibt it ja dieser >kleine< Android Schriftzug.
Und eben daß mir im Boot-Recovery gesagt bekomme, daß bei >E< nicht alles gefunden wird.
Naja, mal abwarten, vielleicht hat ja einer noch ne Idee...
 
androidbär

androidbär

Ambitioniertes Mitglied
Hallo zusammen,
so habe jetzt nach vielen Versuchen wieder ein alufendes Pulse :scared:

In der Anleitung ist so einiges nicht ganz klar....

Neues Recoverypaket mit ClockworkMod 2.5 - Root über die Gratisapp z4root wegen 2.1 ?????

Habe ich so nicht machen können weil keine App zum Rooten ?

Nächstes Problem SD Karte partitionieren - geht nicht mit 2.5 !

O.k. fragt jetzt nicht wie ich es wieder ans laufen bekommen habe - über jede Menge Goback - und - Apps installieren - und - offizielle updates - nach vielen Versuchen lief dann eins nach dem anderen :razz:

Nur was ich jetzt beim FTB 09 vermisse ist Apps2SD wo finde ich das ???

Wo finde ich denn die Kernels zum übertakten ??

Dann wird mein Phone jetzt als 8230 angezeigt ?? Firmware 2.1 update1

Ist das denn richtig ?????

Gruß
 
Helix

Helix

Experte
Threadstarter
Habe ich so nicht machen können weil keine App zum Rooten ?
In der Tat, habe ich wohl vergessen zu integrieren, danke für den Hinweis ;) Lade eine gefixte Version hoch. Fertig.


Nächstes Problem SD Karte partitionieren - geht nicht mit 2.5 !
Ich habs glaube ich mit nem Kartenleser gemacht. Hast du noch ein anderes Handy? Sonst probier es mit dem Rom Manager.


Dann wird mein Phone jetzt als 8230 angezeigt ?? Firmware 2.1 update1

Ist das denn richtig ?????
Richtig.
 
androidbär

androidbär

Ambitioniertes Mitglied
Hallo,
partitionieren ging dann hoffentlich über den Rom Manager...

Was ist mit aps2sd und übertakten ???

Gruß
 
Oben Unten