1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. hauteinterieur, 08.08.2011 #1
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Hallo ihr Lieben!

    Ich habe vor ein paar Tagen versucht, mein Armani mit speedmod zu flashen und dabei nicht bedacht, dass ich eine Captivate Version brauche.

    Nachdem icheinige Fehler feststellen musste, habe ich das Handy wieder mit der Originalsoftware von Samfirmware geflasht, nach dem Startbildschirm kommt jedoch leider nur ein Schwarzer Bildschirm und das Handy vibriert gelegentlich - was mache ich falsch?

    .Pit und .PDA sind Original von der Website.

    Ich danke für Eure Hilfe!:rolleyes2:
     
  2. frank_m, 08.08.2011 #2
    frank_m

    frank_m Ehrenmitglied

    Hast du einen Wipe durchgeführt? War eine dbdata.rfs im Flash-Image?
     
  3. hauteinterieur, 08.08.2011 #3
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Wipes hab ich gemacht.
    dbdata? Oh ja, das konnte er nicht finden...
    Woher bekomm ich das? Und wo muss das in ODIN hin?

    Danke schonmal!
     
  4. frank_m, 08.08.2011 #4
    frank_m

    frank_m Ehrenmitglied

    Normalerweise sollte das Bestandteil der Firmware sein, die du heruntergeladen hast. Du benötigst eine 3-teilige Low-Level Firmware. Damit sollten deine Probleme anschließend gelöst sein.

    Eventuell hilft eine dbdata aus einer i9000 Firmware. Das wird aber nur funktionieren, wenn das Flashlayout von i9000 und i9010 identisch sind. Ist das der Fall? Ich habe kein i9010 und kann es dir nicht sagen.
     
  5. hauteinterieur, 08.08.2011 #5
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Das handy sagt nun tatsächlich, dass es keine dbdata mounten kann.
    wo bekomme ich die her und wie flashe ich es aufs handy?
     
  6. frank_m, 08.08.2011 #6
    frank_m

    frank_m Ehrenmitglied

    Das ist ein typischer Fall. Wenn du mit Repart flasht, aber ohne dbdata im Image, dann tritt genau das auf.
    Du benötigst eine Firmware mit dbdata für dein i9010. Das ist die einzige Chance, die du hast.
     
  7. hauteinterieur, 08.08.2011 #7
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Aber die firmware ist von samfirmware... Woher sonst nehmen? ;-)
     
  8. frank_m, 08.08.2011 #8
    frank_m

    frank_m Ehrenmitglied

    Keine Ahnung.

    Kannst du nachvollziehen, ob das Flash-Layout so ist, wie beim i9000 oder beim Galaxy Tab? Falls ja: Dann kannst eine dbdata von da nehmen.
     
  9. hauteinterieur, 08.08.2011 #9
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Hmmm. Wie sollte ich - das Handy geht ja nicht ;-)
    Da ist noch eine zweite Armani Firmware. Normalerweise nicht meine Buildnummer - aber erstaunlicherweise gute 200mb größer. Ich werde die mal ausprobieren und berichten.
     
  10. frank_m, 09.08.2011 #10
    frank_m

    frank_m Ehrenmitglied

    Eine leere dbdata sollte ca. 1.3 MB groß sein.
     
  11. hauteinterieur, 09.08.2011 #11
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Edit: Eine i9000 Firmware funktioniert nicht. Deshalb hatte ich auch die Probleme.
    Klassischer Fall: Die Menütaste funktionierte nicht mehr, da das Armani ja vier Softtouch-Tasten unten hat -> falsche Belegung.
     
  12. frank_m, 09.08.2011 #12
    frank_m

    frank_m Ehrenmitglied

    Nee, das kannst du nicht vergleichen. Dass ein falscher Kernel oder ein falsches System Image nicht geht, ist klar. Die Hardware ist unterschiedlich, also muss das zusammen passen.

    Bei deinem dbdata Problem geht es nur darum, eine leere Partition erst mal zu formatieren. Wenn du für eine frische Windows Installation die Festplatte partitionierst, dann formatierst du sie ja auch, bevor du Windows installierst. Genau das fehlt für dbdata auf deinem i9010 im Moment. Du brauchst also lediglich eine leere dbdata in der passenden Partitionsgröße, das ist völlig unabhängig von der Hardware, sondern nur vom Flash-Layout. Die dbdata fürs i9000 und fürs P1000 sind auch identisch, obwohl die Hardware beider Geräte stark unterschiedlich ist (wenn man da die falsche Firmware flasht, kann man es einschicken, da geht gar nichts mehr. Hatten wir schon). Aber beide Geräte benutzen eine 128 MB große dbdata: Die kann man also austauschen. Wenn dein i9010 auch eine 128 MB große dbdata verwendet, kannst du problemlos die dbdata vom Tab oder vom i9000 nehmen.
     
    hauteinterieur gefällt das.
  13. hauteinterieur, 09.08.2011 #13
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Fehlende dbdata war in der csc der anderen armani firmware. das handy rödelt nun und updatet. bis jetzt keine roten warnmeldungen...
     
  14. hauteinterieur, 09.08.2011 #14
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    DAS HANDY FUNKTIONIERT WIEDER!

    Vielen herzlichen Dank! An der dbdata lag es einfach!
     
  15. frank_m, 09.08.2011 #15
    frank_m

    frank_m Ehrenmitglied

    Das freut mich. Heb dir die dbdata auf! Die sollte für alle weiteren Firmwareversionen ebenfalls funktionieren.
     
    hauteinterieur gefällt das.
  16. hauteinterieur, 09.08.2011 #16
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Ich scheine mir nur nun ein Simlock eingefangen zu haben - meine Simyo-Karte wird nicht erkannt -> kein Dienst...
     
  17. frank_m, 09.08.2011 #17
    frank_m

    frank_m Ehrenmitglied

    Das kann auch andere Ursachen haben. Was spucken folgende Tastencodes aus?

    *#06# (zeigt die IMEI-Nummer)
    *#1234# (zeigt die momentane Firmware)
    *2767*4387264636# (zeigt den Product Code)
     
    hauteinterieur gefällt das.
  18. hauteinterieur, 09.08.2011 #18
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    IMEI ist weg. (Wenn ich wieder telefonieren kann, stört mich das auch nicht)

    PDA I9010XXKB2
    PHONE Unknown
    CSC I9010OXAKB2

    Und beim letzten Code kommt auch nichts mehr.

    Modem nochmal aufspielen?

    DANK dir!
     
  19. hauteinterieur, 09.08.2011 #19
    hauteinterieur

    hauteinterieur Threadstarter Neuer Benutzer

    Hallo ihr Lieben!

    Nachdem ich eine regelrechte Odysee mit den falschen flash-Dateien (wegen Captivate und so...) hinter mir hatte, habe ich mein Handy mit der
    Originalfirmware von samfirmware geflasht.

    Soweit so gut, das Handy funktioniert fast einwandfrei.
    Nur habe ich kurz vor dem Ziel folgendes Problem: Es wird keine Simkarte erkannt.

    Abgefragt habe ich:
    *#06# (zeigt die IMEI-Nummer)
    *#1234# (zeigt die momentane Firmware)
    *2767*4387264636# (zeigt den Product Code)

    Angezeigt bekomme ich:
    IMEI ist weg. (Wenn ich wieder telefonieren kann, stört mich das auch nicht)

    PDA I9010XXKB2
    PHONE Unknown
    CSC I9010OXAKB2

    Und beim ProductCode kommt auch nichts mehr.

    Was kann ich tun, um mein Handy von einem schicken MP3-Player wieder in ein funktionales Handy zu verwandeln?

    DANKE für eure Hilfe!
     
  20. Donald Nice, 09.08.2011 #20
    Donald Nice

    Donald Nice Android-Guru

    hauteinterieur gefällt das.