Lokalen Webserver mit Chrome erreichen

  • 3 Antworten
  • Neuester Beitrag
Diskutiere Lokalen Webserver mit Chrome erreichen im Sonstige Hard- und Software-Fragen im Bereich Weitere Themen.
M

mrpaul

Neues Mitglied
Ich möchte gern mein privates Wiki (Mediawiki) mit Hilfe eines lokalen Webservers und meinem Android-Gerät mit Chrome anzeigen.

Leider kann ich durch Eingabe der IP diesen nicht erreichen. Von meinem Notebook, welches im gleichen (W)Lan ist, funktioniert es.

Auf dem Webserver (arch linux):
Code:
/etc/hostname
server
Code:
/etc/hosts
127.0.0.1 server
Wenn ich auf meinem Notebook im Browser (Firefox) https://server/mediawiki/index.php eingebe, sehe ich das Wiki. Die Eingabe von 192.168.xxx.10/mediawiki/index.php funktioniert ebenfalls, die Angabe in der Adresszeile wird sogar in https://server/mediawiki/index.php umgewandelt.

Wenn ich nun auf meinem Android-Gerät mit Chrome die gleiche IP aufrufe 192.168.xxx.10 sehe ich die unter lighttpd (Webserver) hinterlegte "Hallo Welt!"- Nachricht. Sobald ich aber die Adresse auf 192.168.xxx.10/mediawiki/index.php erweitere, bekomme ich eine Fehlermeldung angezeigt, wonach die Adresse nicht existiert DNS_PROBE_FINISHED_NXDOMAIN.
Ich verstehe nicht, wieso Chrome eine DNS-Anfrage losschickt, wenn ich doch schon die Ziel-IP meines lokalen Netzwerks angebe? Muss man da bei Chrome was einstellen?
Gibt es für Chrome unter Android auch eine Art /etc/hosts? Wenn ja, ich habe auch schon gelesen, dass diese ignoriert wird.
 
maik005

maik005

Urgestein
mrpaul schrieb:
Ich verstehe nicht, wieso Chrome eine DNS-Anfrage losschickt, wenn ich doch schon die Ziel-IP meines lokalen Netzwerks angebe?
mrpaul schrieb:
Die Eingabe von 192.168.xxx.10/mediawiki/index.php funktioniert ebenfalls, die Angabe in der Adresszeile wird sogar in https://server/mediawiki/index.php umgewandelt.
offenbar hast du das bei dem Webserver oder der Umleitung so eingestellt und Chrome kann "server" nicht auflösen.
Nutzt du am Smartphone Private DNS/einen anderen DNS als in deinem Heimnetz?
 
M

mrpaul

Neues Mitglied
Das der Aufruf von meinem Notebook aus gelingt, kann auch daran liegen, dass ich dort in der
Code:
 /etc/hosts
192.168.xxx.10 server
eingetragen habe.

Die DNS beziehen alle Teilnehmer per DHCP und als Adresse ist die Adresse des Routers eingetragen. Dass eine DNS-Anfrage schief geht ist klar, denn werder die Welt noch mein Router weiß, dass ich auf einem Netzwerkteilnehmer einen Webserver laufen habe.

Mich wundert, dass ich durch Eingabe der IP
Code:
192.168.xxx.10
des Webservers in Chrome die Standard-index.html-seite des lighttpg-Webservers angezeigt bekomme. Eine Erweiterung der Adresse auf eine Unterseite wie
Code:
192.168.xxx.10/mediawiki/index.php
geht jedoch schief. Die Eingabe von
Code:
192.168.xxx.10/mediawiki/index.html
(die index.html existiert im Gegensatz zu index.php nicht im Unterordner mediawiki) liefert jedoch als Ergebnis "Error 403". Hier kommt komischerweise kein DNS-Fehler.
 
Zuletzt bearbeitet:
maik005

maik005

Urgestein
mrpaul schrieb:
192.168.xxx.10/mediawiki/index.php
die Datei wird wohl eine Weiterleitung zu "server" enthalten?
Da ist dein Problem.
 
Ähnliche Themen - Lokalen Webserver mit Chrome erreichen Antworten Datum
3