Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

[SmartWatch 2][Bluetooth][JB 4.3] ständig nicht verbunden

  • 18 Antworten
  • Neuester Beitrag
Diskutiere [SmartWatch 2][Bluetooth][JB 4.3] ständig nicht verbunden im Sony Smartwatch 2 Forum im Bereich Sony Forum.
E

eponra

Fortgeschrittenes Mitglied
Hallo zusammen liebe Sony Gemeinde :)


Ich brauche mal die Hilfe der Sony Handybesitzer. :)


Folgende Problematik:
Meine nagelneue SmartWatch 2 kann ich erfolgreich mit meinem Handy pairen, sie zeigt sich kurz danach auch als verbunden an, kappt die Verbindung allerdings nach 5-30sek, und verbindet sich danach (von alleine) nicht wieder.

Starte ich die SmartWatch 2 neu, verbindet sie sich wieder, ich kann WatchFaces oder Hintergründe per App ändern, Apps wie Wetter funktionieren, und wieder 5-30sek nach erfolgter Verbindung kappt sie die selbige und verbindet sich (von alleine) wiederum nicht mehr.


Hinzu kommt erschwerend: Ich besitze kein Sony Handy. (bitte keine Steine werfen :biggrin: ich würde ja gerne, aber Sony bietet im Phablet-Format nichts mit DualSim an.) Ich habe ein Asus Zenfone 6 mit BT 4.0 und JB 4.3.
Ich dachte auch zwischendurch das es an Asus liegt.
Um das auszuschliessen, habe ich die SmartWatch 2 nochmals per Tool geflasht (weil sie sich nur dann wirklich zurücksetzt), und mit einem Acer Liquid S1 Duo (JB 4.2, BT 3.0) verbunden, und danach das gleiche mit einem Samsung Galaxy S5 (KitKat 4.4, BT 4.0; mehr Geräte hab ich leider gerade nicht rumliegen ;-) ) gemacht.
Bei allen das gleiche Ergebnis. Nach dem Pairing erstmal ein Connnect, danach nie wieder.

Ich dachte dann es läge am Wechsel von Bluez zu Bluedroid von Android selbst, aber dann dürften eure Geräte mit 4.3 und 4.4 sich auch nicht verbinden.
Ich habe hier allerdings von Xperia Z/ZX/etc-Besitzern auf 4.3 oder 4.4 gelesen, bei denen genau das mit der SmartWatch 2 tadellos klappt.


Nun will ich aber unbedingt diese SmartWatch 2 nutzen, und nicht wieder zurückschicken müssen. Nur deswegen habe ich vorgestern 4, gestern 6, und heute schon wieder 2 Stunden in Recherche gesteckt.


Und jetzt hatte ich noch eine Idee, bei der Ihr ins Spiel kommt:

Ich bräuchte von jemandem, der JB 4.3 oder KitKat 4.4 und eine SmartWatch 2 hat, die Dateien aus system/etc/bluetooth (sind bei mir auto_pair_devlist.conf, bt_did.conf, bt_stack.conf, bt_vendor.conf), weil ich vermute (hoffe) das dort ein fehlender oder falscher Parameter bei Asus/Acer/Samsung gelangweilt rumsteht. ;-)
Vielleicht weiss auch einer von euch mehr über BT, und sagt mir gleich das da nichts relevantes drin stehen kann, aber bis jetzt ist das meine letzte Idee.

Oder natürlich, wenn jemand noch eine andere Idee hat, immer gerne her damit. :)


Mit freundlichen Grüßen aus Bärlin,
Nico


P.S.: Zur Visualisierung der Problematik hänge ich mal noch ein paar Bilder an.





 
Zuletzt bearbeitet:
holzhupe

holzhupe

Stammgast
Alle Verbindungen der verschiedene Phones löschen. Die SW2 kann nur mit einem Phone verbunden werden.
Dann SW2 Reset. Alle BT Verbindungen aller getestete Phones löschen. Dann nur ein Phone die Software draufspielen dann pairen.

Das Deine SW2 gespackt hat, lag vermutlich daran,das es sich erstmal das Update gezogen hat. Jetzt haste ja die neuste Version drauf.

Und darauf achten das im Phone BT verbindung auf Automatisch ist nach dem pairen....

good luck
 
E

eponra

Fortgeschrittenes Mitglied
Ich habe vor jedem neuen Anlauf die SmartWatch 2 zurückgesetzt, und da das nie gereicht hat, immer nochmal die aktuelle Firmware über die SmartWatch 2 gebügelt (per Sony PC Companion).

Das die SmartWatch 2 nur eine Verbindung verträgt, liest man ja überall als erstes.

Daran liegt es also (leider) nicht

Und darauf achten das im Phone BT verbindung auf Automatisch ist nach dem pairen....
Wo kann man das denn einstellen? In den 3 erwähnten Handys habe ich bei BT unter Einstellungen nur "Telefon umbenennen", "Timeout für Sichtbarkeit" und "Erhaltene Dateien anzeigen". Mehr kann man ja leider nicht mehr ändern...
 
holzhupe

holzhupe

Stammgast
du musst im Connector noch diese Software installieren
 
E

eponra

Fortgeschrittenes Mitglied
Smart Connect und SmartWatch 2 SW 2. Ich weiss. Steht doch in meinem Text das ich Watchfaces und Apps installieren/ändern konnte, und das kann man ja nur über die SmartWatch 2 SW 2.
 
holzhupe

holzhupe

Stammgast
also schon komisch...hab die SW2 innerhalb 30 Sekunden auf meinem Tablet instaliert
 
E

eponra

Fortgeschrittenes Mitglied
Hast du denn JB 4.3 auf deinem Tablet?
 
holzhupe

holzhupe

Stammgast
KitKat aber auf dem Note mit 4.3 geht es auch
 
E

eponra

Fortgeschrittenes Mitglied
Dann ist natürlich noch möglich das die neue SmartWatch 2 einen defekt hat. Fu..

Alternativ: Kannst du mir die auto_pair_devlist.conf, bt_did.conf, bt_stack.conf, bt_vendor.conf, egal ob aus Tablet oder Handy, zukommen lassen?
Vielleicht steht in denen configs irgendwas anderes als in meinen...
Findest du unter system/etc/bluetooth auf deinem internen Speicher.
 
holzhupe

holzhupe

Stammgast
Autopair:

# Do NOT change this file format without updating the parsing logic in
# BT IF module implementation (btif_storage.c)

# This file contains information to prevent auto pairing with Bluetooth devices.
# Blacklisting by vendor prefix address:
# The following companies are included in the list below:
# ALPS (lexus), Murata (Prius 2007, Nokia 616), TEMIC SDS (Porsche, Audi),
# Parrot, Zhongshan General K-mate Electronics, Great Well
# Electronics, Flaircomm Electronics, Jatty Electronics, Delphi,
# Clarion, Novero, Denso (Lexus, Toyota), Johnson Controls (Acura),
# Continental Automotive, Harman/Becker, Panasonic/Kyushu Ten,
# BMW (Motorola PCS), Visteon, Peugeot, BMW (MINI10013), Venza (Toyota)
AddressBlacklist=00:02:C7,00:16:FE,00:19:C1,00:1B:FB,00:1E:3D,00:21:4F,00:23:06,00:24:33,00:A0:79,00:0E:6D,00:13:E0,00:21:E8,00:60:57,00:0E:9F,00:12:1C,00:18:91,00:18:96,00:13:04,00:16:FD,00:22:A0,00:0B:4C,00:60:6F,00:23:3D,00:C0:59,00:0A:30,00:1E:AE,00:1C:D7,00:80:F0,00:12:8A,00:09:93,00:80:37,00:26:7E,08:76:95,00:1E:B2,00:26:E8,60:38:0E

# Blacklisting by Exact Name:
ExactNameBlacklist=Motorola IHF1000,i.TechBlueBAND,X5 Stereo v1.3,KML_CAN

# Blacklisting by Partial Name (if name starts with)
PartialNameBlacklist=BMW,Audi,Parrot,Car,CAR

# Fixed PIN keyboard blacklist. Keyboards should have variable PIN
# The keyboards below have a fixed PIN of 0000, so we will auto pair.
# Note the reverse logic in this case compared to other's in this file
# where its a blacklist for not auto pairing.
FixedPinZerosKeyboardBlacklist=00:0F:F6

# Blacklisting by addition of the address during usage

Der ursprüngliche Beitrag von 12:20 Uhr wurde um 12:22 Uhr ergänzt:

Did:

# Device ID (DID) configuration
[DID]

# Record Number: 1, 2 or 3 - maximum of 3 records
recordNumber = 1

# Primary Record - true or false (default)
# There can be only one primary record
primaryRecord = true

# Vendor ID '0xFFFF' indicates no Device ID Service Record is present in the device
# 0x000F = Broadcom Corporation (default)
# 0x0075 = Samsung Electronics Co. Ltd.
vendorId = 0x0075

# Vendor ID Source
# 0x0001 = Bluetooth SIG assigned Device ID Vendor ID value (default)
# 0x0002 = USB Implementer’s Forum assigned Device ID Vendor ID value
#vendorIdSource = 0x0001

# Product ID & Product Version
# Per spec DID v1.3 0xJJMN for version is interpreted as JJ.M.N
# JJ: major version number, M: minor version number, N: sub-minor version number
# For example: 1200, v14.3.6
# Version bluez : 0x0100 , bluedroid : 0x0200
productId = 0x0100
version = 0x0200

# Optional attributes
#clientExecutableURL =
#serviceDescription =
#documentationURL =

#=================================================================================================#
# Device ID (DID) configuration
[DID]

# Record number: 1, 2 or 3 - maximum of 3 records
#recordNumber = 2

# Primary Record - true or false (default)
# There can be only one primary record
#primaryRecord = false

# Vendor ID '0xFFFF' indicates no Device ID Service Record is present in the device
# 0x000F = Broadcom Corporation (default)
#vendorId = 0x000F

# Vendor ID Source
# 0x0001 = Bluetooth SIG assigned Device ID Vendor ID value (default)
# 0x0002 = USB Implementer’s Forum assigned Device ID Vendor ID value
#vendorIdSource = 0x0001

# Product ID & Product Version
# Per spec DID v1.3 0xJJMN for version is interpreted as JJ.M.N
# JJ: major version number, M: minor version number, N: sub-minor version number
# Default: 0x0000, v00.0.0
#productId = 0x0000
#version = 0x0000

# Optional attributes
#clientExecutableURL =
#serviceDescription =
#documentationURL =

#=================================================================================================#
# Device ID (DID) configuration
[DID]

# Record number: 1, 2 or 3 - maximum of 3 records
#recordNumber = 3

# Primary Record - true or false (default)
# There can be only one primary record
#primaryRecord = false

# Vendor ID '0xFFFF' indicates no Device ID Service Record is present in the device
# 0x000F = Broadcom Corporation (default)
#vendorId = 0x000F

# Vendor ID Source
# 0x0001 = Bluetooth SIG assigned Device ID Vendor ID value (default)
# 0x0002 = USB Implementer’s Forum assigned Device ID Vendor ID value
#vendorIdSource = 0x0001

# Product ID & Product Version
# Per spec DID v1.3 0xJJMN for version is interpreted as JJ.M.N
# JJ: major version number, M: minor version number, N: sub-minor version number
# Default: 0x0000, v00.0.0
#productId = 0x0000
#version = 0x0000

# Optional attributes
#clientExecutableURL =
#serviceDescription =
#documentationURL =

Der ursprüngliche Beitrag von 12:22 Uhr wurde um 12:23 Uhr ergänzt:

Stack:

# Enable BtSnoop logging function
# valid value : true, false
BtSnoopLogOutput=true

# BtSnoop log output file
BtSnoopFileName=/sdcard/Android/data/btsnoop_hci.log

# Enable trace level reconfiguration function
# Must be present before any TRC_ trace level settings
TraceConf=true

# Trace level configuration
# BT_TRACE_LEVEL_NONE 0 ( No trace messages to be generated )
# BT_TRACE_LEVEL_ERROR 1 ( Error condition trace messages )
# BT_TRACE_LEVEL_WARNING 2 ( Warning condition trace messages )
# BT_TRACE_LEVEL_API 3 ( API traces )
# BT_TRACE_LEVEL_EVENT 4 ( Debug messages for events )
# BT_TRACE_LEVEL_DEBUG 5 ( Full debug messages )
# BT_TRACE_LEVEL_VERBOSE 6 ( Verbose messages ) - Currently supported for TRC_BTAPP only.
TRC_BTM=2
TRC_HCI=2
TRC_L2CAP=2
TRC_RFCOMM=2
TRC_OBEX=2
TRC_AVCT=2
TRC_AVDT=2
TRC_AVRC=2
TRC_AVDT_SCB=2
TRC_AVDT_CCB=2
TRC_A2D=2
TRC_SDP=2
TRC_GATT=2
TRC_SMP=2
TRC_BTAPP=2
TRC_BTIF=2
TRC_PROTOCOL=3
 
E

eponra

Fortgeschrittenes Mitglied
also bei autopair hast du einige Einträge mehr als ich, habe ich mal hinzugefügt. Dazu war meine vendor_id ausgeklammert in meinem File, und eine Textzeile im Stack hat gefehlt.

Ich flashe gerade nochmal die SmartWatch 2, damit die jungfräulich ist, und boote mein Handy neu. (damit die Änderungen auch aktiv sind)

Wollen wir mal sehen...

Erstmal schonmal Danke für die Files :)


Edith: Nein, hat nicht geholfen.

Trotzdem Danke. :) Dann schick ich die zurück. Schade eigentlich.







Und dann wieder mal:


damn...
 
Zuletzt bearbeitet:
holzhupe

holzhupe

Stammgast
für was ist das USB Kabel? Laden oder Software?
 
E

eponra

Fortgeschrittenes Mitglied
Damit flashe ich die Firmware auf die Uhr. Nur so wird die Smartwatch 2 wirklich zurück gesetzt.

Bestes Beispiel: nur nach dieser Art des zurücksetzens kommt sie damit zurecht, mittels eines Keys zu pairen (zeigt dann nämlich den Key auf der SmartWatch an), was bei einem normalen Reset über das Menu der SmartWatch nicht funktionieren.
 
holzhupe

holzhupe

Stammgast
Stop stop stop.....
nimm den Key raus. aber am Display der Uhr. Nicht am PC. Die Uhr hat amPC nichts zu suchen.

Also:

Key raus.
BT Verbindung am Handy löschen.
Uhr auf der Uhr unter Einstellungen zurücksetzten.
warten bis Uhr Symbol Uhr mit Pfeil Handy am Display zeigt.
Dann Handy BT anmachen.
Dann Smart Connect am Handy starten....
 
E

eponra

Fortgeschrittenes Mitglied
Das hab ich doch alles schon gemacht. ;-) und die Uhr hat für einen echten Reset sehr wohl was am PC zu suchen.


Wie gesagt, die geht jetzt zurück. Ich vermute einen Hardwaredefekt.
 
Shockwave71

Shockwave71

Erfahrenes Mitglied
Irgendeine App auf dem Handy, die Hintergrunddaten bündelt, oder nur alle z.B. 15 min abruft???
Hab ich mir mal ein Ei mit gelegt.....
 
19sleepless87

19sleepless87

Neues Mitglied
Hallo,

hatte auch ständige Abbrüche und Probleme bzgl. der Verbindung zwischen der SW2 und meinem XZU.

Hab dann reklamiert und eine neue bekommen, seit dem keine Probleme mehr - scheint ein Hardwaredefekt gewesen zu sein.

Grüße

Toby
 
D

DavidBozic14

Neues Mitglied
Hallo,
Bitte kann mir jemand weiter helfen, ich habe die Sony SW2 und das Sony Xperia Z und habe die selben Probleme...
die Verbindung geht dauernd weg und wieder hin.
Bitte Hilfe wenn ihr etwas wisst!
LG David :biggrin:
 
Holzi001

Holzi001

Ehrenmitglied
Wie lange hast Du die SW2 schon? Neu oder gebraucht?
Da keiner hier eine Lösung bieten konnte, schätze ich dass Deine SW2 evtl. auch defekt sein könnte.