Accelerometer kaputt?

H

Hellek

Fortgeschrittenes Mitglied
Threadstarter
Bei meinem G1 geht seit neuestem der Beschleunigungssensor nicht mehr. D.h. "GPS Status" zeigt bei "Acceleration" nichts mehr an, und es findet auch kein Wechsel zum Querformat mehr statt, wenn man das Gerät quer hält (betrifft natürlich alle Apps).

Ich habe das Gerät nie gerootet oder sonstwie modifiziert. Hat schon jemand dieses Problem gehabt, und kann man da irgendwas machen? Von einem Reset habe ich bisher abgesehen, da ich nicht scharf drauf bin alles neu zu installieren und zu konfigurieren, nur um vermutlich festzustellen, dass es eh nix bringt. Natürlich habe ich aber das Gerät abgeschaltet, Akku kurz entnommen, und neu gestartet. Hat nichts gebracht.

PS: Ziemlich nervig: Die Suche im Forum meldet "Die folgenden Wörter sind sehr allgemein und wurden in der Suchanfrage ignoriert : beschleunigungssensor". Sorry also, falls es dazu schon einen Thread gibt, ich konnte nur nach "Accelerometer" suchen, damit habe ich nichts gefunden.
 
goto

goto

Ambitioniertes Mitglied
Sieht ganz danach aus das er kaputt ist.
Du kannnst dir mal Bubble aus dem Market runterladen und schauen ob sich da überhaupt noch etwas tut:
Androidpit - Bubble
 
K

kicka

Fortgeschrittenes Mitglied
Such mal nach "Lagesensor defekt", da gabe es schonmal nen Tread oder -> Klick :)

Hatte vor einiger Zeit auch das Problem, allerdings hatte ich da schon das Cyanogen Mod drauf. Bei mir hat damals nur ein Wipe geholfen, danach ging der Sensor komischerweise wieder.

Lg
 
Zuletzt bearbeitet:
Kranki

Kranki

Ehrenmitglied
Das Problem tritt häufiger auf und ist in der Regel kein Hardwaredefekt.
Man behebt es mit root durch Löschen bestimmter Dateien:
Code:
rm /data/misc/akmd*
rm /data/misc/rild*
reboot
Ohne root wird man diese Dateien leider nur durch Wipen los.
Die OneClick-Methode funktioniert meines Wissens aktuell noch. Damit könntest du einmalig das Cyanogen-Recovery booten und damit obige Befehle an dessen Konsole ausführen. Weitermachen brauchst du das Rooten ja dann nicht, und zurückbleiben wird auch nichts, weil das System die originale Recovery von alleine wiederherstellt.
 
H

Hellek

Fortgeschrittenes Mitglied
Threadstarter
Danke für die rasche Antwort. An das Wort "Lagesensor" habe ich nicht gedacht. Ein Wipe scheint den Topics die ich damit gefunden habe zufolge, doch vielversprechender als gedacht :)

Edit: Oder ich probiere die Methode von Kranki, das klingt auch gut. Dieses Post war noch nicht da als ich ursprünglich geantwortet habe.
 
H

Hellek

Fortgeschrittenes Mitglied
Threadstarter
Mein besonderer Dank gilt Kranki. Habe erst jetzt Zeit gefunden mich mit dem one-click-recovery-flasher auseinanderzusetzen, hat prima funktioniert. Wie angekündigt bleibt hier auch nichts zurück: Nachdem ich einmal normal gebootet hatte, war der Recovery Modus wieder wie früher.

Ein Hinweis, falls jemand anderer es auch so macht: Vor die "rm ..." gehört diese Zeile:
Code:
mount /data

Hier der Link zu XDA-Developers falls man zur Sicherheit eine 2. Quelle sucht: xda-developers - View Single Post - [ROM] CyanogenMod - One Step Ahead (STABLE) [UPDATED 8/28- v4.0.4]

Tja jetzt bin ich vielleicht sogar auf den Geschmack gekommen mein Phone doch noch zu rooten, scheint ja wirklich nicht schwer zu sein :D
 
Oben Unten