Sipdroid (VoIP) schaltet sich immer wieder ab!

  • 11 Antworten
  • Neuester Beitrag
Diskutiere Sipdroid (VoIP) schaltet sich immer wieder ab! im VoIP Apps im Bereich Kommunikation.
E

egerlach

Ambitioniertes Mitglied
Liebe Leute,
Sipdroid auf meinem Medion Lifetab E7316, Android 4.2.2 schaltet sich immer wieder ab sobald es mit der Taste oben rechts in den Ruhezustand schalte, also das Display ausgeht oder das Display von alleine ausgeht. Es hängt ständig über USB am Strom, Strom sparen brauche ich nicht, ich will aber auch nicht, dass das Display die ganze Zeit an ist. Ich will darüber telefonieren mit meinem Bluetooth headset, was auch gut funktioniert und erreichbar sein. Da wo ich bin habe ich immer Strom.

Habe schon viel, viel gegoogelt: unter sipdroid -> einstellungen -> drahtlos: dort alles probiert, z.B. Bildschirm an, WiFi an/abschalten, ... überall mal Häkchen gesetzt und dann wieder nicht. Es ist ja grausam schlecht erklärt was "Bildschirm an" für eine Wirkung hat. Habe mittlerweil auch in den Adroid-einstellungen das WLAN -> Erweitert -> "WLAN im ruhezustand aktiviert lassen" aktiviert und Stromsparfunktion für WLAN rausgenommen. Das WLAn ist jetzt auch immer sofort da, wenn ich das Tablet wieder einschalte, WLAN scheint immer EIN-geschaltet zu bleiben, auch Sipdroid ist mit "grüner"-Punkt da, also aktiv. Aber es nimmt kein Gespräch an! ich muss immer erst vor jedem Anruf das Tablet einschalten, dann Sipdroid-App antippen, dann erst nimmt es Gespräche an. Wenn ich wenigstens an das Gespräch rankäme, wenn ich höre, dass ein anderes VoIP-Tel hier klingelt, aber NEIN: der Anrufer müßte wieder anrufen - Mist!

Habe auch die App "WLAN Sperre" installiert. Hilft auch nicht, die macht angeblich eh nichts anderes als das WLAN dauer zu schalten, was ich ja schon in den Android-WLAN-Einstellungen unter "erweitert" gemacht habe, siehe oben.

Ideal wäre wenn WLAN dauerhaft EINgeschaltet wäre, wenn Strom gesteckt, diese Funktion gibt es auch, habe ich gefunden, aber Sipdroid geht immer wieder aus. Und Sipdroid kann dauerhaft EINgeschaltet bleiben, habe schon viel MAle mit google gefunde, da berichten Handy-Nutzer, dass Sipdroid über Nacht den ganzen Akku leersaugt. Die haben es geschafft, ich noch nicht ... :(

Jetzt kommt der Hammer: selbst wenn ich das DIsplay auf Dauer-EINgeschaltet lasse, dieses sich also nie abschaltet, selbst dann deaktiviert sich Sipdroid nach ca. 2 Minuten! Ich muss nicht nur das Tablet einschalten, sondern Sipdroid immer wieder explizit anstupsen, dann erst klingelt es bei einem Anruf. Und Sipdroid schaltet sich etwa immer nach 2 Minuten ab. Und wie schon gesagt: Anzeige von Sipdroid oben links in der Statusanzeige ist "grün", also eigentlich aktiv. Daneben ist ein Zeichen für einen Aufgelegten Hörer, das ist immer da, ob Sipdroid funktioniert oder nicht.

Bin mit Sipdroid übrigens bei Sipgate-Provider.

Wer hat mir noch einen Tipp?

@ Es ist offenbar ein bug in Sipdroid, der bei manchen Android-Versionen auftritt: https://code.google.com/p/sipdroid/issues/detail?id=1058 Auch "Wifi aus/einschalten" deaktivieren bringt bei 4.2.2 nichts. Also weg mit Sipdroid ... :(

Gruss
Eckard
 
Zuletzt bearbeitet:
E

egerlach

Ambitioniertes Mitglied
Danke Hanseatix.
Habe gestern abend noch Zoiper selbst gefunden. Mann, viel besser!!!! Der hat auch den PC Software, dann brauche ich mein Tablet gar nicht dafür, toll! Leute nehmt Zoiper und für nur 33 Euro bei Business-Einsatz.

Allerdings geht Zoiper auch nur wenn das display "AN" bleibt. Ich vermute es bieißt sich einfach, wenn das Tablet "aus" ist und dennoch ein Programm "Lärm" machen soll. Aber Zoiper funktioniert richtig: klingelt ein anderes VoIP-Tel hier bei mir, dann muss ich nur das Tablet anschalten, und schon klingelt auch das und ich kann da annehmen. Das mache ich künftig aber vermutlich mit meinem Laptop (linux). Selbst für Linux hat Zoiper Software, waohh! Leider funktioniert mein Bluetooth-Headset noch nicht mit Zoiper, mit Sipdroid sofort funktioniert. Ich höre im headset jeden Tastenanschlag (klicks), aber das GEspräch wird da nicht an der BT-headset geleitet. Wer weiss da weiter? - Wenn ich hier keine Hilfe bekomme, dann wende ich mit an den Zoiper-Support, die rufen ja gerade dazu auf sie anzuschreiben. Ich werde die Software vermutlich auch kaufen, ich werde sie vermutliuch auch beruflich einsetzen.

Gruss
Eckard
 
ottosykora1

ottosykora1

Android-Hilfe.de Mitglied
schau doch nochmal nach ob du in deinem Android nicht den internen, von Android schon eingebauten SIP Client verwenden kannst. Ich habe damit bis jetzt die besten Erfahrungen gemacht, ohne gross was fummeln, geht es dann immer wie ein normales Telefon.
 
G

girouno

Gast
verstehe auch nicht, warum man nicht im WLAN erstmal den mitgelieferten VoIP-Client nimmt, zumal das der einzige ist, der zuverlässig auch mit BT-Headsets funktioniert und ggf. lästige Mehrfachabfragen beim Wählen verhindert.
 
H

Hanseatix

Experte
Mal ganz dumm gefragt: warum nutzt Du nicht ein "normales" SIP-Telefon oder einen entsprechenden Router(Fritz!Box, Easybox o. ä.) zum Telefonieren?
 
G

girouno

Gast
Hanseatix schrieb:
Mal ganz dumm gefragt: warum nutzt Du nicht ein "normales" SIP-Telefon oder einen entsprechenden Router(Fritz!Box, Easybox o. ä.) zum Telefonieren?
keine Ahnung, was den Fragesteller antreibt. Aber mein Smartphone habe ich eigentlich immer in der Hosentasche während die DECT-Telefone irgendwo im Haus verstreut sind. Außerdem klingelt Festnetz und Handy dann am gleichen Gerät - ist doch praktisch.
 
E

egerlach

Ambitioniertes Mitglied
girouno schrieb:
verstehe auch nicht, warum man nicht im WLAN erstmal den mitgelieferten VoIP-Client nimmt, zumal das der einzige ist, der zuverlässig auch mit BT-Headsets funktioniert und ggf. lästige Mehrfachabfragen beim Wählen verhindert.
danke für den Hinweis. Habe es getestet. Leider funktioniert die "alive"-Funktion nicht, weder bei Zusatz-Option "automatisch" noch bei "immer". Nach wenigen Minuten klingelt das HTC Desire S nicht mehr, auch bei abgeschaltetem zoiper nicht. Und es stört sich zudem daran, dass noch eine FritzBox7270 VoIP macht und daran auch ein Tel klingelt, denn dann ist der VoIP-Client von Android noch viel schneller "beleidigt" und verweigert Rufannahme. Mein HTC Desire hat Android 2.3.5. Zoiper schafft "alive" und stört sich nicht an der FritzBox. Leider funktioniert BT mit Zoiper nicht immer, wie Du schon sagtest, es muss sich nach jedem Anruf erstmal wieder "erholen", braucht Zeit, eine Pause, da wäre der mitgelieferte SIP-Client besser. Alles getestet mit WLAN also mit dauerhaften Internet-Zugang. Tja ... ist Android 4.x da besser? - Ich meine mit guter Hardware, also Handys der Oberklasse (Samsung Galaxy3/4/5, ..., ...)?
 
Zuletzt bearbeitet:
ottosykora1

ottosykora1

Android-Hilfe.de Mitglied
willst du zwei Clients gleichzeitig online haben für das gleiche SIP Konto?
oder was versuchst du ganz genau zu erreichen?
 
E

egerlach

Ambitioniertes Mitglied
einer würde reichen, aber der eingebaute schafft ja kein "alive". Daher ist zoiper der bessere, trotz seiner Schwächen bei BT-Headset.
 
ottosykora1

ottosykora1

Android-Hilfe.de Mitglied
du sollt nicht zwei Clients gleichzeitig bei einem Server anmelden. Dann geht alles. Weiss nicht was du meinst 'schafft kein alive'.
Keep alive Pulse schicken alle, kommt etwas darauf an ob das auf das gleiche Konto auch ein anderer Client macht oder ob der sich vor her richtig abgemeldet hat etc.
Den Intervall kann man auch einstellen. Kommt etwas darauf an wie der Server eingestellt ist wie oft man die KeepAlive schicken muss. Kann sicher der Provider sagen.
Aber wenn du gleichzeitig Fritzbox und sonstige Clients am laufen hast, dann musst halt damit leben dass es nicht richtig funktionieren wird.


Sämtlichen Apps sind die eingebauten, falls vorhanden, vorzuziehen wenn man nur telefonieren will.

Man kann also nicht verschiedene Programme oder gar Geräte testen.
 
E

egerlach

Ambitioniertes Mitglied
ich hatte Fritz deaktiviert, zoiper-App war beendet. Trotzdem machte der eingebaute kein "alive", sowohl nicht bei Einstellung "automatisch" noch bei "immer". Das hatte ich schon geschrieben. Zoiper macht kein Ärger, bis auf BT-headset. Habe jetzt beide SIP-Clients laufen, beim raustelefonieren nehme ich den eingebauten, dann funktioniert BT-headset gut. Empfang geht nur mit zoiper, daher ist Empfang mit eingebautem SIP-Client immer abgeschaltet. Damit kann ich gut leben.

Des weiteren werde ich das HTC demnächst "rooten". Dann gibts eine App Prioritizer, das macht auch bei Mobilfunk-Internet (unterwegs, kein WLAN) ein alive (und funktioniert hoffentlich). Also bekomme ich dann eingehende Rufe von zoiper angenommen bzw höre das klingeln. Die Gespräche drücke ich dann weg, weil das Gespräch meistens sowieso nicht funktioniert, weil die Mobilfunk-Anbindung für VoIP zu schwach. Dann rufe ich sofort zurück, das klappt perfekt, weil dann auch die Anrufer-Nr nicht nur bei zoiper angezeigt wird, sondern auch im eigenbauten Telefon-Journal. Also rufe ich dann über Mobilfunk zurück, bei dem ja BT-headset nativ gut funktioniert. Da der eingebaute SIP-Client sowieso NUR bei WLAN-Anbindung funktioniert, brauche ich zoiper auf jeden Fall. Also ist es so, wie es jetzt ist, das Optimum. Das zoiper "Alive" funktioniert sogar heute schon mit Mobil-Internet gelegentlich, vermutlich wenn das Handy sich per Internet irgendwas gesaugt hat oder whatsapp aktiv war und dann zoiper mit seinem "alive" die berühmten 90 Sekunden Glück hat.
 
Zuletzt bearbeitet: