FM Radio Stock .APK 4.2.2

  • 12 Antworten
  • Neuster Beitrag
S

Sukusuku

Neues Mitglied
Threadstarter
Hallo Rainbowgemeinde,

Ich habe mir auf meinem gerooteten Phone wohl irgendwie mein stock-fm Radio zerlegt. Leider finde ich im Netz nicht die passende apk. Bei allen Versionen wird die Installation nicht durchgeführt. Hat hier vielleicht jemand eine Idee, wo ich die richtige apk herbekomme? Bei mir ist sie nicht mehr funktionsfähig. Selbst ein Reset in den Werkszustand des Phones hat nix genutzt.
Hilflose Grüße von sukusuku

Edit: Rechtschreibung
 
Zuletzt bearbeitet:
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
@Sukusuku Wenn du einen Werksreset nicht scheust, kannst du mit dem Update-Programm von Wiko die Gesamtsoftware neu einspielen. Damit ist die Radio-App definitiv wieder auf dem Gerät. Bitte Anleitung exakt befolgen. Update Wiko RAINBOW
 
S

Sukusuku

Neues Mitglied
Threadstarter
Danke, guter Tipp. Habe ich schon versucht mit 2 entscheidenden Schwierigkeiten: flash von Wiki gibt es nur noch als Update für KitKat (4.4). Ich will gerne Jelly Bean (4.2.2) behalten. Außerdem funktioniert das nicht über das Phone (Meldung: neueste Version ist schon installiert; wahrscheinlich wegen root). Und, man glaubt es kaum, ich habe keinen Zugang zu einem Windows PC. Mit Linux und wine habe ich versucht, geht nicht. Vielleicht findet sich ja jemand, der/die die apk kopieren kann und die mir zur Verfügung stellt?
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Sorry, mir war nicht aufgefallen, dass Wiko die Seite umgebaut hat. Bisher war unten unter "Vorgängerversioene" auch ein Download des Programms für JB. Ist jetzt aber nicht mehr der Fall. Du bekommst das Programm aber noch direkt von den Wiko-Servern: http://update.wikomobile.com/RAINBOW_V1413651.zip

Da das Programm die Software komplett neu einspielt, kann Root da eigentlich nicht stören. Mit dem Update-Programm wurden schon komplett zerschossene Geräte wiederbelebt. Ich vermute, dass das eher an Linux hängt. Hast du denn wirklich keine Möglichkeit, an einen Windows-PC zu kommen? Oder evtl. die 30 Tage Demo von Windows 7 auf eine alte Festplatte installieren und danach wieder löschen. Ob du über eine Virtual Box flashen kannst, weiß ich leider nicht.
 
S

Sukusuku

Neues Mitglied
Threadstarter
Danke für deine Tipps! Die 4.4 Version von der deutschen Wiko Seite lässt sich nicht entpacken, aber das ist hier wohl bekannt, habe ich gelesen. Insofern ist dein Link wirklich wertvoll. Vor allem, weil es die alte Version ist :)

Über die Virtual Box zu flashen dürfte kein Problem sein, leider gibt es die Trial-Version von Windows nicht mehr.

Wenn ich mal viel Mut habe, versuche ich über Wine zu flashen, ein Programm, das Windows emuliert. Ich konnte dazu im Netz aber keine Erfahrungen finden...

Mit meiner Vermutung, dass root am Update hindert, meinte ich die Vorgehensweise ohne PC, direkt über das Phone. Die wird von Wiko als Alternative vorgeschlagen. Da behauptet mein Rainbow aber, ich hätte bereits die neueste Version der Software.
Ich werde zunächst Mal noch abwarten, ob sich noch eine andere Möglichkeit findet, wenn ich wieder Radio hören kann, schreibe ich hier rein, welcher Weg erfolgreich war. Nochmal vielen Dank für die prompte und fachkundige Hilfe.

Sukusuku
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Das sollte ausreichen ;) Windows 7 Professional mit Service Pack 1 - ISO-Datei | WinFuture.de
Wie schon gesagt, ist das aber ohne Key nur 30 Tage nutzbar, was in deinem Fall ja völlig ausreicht:
WinFuture schrieb:
Windows 7 Professional SP1 lässt sich auch ohne Eingabe eines gültigen Produktschlüssels installieren und 30 Tage lang testen. Danach müssen Sie einen Key kaufen.
Win7 ist unproblematischer als die moderneren Windows-Versionen, da hier die erzwungene Treibersignatur noch nicht so scharf ist und es nur einen Hinweis zum nicht signierten Treiber gibt, den man bestätigen kann. Bei späteren Windows-Versionen muss man vorher am System rumbasteln.
 
S

Sukusuku

Neues Mitglied
Threadstarter
Unglaublich! Schneller gehts echt nicht. Und dazu noch auf dem Silbertablett serviert:thumbsup:.
Jetzt brauchst du eigentlich nur noch vorbeikommen, und das für mich machen:biggrin:.
Muss das Wühlen im Netz wohl nochmal üben.
Ich werde Mal sehen, ob ich am WE dazu komme und melde mich hier dann nochmal.
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Vorbeikommen und machen? Klar, kein Problem. Anfahrt kostet 40 Euro pro Fahrtstunde. Rückfahrt natürlich auch. Für die Durchführung erhebe ich beim Wiko-Update eine Bearbeitungspauschale von 120 Euro. Jetzt fehlt mir nur noch deine Adresse :D.

Spaß bei Seite: Ich habe für Virtuelle Maschinen den Link immer mal wieder benötigt und wusste, wo man den Download noch bekommt ;). Habe mich aber bisher nicht getraut, aus einer VM heraus zu flashen. Dafür habe ich mein altes Notebook mit Windows 7 rumstehen. Das wird sonst kaum genutzt aber wegen der Treibersignaturen ist Win 7 da einfach am Besten ;).
 
S

Sukusuku

Neues Mitglied
Threadstarter
So, wie versprochen eine kurze Rückmeldung zum Flashversuch über VM in Ubuntu mit Windows 7: nach einigem Durchwurschteln läuft das Flashprogramm durch bis zu dem Punkt, an dem das ausgeschaltete Phone an USB angeschlossen wird. Leider erkennt die Virtual Box das Gerät im ausgeschalteten Zustand aber nicht. Wahrscheinlich ein Problem unterschiedlicher Treiber für USB von Ubuntu zu Windows.
Das Phone anzuschalten habe ich mich nicht getraut, weil das komplett gegen die Anleitung verstößt. Keine Lust auf Brick :blink:.
Vielleicht... vielleicht... vielleicht... versuche ich das in einem Anfall geistiger Umnachtung mal mit Wine, klüger wäre wohl, auf das Radio zu verzichten oder einen Freund mit Windows zu belästigen, mal sehen...
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Auch wenn es eigentlich nicht zum Brick führen könnte: Das Anschließen im eingeschalteten Zustand kann nicht funktionieren, da sich das Gerät dann im falschen Modus befindet ;). Du hast das Gerät wirklich erst dann angeschlossen, wenn du dazu aufgefordert wurdest?. Schau mal bitte in den Windows Gerätemanager. Was passiert da? Erscheint da kurz ein Gerät "Mediatek Prelaoder" und hat das ein gelbes Ausrufezeichen oder ist der Treiber korrekt installiert? Und ja, es ist korrekt, dass das nur kurz erscheint. Ist ein Sicherheitsfeature mit dem das versehentliche Flashen eines bereits angeschlossenen Gerätes verhindern soll.
 
S

Sukusuku

Neues Mitglied
Threadstarter
Hi,

die VM funktioniert leider anders: Wenn man ein Gerät an die USB-Buchse des Rechners anschließt, dann wird dieses zunächst vom Wirtssystem (bei mir Ubuntu) erkannt und bei Linux automatisch eingehängt. Linux "meldet" das Gerät dann an die VirtualBox weiter, es erscheint dort in einer Liste, aus der man dann auswählen kann, welches Gerät für das Gastsystem (in diesem Fall Windows) freigegeben wird. Das wird dann in Linux ausgehängt und steht Windows zur Verfügung. Wenn das ausgeschaltete Phone bei Linux nicht erkannt wird, kann es auch für die VM und schließlich für Windows nicht freigegeben werden. Die Treiber von Windows kommen also garnicht erst zum Zuge. Das ist der Architektur von Linux und auch der VirtualBox geschuldet. Entsprechend nützt ein Nachsehen im Gerätemanager nix. Ich hab´s auf Deinen Rat hin probiert und...es passiert leider nichts.

Eine Lösung, die mir einfällt, wäre Windows parallel einzuspielen und direkt damit zu booten. Werde ich wohl irgendwann auch noch probieren, obwohl mir Windows als vollberechtiges System auf meinem (Linux)Rechner extrem widerstrebt. Ist schon diskriminierend, dass die Flashsoftware von (nicht nur) WIKO nur auf Windows ausgelegt ist, obwohl das Betriebssystem der Telefone (Android) eigentlich einen Linux-Kernel hat.:thumbdn:

Aber wenigstens habe ich herausgefunden, dass die Trial-Version funktioniert.:D
 
M

mahoro

Neues Mitglied
Sukusuku schrieb:
...
Eine Lösung, die mir einfällt, wäre Windows parallel einzuspielen und direkt damit zu booten. Werde ich wohl irgendwann auch noch probieren, obwohl mir Windows als vollberechtiges System auf meinem (Linux)Rechner extrem widerstrebt.
...
Hi,
meine Lösungen waren in der Vergangenheit:
- Wenn Du die Platte in deinem Laptop einfach wechseln kannst (geht z.B. bei alten Thinkpads), einfach 'ne alte kleine Platte mit Win bespielen und bei Bedarf einschieben.
- Im Tower entweder dito oder eine Extra-Platte einsetzen und Windows per Grub starten.
- Den ungenutzten Dritt-, Viert-,...Rechner mit Windows aufsetzen und nur dafür nutzen.

Ciao, Martin
 
S

Sukusuku

Neues Mitglied
Threadstarter
Kurze Rückmeldung: ein geliehenes Laptop mit Windows 7 hat Abhilfe geschaffen. Flash von 4.2.2 hat funktioniert, alles läuft wieder, root wieder drauf mit allen von mir gewünschten Einstellungen. Danke nochmals für die Hilfe. Besonders die Download-links haben sehr geholfen. Alleine hätte ich die 4.2.2 Version niemals gefunden.
Viele dankbare Grüße von
Sukusuku
 
Oben Unten