Blackscreen nach Rootversuch am Mi A2 Lite

B

big panda

Neues Mitglied
Threadstarter
Ich hoffe, dass ich hier richtig bin und mir eventuell jemand helfen kann, denn ich weiß nicht mehr weiter.
Ich wollte heute mein Mi A2 Lite mit Magisk rooten. Nachdem es aus welchen Gründen auch immer nach einiger Zeit immer noch nicht funktioniert hat, hab ich mir gedacht, dass ich vielleicht irgendwas nicht ganz verstehe und wollte mir die neuste Stock Firmware flashen und mich an einem anderen Tag damit auseinander setzen.
Nachdem ich fertig war mit dem flashen war mein Handy in einer Boot Loop, daraufhin habe ich nun wieder auf meine alte Firmware downgraden wollen aber als ich mit dem flashen fertig war ging garnichts mehr. Ich habe ein Blackscreen und auch sonst gibt das Handy kein Zeichen von sich, außer dass der PC es erkennt.Ich habe jetzt schon gefühlt jedes Forum durchsucht und alles ausprobiert was ich gefunden habe. Aber nicht hilft.
Im EDL Modus erkennt der Geräte Manager zwar das Gerät aber MiFlash zeigt mein Gerät nicht als COM an wie ich es gelesen hatte und wenn ich es trotzdessen versuche zu flashen passiert nichts. Auch zeigt mir MiFlash mein Gerät genauso an wenn ich es einfach nur so an meinen PC anschließe. ADB und Fastboot erkennen das Gerät garnicht mehr.
Ich wäre sehr froh, wenn hier noch jemand einen Vorschlag hat, was man machen könnte!
 
BOotnoOB

BOotnoOB

Stammgast
big panda schrieb:
Ich habe jetzt schon gefühlt jedes Forum durchsucht und alles ausprobiert was ich gefunden habe.
Hallo,
es wäre hilfreich zu wissen, was genau du ausprobiert hast. Sowie die Versionen beider FWs, die du geflasht hast.
 
B

big panda

Neues Mitglied
Threadstarter
Die FWs die ich geflasht habe waren V10.0.3.0 & V10.0.10.

Ich habe probiert in den Fastboot- und Recoverymodus zu kommen, auf beides hat der Gerät allerdings nicht reagiert.
Unabhängig von gedrückten Tasten (Lautstärke + / - und Powerbutton, Lautstärke + / - während des einsteckens des USB Kabels oder alles gleichzeitig) zeigt MiFlash das Gerät mit einer ID von 0 an und wenn ich es versuche zu flashen geht die vergangene Zeit nur immer weiter ansonsten passiert nichts. ADB erkennt in keinen fällen überhaupt ein Gerät.
Danach habe ich versucht in den EDL Modus zu kommen um danach mit MiFlash die FW neu zu flashen aber auch dann erkennt MiFlash das Gerät nicht. Wobei ich mir nicht sicher bin ob das Handy überhaupt in diesen Modus kommt, da es keine Unterschiede beim erkennen des Gerätes gibt und auch das Handy keinerlei Feedback über vibrieren und LED gibt.
Über den Geräte Manager wird das Handy als HS USB Diagnostic 900E erkannt. Wenn ich bei dem Gerät die Treiber auf den HS USB QDLoader 9008 ändere, erkennt der MiFlasher zwei Geräte. Einmal das gleiche wie vorher und das andere mal ein COM20 Gerät, wenn ich dann versuche zu flashen bekomme ich die Fehlermeldung "Can not read from port COM20 oder "Can't recieve hello packet".
Außerdem habe ich auch versucht über den Qualcomm Flash Image Loader zu flashen was aber nur zu folge hat das sich das Gerät einmal kurz trennt und wieder neu verbindet und daraufhin nichts passiert.

Bei allen Versuchen zu flashen, nach dem Blackscreen habe ich die Firmware V10.0.3.0 verwendet da ich diese schonmal geflasht habe und sicher weiß, dass diese funktioniert.
 
H

harv

Erfahrenes Mitglied
Wenn du einen Blackscreen hast lässt sich ja schlecht erkennen, ob das Handy in einem bestimmten Modus ist, oder überhaupt eingeschaltet.
Vermutlich hilft hier nur noch der Hardware EDL-Mode: Aufmachen des Geräts und kurzschliessen der entsprechenden Kontakte (ich gehe davon aus, dass du nicht diesen gemeint hast oben?)

Alternativ könntest du mal unter Linux fastboot ausprobieren, dass ist nicht so pingelig mit den Treibern. Da reicht auch eine Live-Version ohne Installation. imo kannst du sowieso nur mit fastboot was erreichen, adb funktioniert nur bei gestartetem Android. Solange fastboot kein device erkennt, bist du nicht im fastboot modus. Den benutzt miflash auch (soviel ich weiss, habe kein windows).
 
Nuitiodo

Nuitiodo

Fortgeschrittenes Mitglied
Riecht nach einem HardBrick, da du den Downgrade versucht hattest und nu in der "AntiRollBack" gefangen bist.
Sollte dies der Fall sein, kommst du nur noch mit einem EDL Flash da raus, Sollte das der Fall sein, kostet dich das mal rund $50 (Ich musste es auch erst letzte Woche bei meinem 9T machen lassen :/)

Wenn du im EDL bist, zeigt er dir im Geräte Manager überhaupt was an? Hast du den die Qualcom Treiber installiert?
 
B

big panda

Neues Mitglied
Threadstarter
harv schrieb:
Wenn du einen Blackscreen hast lässt sich ja schlecht erkennen, ob das Handy in einem bestimmten Modus ist, oder überhaupt eingeschaltet.
Vermutlich hilft hier nur noch der Hardware EDL-Mode: Aufmachen des Geräts und kurzschliessen der entsprechenden Kontakte (ich gehe davon aus, dass du nicht diesen gemeint hast oben?)
Ich habe versucht in den Hardware EDL-Mode zu kommen aber entweder mache ich irgendwas grundlegend falsch oder es will aus irgendwelchen Gründen nicht in den Modus. Wenn ich die Kontakte kurzschließe und das Gerät währenddessen per USB verbinde erkennt keine Anwendung das Gerät in einer anderen Weise als wenn ich es ohne irgendwas zu machen anschließe.

Nuitiodo schrieb:
Wenn du im EDL bist, zeigt er dir im Geräte Manager überhaupt was an? Hast du den die Qualcom Treiber installiert?
Wie gesagt bin ich mir nicht sicher überhaupt in den EDL zu kommen. Der Geräte Manager zeigt das Gerät als Qualcomm HS-USB Diagnostics 900e an. Ob ich nun versuche in den EDL zu kommen oder nicht. Die Treiber habe ich installiert.
 
Nuitiodo

Nuitiodo

Fortgeschrittenes Mitglied
Ja, solange wie da nicht gerad steht " Qualcomm Hs USB Qdloader 9008 " bist du nicht wirklich im EDL Mode.
Achte bei der "testpoint" Variante darauf, das du Batterie und Display abgesteckt hast und das du die richtigen Qualcomm Treiber vorinstalliert hast.
 
Zuletzt bearbeitet:
B

big panda

Neues Mitglied
Threadstarter
Das habe ich befürchtet. Ich habe es mit einer Pinzette und einer Büroklammer jetzt gefühlt ewig probiert, aber es will einfach nicht.
Ich berühre beide Testpunkte aber es will nicht funktionieren. Ich denke das wars mit dem Handy.
 
Nuitiodo

Nuitiodo

Fortgeschrittenes Mitglied
Ich sag mal so, der nächste Dämpfer wäre dann eh das du ein EDL autorisierten Account brauchst um dort zu flashen, wenn du keinen hast, würde dich das ca. $50 kosten, für den Service.
 
H

harv

Erfahrenes Mitglied
Das Lite hat kein MIUI, sondern Android One. Da braucht es keinen Account. Ebenfalls hat das Teil kein Antirollback.

@BigPanda: zum EDL Mode kann ich nicht viel sagen, habe nur darueber gelesen und es selbst noch nie gebraucht. Frag entweder hier im Unterforum root oder such mal bei xda-developers.
 
Zuletzt bearbeitet:
Nuitiodo

Nuitiodo

Fortgeschrittenes Mitglied
Uff, ich dachte das wäre universal, dann ist das ja zu mindestens ein Vorteil vom A2/Lite. ;)
Hatte mich wohl getäuscht, da ich MIUI auf mein das A2 Lite geflasht habe.

Danke für die Info

@big panda, hast du es mittlerweile noch einmal probiert?
Zur Not einfach, ganz in Ruhe alles noch einmal von vorne machen. Schau das du die aktuellen Qualcom Treiber von deinem PC entfernst und dann die richtigen Installierst (achte darauf, das du die Treibersignatur abschaltest in Windows 10 - reboot mit gehaltener Shift Taste - Auswahlmaske 7). Und dann das Testpoint in Ruhe startest. Batterie - Display - Fingerprint - alles nicht verkabelt.
 
B

big panda

Neues Mitglied
Threadstarter
Danke für den Tipp! Habe mir jetzt die letzten Tage keine Gedanken darum mehr gemacht und habe jetzt heute in Ruhe alles nochmal auf 0 gesetzt und von vorn gestartet. Ich habe es geschafft in den EDL Modus zu kommen, ich hatte vorher nur die Batterie und nicht den Display getrennt. Jetzt läuft alles wieder!
Danke für die Zeit die ihr genommen habt um zu helfen! :)
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von MSDroid - Grund: Direktzitat entfernt. Du kannst jemanden auch mit @ Benutzername markieren. Gruß MSDroid
Nuitiodo

Nuitiodo

Fortgeschrittenes Mitglied
:) freut mich das du es wieder hin bekommen hast.
Und für die Zukunft, kein Rollback auf alte Versionen mehr :p
 
Ähnliche Themen - Blackscreen nach Rootversuch am Mi A2 Lite Antworten Datum
7
0
5
Oben Unten