Backup des Mi Note 10 mit TWRP schlägt fehl - Error 255

  • 11 Antworten
  • Neuester Beitrag
Diskutiere Backup des Mi Note 10 mit TWRP schlägt fehl - Error 255 im Xiaomi Mi Note 10 Forum im Bereich Xiaomi Forum.
F

Fu-ore

Fortgeschrittenes Mitglied
Hallo,

ich wollte gerade ein Backup machen, um ein "dirty" Firmwareupgrade von Miui 12 (Android 10) auf Miui12 (Android 11) zu probieren.
Das Backup schlägt leider fehl. "ERROR 255"

Was mache ich falsch? Ich habe mich auch umgeschaut, jedoch finde ich keine Anleitung wie ich mit TWRP ein anständiges Backup machen kann.
Ich lese immer wieder "häckchen an -System, Data und Boot.

Kann mir jmd weiterhelfen?

Danke im Vorraus
 
TheMissingLink

TheMissingLink

Senior-Moderator
Teammitglied
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
@Fu-ore Lad das recovery.log hoch
 
F

Fu-ore

Fortgeschrittenes Mitglied
@sGässje das habe ich selber geöffnet und es ist nur eine Antwort drin.

@BOotnoOB ich habe das Log hier:
 

Anhänge

  • recovery.txt
    733,8 KB Aufrufe: 1
BOotnoOB

BOotnoOB

Guru
@Fu-ore Benutzt du eine App, die mehrfache Benutzerkonten unterstützt? Sowas wird verwendet, um z.B. zwei WhatsApp-Konten parallel auf einem Gerät laufen zu lassen.

Jedenfalls erkennt TWRP ein weiteres Benutzerkonto und bricht daher das Backup ab, was standardmäßig auch gewollt ist. Für Android ist dein Benutzerkonto im System immer mit user0 verknüpft. Installierst du eine App wie oben genannt, muss ein weiterer Benutzer im System angelegt werden. Schau dir die letzten Zeilen deines Logs an, dann siehst du, dass vor deinem Fehler das Verzeichnis /data/vendor_ce/0 gesichert wurde und beim Versuch /.../999 anzulegen, kommt es zu einem Error.

Falls du so eine App installiert hast, musst du sie anders sichern und deinstallieren. Wenn nicht und du hast keine Ahnung, woher das Konto stammt, kannst du probieren user999 über ADB/Terminalapp zu entfernen:

ADB-Befehl:
Code:
adb shell pm remove-user 999
Terminalapp:
Code:
su
pm remove-user 999
 
F

Fu-ore

Fortgeschrittenes Mitglied
Ich probiere es später und berichte, danke.

Beim Backup: was soll ich alles anklicken, wenn ich ein vollständiges Backup haben will?

*Endet mit fehlermeldung:

C:\Program Files (x86)\Minimal ADB and Fastboot>adb shell pm remove-user 999
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
error: no devices/emulators found

@Gässje : Ich habe jetzt das Twrp 3.4.0.1 drauf gemacht und siehe da, das Backup läuft durch...

Ich habe in Apps>Duale Apps>im menü "alle dualekonten löschen" angeklickt. kann auch sein, dass es daran hackte...

Danke für eure hilfe!
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
@Fu-ore Dein Gerät wird nicht gefunden. USB-Debugging ein und den Zugriff am Handy freigegeben? Was gibt dir adb devices aus?
 
F

Fu-ore

Fortgeschrittenes Mitglied
@BOotnoOB
USB debugging ist aktiv, Freigabe auch

(adb devices) da kommt eine ziffernfolge und das eine Gerät wird aufgelistet
 
Zuletzt bearbeitet von einem Moderator:
BOotnoOB

BOotnoOB

Guru
@Fu-ore Kannst du bitte einen Screenshot machen oder genau schreiben, was dort steht?
 
F

Fu-ore

Fortgeschrittenes Mitglied
Ich habe es mittlerweile augegeben... Nachdem ich das TWRP 3.4.xx aufgespielt hatte, konnte ich ein backup machen. ich habe einmal boot, system und data gecheckt und das backup ist durchgelaufen. Dann nochmal alles angeklickt und auch das backup ist durchgegangen. Beide BAckups habe ich auf dem PC gesichert.

Nachdem ich dann die letzte Weekly drauf hatte und es mir zu buggy ist, wollte ich zurück, indem ich einefach das letzte Android Q basierte Rom geflasht habe. Das Ergebnis war ein bootloop. Also clean wipe gemacht und das backup vom Pc wieder rüberkopiert:
Irgendweshalb überträgt er eine 4 GB große Datei nicht, weshalb das restore nicht funzt...

Ich habe nun komplett neu aufgesetzt und alles manuell neu eingerichtet...
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
Fu-ore schrieb:
überträgt er eine 4 GB große Datei nicht,
Das kann nur an einer FAT32-Formatierung liegen. Alles größer als 4GB kann FAT32 nicht mehr verarbeiten.

Mach dir das Leben doch nicht so schwer und installiere die Stock ROM und bring zunächst wieder alles zum Laufen, zurück zum Anfang. Dann in Ruhe von vorne, aber richtig anfangen.
 
F

Fu-ore

Fortgeschrittenes Mitglied
@BOotnoOB da hast du recht. Danke für deine Unterstützug! :)