USB-C <-> RJ45 Ethernet

  • 11 Antworten
  • Neuester Beitrag
Diskutiere USB-C <-> RJ45 Ethernet im Zubehör für Google Pixel C im Bereich Google Pixel C Forum.
Happosai

Happosai

Stammgast
Ich bin gerade für ein paar Wochen auf Reha und habe in meinem Zimmer einen LAN-Anschluss. Ich habe zwar WLAN, aber das ist echt zum vergessen (extrem langsam, instabil usw.). Laut Nutzungshinweis ist ein WLAN-Router wie Fritz!Box nicht erlaubt (mit den eigenen Anmeldedaten wird es wahrscheinlich auch nicht funktionieren). Daher habe ich auch nach einer anderen Möglichkeit umgeschaut. Es gibt einen Adapter, welches man damit via USB-C ans Netzwerk anschließen kann. Kann das mit dem Pixel C funktionieren? Ich habe bisher keinen Hinweis dazu gefunden.

Adapter z.b. https://www.amazon.de/Gigabite-Alum...01DY3MNEA/ref=cm_cr_arp_d_product_top?ie=UTF8
 
Happosai

Happosai

Stammgast
Danke, hört sich gut an das Teil. Ich habe trotzdem mal den USB-C-Ethernet-Adapter gekauft, in der Hoffnung, dass sie mit dem Pixel C funktioniert. Ist erstmal nicht so teuer und viel ausprobieren, wie zuhause, kann ich hier gerade auch nicht.

In den Nutzungshinweisen steht leider ausdrücklich drin, dass ein Mitbringen eines Routers verboten ist. Sie können doch nicht herausfinden, ob ich damit mit dem Router oder Gerät verbunden bin?
 
fazerdirk

fazerdirk

Experte
Hängt davon ab, wie kompetent der Admin des Netzwerks ist.
Theoretisch könnte er es erkennen.
In medizinischen Einrichtungen herrscht oft Funkverbot
um das empfindliche elektronische Equipment zu schützen.
 
Zuletzt bearbeitet:
Klartext

Klartext

Moderator
Teammitglied
Happosai schrieb:
Sie können doch nicht herausfinden, ob ich damit mit dem Router oder Gerät verbunden bin?
fazerdirk schrieb:
Admin des Netzwerks
Als Netzwerktechniker kann ich dir sagen, dass man das relativ schnell herausfinden kann und wenn es vernünftig eingerichtet ist, wird es er gar nicht funktionieren.
Und damit BTT, hat hier nichts verloren ;)
 
Happosai

Happosai

Stammgast
Danke für die Antworten. Das ist natürlich auch einleuchtend. Dann warte ich einfach mal auf den Adapter, das hoffentlich morgen bei mir ankommen soll. Wenn es funktioniert (oder auch nicht) melde ich mich hier nochmal. :)
 
T

tlindne1

Neues Mitglied
Hallo,

ich arbeite an einem Projekt mit dem Pixel C (Android 7.1.2) und habe mir einen USB-C Hub von der Fa. Anker bestellt. Ziel ist es, dass eine permanente Netzwerkverbindung besteht und das Tablet geladen wird!
Bei der Inbetriebnahme funktionierte alles einwandfrei. Da in diesem Projekt eine dauerhafte Verbindung notwendig ist, ließ ich es zum Testen über die Nacht durchlaufen. Am nächsten Tag wurde das Tablet zwar noch mit Strom versorgt, aber die Internetverbindung war getrennt und konnte nur durch trennen vom Strom reaktiviert werden!

Wisst ihr vielleicht woran das liegt, bzw. wisst ihr einen alternativen Hub der das ermöglicht?

LG
 
TheBrad

TheBrad

Ehrenmitglied
@tlindne1: Spontan würde ich darauf tippen, dass das Verhalten auf irgendwelche Energiespar-Einstellungen zurückzuführen ist (Trennung der Verbindung nach Zeit X im Standby). Hast Du die dbzgl. Einstellungen mal überprüft?
 
T

tlindne1

Neues Mitglied
@TheBrad Danke für die Antwort! Habe nun alle möglichen Einstellungen überprüft, aber alle abgeschalten. Habe sogar das Tablet auf Werkszustand zurück gesetzt, jedoch tritt nach ca. 8 Stunden langer Nutzung das selbe Problem auf. Meine Inbetriebnahme der kompletten Architektur:

1) Tablet einschalten (Android v7.1.2)

2) Hub an Strom anschließen

3) Tablet lädt

4) Netzwerkkabel anschließen

5) Zeichen erscheint (<…>)

6) Hub mit Tablet verbinden

7) Internetverbindung hergestellt

Ich bin wirklich ratlos,weil ich habe einen anderen Hub auch ausprobiert --> selbe Problem
Insgesamt wurden 2 Pixel Tablets getestet und bei beiden tritt das selbe Problem auf

LG
 
TheBrad

TheBrad

Ehrenmitglied
Hmm.. vielleicht muss/soll der Ethernet-Port beim Pixel ja nach einem Zeitraum x die Verbindung trennen? Alternativ könnte das Problem natürlich auch beim Ethernet Chip des Anker Hub liegen. Eine weitere Idee: Könnte das Problem mit der (normalen) Zwangstrennung Deines Routers zusammenhängen und das Pixel aktiviert die Verbindung dann nur nicht wieder selbständig?

Oder Du testest mal einen anderen Adapter, der lt. Beschreibung für das Pixel gedacht ist (hier einige Beispiele).

Ansonsten bliebe noch, die Frage mal direkt an Google zu stellen.
 
T

tlindne1

Neues Mitglied
@TheBrad danke für deine Hilfe! Ich bin mir ziemlich sicher das ich das Problem endeckt habe:

Das Tablet hat die Einstellung "dynamische IP". Aus diesem Grund trennt sich die Internetverbindung obwohl das Tablet noch geladen wird und darum verbindet es sich nach 5 sec wieder nachdem ich den Hub kurz vom Strom getrennt habe..
Ich habe mich nun einige Zeit informiert, wie man die IP auf statisch wechselt, da es nicht so einfach geht wie beim WLAN. Bin auf einige Lösungen gekommen, aber keine davon funktioniert ohne root.
Wisst ihr vielleicht eine Lösung (ohne root) bezüglich des IP - Wechsels?

Vielen Dank im Vorhinein!

LG
 
TheBrad

TheBrad

Ehrenmitglied
tlindne1 schrieb:
Ich habe mich nun einige Zeit informiert, wie man die IP auf statisch wechselt, da es nicht so einfach geht wie beim WLAN.
Das müsste doch eigentlich in Deinem Router passend einstellbar sein..?