1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

2.1 Root ECOD Marker Occurs - Was mache ich falsch?

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von pmcee, 23.05.2010.

  1. pmcee, 23.05.2010 #1
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    Hallo,

    ich habe ein Vodafone Milestone mit 2.1Update1 OHNE root, also original.

    Nun versuche ich seit etwa 5 Stunden darauf root zu installieren... habe glaub ich theorethisch alles verstanden... aber praktisch klappts nicht...

    1. rsdlite 4.6 installiert und als admin ausgeführt

    2. SHOLS_U2_01.14.0_recovery_only.sbf ins milestone geflashed. Problem ist, es bleibt genau bei 100% stehen und sagt "please manually boot up phone". habe aber gegooglet und die leute sagen nur, daß das n fehler von rsdlite is, der nicht weiter schlimm ist, da die 100% ja erreicht wurden.

    3. dann in den recovery modus und "apply sdcard update.zip" ausgewählt. (die update.zip is die Motorola Milestone rooten - Android Wiki - AndroidPIT und extra für vodafone... habs auch mit der DACH ausprobiert)

    jetzt kommt die fehlermeldung :

    -- Install from sdcard
    Finding update package...
    Opening update package...
    E:EOCD marker occurs after start of EOCD
    E:signature verification failed
    Installation aborted.



    nun, jemand ne ahnung was ich falsch mache?
     
  2. -FuFu-, 23.05.2010 #2
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    Update 14.05.2010 - Einige haben das neueste Update bereits OTA mit dem 90_78 Bootloader drauf, die werden mit der alten recovery oben kein Glück haben. Es gibt aber eine neue Version mit RAMDLD90_78:

    vulnerable_recovery_only_RAMDLD90_78.zip

    lad mal die und flash sie mit rdslite...
     
  3. pmcee, 23.05.2010 #3
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    das habe ich auch probiert. ging bis 100% dann stand wieder da manually reboot phone und als ich den power knopf angefasst habe stand sofort da "FAIL".... weiß jetz nich woran es lag...ob es automatisch kam oder erst wirklich als ich den knopf gedrückt habe... aber danach ging auch kein update.zip
     
  4. -FuFu-, 23.05.2010 #4
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    hattest du 2.1 per sbf geflasht oder OTA gehabt?
     
  5. pmcee, 23.05.2010 #5
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    2.1 per ota
     
  6. -FuFu-, 23.05.2010 #6
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    dann sollte das mit der von mir geposteten sbf funktionieren... sonst teste mal ne andere update.zip
     
  7. pmcee, 24.05.2010 #7
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    also ich hab jetz per rsd lite eine FULL SBF von Vodafone geflashed und hat funktioniert. danach habe ich nochmal den vulnerable_recovery_only_RAMDLD90_78.zip geflashed und hat auch funktioniert diesmal sogar mit PASS.

    jetz ziehe ich die vodafone update.zip drauf und probiers nochmal...
     
  8. pmcee, 24.05.2010 #8
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    es läuft ;)

    zu früh gefreut...

    cannot find update_binary
    assert failed: rb_fs_patch("/tmp/delta.bin", "/")
    E:Error in /sdcard/update.zip
    (Status 7)


    Nachtrag:

    bin auf diesen link hier gestossen : http://www.android-hilfe.de/root-ha...im-rooten-von-milestone-2-1-update-1-a-5.html

    habe von dort das update.zip nun bei mir eingesetzt. jetzt kommt folgende meldung :

    Installing update...
    cannot find update_binary
    Rooting your phone...

    Install from sdcard complete.


    Und das in 30 Sekunden... hab ich jetz root? ;)
     
    Zuletzt bearbeitet: 24.05.2010
  9. -FuFu-, 24.05.2010 #9
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    schau im appmenu ob du superuser whitelist hast
     
  10. pmcee, 24.05.2010 #10
    pmcee

    pmcee Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    4
    Registriert seit:
    23.05.2010
    ja alles da alles drin. ;)
     
  11. -FuFu-, 24.05.2010 #11
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    na dann ist gut ;)
    dann viel spaß mit root ^^ und immer fein backups machen
     
  12. skysat, 28.01.2011 #12
    skysat

    skysat Android-Lexikon

    Beiträge:
    1,630
    Erhaltene Danke:
    396
    Registriert seit:
    09.10.2009
    Der Thread ist schon etwas alt aber ich komme hier nicht mehr weiter.

    Habe selbige Fehlermeldung wenn ich die update.zip ausführen will.

    -- Install from sdcard
    Finding update package...
    Opening update package...
    E:EOCD marker occurs after start of EOCD
    E:signature verification failed
    Installation aborted.

    vulnerable_recovery_only_RAMDLD90_78.zip

    flashen brachte auch nichts.
    Kann mir jemand weiterhelfen ?

    gruß skysat
     
  13. -FuFu-, 28.01.2011 #13
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    skysat bedankt sich.
  14. skysat, 28.01.2011 #14
    skysat

    skysat Android-Lexikon

    Beiträge:
    1,630
    Erhaltene Danke:
    396
    Registriert seit:
    09.10.2009
    Danke vielmals FuFu, habs mit deinem obigen How-To Link hingekriegt.

    Gruß skysat
     
  15. Denowa, 28.01.2011 #15
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,872
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    Dann lass uns an deiner Lösung teil haben! So funktioniert das nämlich hier ...
     
  16. -FuFu-, 28.01.2011 #16
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    schau in den How To Link ;) ich wette fast, das es daran lag, das er per OTA geupdatet hatte und das script was dabei mit installiert wird die recovery immerwieder überschrieben hat ;)
     
  17. Denowa, 28.01.2011 #17
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,872
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    Das HowTo kenne ich. :winki:

    Mich würde halt interessieren was genau bei ihm das Problem war und mit welchen Mitteln er es gelöst hat.

    So können andere User, die über die SuFu auf diesen Thread stoßen, seinen Lösungsweg gleich ausprobieren. :D
     
  18. skysat, 31.01.2011 #18
    skysat

    skysat Android-Lexikon

    Beiträge:
    1,630
    Erhaltene Danke:
    396
    Registriert seit:
    09.10.2009
    Hi,

    wie FuFu schon in Post #16 schrieb so war es. Machte ein OTA Update!
    Was soll ich noch schreiben ? Mein Problem stand doch in Post #12
    Ich hab nur nochmal jeden Schritt vom How To ausgeführt und dann ging es plötzlich.

    gruß skysat
     

Diese Seite empfehlen