1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

2.2 & 801.x Enterprise

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von dotartist, 25.11.2010.

  1. dotartist, 25.11.2010 #1
    dotartist

    dotartist Threadstarter Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Hallo Community.
    Ich hatte schon auf meinem Milestone die 2.2.1 GOT drauf. Lief auch ganz akzeptabel, jedoch hatte das Release einen großen Makel.

    Ich kann mich nicht mit WLAN Netzwerken verbinden, die auf 801.x Enterprise mit PEAP und MSCHAPV2 basieren.
    Ich habe schon viel recherchiert, der Bug ist nicht neu und ebenfalls auf anderen 2.2 Androidgeräten vorhanden.
    Dass ich einen Fehler unter 2.2 bei den WLAN Einstellungen gemacht habe, ist eigentlich auch ausgeschlossen. Ich habe auch per Hand sogar die configs editiert.

    Unter 2.1 lief diese Art von Netzwerk (mit selbigen Einstellungen) ordentlich.
    Deswegen bin ich auch seit einiger Zeit wieder mit 2.1 unterwegs, denn 801.x Enterprise WLAN ist für mich essentiell.

    Das alles war vor einiger Zeit. Ich würde eigentlich äußerst gerne auf 2.2 umsteigen, da es natürlich einige Vorteile bietet 2.1 gegenüber.
    Deswegen ist meine Frage:
    Kann einer mir bestätigen, dass dieser Bug mittlerweile gelöst wurde?
    Vorallem Studenten sind hier gefragt, da viele Unis und FHs auf diesen WLAN Standard setzen. Eduroam hat beispielsweise die gleiche Verschlüsselung.

    Ob es in CM6, GOT 2.2.1 oder sonstigen FroyoMods funktioniert ist mir gleich. Hauptsache 2.2.
    Ich bitte um Rückmeldungen :)

    Grüße
     
    Zuletzt bearbeitet: 10.01.2011
  2. gaskocher, 25.11.2010 #2
    gaskocher

    gaskocher Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    9
    Registriert seit:
    21.01.2010
    Habe es auf meinem Milestone unter 2.2 auch noch nicht zum Laufen gebracht. Liegt vermutlich am Treiber. Hatte auch erst die Hoffnung, dass es mit dem neuen Kernel vom 8.11. laufen würde, der im CM6 drin ist. Habe bei Nadlabak nachgefragt und er meinte, das sei noch der gleiche Treiber wie bei GOT 2.2.1.

    Die anderen 2.2 basierten Mods, die ich getestet haben konnten sich auch nicht verbinden. Da diese aber auch den gleichen Treiber benutzen ist das auch nicht weiter verwunderlich.

    Habe bisher noch die Hoffnung, daß es spätestens mit der Final 2.2.1 läuft.
     
  3. rasor89, 25.11.2010 #3
    rasor89

    rasor89 Android-Experte

    Beiträge:
    521
    Erhaltene Danke:
    46
    Registriert seit:
    24.03.2010
    Also ich hab die 20.11 CM6 und muss sagen ich kann mich ohne Probleme und ohne irgendwelche Zertifikate zu installieren an unser FH-Netzwerk anmelden!
     
  4. Riffer, 25.11.2010 #4
    Riffer

    Riffer Android-Lexikon

    Beiträge:
    1,261
    Erhaltene Danke:
    220
    Registriert seit:
    06.03.2010
    Phone:
    OnePlus Two
    Tablet:
    Samsung Galaxy NotePRO 12.2
    Schau mal hier. Da gibt es einen Fix (als Script für OR), der das WLAN auf 54g zwingt. Ich hatte das gleiche Problem wie ihr und es lag eben nicht an dem eigentlichen Netzwerk-Protokoll, sondern daran, dass der Zugang eben auch N-Standard sprach und das Milestone das einfach nicht unterstützt und beim Versuch der Verbindungsaufnahme ständig droppte.
     
  5. eybee1970, 25.11.2010 #5
    eybee1970

    eybee1970 Android-Ikone

    Beiträge:
    5,390
    Erhaltene Danke:
    4,990
    Registriert seit:
    19.01.2010
    Phone:
    HTC One M9
  6. PatSend, 25.11.2010 #6
    PatSend

    PatSend Android-Lexikon

    Beiträge:
    1,432
    Erhaltene Danke:
    497
    Registriert seit:
    21.03.2010
    Das wäre es, wenn ich jetzt auch noch Leuten helfe, denen ich gar nicht helfen wollte :D

    Aber ich bin nun mal sozial veranlagt :thumbsup:
     
  7. Riffer, 26.11.2010 #7
    Riffer

    Riffer Android-Lexikon

    Beiträge:
    1,261
    Erhaltene Danke:
    220
    Registriert seit:
    06.03.2010
    Phone:
    OnePlus Two
    Tablet:
    Samsung Galaxy NotePRO 12.2
    @dotartist: Wäre nett, wenn Du uns auch wissen lässt, ob und wenn ja welche der vorgeschlagenen Lösungen Dir geholfen hat.
     
  8. watschu, 26.11.2010 #8
    watschu

    watschu Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    5
    Registriert seit:
    26.07.2010
    Das gleiche problem hab ich auch, ich komm und komm einfach nicht ins uni-netz... die fixes haben mich leider allesammt nicht weitergebracht und das problem bestand auch schon auf 2.1...
    Andere android (auch 2.2) geräte haben damit keine probleme, auch milestone 2 schafft das nur milestone 1 eben nicht :(
     
  9. dotartist, 27.11.2010 #9
    dotartist

    dotartist Threadstarter Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Erstmal vielen Dank für die Beiträge.
    Ich werd mir ein CM6 aufs Handy aufspielen probiere die Fixes aus.
    Ob es allerdings dann klappt, kann ich erst am Montag testen.
     
  10. RiotMonkey, 27.11.2010 #10
    RiotMonkey

    RiotMonkey Fortgeschrittenes Mitglied

    Beiträge:
    262
    Erhaltene Danke:
    59
    Registriert seit:
    13.03.2010
    Phone:
    LG G4, G2, Samsung S2,
    Tablet:
    Sony Xperia Tablet S
    Also ich habe das gleiche Problem.
    Habe 2.2.1 von GOT drauf und kann mich nicht ins Uni-Netzwerk einwählen. mit 2.1 funktionierte es tadellos. Auch die OR-Fixes per Script haben nichts gebracht.
    Ich hoffe, dass sich das so schnell wie möglich ändert, weil man in unseren Hörsäälen nicht immer ein Mobilfunknetz hat und wir Studenten mit begrenzten Stromressourcen an das WLAN-Netzwerk der Uni gebunden sind :D
     
  11. bonanza, 28.11.2010 #11
    bonanza

    bonanza Android-Hilfe.de Mitglied

    Beiträge:
    49
    Erhaltene Danke:
    6
    Registriert seit:
    07.01.2010
    Hey,

    also ich hatte mit GOT 2.2.1 und eduroam keine problem (ok nur selten :D ) aber bei CM6 muss ich jedes mal den AP löschen und neu erstellen sobald ich mich verbinden will...habe da auch schon einiges rumprobiert (wpa supplicant usw) aber hat nix geholfen.

    Alle anderen Verschlüsselungen (nicht 802.1x) funktionieren aber einwandfrei ...
     
  12. faesi, 28.11.2010 #12
    faesi

    faesi Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    3
    Registriert seit:
    22.03.2010
    Ich hab das G.O.T Relase drauf. Bei meiner Uni ist die WLAN-Konfiguration exakt die gleiche wie bei dotartist, aber ich habe keine Verbindungsprobleme. Ok, ich muss dazu sagen, dass sich das Milestone manchmal nicht mit dem WLAN verbinden will, aber nachdem ich die WLAN-Einstellungen aufmache, klappt auch dies von alleine.

    Was siehst du den auf dem Radius resp. Anmeldungsserver des WLAN?
    Hast Du ein spezielles Sonderzeichen in deinem Passwort? Habe schon festgestellt, dass z.B. das Doppel-S Probleme macht.
     
  13. gaskocher, 29.11.2010 #13
    gaskocher

    gaskocher Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    9
    Registriert seit:
    21.01.2010
    Habs eben mit dem Fix getestet. Geht immer noch nicht. :(
    EAP mit MSCHAPV2
     
  14. dotartist, 29.11.2010 #14
    dotartist

    dotartist Threadstarter Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Habe auch gerade alles getestet. Mit CM6 von 27., mit GOT2.2.1 und alle Fixes die vorgeschlagen wurden. Kein Erfolg.

    //Nachtrag: Morgen versuche ich es nocheinmal. Ich habe mir nun die vorgeschlagenen Lösungen angeschaut; dacki und eybee1970 empfehlen die WLAN Dateien aus 2.1 zu nehmen. Das Update überschreibt einfach die Dateien.
    Riffers Tipp ist den n-Stand abzuschalten. Beide Sachen schließen sich nicht aus und deshalb werd ich morgen beides in unterschiedlichen Kombinationen testen.
     
    Zuletzt bearbeitet: 29.11.2010
  15. dacki, 29.11.2010 #15
    dacki

    dacki Android-Hilfe.de Mitglied

    Beiträge:
    105
    Erhaltene Danke:
    10
    Registriert seit:
    14.02.2010
    Hier in dem Thread die wifi.zip runterladen und entsprechend in /etc/wifi/ (nach backup) kopieren. Das sind die wifi-Dateien von 2.1er Version, die haben bei mir funktioniert. Kannst ja auch mal schauen, ob es bei dir damit klappt!
     
  16. gaskocher, 29.11.2010 #16
    gaskocher

    gaskocher Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    9
    Registriert seit:
    21.01.2010
    Der Fix wurde schon auf Seite 1 erwähnt und hat bei mir keine Besserung gebracht. Trotzdem danke für den Hinweis.
     
  17. dotartist, 05.12.2010 #17
    dotartist

    dotartist Threadstarter Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Ich zitiere aus dem CM6 Thread:
    Hervorhebung von mir. Wird geladen und gleich getestet. :)
     
  18. watschu, 05.12.2010 #18
    watschu

    watschu Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    5
    Registriert seit:
    26.07.2010
    Na hats geklappt? Spann uns nicht auf die folter ;-)
     
  19. dotartist, 05.12.2010 #19
    dotartist

    dotartist Threadstarter Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    25
    Registriert seit:
    26.07.2010
    Sorry, ich kann es erst morgen testen. Wollte nur es schon einmal euch auch zeigen, vielleicht hat ja jemand vor mir die Möglichkeit.

    Morgen mittag gibts Feedback von mir.
    Aber selbst wenn es jetzt nicht klappt, bleib ich glaub bei CM6. Soll echt gut sein und auch bessere Akkuzeiten haben als 2.1.36.
    Aber diesbezüglich geb ich euch auch noch dann Infos, wenn es soweit ist.
     
  20. gaskocher, 06.12.2010 #20
    gaskocher

    gaskocher Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    9
    Registriert seit:
    21.01.2010
    Funktioniert immer noch nicht. Ob es im Zusammenspiel mit dem oben erwähnten Fix geht, habe ich bisher aus Zeitmangel noch nicht getestet.
     

Diese Seite empfehlen