1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Brauche Hilfe bei Installation des SDK

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von cybercrash, 12.01.2010.

  1. cybercrash, 12.01.2010 #1
    cybercrash

    cybercrash Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    1
    Registriert seit:
    26.11.2009
    Phone:
    Motorola Milestone
    Hi Leute,
    ich nutze Win7 x64 Version.

    Ich habe das Milestonestone und möchte mich gerne in die Programmierung einarbeiten.

    Leider scheitere ich bereits am SDK.

    Ich lud das SDK für Windows herunter und entpackte die .zip Datei.
    Ebenso auch das Eclipse (lud das oberste mit 189MB herunter).

    Das Eclipse lässt sich nicht Starten ohne Fehlermeldung, dass etwas nicht gefunden wurde im Unterordner Eclipse.

    Bitte gebt mir einen Tipp.

    Gruß
    Kai
     
  2. Shinigami, 13.01.2010 #2
    Shinigami

    Shinigami Fortgeschrittenes Mitglied

    Beiträge:
    436
    Erhaltene Danke:
    69
    Registriert seit:
    08.04.2009
    Hi,

    welche Version des Java SDK hast Du denn drauf? Meines Wissens gibt es da Versionen für 32bit und 64bit-Systeme. Ich hatte das Problem, dass ich erst eine 64bit-Version von Ecilpse runterladen musste, die dann letztlich mit der 64bit-Version des Java SDKs (inkl. JRE) zusammengearbeitet hat. Alternativ tut's auch eine 32bit-Version des JRE im Eclipse-Verzeichnis (einfach darin einen Unterordner jre anlegen und das JRE darin installieren).

    Gruß,
    Shini
     
  3. garak, 13.01.2010 #3
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,794
    Registriert seit:
    12.12.2009
    Besser ist für dich die Version http://www.eclipse.org/downloads/do...alileo/SR1/eclipse-java-galileo-SR1-win32.zip (zweite von oben), da du nicht unnötig mit den Modulen zur Enterprise Edition belastet wirst.

    Da Windows als 64bit OS ein Problemkind ist, gibt es nur eine 32bit Version von Eclipse. Deshalb musst du auch das passende Java SDK in 32bit verwenden.

    Dann sollte es aber problemlos laufen.

    Gruß
    Chris
     
    Zuletzt bearbeitet: 13.01.2010
  4. cybercrash, 13.01.2010 #4
    cybercrash

    cybercrash Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    1
    Registriert seit:
    26.11.2009
    Phone:
    Motorola Milestone
    Hallo Leute,
    danke für die Hilfe.

    Also ob das Java nun 32Bit oder 64Bit sein soll hängt nicht vom Windows, sondern von der Eclipse Version ab.??

    Als Java lud ich mir folgende Version herunter...installierte ich jedoch noch nicht:

    jdk-6u17-windows-x64.exe

    Die fand ich hier: Java SE Downloads - Sun Developer Network (SDN)
    unter dem großen Icon ganz links.

    Also lade ich mir Java nun erneut als 32Bit Version herunter und installiere diese?

    Gruß
    Kai
     
  5. garak, 13.01.2010 #5
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,794
    Registriert seit:
    12.12.2009
    Das ist richtig!
     
  6. cybercrash, 13.01.2010 #6
    cybercrash

    cybercrash Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    1
    Registriert seit:
    26.11.2009
    Phone:
    Motorola Milestone
    Danke für die Hilfe...

    Fand durch Zufall diese Anleitung, nach dieser klappt nun alles...

    ...sind doch ein paar Tricks nötig...


    Anleitung
     
  7. garak, 14.01.2010 #7
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,794
    Registriert seit:
    12.12.2009
    Nachtrag: Seit heute wurde von SUN offiziell Java für Windows 7 freigegeben. Jetzt sollte es (auch in der 64bit Version) problemlos gehen.
     
  8. funk, 25.01.2010 #8
    funk

    funk Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    1
    Registriert seit:
    21.12.2009
    Phone:
    Motorola Milestone
    Ich bin mir nicht sicher, ob das jetzt Off-Topic ist, aber ich hab auch
    kleine Probleme mit der Entwicklung:

    - ich hab Windows 7 Professional 32 Bit;

    - hab mir heute eclipse runter geladen (der erste link auf der
    Download-Seite),
    - hab das neuste Java DK von Sun runtergeladen und installiert und mir
    dann bei Google das Android SDK gezogen;

    - Eclipse liegt und C:\Program Files\eclipse; Java unter
    C:\Program Files\Java\jdk1.6.0_18 bzw....\Javaßjre6;
    - Das Android SDK liegt unter e:\android-sdk-windows

    Eclipse und auch das ADT funktionieren, aber als ich jetzt das
    hello-android-tutorial von Google gemacht hab kam ich immer auf den
    gleichen Fehler:

    der Emulator startet zwar, er braucht aber teilweise bis zu 10 Min um
    überhaupt den Bootvorgang zu simulieren (wenn er das überhaupt macht)
    und bleibt dann meist dabei hängen...ich habe es durch mehrfaches
    "Run" zwar irgendwann geschafft (während der Emulator noch lief), dass
    es mir mein "Hello, Android" angezeigt hat, aber das auch bisher nur
    2mal von ungefähr 100 Versuchen.
    [Bleibt hängen bei der Konsolenmeldung:
    Waiting for HOME ('android.process.acore') to be launched...]
    [Manchmal wurde auch der Fehler "Can't dispatch DDM chunk" mit
    verschiedenen Hex-Codes ausgegeben...ich hab keine Erklärung dafür!]

    Kann es sein, dass Windows 7 Probleme mit dem Emulator hat? Auf meinem
    Milestone funktioniert die .apk problemlos

    Oder muss ich noch irgendwelche Rechte oder Pfade setzen, damit der
    Emulator auf Windows 7 funktioniert?

    Vielen Dank schon mal für eure Antworten!

    Gruß,
    Frank
     

Diese Seite empfehlen