Brauche mal Build.Prop hilfe

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von Oliver Beyer, 24.07.2010.

  1. Oliver Beyer, 24.07.2010 #1
    Oliver Beyer

    Oliver Beyer Threadstarter Android-Lexikon

    Beiträge:
    1,132
    Erhaltene Danke:
    173
    Registriert seit:
    31.12.2009
    Hallo,

    ich beobachte zusehens, dass Apps aus nichtigen Gründen im Market meines 2.0.1 nicht mehr auftauchen (Opera Mini, Mein O2, die aktuellste Version von XScope etc). Die scheinen alle mit "2.1 aufwärts" deklariert und werden mir damit nicht mehr angezeigt.

    Ich dachte nun, ich bin ganz schlau und nehme einfach die Build.Prop von der neuesten 2.36er her und überschreibe meine. Das hat auch gut geklappt und im Market ist alles da.

    Groteskerweise funktioniert der RootExplorer dann aber nicht mehr. Beim Start des RootExplorers gibts einfach nen Reboot (allerdings nur nen "halben" ab dem Android-Logo).

    Kann mir das einer erklären? Und mir nen Tipp geben, welche Build.Prop ich nehmen kann bzw. was ich in der 2.0.1er ändern muss, damit die aktuellen Apps auftauchen?

    Das wäre toll, danke.
     
  2. Hans Wurst 3535, 24.07.2010 #2
    Hans Wurst 3535

    Hans Wurst 3535 Android-Hilfe.de Mitglied

    Beiträge:
    116
    Erhaltene Danke:
    2
    Registriert seit:
    24.02.2010
    Phone:
    Motorola Milestone
    deinstalliere und installier mal root explorer
     
  3. TimeTurn, 25.07.2010 #3
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Mach doch einfach die aktuelle SHOLS_U2.2.36.0 drauf. Die Kamera-App der 2.0.1.er hab ich bei mir aber auch behalten :D Mit meinem Script kann man die neue Kamera rauskicken und dann einfach die 2.0.1er-Kamera installieren.
     
  4. Oliver Beyer, 25.07.2010 #4
    Oliver Beyer

    Oliver Beyer Threadstarter Android-Lexikon

    Beiträge:
    1,132
    Erhaltene Danke:
    173
    Registriert seit:
    31.12.2009
    So, habs rausgefunden. Es war nicht der RootExplorer, sondern die Superuser-Whitelist. Denn auch AdFree crashte auf die gleiche Weise. Ich hatte die etwas besser bedienbare Superuser-Version aus der OpenRecovery drauf und die packt die kleiner Änderung in der Build.Prop nicht (von SDK=6 auf SDK=7, mehr ist ja nicht). Mit der alten Superuser - die, die quasi unbedienbar ist - klappts wunderbar und die Root-Programme gehen wieder und der Market ist voll da und zeigt mir auch die 2.1er Programme an. So soll das sein ...

    @TimeTurn: Das ist nicht so direkt mein Problem. Die beiden Milestones in der Familie laufen mit 2.0.1 einfach deutlich runder. Die Performance ist merklich schneller (auch messbar: ~40fps mit 2.1 vs ~52fps mit 2.0.1) und der Akku hält deutlich länger. Die 2.34 und 2.36 rocken den Akku hierzulande irgendwie deutlich schneller runter als 2.0.1 - keine Ahnung, warum, ist aber auf beiden Geräten genauso. Muss wohl am Netz liegen. Und da 2.1 nix bietet, wofür ich Performance und Laufzeit opfern würde, bleibt die Family bei 2.0.1
     
    MilestoneAlex bedankt sich.
  5. TimeTurn, 26.07.2010 #5
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Jeden das Seine :D

    Das Einzigste was ich bei der 2.0.1 besser fand, war der gerundete (statt gerade) Unlock-Slider und die Kamera-App :p
     
  6. sk92le, 26.07.2010 #6
    sk92le

    sk92le Erfahrener Benutzer

    Beiträge:
    229
    Erhaltene Danke:
    88
    Registriert seit:
    13.05.2010
    der gerundete unlock-slider gabs aber nur bei 2.0 , bei 2.0.1 war er schon gerade... ;)
     
  7. TimeTurn, 26.07.2010 #7
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Upps - schon soooo lange her - fast 3 Monate :D
     
  8. Gregor901, 26.07.2010 #8
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    Frage: Wo kriegt man eine Build.Prop her ?? Ich suche die von o2 für die 2.36.
     
  9. Finntroll82, 26.07.2010 #9
    Finntroll82

    Finntroll82 Android-Guru

    Beiträge:
    2,363
    Erhaltene Danke:
    362
    Registriert seit:
    29.12.2009
    Phone:
    Samsung Galaxy Note 7
    Gregor901 bedankt sich.
  10. Gregor901, 26.07.2010 #10
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    @Danke Finntroll82.

    Ich dachte, mit der o2-build-prop könnte ich (wie früher) den Market wieder dazu kriegen, dass er mir bei "documents" wieder über 100 Ergebnisse (statt 67) anzeigt.

    EDIT: Nach zurückflashen auf die DACH-Build geht jetzt plötzlich der Market. Habe 117 Ergebnisse.
     
    Zuletzt bearbeitet: 26.07.2010
  11. MilestoneAlex, 29.07.2010 #11
    MilestoneAlex

    MilestoneAlex Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    121
    Registriert seit:
    28.03.2010
    @Oliver Beyer
    Ich hatte auch das Problem, daß ich seit ca. 1 Woche unter 2.0.1 verschiedenste Apps im Market nicht mehr finden konnte. Habe deinen Tipp befolgt und in der build.prop SDK=6 auf SDK=7 geändert und schon zeigt der Markt wieder alles. Danke.
     
  12. TimeTurn, 30.07.2010 #12
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Ihr seid ja olle schummler :D Warum installiert ihr nich einfach SHOLS_U2.02.36.0 statt nur die build.prop zu verändern?
     
  13. Gregor901, 30.07.2010 #13
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    Grund:

    Bei der 36-er DACH-Version funktioniert der Market nicht richtig.

    Bei der 36-er o2-Version (und VF) klappt alles.

    Also nehmen die Leute die DACH-Version, ändern aber die Build-prop auf o2 oder Vodafone um.

    Alles klar ?
     
  14. TimeTurn, 30.07.2010 #14
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,106
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet

Diese Seite empfehlen