1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Brick des Defy+

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Defy+" wurde erstellt von Vollanin, 08.11.2011.

  1. Vollanin, 08.11.2011 #1
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    Wie der Titel schon sagt ist das Defy+ anscheinend gebrickt, hab als letztes n Lagfix ausprobiert und nun funktioniert das Handy nicht mehr seitdem ich es neugestartet hab, komme nur bis zum Motorola-Logo und zu dem Zeitpunkt, an dem es normalerweise in die Animation kommt, stürzts ab und startet sich neu. kann somit nur in das BootMenü von 2nd-init rein, mehr nicht.

    Was nun? :/
     
  2. RATTAR, 08.11.2011 #2
    RATTAR

    RATTAR Gast

    1. Wenn du noch ins CWM kommst, mache unter stable oder latest einen Cache-Wipe und unter advanced einen Dalvik-Cache-Wipe.
    2. Sollte das nicht helfen mache unter stable oder latest einen FactoryReset.
    3. Sollte das nicht helfen musst du neu flashen, in den Bootloader kommst du mit
      Akku raus > Powertaste und Lautstärketaste oben gedrückt halten > dabei Akku rein > Bootloaderschirm erscheint
      mache aber sofern es möglich ist vorher einen FactoryReset im Stock-ROM
    4. Akku raus > Powertaste und Lautstärketaste unten gedrückt halten > dabei Akku rein > Vor-Recoveryschirm erscheint > beide Lautstärketasten gleichzeitig drücken > Recoveryschirm erscheint > FactoryReset durchführen
    5. flashe mit RSD Lite neu.

    EDIT:
    Alternativ kannst du versuchen das Nandroid-Backup einzuspielen, nach der Durchführung des FactoryResets im latest und stable-Bereich.
     
  3. Vollanin, 08.11.2011 #3
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    woher krieg ich die stock-rom?

    außerdem: factoryreset klappt nicht und alles andere auch nicht, hab sogar versucht mit der ms2ginger-fw zu flashen, klappte nicht so wirklich, tritt der gleiche effekt auf.

    ich glaub das liegt an dem lagfix den ich drauf hatte, der hat anscheinend das ganze dateisystem umgeschrieben in eine andere formatierung.... wenn das so is hab ich wirklich n problem, weiß echt nicht wie ich da aus der misere rauskomm :/
     
  4. RATTAR, 08.11.2011 #4
    RATTAR

    RATTAR Gast

  5. Vollanin, 08.11.2011 #5
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    in den bootloader komm ich schon und hab auch darüber geflasht mit der ms2-ginger-cfw und ging ja auch nicht :/ gleicher fehler.
     
  6. Vollanin, 09.11.2011 #6
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    update: immer noch das gleiche problem, auch mit der fixed-sbf 134.
     
  7. cloogshizer, 09.11.2011 #7
    cloogshizer

    cloogshizer Fortgeschrittenes Mitglied

    Beiträge:
    267
    Erhaltene Danke:
    142
    Registriert seit:
    15.07.2011
    Hast Du alles gewiped? Nach der Installation von einem SBF über RSDLite sollte eigentlich weitgehend alles wieder gehen.
     
  8. Vollanin, 09.11.2011 #8
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    hab alles so wie es oben steht gemacht, noch beim eigentlichen rebooten per rsd-lite beim flashen der sbf tritt der gleiche effekt auf.

    hab aber auch evtll. den grund dafür gefunden:
    "Bei einem Update / Flash eines Systems mit aktiviertem Lagfix, und damit veränderten Partitionsinformationen, werden genau diese veränderten Informationen im System durch die Originaleinstellungen der neuen Firmware überschrieben.
    Folge ist, dass das System beim Startvorgang wieder das originale rfs Dateisystem auf den enstprechenden Partitionen erwartet, die veränderten extx-Partitionen nicht sieht und in einem Bootloop (s.u.) steckt. Somit sind wichtige Systeminformationen aber auch unsere privaten Informationen zwar noch da, aber für das System nicht mehr abrufbar und damit für die meisten von uns unerreichbar. Um diese noch zu retten werden erweiterte Linux-Kenntnisse benötigt."
    Quelle: aus dem Samsung Galaxy S-Forum hier

    heißt eigentlich: ich muss die angelegten partitionen wieder de-partitionieren, lieg ich da richtig? wenn ja, wie mach ich das am besten? denn die galaxy-s tipps funktionieren ja beim defy nicht. eigentlich müsste doch eine linux-partitionierungssoftware ausreichen, wenn ich mit usb-massenspeichermodus verbinde und dann den kram wieder departitionier oder?
     
  9. cloogshizer, 09.11.2011 #9
    cloogshizer

    cloogshizer Fortgeschrittenes Mitglied

    Beiträge:
    267
    Erhaltene Danke:
    142
    Registriert seit:
    15.07.2011
    Hm, mir dämmert es erst jetzt. Daher folgende Frage:

    Hast Du etwa den Lagfix für das Galaxy S bzw. ein Samsung-Gerät installiert?

    Wenn ja: Der ist sehr spezifisch für das jeweilige Samsung-Gerät und ändert dort eine Gerätepartition. Es ist eine sehr sehr sehr schlechte Idee so was auf anderer Hardware, noch dazu von einem anderen Hersteller, zu verwenden. V.a. Wenn man keine Ahnung hat, was man bzw. das Tool/die App macht (das Problem, das durch den Lagfix auf dem Galaxy S theoretisch behoben wird, existiert beim Defy+ nicht).

    An den internen Speicher wirst du mit einen externen Partitionierungstool schwer (d.h. gar nicht) drankommen. Meines Wissens hat das Defy+ auch keinen JTAG, mit dem man evtl. noch was retten könnte.

    Wenn du also alles probiert hast (v.a. Factory Reset, SBF flash), was RATTAR oben geschrieben hat, und nichts geht, dann hast du sehr schlechte Karten.

    Freunde dich schon mal mit dem Gedanken an, das D+ einzuschicken.

    Ich hoffe aber natürlich für Dich, dass doch noch jemand eine Idee hat. Ich habe keine.
     
  10. Vollanin, 09.11.2011 #10
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    habs mir schon durchgelesen was es macht und hab mich auch erkundigt obs auf dem defy lief, da liefs jedenfalls überall, zudem dacht ich mir dass das halt nicht so schlimm sein wird, aber hab ich mich wohl getäuscht.

    dann hoff ich mal dass motorola/dat-repair so kulant ist und mir das defy+ reparieren wird, weil die tools haben die ja, und bei dem fall kanns von mir aus auch was kosten, hauptsache das ding läuft wieder. anfragen sind jedenfalls an dat-repair direkt und bei motorola geschickt, sollte ich aber irgendwann erwähnen dass ich einen root drauf hab? ist bis jetzt nämlich nirgendwo erwähnt. zudem noch: sollte der fall kommen, dass mein defy+ eingeschickt werden könnte, sollte ich dann den root per bootmenü und dann danach das bootmenü an sich löschen oder drauflassen?

    ps: hab auch außer dat-repair und motorola selbst als ansprechpartner w-support gefunden und zugleich sehr viel positives davon gelesen, werd wohl auch noch ne anfrage an die schreiben.


    ps2: bin noch in der 30-tage frist bei amazon drin, wenn NICHTS anderes geht sollte ich dort anrufen und das ding zurückschicken, klar, moralisch eine sehr schlechte lösung, aber besser als 240€ rauszuwerfen.. oder?
     
    Zuletzt bearbeitet: 09.11.2011
  11. cloogshizer, 09.11.2011 #11
    cloogshizer

    cloogshizer Fortgeschrittenes Mitglied

    Beiträge:
    267
    Erhaltene Danke:
    142
    Registriert seit:
    15.07.2011
    Naja, ich würde Sie jetzt nicht mit der Nase daraufstoßen. Dass was vermurkst ist, finden die im Zweifel eh raus und die Root und 2nd-Init Spuren lassen sich eh nicht 100%ig entfernen.

    Motorola schickt die Defys AFAIK an DAT. Wenn Du das über Motorola laufen lässt, dauert es nur länger. Ergebnis dürfte gleich sein.

    Ethisch sehr bedenklich, ja.
     
    Vollanin bedankt sich.
  12. RATTAR, 09.11.2011 #12
    RATTAR

    RATTAR Gast

    Das einzige was mir einfällt, wäre so du CWM noch hast die einzelnen Partitionen via ADB Daemon auf dein Defy zu pushen.

    Wie das geht k.A., ich weiß nur das diese Möglichkeit besteht, dazu müsstest du wohl die einzelnen img.Datenpakete aus dem Nandroid verwenden.

    Ist sehr theoretisch aber vielleicht geht es.
     
    Vollanin bedankt sich.
  13. Vollanin, 09.11.2011 #13
    Vollanin

    Vollanin Threadstarter Erfahrener Benutzer

    Beiträge:
    239
    Erhaltene Danke:
    22
    Registriert seit:
    15.10.2011
    Phone:
    Oneplus One
    ich probiers mal aus, ich meld mich wenns klappt/nicht klappt. ;)

    UPDATE: komm nicht über adb rein, habs per CWM versucht und übers Bootmenü versucht, connected nichts. auch über windows-cmd mit ner irgendwo-bezogenen adb.exe klappts nicht.
     
    Zuletzt bearbeitet: 09.11.2011

Diese Seite empfehlen