1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Emulator im SDK sehr langsam

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von mr.freeze, 25.11.2010.

  1. mr.freeze, 25.11.2010 #1
    mr.freeze

    mr.freeze Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    74
    Erhaltene Danke:
    1
    Registriert seit:
    02.09.2010
    Hallo,

    der emulator des sdk ist sehr langsam.
    ist das immer so?
    gibt es einen schnelleren?
    kann man ihn beschleunigen?

    Gruß
     
  2. funcoder, 25.11.2010 #2
    funcoder

    funcoder Erfahrener Benutzer

    Beiträge:
    218
    Erhaltene Danke:
    38
    Registriert seit:
    15.08.2009
    Die Performance ist deshalb so "schlecht", da die CPU Instruktionen umgewandelt werden müssen zwischen einem herkömmlichen x86 Prozessor und den in Android Smartphones verbauten ARM CPUs.

    Den einzigen Performance Boost den ich kenne ist die Boot Animations auszuschalten, indem der Parameter -no-boot-anim verwendet wird.

    Sonstige Performance Boosts kenne ich nicht und ich glaube es gibt auch kaum welche. Höchstens einen schnellen Prozessor im PC verbaut zu haben.;)
     
  3. EarMaster, 25.11.2010 #3
    EarMaster

    EarMaster Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    4
    Registriert seit:
    23.12.2009
    Wenn es nur um die Startzeiten geht: Der Emulator kann weiterlaufen auch wenn es zu Fehlern im Programm kam. Du musst ihm also nicht jedesmal, wenn du etwas debuggen willst beim booten zuschauen, sondern kannst den Emulator einfach weiterlaufen lassen, während du am Code arbeitest.
     
  4. miha, 25.11.2010 #4
    miha

    miha Fortgeschrittenes Mitglied

    Beiträge:
    294
    Erhaltene Danke:
    43
    Registriert seit:
    12.01.2010
    Kannst ja mal "Youwave" (.com) ausprobieren. Vielleicht hilft dir der. Hab ihn selber noch nicht probiert.
     
  5. mr.freeze, 26.11.2010 #5
    mr.freeze

    mr.freeze Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    74
    Erhaltene Danke:
    1
    Registriert seit:
    02.09.2010
    Hallo,

    wo stelle ich denn den Parameter "-no-boot-anim" ein?

    Gruß
     
  6. ts-apps, 26.11.2010 #6
    ts-apps

    ts-apps Erfahrener Benutzer

    Beiträge:
    194
    Erhaltene Danke:
    39
    Registriert seit:
    27.03.2010
    Run Configurations - Target - Additional Emulator command Line Options

    mfg
     
    mr.freeze bedankt sich.
  7. ui_3k1, 15.02.2014 #7
    ui_3k1

    ui_3k1 Gesperrt

    Beiträge:
    1,140
    Erhaltene Danke:
    192
    Registriert seit:
    27.01.2013
    Tablet:
    Samsung Galaxy Note 10.1 2014
    Hallo, die Frage ist ja schon etwas älter... Habe aber das gleiche Problem. Mein Emulator ist auf einem i7 64bit System (Windows 8.1) mit 8GB RAM ebenfalls super langsam. Snapshot habe ich aktiviert, habe mal gehört, dass das den jeweiligen Zustand des Geräts speichert und dann das Booten nicht mehr so lange dauert.

    Hat jemand noch einen Tipp, wie sich der Emulator beschleunigen lässt?
     
  8. kleinerkathe, 15.02.2014 #8
    kleinerkathe

    kleinerkathe Android-Lexikon

    Beiträge:
    1,365
    Erhaltene Danke:
    219
    Registriert seit:
    23.01.2010

Diese Seite empfehlen