1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Grüner Android nach Update

Dieses Thema im Forum "Root / Hacking / Modding für ZTE Blade / OSF / Lutea" wurde erstellt von mweissen, 09.07.2011.

  1. mweissen, 09.07.2011 #1
    mweissen

    mweissen Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    09.07.2011
    Hi,

    ich habe die Anleitung Tutorial: ZTE Blade von Gen1 zu Gen2 konvertieren (TPT-Upgrade) Punkt für Punkt durchgearbeitet, um auf Android 2.3 upzugraden. Besten Dank, ein wirklich gut aufbereitetes Tutorial. Kein Fehlermeldung, alles sieht gut aus.

    Nach dem letzten Reboot sehe ich nur mehr eine großen grünen Androiden. Abschalten geht nur durch Herausnehmen des Akkus.

    Bitte um einen Tipp....
     
  2. reboot, 09.07.2011 #2
    reboot

    reboot Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    09.07.2011
    Als DAU, aber weil ich das heute Nacht gerade gemacht habe und es geklappt hat: Hast du auch lange genug gewartet, bevor du den Akku heraus genommen hast?
     
  3. chris67, 09.07.2011 #3
    chris67

    chris67 Android-Lexikon

    Beiträge:
    1,554
    Erhaltene Danke:
    295
    Registriert seit:
    27.10.2010
    Der erste Bootvorgang zieht sich schon mal etwas, länger als 15 Minuten sollte es aber nicht dauern.
     
  4. FelixL, 09.07.2011 #4
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Hast du auch den unteren Teil gemacht, bist also in Clockwork und hast von dort aus ein Costum-Rom geflasht? Ich denke mal ja, da du sonst beim Booten wieder in Clockwork landen müsstest... Kannst du sagen was du genau geflasht hast?
     
  5. mweissen, 09.07.2011 #5
    mweissen

    mweissen Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    09.07.2011
    Gelöst!

    Ich habe zwar alle Schritte wie im Tutorial vorgesehen ausgeführt, aber statt der Datei update-cm-7.1.0-RC1-Blade... die Datei update-cm-7.0.3-Blade.... verwendet, da ich lieber eine stabile Version als einen RC einsetzen wollte.

    Ich habe alles noch einmal mit der Version 7.1.0-RC1 gemacht und habe nun ein funktionierendes ZTE Blade.

    Danke an alle, die mir ihre Hilfe angeboten haben!
     
  6. FelixL, 09.07.2011 #6
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Nur noch mal zur Info, "stable" bezieht sich nur auf den Cyanogen-Teil, nicht auf die für das Blade nötigen Anpassungen. Manche Stable läuft deutlich schlechter als manche Nightly.
     
  7. bhf, 09.07.2011 #7
    bhf

    bhf Android-Guru

    Beiträge:
    3,348
    Erhaltene Danke:
    1,254
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Falls du dich wunderst, warum im Tutorial nicht auf ein stable release zurückgegriffen wird, das hat einen sehr simplen Grund: CyanogenMod ist Software. Software ist nie fertig. Es fließen immer Verbesserungen oder Fehlerbehebungen in die laufende Arbeit (=Nightlies) mit ein. Deshalb ist der stable release eine Momentaufnahme, ein Label sozusagen, während die Entwicklung stetig voranschreitet.

    Obendrein gilt, wenn du als Anfänger schlauer sein willst, als der, der das Tutorial erstellt hat, geht das regelmäßig in die Hose. Es hat seinen Grund, warum dort eine bestimmte Version verlinkt ist.
     
  8. Spooky-Bear, 22.07.2011 #8
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Hallo, ich bin ganz neu hier und habe absolut keine Ahnung von Android. Das hat mich natürlich nicht davon abgehalten, mit meinem ZTE San Francisco solange herumzuspielen, bis nichts mehr geht. Eben nur besagter grüner Android ist zu sehen. Ich habe ein falsches ROM benutzt und nun komme ich nicht einmal mit "Einschalten und drücken auf Lautstärke - ins Handy. Was kann ich machen, kann man was deinstallieren über den PC z. B? Im Moment bin ich wirklich ratlos. Ich weiß, ich hätte nichts alleine machen sollen aber, ich wollte das Cyanogen nicht haben, sondern das Froyo. Dabei hab ich das gründlich vermurkst.

    Vielen Dank und viele Grüße
    Spooky
     
  9. FelixL, 22.07.2011 #9
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Willkommen im Forum.

    Mit Drücken und Halten der Lautstärke runter (nicht rauf, aufpassen!) + Einschalten kommt man normalerweise ins Recovery-Menü. Siehst du das noch?
    Ansonsten kann ich dich erst mal beruhigen, wenn du wirklich nur das falsche ROM benutzt hast brauchst du keine Panik zu haben.
    Bevor ich dir aber sagen kann wie du dein Handy wieder in einen benutzbaren Zustand bringst bräuchte ich ein paar Infos.
    1. Bist du einer Anleitung gefolgt? Wenn ja bitte benennen, am Besten mit Link und Angabe ob du irgendwo andere Dateien als die dort genannten benutzt hast, außerdem bis zu welchem Schritt du gekommen bist.
    2. Wenn du keiner Anleitung gefolgt bist, was hast du gemacht? Ein ROM über das Recovery geflasht oder einen TPT versucht (Volume+Lautstärke hoch)

    Häng am Besten jetzt das Gerät mal ans Ladegerät damit es nachher nicht am Strom scheitert. Außerdem, falls du nicht mehr ins Recovery kommst (die Sache mit dem Volume runter), hast du einen Kartenleser oder ein anderes Gerät im Haus mit dem du Dateien auf die micro-Sd-Karte des Blade schieben könntest?
     
  10. Spooky-Bear, 22.07.2011 #10
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Hallo, erst einmal vielen Dank für deine Antwort.

    Nein, ich komme absolut nicht mehr ins Recovery Menü. Ich habe immer und immer wieder probiert aber leider nichts zu machen.

    Einer Anleitung bin ich gar nicht gefolgt. Da bei mir das Cyanogen 7 drauf war, muss der Vorbesitzer schon etwas damit gemacht haben. Ich habe mir ROMs, die für das ZTE Blade ausgewiesen waren, runtergeladen. Dann habe ich sie versucht sie nach und zu installieren. Das ging nicht und ich hing beim grünen Androiden fest, konnte aber noch ins Recovery Menü. Als ich dann ein ROM für Eplus erwischte ging nichts mehr und mein Android hing ganz.

    Ja, ich habe einen Kartenleser zu Hause (bin gerade im Büro) und hatte so auch die verunglückten ROMs als zip draufgezogen.
    An und für sich wollte ich nur, dass es so ähnlich aussieht wie das HTC. Die große Uhr und das Wetter vorne drauf und eben ein nicht so düsteres Thema. Da ich dachte, es handelt sich um das Froyo Android, habe ich danach gesucht und eben so rumprobiert. Und, ich wollte gerne die App von Facebook mit drin haben. Na ja, hätte ich wohl auch anders haben können.

    Mehr Infos kann ich leider nicht geben, weil ich ja einfach blind was gemacht habe ohne vorher zu fragen.

    Viele Grüße
    Spooky

    Volume + Lautstärke + habe ich nie gemacht. Einfach ROM auf die Mini SD Karte kopiert, dann in den Recovery Modus gegangen, dort auf von SD Karte installieren ausgewählt und drüber installiert.
     
    Zuletzt bearbeitet: 22.07.2011
  11. FelixL, 22.07.2011 #11
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Gut, wie gesagt lade es erst mal voll auf, am Original-Ladegerät 3-4 Stunden mindestens. Kannst du ja vielleicht auch im Büro schon machen. Stelle außerdem sicher das du vielleicht nicht nur nicht mehr ins Recovery kommst weil dein Gerät keinen Strom mehr hat...

    Das Seltsame daran ist das eine ROM-Installation das Recovery eigentlich nicht zerstören kann. Schau am Besten zu Hause erst mal nach ob du auf der Speicherkarte einen Ordner namens ''/image'' hast. Wenn das der Fall ist melde dich hier erst mal und benutze nicht die Anleitung in diesem Post weiter unten! Hast du irgendwann mal einen Grünen Text durchlaufen sehen der nicht das Recovery war sondern irgendwas mit ''images'' oder so? Wenn du keinen Ordner namens /image oder /images oder ähnlich auf der SD-Karte findest versuche mal das Blade mit Lautstärke-Hoch einzuschalten statt Lautstärke runter. Dann soll das Gerät beim grünen Androiden hängen bleiben und kann über einen PC geflasht werden.

    Kannst du den Verkäufer kontaktieren? Die Frage ist wie er Cyanogen drauf installiert hat. Entweder war es schon älter (wann hast du es von ihm gekauft?) und CM7 lief noch auf GEN1 (unwahrscheinlich, sonst hätten die alten ROMs alle funktioniert) ,mit KKs Converter (wäre auch gut für uns), mit einem TPT (wäre auch gut für uns), mit dem Windows-Flash-Tool (das wäre schlecht für uns) oder es war schon auf GEN2 (auch eher schlecht für uns).

    Kannst du auch mal aufzählen welche ROMs alle beim grünen Androiden hängen geblieben sind?

    Ich poste hier schon mal eine Anleitung, führe diese bitte noch nicht aus!

    Code:
    Eine mögliche Lösung für dein Problem dürfte die folgende sein:
    Im Grunde ist jetzt dieses Tutorial durchzugehen, aber ohne die Möglichkeit das Gerät dafür zu benutzen:[url]http://www.android-hilfe.de/root-hacking-modding-fuer-zte-blade-osf-lutea/117339-how-tutorial-zte-blade-von-gen1-zu-gen2-konvertieren-tpt-upgrade.html[/url]
    
    Schritt 1:
    Lade die Datei Gen1-to-Gen2-TPT-v8.zip die im Turorial verlinkt ist runter. Entpacke sie auf die im Kartenleser liegende Speicherkarte. Es sollte dann direkt im Hauptverzeichnis ein Ordner ''/image'' liegen. Besorge dir für den PC ein MD5-Testprogramm. Ich benutze [url=http://download.cnet.com/DigestIT-2004/3000-2248_4-10387706.html]DigestIT 2004 - Free software downloads and software reviews - CNET Download.com[/url]
    Einfach runterladen, installieren, danach kannst du über rechtsklick auf eine Datei im Explorer unter -->digestIT-->Verify MD5 die Checksumme überprüfen. Die Checksummen der einzelnen Dateien im /image-Ordner stehen in einer Datei namens nandroid.md5, die sich ebenfalls im Ordner befindet. Es sind alle Dateien zu überprüfen! Nur wenn alle "digest matches" von sich geben kann fortgefahren werden.
    
    Schritt 2:
    SD-Karte wieder in das einige Stunden aufgeladene Blade legen. USB-Kabel am Blade abziehen falls eins dran ist. Den Lautstärke-Hoch(nicht runter diesmal!)-Knopf drücken und gedrückt halten, die Menü-Taste drücken und gedrückt halten und das Gerät einschalten. Sobald die Grüne Schrift erscheint darf dir ein Stein vom Herzen fallen und du kannst die Tasten loslassen. Abwarten bis alles durchgelaufen ist. Das Recovery-Menü startet automatisch. Dort kannst du dein Blade im Punkt ''mounts and storage''-->''mount USB'' mit dem PC verbinden und Cyanonmod draufladen. Du bist jetzt auf GEN2, damit funktioniert nur Cyanogenmod, ein ROM das auf dem 2.3er-Leak aufbaut (z.B. Ginger Stir Fry) oder, wenn du unbedingt ein 2.2er willst Swedish Spring. Alle anderen ROMs werden im Grünen Androiden enden! Für CM7 gibt es übrigens sowohl Facebook als auch Sense-Themes...


    @ Rest: Bisher wurde noch kein Blade gebrickt weil ein TPT auf GEN2 ausgeführt wurde, richtig? Afaik nimmt ein natives GEN2-Gerät den TPT einfach nicht an...
    Wenn kein /image-Ordner auf der SD-Karte ist kann man auch Fastboot probieren, da ist die Gefahr erst mal gleich null das was schief geht.
     
    Zuletzt bearbeitet: 22.07.2011
  12. Spooky-Bear, 22.07.2011 #12
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Auf meiner Mini SD Karte war eine Zip-Datei mit dem Cyanogen drauf, die hatte ich auch drauf gelassen.
     
  13. FelixL, 22.07.2011 #13
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Die war noch vom Vorbesitzer drauf? Kannst du mal den genauen Dateinamen posten sobald du zuhause bist?
     
  14. Spooky-Bear, 22.07.2011 #14
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Ja, vom Vorbesitzer und ich poste gleich, wenn ich zu Hause bin.
     
  15. Spooky-Bear, 22.07.2011 #15
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Ich habe jetzt die Mini SD im Kartenleser.

    1. Das Telefon geht trotz aufgeladenem Akku nicht in den Recovery Modus.
    2. Da ist kein Ordner mit /image
    3. Das ROM, was drauf war heißt: cm_blade_full-85
    4. Probiert hatte ich zuletzt: EPLUS_P729KV1.0.0B03-update_signed
    5. Beim flb-froyo-r9 und r11-zte kam ich zumindest noch in den Recovery Modus.

    Ich hoffe, ich habe jetzt nichts vergessen und nichts durcheinander gebracht.

    Das ist auf der SD Karte drauf (siehe PDF)
     

    Anhänge:

    Zuletzt bearbeitet: 22.07.2011
  16. FelixL, 22.07.2011 #16
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Hast du nach der Installation der Roms einen Wipe gemacht? Die Wahrscheinlichkeit ist ziemlich hoch das dein Gerät schon auf Gen2 ist. N85 ist ein Gen2-ROM, die die du versucht hast und die nicht liefen Gen1. Das erschwert die Sache. Kannst du versuchen den Verkäufer zu fragen wie er auf Gen2 gekommen ist?
     
  17. Spooky-Bear, 22.07.2011 #17
    Spooky-Bear

    Spooky-Bear Android-Hilfe.de Mitglied

    Beiträge:
    47
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2011
    Nein, ich habe kein Wipe gemacht, nur direkt Image von SD Karte installieren. Fragen kann ich den Verkäufer aber, mir ist das a. peinlich und b. wenn ich Pech habe, sagt der nix. Aber, ich werde es gleich versuchen. Vielleicht hat er das ja selbst gemacht.
     
  18. bhf

    bhf Android-Guru

    Beiträge:
    3,348
    Erhaltene Danke:
    1,254
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Korrekt, so die Theorie. wbaw selbst schreibt in seiner Anleitung/Initialposting:
    Um dann was zu machen? Ohne zu wissen, welche Gen das Telefon ist, kannst du per Fastboot keine passende Recovery aufs Telefon schieben. Und da beißt sich die Katze in den Schwanz. Was vielleicht ginge, wäre per adb shell 'df -h' aufzurufen und anhand des Partitionslayouts zu bestimmen, ob und ggfls. welches TPT-Paket verwendet wurde. Nur weiß ich momentan nicht, ob in dem zerfraggten Zustand überhaupt adb funktioniert.
     
  19. FelixL, 22.07.2011 #19
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Könnte es sein das beim Stock-Rom das er geflasht hat auch das Recovery drin war? Damit wäre das logischerweise Gen1 und nicht mehr bootbar. Wenn Fastboot geht kann man ein Gen2 Recovery flashen und es geht wieder. Kaputt gehen kann dabei nichts, auch wenn das Gerät Gen1 ist. Das Recovery wäre dann nur weiter nicht bootbar, dann könnte man ein Gen1 testen.

    ich sitz gerade im Kino, film geht gleich los. ich schau mir das morgen früh mal genau an.
     
  20. FelixL, 23.07.2011 #20
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Das eplus-Stock-ROM enthält auch das Recovery -.-

    Gut...dann wissen wir jetzt sicher das das Gerät Gen2 ist, das Recovery und das ROM Gen1. Was wir nicht wissen ist wie das Gerät auf Gen2 kam.

    Okay, bitte mache jetzt das:
    Falls du aus irgendeinem Grund einen Ordner namens /image auf der SD erstellt haben solltest zwischen gestern abend und heute morgen, lösche den. Es darf kein Ordner namens /image drauf sein!
    Dann gehst du hier nach Methode 2 vor:
    [Guide] de-bricking a ZTE Blade - Android @ MoDaCo

    1.:
    blade-fastboot-recovery.zip
    Runterladen und extrahieren.

    2.: Das Gerät mit Lautstärke HOCH (!) gehalten anschalten. Es sollte nicht weiter kommen als der Grüne Androide, aber das macht es bei dir ja sowieso nicht. Dann an den PC anschließen. In der Anleitung steht es kann ein paar Minuten dauern bis der PC es erkennt. Schau im Gerätemanager nach ob es dort auftaucht oder achte darauf ob der PC eine Nachricht anzeigt das er Treiber installiert. In diesem Fall hast du Glück :)
    Noch ne kurze Frage, welches Windows benutzt du an deinem Privat-PC?

    3.: Wenn du nicht Windows7 benutzt oder falls dein Handy im Gerätemanager nicht ordentlich erkannt wird musst du die Treiber von Hand installieren: ZTE Handset USB Driver 5.2066.1.8.exe

    4.: Führe die windows-flash-gen2-recovery.bat aus, die ist im ersten Download enthalten. Danach solltest du wenn du mit Lautstärke-Runter startest wieder in das Recovery kommen.


    Wenn du bis zum Ende durch bist oder irgendwo hängst melde dich bitte hier.


    Edit: Okay, inzwischen ist das EPlus-ROM bei mir auch runter geladen, es enthält ein Recovery, damit ergibt das alles einen Sinn.
     
    Zuletzt bearbeitet: 23.07.2011

Diese Seite empfehlen