1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[How-To] Fastboot unter Windows einrichten

Dieses Thema im Forum "Root / Hacking / Modding für Dell Streak" wurde erstellt von youandme, 31.08.2010.

  1. youandme, 31.08.2010 #1
    youandme

    youandme Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    84
    Erhaltene Danke:
    36
    Registriert seit:
    18.04.2010
    Hallo zusammen!

    Um vielleich dem einen oder anderen Interessenten die Möglichkeit zur ermöglichen, Modifikationen am Streak vorzunehmen, möche ich ein kurzes How-To anbieten, wie man denn den Fastboot Modus beim Dell Streak einrichtet. Ich habe sowohl bei den xda-devs als auch bei modaco gesehen, dass viele Benutzer mit einem "< waiting for device >" Problem vor dem Rechner sitzen und verzweifeln.

    Los geht´s!

    1. Ladet euch die Dell PC Suite herunter:
    Drivers & Downloads
    1.1 Natürlich müsst Ihr diese auch installieren
    1.2 Startet den Rechner nach der Installation neu. Die PC Suite wird euch das eh vorschlagen. Bestätigt mit "JA"
    2. Bringt euer Dell Streak in den "Fastmode". Hierzu müsst Ihr das Gerät neustarten und beim Hochfahren den "Kamera-Knopf" gedrückt halten. Hierbei ist das Gerät vom PC getrennt!
    2.1 Das Gerät wird einen weißen Bildschirm anzeigen, auf dem "Waiting for SD {siehe Update} detect" steht. Nach wenigen Sekunden ändert sich der Text dann. Wählt hier rechts oben "FastBoot" aus.
    *Update 04.09.10*
    Es heißt "Waiting for SD detect", nicht wie ich vorher geschrieben habe "Waiting for USB detect". Es ist jedoch nur ein Hinweis für Euch - beeinflusst fastboot also nicht.

    2.2 Verbindet den Dell Streak nun mit dem PC, indem Ihr das entsprechende Kabel benutzt

    3. Euer PC wird euch sagen, dass die Treiber fehlen. Eigentlich stimmt das nicht. Windows ist einfach nur zu faul, sich diese zu suchen :razz:
    3.1 Öffnet den Geräte-Manager von Windows und wählt unter "Anschüsse" bzw. "Android Phone" den entsprechenden Beitrag aus. Mit der rechten Maustaste kommt Ihr zum Punkt "Treibersoftware aktualisieren".
    3.2 Hier wält Ihr "Auf dem Computer nach Treibersoftware suchen"
    3.3 Weiter geht´s mit "Aus einer Liste von Gerätetreibern auf dem Computer auswählen"
    3.4 Jetzt müsst Ihr ein wenig warten. Abhängig davon, wie viele Geräte bzw. Treiber Ihr schon auf eurem PC installiert habt, kann das einige Minuten dauern.
    3.5 Scrollt nach unten bis Ihr "Google INC" findet. Wählt es aus.
    *Update 02.09.10*
    Es kann auch "Android Phone" auf einigen Win7 und WinVista PCs heißen.


    3.6 Nun wählt Ihr "Android Bootloader Interface aus
    3.7 Windows wird noch ein Mal meckern, aber Ihr könnt mit "Ja" die Installation einleiten.

    So. Nun habt ist Fastboot erfolgreich eingerichtet. Damit ist es möglich, dass Dell Streak zu rooten oder ein neues Recovery-Image auf das Gerät zu überspielen.
     
    Zuletzt von einem Moderator bearbeitet: 13.03.2011
    boomst, Deva, ST-JimmY und 14 andere haben sich bedankt.
  2. sir-ay, 02.09.2010 #2
    sir-ay

    sir-ay Fortgeschrittenes Mitglied

    Beiträge:
    352
    Erhaltene Danke:
    29
    Registriert seit:
    21.12.2009
    Hi, danke für die tolle Erläuterungn. Eine Sache die nicht auffindbar war "Google Inc" bei Visat und Win7 heisst es Android Phone. LG
     
    youandme bedankt sich.
  3. youandme, 02.09.2010 #3
    youandme

    youandme Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    84
    Erhaltene Danke:
    36
    Registriert seit:
    18.04.2010
    Hi!
    Ok, ich hab´s ergänzt. Danke für den Hinweis.
     
  4. graysson, 03.09.2010 #4
    graysson

    graysson Fortgeschrittenes Mitglied

    Beiträge:
    430
    Erhaltene Danke:
    64
    Registriert seit:
    16.11.2009
    Ich habe auf einem gerootetem 6267er Gerät Schritt 1. &2. ausführen können. Dann rödelt mein Netbook mit Win7 32bit etwas rum und sagt alle Treiber installiert (ADB...irgendwas).
    Muss ich den trotzdem manuell auswählen?

    p.s. unter 2.1 steht bei mir was von waiting for sd-detect oder so. Das Warten auf USB kommt erst bei 2.2
     
  5. youandme, 04.09.2010 #5
    youandme

    youandme Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    84
    Erhaltene Danke:
    36
    Registriert seit:
    18.04.2010
    Hi!
    Wenn dir Windows sagt, dass adb treiber installiert wurden, ist es gut. Solltest du aber nach dem Anschlißen des Kabels an das Gerät ein "< waiting for device >" bekommen, dann musst du die Treiber nach der Anleitung neu installieren.

    Recht hast! Das hab ich verwechselt. Ist geändert, danke!
     
  6. ukwach64, 07.10.2010 #6
    ukwach64

    ukwach64 Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    5
    Registriert seit:
    06.10.2010
    Hallo!
    Das ist mal wirklich eine eindeutige Anleitung... Danke dafür!
    Auch ich saß mal vor dem "Waiting for Device" und kam auch ins grübeln.

    An dieser stelle möchte ich noch von meiner persönlichen Erfahrung berichten!
    Eine einmal "verbockte" USB-Treiber Installation bekommt man damit nicht mehr zum laufen.
    Ich hab damals Windows neu aufgebaut und mich dann an diese Anleitung gehalten:smile:

    Gruß Uli

    Und hier noch was Interessantes!
     
  7. maxoom, 05.01.2011 #7
    maxoom

    maxoom Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    05.01.2011
    Hallo,
    da ich völliger Anfänger bin und mein Treiber wohl anders lautet als der in der Anleitung, frage ich besser nach. Sieht das so richtig aus?

    [​IMG]

    Kann ich jetzt den anderen How-To's folgen? Bzw. wie komme ich aus dem Fastboot Modus wieder raus?! Ich hänge im weißen Bildschirm mit dem FASTBOOT_MODE Schriftzug unten links. Ausschalten kann ich es aber nicht... oder doch?
    Manoman, Android für Laien ist wohl ne Nummer heftiger als ein iPhone Jailbreak für Laien. Köpft mich nicht, ich werde noch viele dumme Fragen stellen... :(

    Grüße
     
    Zuletzt bearbeitet: 05.01.2011
  8. UKSheep, 06.01.2011 #8
    UKSheep

    UKSheep Android-Lexikon

    Beiträge:
    1,786
    Erhaltene Danke:
    545
    Registriert seit:
    06.09.2010
    Ja ist okay so...

    Du kannst per cmd / shell einen reboot command an das Handy schicken.
    Code:
    fastboot-windows.exe -i 0x413c reboot
    
    "fastboot-windows.exe" kann auch einen anderen Namen haben.

    http://www.android-hilfe.de/dell-st...dell-2-2-318-performancefix-04-01-2011-a.html <- wenn du das Pack herunterlädst, hast du die nötigen Dateien.

    MfG

    UKSheep

    P.S. wie man eine cmd / shell öffnet, steht hier.

    -> http://www.android-hilfe.de/dell-streak-forum/67415-anleitung-dell-2-2-318-rooten-04-01-2011-a.html <-

    nur musst natürlich in den Ordner wo sich die "fastboot-windows.exe" befindet und nicht "adb"
     
  9. Tom.Braun, 25.01.2011 #9
    Tom.Braun

    Tom.Braun Android-Hilfe.de Mitglied

    Beiträge:
    57
    Erhaltene Danke:
    6
    Registriert seit:
    25.01.2011
    Na super.
    Ich habe den Streak in den Fastboot-Mode versetzt.
    Hat alles geklappt.

    Wie bitte kann ich den Fastboot-Mode wieder verlassen, ohne dass ich am Gerät etwas verändere???
    :o

    "fastboot-windows.exe -i 0x413c reboot" in der cmd-shell (in Windows?!) funktioniert bei mir nicht.
    :huh:

    Danke für jede Unterstützung.
    Tom
     
  10. UKSheep, 25.01.2011 #10
    UKSheep

    UKSheep Android-Lexikon

    Beiträge:
    1,786
    Erhaltene Danke:
    545
    Registriert seit:
    06.09.2010
    Wenn die exe einen anderen Namen hat... musst du es auch dementsprechend anpassen...

    Code:
    NameDerDatei.exe -i 0x413c reboot
    
    Zudem musst du dich mit der cmd natürlich in dem Ordner befinden in dem die fastboot.exe liegt... bei mir ist das "C:\fastboot\"

    MfG

    UKSheep
     
  11. Tom.Braun, 25.01.2011 #11
    Tom.Braun

    Tom.Braun Android-Hilfe.de Mitglied

    Beiträge:
    57
    Erhaltene Danke:
    6
    Registriert seit:
    25.01.2011
    Das Problem ist, dass es bei mir keinen Fastboot Ordner - ich nehme an, Du meinst das WIN System - gibt.
    Auch die Suchfunktion ergab nichts, was irgendwie fastboot heißt.
    Auch die Suche nach fastboot.exe etc. ergab kein Ergebnis.

    Ich kann auch nicht auf denn Dell zugreifen - er taucht nirgends auf. Auch wenn er über Kabel mit dem PC verbunden ist.

    Wie gesagt: Ich hatte den Streak einfach nur in den Fastboot_Modus versetzt und sonst nichts gemacht.

    Sitz ich nun völlig auf dem Schlauch?:o:o
     
  12. UKSheep, 25.01.2011 #12
    UKSheep

    UKSheep Android-Lexikon

    Beiträge:
    1,786
    Erhaltene Danke:
    545
    Registriert seit:
    06.09.2010
    Hi,

    habe dir meinen fastboot Ordner mal gepackt und hochgeladen.

    fastboot.rar <- dort zu finden.

    Fastboot ist nicht teil des Windows Systems ;) sondern man muss es sich vorher irgendwo runterladen ;)

    MfG

    UKSheep
     
  13. TimoBeil, 25.01.2011 #13
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,869
    Erhaltene Danke:
    3,531
    Registriert seit:
    20.09.2010
    Der eben hochgeladene Ordner ist ein wesentlicher Teil;

    wenn ich jedoch ergänzen darf: falls der Streak überhaupt nicht erkannt wird, fehlt jeglicher Treiber auf dem PC. Man sollte schon vorher die alte Dell-Sync-Suite installiert haben. Dann wird er infolge der nun vorhandenen Treiber auch erkannt.

    PS: aus dem fastboot-Modus kommst du zur Not auch durch ziehen des Akkus wieder raus...
     
    Zuletzt bearbeitet: 25.01.2011
  14. mobile-freak, 06.03.2011 #14
    mobile-freak

    mobile-freak Android-Experte

    Beiträge:
    720
    Erhaltene Danke:
    113
    Registriert seit:
    22.07.2010
    Woran erkenne ich eigentlich ob ich alles richtig gemacht habe?
    Bei mir hing mein Streak auch und hat nicht neugestartet musste also akku rausnehmen
     
  15. TimoBeil, 06.03.2011 #15
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,869
    Erhaltene Danke:
    3,531
    Registriert seit:
    20.09.2010
    Hi,

    ob du es richtig durchgezogen hast erkennst du spätestens daran, dass bei der nächsten Fastboot-Verbindung des Streak mit dem PC der Text auf weißem Display beim Streak von "waiting for USB detect" nach "FASTBOOT MODE" wechselt.
    Vor dem Entfernen des Akku sollte eine "DONE" als Bestätigung angezeigt worden sein.

    Damit hast du nun Zugang vom PC aus um etwa ein recovery zu flashen.

    Dass du den Akku ziehen musstest, ist übrigens kein Problem, da es eine der beiden Möglichkeiten ist, den Neustart auszulösen.

    Grüße
     
    Zuletzt bearbeitet: 06.03.2011
  16. mobile-freak, 06.03.2011 #16
    mobile-freak

    mobile-freak Android-Experte

    Beiträge:
    720
    Erhaltene Danke:
    113
    Registriert seit:
    22.07.2010
    Also das mit dem DONE ist bei mir nicht aufgetaucht bei mir hing der mindestens 20 minuten bei Fastboot Mode. Als nichts geschehen ist, habe ich den Akku rausgeholt und normal gestartet.

    Edit:
    Anscheinend hat es geklappt funzt auch so wie ich es gemacht habe
     
  17. einfach_dirk, 01.04.2011 #17
    einfach_dirk

    einfach_dirk Fortgeschrittenes Mitglied

    Beiträge:
    344
    Erhaltene Danke:
    30
    Registriert seit:
    26.02.2011
    puh... ich weiß nicht weiter... ich hänge schon bei dem Problem, daß mein gerätemanager (win7) nichtmal das ds erkennt und ich bei dell nur diesen delldriverdownloadmanager bekomme und der keine treiber findet...wenn ich die seite aufrufe, erhalte ich immer das selbe...diese pc suite läuft nicht...

    was mache ich falsch???

    ich will doch nur rooten

    habe android 2.2 build 318...:huh:
     

    Anhänge:

  18. TimoBeil, 01.04.2011 #18
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,869
    Erhaltene Danke:
    3,531
    Registriert seit:
    20.09.2010
    Hi,

    ohne jetzt tief einzusteigen: wenn du das 318er rooten willst, sollte da nicht z4root reichen? Jedenfallls hatte ich das kürzlich einen User empfohlen und bei ihm hatte es wunderbar geklappt. Es kann sogar mit UniversalAndroot 1.6.1b funktionieren. Auch hier hatte ich positives feedback.

    Grüße

    PS: wg. diesem Downloadmanager: du hast einmal zu voreilig geklickt. Wenn man das erste Mal auf diese Dell Seite kommt, wird man gefragt, ob man direkt downloaden will, oder eben per Downloadmanager. Du hast dich ebenso falsch entschieden wie ich seinerzeit auch. Dieser DM ist wohl ein Addon oder ein ActivX, ich weiß es nicht mehr genau. Man kann es jedenfalls wieder entfernen - oder kurzzeitig einen anderen Browser nehmen.
     
    Zuletzt bearbeitet: 01.04.2011
  19. einfach_dirk, 01.04.2011 #19
    einfach_dirk

    einfach_dirk Fortgeschrittenes Mitglied

    Beiträge:
    344
    Erhaltene Danke:
    30
    Registriert seit:
    26.02.2011
    sooo...mit UniversalAndroot 1.6.1b kommt ne fehlermeldung am schluß:( mit z4root habe ich auch danach keine root rechte...download läuft gerade...ich meld mich wieder ;)
     
  20. TimoBeil, 01.04.2011 #20
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,869
    Erhaltene Danke:
    3,531
    Registriert seit:
    20.09.2010
    Ein paar mal probieren. Die Apps (oder der Streak) sind zickig...

    Schau mal in den Thread "Schriftgröße". Da hatten wir das Rooten ebenso wie kürzlich im "Hilfe, mein Streak hat Probleme"
     
    Zuletzt bearbeitet: 01.04.2011

Diese Seite empfehlen