1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

HTC Desire W-Lan WPA-PSK Problem

Dieses Thema im Forum "HTC Desire Forum" wurde erstellt von nitron, 09.05.2010.

  1. nitron, 09.05.2010 #1
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    Mahlzeit, bin nun seit einer Woche stolzer besitzer eines Desires und es zaubert mir noch immer ein Lächeln aufs Gesicht. :) Nun ist mir aber ein kleines Problemchen aufgefallen, wobei mir hier hoffentlich einer helfen kann. Also zu meinem Problem: Ich benutze einen DWL-900AP+ Accesspoint mit einer WPA-PSK verschlüsselung. Ich hab nun mein Desire darauf eingestellt, Passwort eingegeben und es hat sich verbunden, allerdings habe ich keine Internetverbindung. Wenn ich jetzt das W-Lan öffentlich mache und mich damit verbinde funktioniert alles wunderbar. Hoffe hier kann mir irgendjemand helfen. :) MfG
     
  2. Handymeister, 09.05.2010 #2
    Handymeister

    Handymeister Foren-Manager Team-Mitglied Foren-Manager

    Beiträge:
    35,048
    Erhaltene Danke:
    23,545
    Registriert seit:
    13.09.2009
    Phone:
    Pixel XL & Nexus 6P
    Tablet:
    Sony Xperia Tablet Z4
    Wearable:
    LG Watch Urbane 2.
    Hallo,

    zu WPA fällt mir spontan ein Thread aus dem Legend-Forum ein. Vielleicht hängt das irgendwie zusammen, auch wenn es dort nur bei bestimmten Fritzboxen zu Problemen führt: http://www.android-hilfe.de/htc-leg...hat-wlan-betrieb-mit-fritz-box-wpa-modus.html

    Probier doch mal WEP aus, dies funktioniert bei den Fritzboxen.

    Eine weitere Möglichkeit kann in einem neuen Passwort liegen. Wenn Du da irgendwelche Sonderzeichen drin hast, macht das evtl. Probleme. Probiers also mal zunächst mit einem einfachen WPA-Passwort.

    Aber es könnte auch am dWL900AP liegen, ich hatte damit auch häufig Probleme und habe das Teil dann irgendwann rausgeschmissen.

    Viele Grüße
    Handymeister
     
  3. mago, 09.05.2010 #3
    mago

    mago Junior Mitglied

    Beiträge:
    33
    Erhaltene Danke:
    4
    Registriert seit:
    30.04.2010
    Phone:
    HTC Desire
    Bist Du denn sicher, dass Dein Desire mit deinem AP verbunden ist? Einstellungen -> Dratlos und Netzwerke -> Wlan (Verbunden mit <Deine SSID>).

    Wenn da Deine SSID steht, dann wäre es interessant auf Deinem Router rauszubekommen, welche IP-Nummer an Dein Desire vergeben wurde.

    Wenn Du diese Information hast, kannst Du von einem anderen Rechner in Deinem Netzwerk ein "ping <IP-Nummer deines Desire>" ausführen und so das Desire erreichen?

    Ich vermute folgendes. Wenn eine Verbindung zustande gekommen ist. Entweder kann Dein Accespoint deinem Desire überhaupt keine IP-Nummmer zuweisen, oder die Konfiguration der Verbindung ist nicht vollständig. Vielleicht kein DNS.

    Wie mein Vorposter schon andeutet, wir wohl das Accesspoint das Problem sein. Denn zB. mein Desire kann mit verschiedenen APs sehr gut.
     
  4. Handymeister, 09.05.2010 #4
    Handymeister

    Handymeister Foren-Manager Team-Mitglied Foren-Manager

    Beiträge:
    35,048
    Erhaltene Danke:
    23,545
    Registriert seit:
    13.09.2009
    Phone:
    Pixel XL & Nexus 6P
    Tablet:
    Sony Xperia Tablet Z4
    Wearable:
    LG Watch Urbane 2.
    Naja nitron hatte ja geschrieben, dass es ohne Verschlüsselung funktioniert.
     
  5. LordOfTheSnow, 09.05.2010 #5
    LordOfTheSnow

    LordOfTheSnow Android-Hilfe.de Mitglied

    Beiträge:
    88
    Erhaltene Danke:
    13
    Registriert seit:
    21.04.2010
    WLAN ohne Verschlüsselung ist irgendwie ein bisschen fahrlässig. Ich hab allerdings "nur" eine FritzBox, und da funktioniert WPA tadellos.
     
  6. schossel, 10.05.2010 #6
    schossel

    schossel Erfahrener Benutzer

    Beiträge:
    236
    Erhaltene Danke:
    27
    Registriert seit:
    22.07.2009
  7. nitron, 10.05.2010 #7
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    Also verbunden bin ich und die einstellungen sind auch alle i. O.

    Was mir der AP zurück gibt, in der Log, ist:

    May/10/2010 13:13:55 Authentication success 00-...
    May/10/2010 13:13:55 state: paeDISCONNECTED
    May/10/2010 13:13:55 Wireless PC connected 00-...

    SSID, IP, Gateway, Subnet, DHCP stimmt mit immer überein - offen und geschlossen.

    Gibts irgendein Screencapture-App?
     
  8. nitron, 10.05.2010 #8
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    Ohne Sperre:
    Ping wird ausgeführt für 192.168.0.157 mit 32 Bytes Da
    Antwort von 192.168.0.116: Zielhost nicht erreichbar.
    Antwort von 192.168.0.157: Bytes=32 Zeit=1301ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=920ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=841ms TTL=64

    Mit Sperre
    Ping wird ausgeführt für 192.168.0.157 mit 32 Bytes Daten:
    Antwort von 192.168.0.116: Zielhost nicht erreichbar.
    Antwort von 192.168.0.157: Bytes=32 Zeit=1301ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=920ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=841ms TTL=64

    Neu mit Sperre:
    Ping wird ausgeführt für 192.168.0.157 mit 32 Bytes Daten:
    Antwort von 192.168.0.157: Bytes=32 Zeit=69ms TTL=64
    Zeitüberschreitung der Anforderung.
    Zeitüberschreitung der Anforderung.
    Antwort von 192.168.0.157: Bytes=32 Zeit=2832ms TTL=64
     
  9. mago, 10.05.2010 #9
    mago

    mago Junior Mitglied

    Beiträge:
    33
    Erhaltene Danke:
    4
    Registriert seit:
    30.04.2010
    Phone:
    HTC Desire
    Die ersten beiden pings deuten darauf hin, daß in Deinem Netz etwas durcheinander geht. Eine Möglichkeit wäre, daß sich zwei Geräte in Deinem Netz als Router zuständig fühlen.
    Die 192.168.0.116 dürfte da nicht vorkommen.
    Kannst Du die IP-Nummer einem Gerät zuordnen?
     
  10. nitron, 10.05.2010 #10
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    hatte das falsche kopiert bei offen:
    Ping wird ausgeführt für 192.168.0.157 mit 32 Bytes Daten:
    Antwort von 192.168.0.157: Bytes=32 Zeit=35ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=32ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=32ms TTL=64
    Antwort von 192.168.0.157: Bytes=32 Zeit=30ms TTL=64
     
  11. mago, 10.05.2010 #11
    mago

    mago Junior Mitglied

    Beiträge:
    33
    Erhaltene Danke:
    4
    Registriert seit:
    30.04.2010
    Phone:
    HTC Desire
    Ja gut. Aber mit Sperre meinst Du warscheinlich WPA. Da kommt dann immer noch die 192.168.0.116 in der Antwort vor. Da musst Du rausfinden wozu diese IP-Nummer gehört.
     
  12. nitron, 10.05.2010 #12
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    Naja, das war anscheind nur das einzigste Mal.
    Die erste IP gehörte zu meinem Computer.

    Die restlichen Pingversuche gehen jetzt, nur
    hab ich desöfteren Zeitüberschreitungen.

    Ping wird ausgeführt für 192.168.0.157 mit 32 Bytes Daten:
    Antwort von 192.168.0.157: Bytes=32 Zeit=6ms TTL=64
    Zeitüberschreitung der Anforderung.
    Antwort von 192.168.0.157: Bytes=32 Zeit=4ms TTL=64
    Zeitüberschreitung der Anforderung.

    bzw. macht er den Selbstping nur wenn das Desire in den Standby geht.
     
    Zuletzt bearbeitet: 10.05.2010
  13. nitron, 11.05.2010 #13
    nitron

    nitron Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    09.05.2010
    Ich hab jetzt auf WEP umgestellt, aber kann es sein dass das Desire keine 256 bit verschlüsselung kann? Musste jetzt 128 bit einstellen. Ansonsten funktioniert es.
     

Diese Seite empfehlen