1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Immer wieder Probleme mit Mail-Abruf

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von DDM, 15.03.2011.

  1. DDM, 15.03.2011 #1
    DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Hi,

    ich werd langsam irre mit dem Mail Abruf vom Defy. Mal gehts, mal nicht ... und der Support konnte mir bisher auch nicht weiterhelfen.

    Hab jetzt schon diverses probiert.
    GMX App ... solala, ruft mir aber nix im Hintergrund ab - Push, bzw. stündlich z.B. geht nicht obwohl eingestellt. Außerdem häufig SSL handshake failure I/O

    Defy eigene Software ... geht/ging per Push, allerdings kann ich dort nicht einstellen welcher Ordner für gelöschte Mails zuständig ist und dann gibts nen Kuddelmuddel im GMX Konto. Ziemlich unschön also, wobeis damit bisher am besten ging mit dem Abruf.

    K9-Mail ... bin ich grad noch am testen. Man kann schön die Ordner einstellen, allerdings geht auch die Verbindung nicht so richtig und es kommt oft SSL handshake failure I/O und die Ordner ausm Konto lassen sich nicht aufs Handy laden bisher. Nur Posteingang und Papierkorb.


    Wie habt ihr das gelöst?
     
  2. henkholland, 15.03.2011 #2
    henkholland

    henkholland Fortgeschrittenes Mitglied

    Beiträge:
    334
    Erhaltene Danke:
    29
    Registriert seit:
    14.12.2010
    Ich benutze die "Hauseigene" von Motoblur und das geht gut. Einmal Gmail (als IMAP account), einmal Hotmail (als POP account) (die ab und zu aber weniger als einmal in die Woche ein Authentification Problem meldet) und drei andere Pop mail accounts (auch ohne Empfang Probleme aber da kan ich nicht beantworten; Frage steht noch offen bei Mail-support).
    Push ist aus und jede 30 minuten wird Mail abgeholt.
     
  3. DDM, 15.03.2011 #3
    DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Wie gesagt, das mitgelieferte geht bei mir so gesehen auch am besten. (Verbindungstechnisch).
    Das Problem ist allerdings, dass ich per IMAP die Konten abrufe. Dadurch legt es mir in GMX einen Ordner "Trash" an. Das ist der Ordner, der im Defy als Papierkorb fungiert.
    Den Ordner "Gelöscht" gäbs zwar auch, aber ich kann ihn nicht als Papierkorb im Defy definieren.
    Arbeite ich jetzt so mit diesen Einstellungen/Ordnern, löscht es mir zwar die Mails, allerdings nicht wirklich komplett.
    Geh ich in GMX, wird mir die "gelöschte" Mail immer noch im Posteingang angezeigt, nur ist sie durchgestrichen und wird nicht neu geladen. In K9-Mail bzw. in der GMX App, könnte ich die Ordner entsprechend angeben. Allerdings hab ich mit den Programmen eben immer Verbindungsprobleme.

    Einzige möglichkeit die mir jetzt gerade einfällt. Die SW von Motorola nutzen und Mails nicht löschen, sondern "Verschieben" und in den Gelöscht Ordner stecken. Und unter GMX einstellen, dass er mir die Mails alle x-Tage löscht.

    Wobei das halt wirklich nur ne Notlösung wär und ich das nicht wirklich schön fände.
     
  4. pedda87, 15.03.2011 #4
    pedda87

    pedda87 Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    08.03.2011
    Ich rufe auch 3 Konten (gmx, aol, gmail)über Motoblur ab und es funktioniert wunderbar.
    Aber wo kann ich nochmal das Intervall einstellen, in dem die Mails abgerufen werden sollen? Ich finde das nicht mehr :(
     
  5. DDM, 17.03.2011 #5
    DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Hab mich nochmal drüber gemacht. Jetzt scheints einigermaßen zu klappen mit K9-Mail.
    Und das "Kuddelmuddel" waren durchgestrichene Mails im GMX Postfach. Das problem ist das komprimieren/expurge. Bei K9-Mail ist das dabei und klappt super. Bei Thunderbird am PC muss ich es auch noch einstellen (wusste nicht, dass es das gibt).
    Bei der Defy eigenen SW gibts leider kein Expurge so wie ich das gesehen hab. Wobei ich nochmal dem Support geschrieben hab und die das gefragt hab.
     
  6. Father, 17.03.2011 #6
    Father

    Father Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    04.02.2011
    Phone:
    HTC Wildfire
    kann mir jemand erklären was expurge bedeutet?
     
  7. DDM, 18.03.2011 #7
    DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    purge = Säuberung.
    Also quasi aufräumen in allen Konten ....
     
  8. FrankDr, 18.03.2011 #8
    FrankDr

    FrankDr Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Ich kriege es auch einfach nicht hin mein normales GMX Freemail Konto mit dem Defy zu syncen. Oft kommen Mails - auch automatisch, wie gewünscht. Dann hängt es im Postausgang.

    Ich habs mit K9 probiert. Das gefällt mir eigentlich gut, aber da kann ich ja keine Ordner anlegen (zb. "gesendete").
    emails bekomme ich zwar (oft auch doppelt - vielleicht weil der original Defy email-Konto auch noch definiert ist), aber emails beantworten geht gar nicht - Fehlermeldung.

    Wenn es jemand geschafft hat sein Defy sauber mit GMX zu verbinden (inkl. Push oder automatischem Abruf) wäre ich super dankbar für seine genauen Einstellungen (Email-Konto, oder nur Blur konto, oder nur K9 oder beides, Ports, usw.). :o
     
  9. DDM, 19.03.2011 #9
    DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Also irgendwie ist das ne Krankheit. Ich werd jetzt wohl mal doch wieder auf die Motorola SW gehen.
    Mit dauerhaft aktiver Inet Verbindung (nur 2G) und K9 per Push, hat er mir das Handy in nichtmal 1,5 Tagen leer gesaugt und das Push hat auch nicht wirklich zufriedenstellend funktioniert. Mail schreiben geht auch nicht so ganz einwandfrei per K9.

    Am besten hat das noch mit der Motorola SW funktioniert (Push und schreiben). Allerdings hab ich halt da das Problem mit fehlendem expurge und den gelöscht Mails.
    Sofern aber der Akkuverbrauch besser ist mit dem Motorola SW und Push und schreiben damit gut funktioniert, werde ich halt einfach keine Mails per Handy löschen sondern nur im Browser und in Thunderbird. Alles andere geht ja soweit gut ...
     
  10. DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Ich bekomm jetzt echt bald nen Hals.
    Erst ging die Motorola SW super per Push bei GMX und Gmail.
    Nur fehlte mir dort eben das "säubern".

    K9-Mail getestet, dort geht Push nicht ordentlich, oft kommt nen SSL handshake failure I/O usw.
    Also wieder Motorola SW getestet und jetzt geht dort gar nix mehr. Weder push noch manuell noch sonstwas. Verbindungsfehler. Nichtmal nen googlemail Account lässt er mir einrichten (automatische Konfiguration unter Konten). Da kommt die Meldung das zum Server keine Verbindung hergestellt werden konnte.

    Und was sagt mir der Support von Motorola, schicks ein zu Dat Repair. Wahahahah. Das ist eh schon das zweite Defy. Das erste was wegen Lautsprecherdefekt getauscht wurde, hatte aber genau die gleichen Probleme. Immer dieser scheiß SSL handshake failure I/O
     
  11. FrankDr, 23.03.2011 #11
    FrankDr

    FrankDr Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Also ich musste auch eine Weile basteln, habe aber mit Hilfe eines alten Forum Beitrags mit einer Anleitung, K9 und GMX, sowie Web.de beides perfekt über IMAP eingerichtet.
    Hatte ein paar Tage Wut im Bauch aber nun läuft es absolut perfekt. Ich will damit nur sagen...es ist nicht so, dass es gast nicht m möglich wäre
     
  12. DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Würdest du mir dann bitte sagen wie du es geschafft hast? Ich hab schon im Forum und in Google gesucht und nerv den Support von Motorola. Aber bisher ohne Erfolg.
    Funktioniert hast noch nie wirklich und umso öfter ich rumprobier, umso schlechter klappts.
     
  13. FrankDr, 24.03.2011 #13
    FrankDr

    FrankDr Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Also wichtigster Schritt ist, das original Programm zu löschen. Also unter "Konten" darf kein GMX Konto mehr sein (ausser dein Motoblur-Konto ist auch bei GMX - dann steht dort ...@gmx.de mit einem Schloß dahinter und dem Vermerk "Blur" darunter). Auch bei weitere Konten darf dein GMX-Konto nicht stehen. Das geht alles nur über K-9.

    Danach habe ich K-9 einmal komplett als Anwendung gelöscht und neu aus dem Market installiert, um keine falschen Einstellungen zu überhmen. Danach mit untenstehender Anleitung weitergemacht.

    Damit ging es dann sowohl mit Pop, als auch per Imap. Ich nutze IMAP, sowohl bei web.de als auch bei GMX.de (Tipp: IMAP GEHT AUCH, WENN MAN NUR FREEMAIL KUNDE IST). Wenn ich auf eine der beiden email-Adressen eine email bekomme, erscheint im gleichen Moment eine Nachricht auf meinem Defy, In meinem Posteingangsordner habe ich es mir nun so eingestellt, dass alle Web.de emails gelb hinterlegt sind und alle auch meine GMX Adresse blau. Natürlich kann man aber auch beide Ordner getrennt anschauen. Hat alles ein wenig gedauert, ist nun aber absolut perfekt.


    Hier mal ne Schritt für Schritt Anleitung für K9 i.V.m. GMX und Defy , wobei es wohl auch bei anderen Android Modellen so funktioniertz. Hab mein Handy auf englisch, dürfte aber nicht schwer sein zu verstehen, was gemeint ist: Im K-9 stellst Du folgendes ein:

    1. Acount hinzufügen
    2. vollständige eMail (mit @gmx.de) und Passwort eintragen
    3. Manuel Setup anklicken
    4. imap auswählen
    5. - Unter Benutzername ist nun nur der Name (ohne @gmx.de) voreingestellt. Hier musst du glaube ich noch "@gmx.de" ergänzen
    - unter imap server: imap.gmx.de eintragen
    - Security Type habe ich "always ssl" gewählt
    - port stellt sich automatisch ein (993)
    - dann auf weiter drücken
    6. nun müsste ein Posteingangsservertest starten und funktionieren
    7. - nun wird der Postausgangsserver eingestellt
    - hier müsste unter smtp server: mail.gmx.de stehen
    - security type wieder: SSL (always)
    - Port 465
    - Haken bei: require sign-in
    - auf weiter drücken
    - nun müsste ein positiver Posteingangsservertest laufen
    8. - Folder Poll Frequency: habe ich auf niemals, da durch push die Nachrichten sowieso kommen und kein poll spart Batterie.
    - Haken bei Enable push mail for this account
    und den Rest einstellen wie Du magst.
    Auf weiter klicken und der Account ist eingestellt.
    Im letzten Fenster kannst Du einen Namen für den account (nur für dich in der K9 App) und einen Absendernamen (sehen dann die Empfänger) eingeben.

    Fertig

    PS: Wer dennoch POP statt IMAP nutzen mag, müsste anstatt obiger Beschreibung dann folgendes beim Eingangsserver eintragen.
    login: Email@gmx.net
    SSL Ja
    server: pop.gmx.net
    Port: 995


    Du kannst ja auf den "Danke" Button drücken, wenn es Dir geholfen hat, dann wirds auch für andere später leichter diese Anleitung zu finden ;-)

    Tags für die Suche: Defy , K9 , K-9 , GMX , WEB , Web.de , GMX.de
     
    Zuletzt bearbeitet: 24.03.2011
    magdap, philofax, KnappTwo und 2 andere haben sich bedankt.
  14. DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Sodala. Habs genau so gemacht wie du gesagt hast. Keins der Mail Konten unter "Konten" drin gehabt.
    K9 gestoppt, Cache geleert, deinstalliert, neu installiert aus dem Market.
    Meine 2 GMX und meine GMail Adresse eingetragen.
    (Bei den Daten für GMX müsste es doch eigentlich jeweils .net und nicht .de heißen bei imap und smtp ... hab aber beides probiert)
    1. Problem, die Prüfung jeweils geht nicht, nichtmal bei Gmail. "Verbindung zum Server konnte nicht aufgebaut werden".
    2. Push eingestellt, abruf auf manuell, aber er pusht nicht.
    3. Manueller Abruf führt zu SSL handshake failure I/O

    Das einzige was vorher einigermaßen jetzt heut funktioniert hat, war der Abruf über Zeitplan alle Stunde z.B. Wobei's da auch so war, dass er oft(immer?) erst abgerufen hat, wenn ich das Handy genutzt hab, also wenn es quasi aktiv und nicht in Ruhemodus war.

    Ich hab jetzt Netzwerk->Hintergrund Sync mal auf Immer gestellt und werde nun noch wieder bei den Konten den zeitlichen Abruf auf ne Stunde oder so stellen.

    Zufriedenstellend funktionieren tuts jedenfalls nicht. Nichtmal googlemail geht, was ich echt für nen Witz halte.
    Der Motorola Kontakt sagt mir nur, ich solls zu DatRepair schicken, sie können das Problem nicht nachstellen ... (null Bock drauf).
     
  15. FrankDr, 25.03.2011 #15
    FrankDr

    FrankDr Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    DDM: Also Du missverstehst da was.
    Es nennt sich POP, wenn du den Maileingang nach einem bestimmten Zeitplan abrufst.
    Es nennt sich IMAP, wenn neue Mails ganz automatisch gepushed werden.

    Du mischst scheinbar beide Einstellungen. Die beschriebene Prozedur oben ist für IMAP. Tatsächlich kann er nur pushen, wenn das Handy aktiv ist. Aber man kann im K9 auch einstellen, in welchem Intervall, er mal kurz aktiv sein soll (Standard sind 24 Minuten, ich selbst habe 12 Minuten). Das heisst, seöbst wenn das Defy unbenutzt daliegt (dann taktet der Prozessor usw. alles runter um Strom zu sparen), wird spätestens nach 12 Minuten kurz aktiv gegangen und per Imap Push kommen die emails... wenn ich das Handy nutze, kommen sie sofort (und zwar exxakt im gleichen Moment wie sie bei GMX oder WEB eingehen).
    Ich hoffe das war nochmal leicht erklärt.

    Du brauchst keinen manuellen Abruf einstellen und du brauchst keinen automatischen Abrufintervall einstellen. Das geht durch IMAP vollautomatisch (s. Anleitung oben).
    POP ginge natürlich auch, braucht aber viel mehr Akku, da dein Defy im eingestellten Intervall sich quasi immer in deinem Email-Konto einloggt, nachprüft und ggf. neue emails zieht. Bei Imap übernimmt dein email-Konto die aktive Seite und pusht Dir neues. Dein defa ist dann quasi nur passiver Empfänger, was quasi kein Strom braucht.

    Also meine email-adresse nennt sich XYXY@gmx.de falls deine .net endet, kann es natürlich sein, dass du es dann so eingeben musst.
     
  16. DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    Ich weiß was pop und imap bedeutet. Jedoch funktioniert push bei mir nicht, obwohl es eingestellt ist. Das ist ja das Problem.
    IDLE Verbindung refreshen hab ich auf den Standard 24min.
    Mit WLan funktioniert alles super, aber sobald ich übers mobile Inet die Mails abrufen lassen will, geht push nicht. Versenden geht auch nicht.
    Es kommt immer dieser doofe SSL handshake failure I/O.


    Meine Mail Adresse endet auch auf .de. Trotzdem sind die Daten für den Server imap.gmx.net und mail.gmx.net
     
  17. DDM

    DDM Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    287
    Erhaltene Danke:
    5
    Registriert seit:
    11.01.2011
    So, warum auch immer, mittlerweile funktioniert es relativ gut.
    Problemchen hab ich trotzdem noch.
    1. Push geht, aber beim manuellen Abruf im mobilen Netz, bekomm ich oft nen SSL handshake failure I/O. Nicht immer, aber meistens.
    2. Nachrichten senden, geht solala. Manchmal gehts, manchmal auch SSL handshake failure I/O.
    3. Ich hab den Eindruck, dass die IDLE Aktivierung nicht funktinoniert bei mir. Eingestellt ist sie auf Standard 24min. Allerdings bekomme ich häufig Mails erst, wenn ich das Handy mal kurz angeschaltet hab. Kann es sein das ich diese IDLE Verbindungserstellung im Defy irgendwie geblockt hab oder sowas?

    Andere Frage:
    Hat jemand den Vergleich MailDroid <-> K9. Hab jetzt schon das ein oder andere mal auch von MailDroid gelesen. Nur selbst testen ... müsst ich wieder K9 erst deinstallieren und wenns dann mit MailDroid doch nicht passt und ich K9 wieder installier, hab ich evtl. die gleichen Probleme wieder wie vorher. Und darauf hab ich keine Lust =)
     

Diese Seite empfehlen