1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

JPM - WLAN Standby-Richtlinie: Oft kein WLAN nach längerem Handystandby

Dieses Thema im Forum "Samsung Galaxy 3 (I5800) Forum" wurde erstellt von DaBigFreak, 30.03.2011.

  1. DaBigFreak, 30.03.2011 #1
    DaBigFreak

    DaBigFreak Threadstarter Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Hallo,
    nun möcht ich auch mal ein Problem starten.

    Ich möchte Strom sparen, darum habe ich unter WLAN Standby-Richtlinie "Bei ausgeschaltetem Display" aktiviert, sprich Display aus, WLAN aus. Display an, WLAN an.
    Funktioniert auch, aber nur so lange, wie der Standby nicht zu lange angedauert hat. Ist das Handy also für eine Weile, mehr als ca 10-30 Minuten, im Stanby, schalte es wieder ein, so wird WLAN nicht richtig aktiviert.
    Anders herum geht es sogar ähnlich. Ich schalte kurz das Display ab, nach 5 bis maximal 8 Minuten (Schätzwert), ist WLAN sofort noch verfügbar, scheint also garnicht abgeschaltet gewesen zu sein.

    Unter 2.1 ging das sehr viel besser, wie oben, Display an, WLAN an und umgekehrt. Ging sofort an und aus.

    Habe einen Werkseinstellungsresett gemacht, alles manuell neu eingerichtet, kein Backupapp verwendet.

    Kann das jemand bestätigen? Sogar sagen wie man es beheben kann?
     
  2. Wicked Ninja, 30.03.2011 #2
    Wicked Ninja

    Wicked Ninja Android-Experte

    Beiträge:
    717
    Erhaltene Danke:
    113
    Registriert seit:
    03.01.2011
    Phone:
    Samsung Galaxy A3 (2016)
    Tablet:
    Huawei MediaPad T1 10
    Hatte ich unter Eclair auch zeitweise.

    Gibt dazu auch hier einen Thread irgendwo... da hat einer ne App gebastelt die nach einer bestimmten Zeit (selbst einstellbar) einen Ping absetzt und somit das WLAN Signal aufrecht erhält.

    Ich habe dem G3 eine feste IP verpasst und seitdem habe ich das Problem nicht mehr.
     
  3. VonDroid, 30.03.2011 #3
    VonDroid

    VonDroid Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    30.03.2011
    Als Einzeiler / kurz: Ja, Nee.
    Erstmal volle Bestätigung: Mit 2.1 war auch bei meinem G3 (zumindest was WLAN betrifft ) - alles so, wie es sein sollte, naja - oder noch genauer - wie man nach Anleitung erwartete.
    Ab Version 2.2 (ich hatte auch die xxJPL, jetzt xxJPM) dann auch bei mir ein verbindungsunwilligeres WLAN.
    Mein Vorantworter - falls nicht noch einer schneller war - benutzt feste IP ohne Probleme. Das kann ich nicht bestätigen:
    Ich benutze auch kein DHCP (also für G3, Gateway und DNS1 feste IPs angegeben. Proxy und DNS2 bei mir keine IP, Netzmaske 255.255.255.0). Der Effekt ist bei mir aber so wie beim Themenersteller, Zeitangaben kommen in etwa hin, sind aber nicht zuverlässig konstant. Tritt bei mir auch auf, wenn ich Standby von 'Wenn Bildschirm ausgeschaltet wird' auf 'Nie wenn eingesteckt' umschalte.
    Zusätzlich bemerkter Effekt: Wenn aus dem Standby zurück und keine WLAN-Verbindung hergestellt wird, dann brauche ich nur einen WLAn-Scanner starten (mehrfach getestet mit 'WiFi Analyzer' und 'WiFi Manager'), schon erwacht meine Verbindung.
    Beobachteter Nebeneffekt: Wenn das WLAN-Signal in der Statuszeile schwach scheint (1 von 3 Strichen),obwohl der Sender nur 2m entfernt steht, dann wird es stärker, wenn ich in die WLAN-Einstellungen gehe und dann ohne Änderungen auf speichern drücke...:blink:
    Hoffentlich nicht zu lange Mitteilung, deshalb dieser Satz auch schon ohne Verb.
     
  4. DaBigFreak, 30.03.2011 #4
    DaBigFreak

    DaBigFreak Threadstarter Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Also ne app, die alle Minuten nen Ping sendet wär ja total am Sinn des Energiesparens vorbei! Ich möchte ja, dass sich WLAN ausschaltet, nur beim Benutzen an ist. Wenn ichs dauerthaft an haben möchte, dann haue ich die Stromsparfunktion raus und mach es dauerhaft an, das geht, zieht aber imenz Akku!!


    Also das hab ich noch nich probiert, einfach den Browser starten, schauen obs sofort von alleine kommt. Wär ja echt mal nen Feature, wenn das WLAN auch erst dann aktiviert wird, wenn eine App drauf zugreifen möchte ^^ Hehe, so hab ichs noch garnich gesehn.
     
  5. Wicked Ninja, 30.03.2011 #5
    Wicked Ninja

    Wicked Ninja Android-Experte

    Beiträge:
    717
    Erhaltene Danke:
    113
    Registriert seit:
    03.01.2011
    Phone:
    Samsung Galaxy A3 (2016)
    Tablet:
    Huawei MediaPad T1 10
    Nein.. nicht alle paar Minuten einen Ping sondern nach einer festgelegten Zeit. Z.B. alle 90 Min.
    Dann weckt diese App quasi nur für diesen einen Ping das Handy einmal auf, nutzt dafür WLAN und danach geht das Phone wieder in den Standby. Dabei sorgt aber die App dann dafür dass das WLAN-Signal nicht verloren geht.
     
  6. DaBigFreak, 30.03.2011 #6
    DaBigFreak

    DaBigFreak Threadstarter Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Naja, is auch nich was ich mir vorstelle.

    Handy im Standby = WLAN AUS
    Handy in Bnutzung = WLAN AN

    mehr nicht, denn alles mehr verbraucht mehr Akku^^

    Ne andere Geschichte wäre, Internet alle 30 Minuten zu aktivieren, für 1-2 Minuten, dann wieder abschalten. Dann könnte man mit längerem Akku auch "dauerhaft" ICQ online bleiben...hat ja aber nix direkt mit WLAN zu tun, eher ne Firewall die man zeitregeln kann^^
     
  7. VonDroid, 31.03.2011 #7
    VonDroid

    VonDroid Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    30.03.2011
    Das hatte ich auch schon mal probiert - einfach mal Brauser starten, aber da ging bei mir das WLAN auch nicht an. Das hatte ich kurz mit xxJPL getestet. Mit xxJPM ging es gestern und heute aber auch nicht. Wer keine app zusätzlich installieren will und auch dasselbe Problem hat:
    Gerade ausprobiert: Aus Standby zurück, kein WLAN da, Brauser surft auf 'H' weiter... Starte ->Einstellungen ->Drahtlos und Netzwerke ->WLAN-Einstellungen und dann sieht man schon beim ersten Punkte 'WLAN' kurz 'scannen' wird angezeigt und die Verbindung ist da (bei mir ohne DHCP ca. 2s).
    Dann kann man ohne etwas zu ändern wieder zurück wo man her kam. Praktisch ist das nicht gerade, aber es geht dann wenigstens. Kommt mir irgendwie bekannt vor - mit GPS und octy und so. Das geht jetzt zwar besser, aber noch nicht richtig gut - naja auch anderes Thema, ich weiss.
    Da brächte man also 'ne app, die gestartet wird, wenn der Standby-Mode verlassen wird und nur einmal WLAN scannt, oder warten auf Firmware xxJPN?
    Oder - habe ich noch nicht probiert, da ich nach dem update auf xxJPM auf Kaufzustand zurückgesetzt hatte - nochmal WLAN auf DHCP stellen und Einstellungen nochmal neu machen? Das half ja irgendwo anders bei einem WLAN-Problem hier im Forum.
     
  8. Keinbockwurst, 31.03.2011 #8
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    Wie sieht es denn bei euch mit der WLAN verbindungsqualität aus? Ich kann euer problem nicht reproduzieren, bei mir springt das wlan immer an.
     
  9. VonDroid, 01.04.2011 #9
    VonDroid

    VonDroid Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    30.03.2011
    WLAN Qualität problemlos. Notebook teilweise zeitgleich im WLAN. Pegel für mein Netz bei ca. -64db (mit WiFi Analyzer), nur wenige andere WLANs im Umfeld. Um das 'nicht reproduzieren' besser reproduzieren zu können wären da ein paar Gegenfragen meinerseits.
    DHCP oder feste IP? Bei 'Einstellungen' 'Standort und Sicherheit' Punkt 'Drahtlosnetzwerke verwenden' an oder aus?. Standby für WLAN auf welche Zeit eingestellt? Bevor der Schoner deaktiviert wird - ist da WLAN aus (sieht man ja schon in der Statuszeile)? Bei 'WLAN Einstellungen' -> 'Netzbenachrichtigung' an oder aus?
     
  10. VonDroid, 08.04.2011 #10
    VonDroid

    VonDroid Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    30.03.2011
    Noch immer keine Lösung, aber vielleicht hilfreiche Beobachtung: Sieht doch so aus, als wenn WLAN von Standby an/aus nicht richtig etwas mitbekommt.
    Standby an per Tastendruck: WLAN bleibt bis zum Timeout an. wenn WLAN aus war hilft erst ein angestossener WLAN-Scan zur Wiederanmeldung, zumindest, wenn man wie ich mit festen IPs konfiguriert hat. Wie sieht es da bei anderen aus?
    Einfache manuelle Abhilfe (wenn Netzteil oder USB angeschlossen ist):
    Wenn man die mittlere Taste drückt sieht man ja kurz in der Statuszeile, ob WLAN an ist. Wenn es nicht an ist - Standby an lassen / einige Sekunden warten, bis der Schirm sich wieder abschaltet und dann nochmal die mittlere Taste drücken und Standby beenden. Das geht bei mir immer - aber nur mit angeschlossenem Netzteil oder USB-Kabel (nur Strom zum Laden, keine Datenverbindung).
    Wie ist denn die Konfiguration bei denen, wo es geht? DHCP, oder wie?
    'Automatisch benachrichtigen bei neuen Netzen' ändert leider auch nichts an der Problematik.
     
  11. DaBigFreak, 08.04.2011 #11
    DaBigFreak

    DaBigFreak Threadstarter Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    DHCP, wie sich das gehört, alles auf automatisch, damit Windows7 das mit der Heimnetzgruppe geregelt bekommt. Die IPs werden aber vom Router für 2 Wochen behalten, da die Geräte aber nie mehr als ein paar Tage getrennt sind, ist die IP quasi statisch.
    Ich muss definitiv erst die Tastensperre lösen, dann kommt WLAN. Nun geht es auch wieder recht zuverlässig, hatte es nun in den letzten Tagen erst einmal wieder dass es nicht ansprang.
    Bildschirm geht nach 30 Sekunden aus, Drahtlosnetzwerke werden verwendet, Netzbenachrichtigung an.
     
  12. VonDroid, 24.04.2011 #12
    VonDroid

    VonDroid Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    30.03.2011
    Tja, da wollte ich gerade zum schimpfen ausholen - was heißt hier 'geht wieder besser'... und dann habe ich denselben Effekt. Ohne zwischendurch etwas grundlegend geändert zu haben wohlgemerkt. Vielleicht kosmische Strahlung? Normalerweise findet sich ja irgendein Grund für Verhaltensänderungen, aber so wüßte ich nicht, wie es dazu kommt. Dafür geht jetzt manch anderes nur noch sporadisch. GPS-Status findet mal schnell was (10 Sek.), mal nach 30 Min nichts (am selben Ort), nach 5 Min Pause.
    Wenn ich mit USB-Kabel lade (nur Stromverbindung) bleibt auch nach dem Abziehen die Statusmeldung auf 'USB verbunden'. Neustart bessert das auch nur bis zur nächsten Ladung.
    Der diesen Thread auslösende Grund ist bei mir aber jetzt auch verdampft.
    WLAN geht wieder zuverläsig an nach Standby, Immer noch mit festen IPs.
    Das finde ich so auch nicht verkehrt. Bei mir geht Win7 auch mit festen IPs.
    Sehe gar nicht ein, dass mir da einer die Nummern vermischt. Aber das nur am Rande, weil mir erwähnenswert scheint, dass ich nicht der Meinung bin, dass bei mir etwas nicht so eingestellt ist, wie es sich gehört.
    Könnte sonst sein, dass die Installation von Apps das Verhalten ändern?
    Mein GPS-Status ging nach Froyo 2.2 mit Wipe nämlich zuerst SEHR gut,
    jetzt auch meistens, aber nicht sicher, AndAndo hing schon zwei Mal...
    Seltener sehe ich bei Elektronik sporadische Selbstheilung.:sneaky:
     
  13. xXmyselfXx, 25.04.2011 #13
    xXmyselfXx

    xXmyselfXx Fortgeschrittenes Mitglied

    Beiträge:
    318
    Erhaltene Danke:
    22
    Registriert seit:
    05.02.2011
    Also ich hab den juice defender ultimate installiert. Da ist alles zum Strom sparen drin inklusive wlan aus im standby. Klappt bei mir super. Die app sagt dass sich meine Akku Laufzeit verdoppelt hat...keine Ahnung ob das stimmt. Handy leer->Strom. Fertig x D

    Gesendet mit der Android-Hilfe.de-App
     

Diese Seite empfehlen