1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Kernel flashen

Dieses Thema im Forum "Root / Hacking / Modding für HTC Wildfire" wurde erstellt von Sascha-Wildfire, 10.04.2012.

  1. Sascha-Wildfire, 10.04.2012 #1
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Edit: >>> gelöst!!! <<<

    Hallo, ich hätte da auch gerne mal ein Problem;)

    Nachdem ich jetzt tagelang gegoogelt und gelesen habe und auch hier nicht weitergekommen bin (trotz Sufunu), mache ich mal diesen Thread auf...

    Zur Sache:
    ich habe, wie man lesen kann, das Wildfire (ohne S) und dieses mit revolutionary gerootet. Froyo 2.2.1 Sense (soll auch so bleinen).

    Wollte jetzt - nachdem ich viel darüber gelesen habe - den HCDR-Kernel 4.1 draufmachen, um dann moderat aber doch mit etwas "Nachdruck" übertakten zu können.

    Großes EDIT:
    Das Flashen des Kernels scheiterte wohl bis jetzt immer daran, dass ich nicht den Clockworkemod Recovery drauf hatte?!
    Immer wenn ich ins normale Recovery gegangen bin, dann hat sich mein WF mit dem berühmten roten Dreieck mit dem Ausrufezeichen drin aufgehängt...

    Da ich auch anscheinend zu blöd dazu bin (trotz goggeln und lesen ohne Ende), ein neues Recovery auf mein Handy zu flashen, habe ich es dann mit der App "Kernel Manager pro" versucht (extra dafür gekauft).

    Das hat dann auch tatsächlich nach dem zweiten Versuch funktioniert.
    Nun hab ich den HDCR Kernel v4.1 drauf und muss leider feststellen, dass das W-Lan nicht mehr funzt! Ich brauche aber W-Lan und will auch auf Tethering nicht verzichten (geht nämlich auch nicht mehr).
    Jetzt hab ich noch ein paar andere Kernel runtergeladen und auf meine SD-Karte gepackt, die ich jetzt mal ausprobieren wollte. Nun funktioniert das aber mit dem Kernel Manager nicht mehr (schließt sich jedes Mal während des Flashens bzw. wird geschlossen).

    Nun komm ich also anscheinend doch nicht drumherum, die andere Recovery zu flashen...

    Aber ich kann es mir so oft durchlesen wie ich will, ich krieg's nicht hin. Horror!
    Ich hab die img-Datei auf meinem Rechner, aber bei der Beschreibung

    Nun öffnet ihr ein Kommando Fesnter (Windows-Suche, Ausführen-Fenster etc.) und wechselt mit Code:
    cd C:\adb-tools\
    in euren ADB Ordner.

    komm ich schon nicht mehr weiter:-(

    Kommandofenster öffnen, das krieg ich noch hin.
    Da steht dann aber schon drin "C:\Dokumente und Einstellungen\HP_Besitzer>"

    Ich habe dann dahinter "cd desktop\recovery" eingegeben (denn in dem Ordner hab ich die recovery.img liegen).
    Nach Enter steht dann da im Fenster "C:\Dokumente und Einstellungen\HP-Besitzer\Desktop\Recovery>"

    Und jetzt???
    Hab's auch schon mit dem ROM Manager versucht, mit dem es ja eigentlich super einfach sein sollte/müsste. Aber auch das geht nicht.
    Der zeigt mir z.B. unter "Clockworkmod Recovery installieren": Aktuelles Recovery-System: Clockworkmod 5.0.2.0
    Aber es ist anscheinend nicht installiert, denn ich finde es im Bootmenü nicht. Nur das normale Recovery, und wenn ich das anklicke (mit Powertaste), dann geht's ab in Richtung rotes Warndreieck = Ende Gelände!
    Und wenn ich im ROM Manager auf "Neustart ins Recovery-System" klicke, dann genau dasselbe: Neustart und dann rotes Dreieck...

    BITTE BITTE helft mir.
    Vielen Dank.
    Der Sascha

    P.S.: also ich hab jetzt mal Setcpu installiert und auf 710 max. und 160 min. gestellt...
    Da geht schon ordentlich die Post ab! Vor allem sieht man ja gleich, wie oft er an die 710 hochfährt. Ich denke, wenn man reichlich Apps installiert hat, dann macht das schon echt Sinn (zumindest beim leistungsmäßig doch eher bescheidenen Wildfire;-))

    Also diese Performance würde ich schon gerne behalten, nur es muss halt das W-Lan funktionieren...

    P.P.S. und EDIT:
    Jetzt hab ich es tatsächlich nach (gefühlten) 84 Versuchen mit "Kernel Manager pro" (der ja immer beim Flashen geschlossen wird) geschafft, einen anderen Kernel (2.6.35.14-n Finity) zu flashen. Auch den kann man übertakten. ABER auch da funktioniert das W-Lan nicht. Liegt das jetzt wirklich noch am Kernel, dass das W-Lan nicht geht?

    Danke für Tipps, Ratschläge usw...:)
     
    Zuletzt bearbeitet: 15.04.2012
  2. Sascha-Wildfire, 11.04.2012 #2
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    So, hab's mit einer anderen Anleitung endlich geschafft!

    P.S. (EDIT): wen's trotzdem noch interessiert (ich will ja hier im Forum nicht nur Fragen stellen, sondern mich auch "beteiligen"):

    Ich hab jetzt insgesamt folgende Kernel ausprobiert, und mit allen genannten hatte ich KEIN WLan und auch nicht immer Mobiles Netzwerk:

    HCDR v. 4.1
    Finity 2.6.35.14-n
    buzz-kernel 2.6.35mc1
    arco.kernel RC4.1 mc1

    Jetzt habe ich folgenden Kernel drauf:

    HCDR v.4.2mc2

    Mit dem funzt es einwandfrei (WLan und mobiles Netzwerk)!

    Den HCDR v. 4.2mc1 habe ich dann gar nicht erst ausprobiert!

    Ich habe die Werte bei Setcpu auf 729 max. und 160 min. gestellt, und ich kann nur sagen: ich hätte echt nicht gedacht, dass ich solche Leistung aus dem "alten" Wildfire rausholen kann! Komm mir vor, als hätte ich ein neues Phone:)

    Ich muss allerdings dazusagen: ich habe eine SD-Karte der Klasse 10 (!) , und die App "SD-Booster" installiert! Da wird jetzt natürlich noch mehr rausgeholt... Denn was nützt z.B eine schnelle CPU, wenn die Daten zwischen SD-Karte und Phone nicht schnell genug "fließen" können (insbesondere bei App2SD-Apps, die erst von der SD geladen werden müssen und beim Laden von Fotos)?!

    Den Stromverbrauch kann ich jetzt noch nicht abschließend bewerten. Bis jetzt (ich editiere hier nach 13 Stunden) habe ich jedenfalls das Gefühl, dass der eher nach unten geht, statt nach oben...
    Aussetzer oder sonst irgendwas konnte ich bis jetzt absolut nicht feststellen! Nur eines: Tempo, Tempo, Tempo!!! Der Wahnsinn!! Freu:thumbsup:

    Das wirklich einzige, was ich negativ erwähnen kann (und der Ehrlichkeit halber auch will), ist, dass das "hauseigene" Tethering nicht mehr einwandfrei arbeitet. Dies hab ich jedoch mit einer kostenlosen Tethering-App ("Barnacle Wifi Tether", scheint auch die einzige zu sein, die mit wirklich jedem Kernel funzt) beheben können.
    Also auch Tethering - auf das ich auf gar keinen Fall verzichten will - funktioniert jetzt einwandfrei!

    Es gingen übrigens auch absolut keine Daten oder Einstellungen bei der ganzen Aktion verloren!

    Ich hoffe, ich konnte einigen vielleicht etwas helfen bei der Frage "Neuer bzw. anderer Kernel, oder lieber doch nicht?"...

    Einen freundlichen "Wildfire-Gruß"
    Sascha aus München
     
    Zuletzt bearbeitet: 13.04.2012
  3. Maetzi, 13.04.2012 #3
    Maetzi

    Maetzi Android-Hilfe.de Mitglied

    Beiträge:
    142
    Erhaltene Danke:
    15
    Registriert seit:
    18.10.2011
    Hallo

    Also ich hab deinen genannten Kernel Finity 2.6.35.14-n drauf und mit dem funktionierte bei mir mit CM7 und jetzt High Voltage three W-Lan und Tethering wunderbar.
     
  4. Sascha-Wildfire, 13.04.2012 #4
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Das freut mich für dich.
    Ich habe jedoch Original Sense drauf (woran ich auf keinen Fall was ändern will) und da ging es leider nicht.
     
  5. Maetzi, 13.04.2012 #5
    Maetzi

    Maetzi Android-Hilfe.de Mitglied

    Beiträge:
    142
    Erhaltene Danke:
    15
    Registriert seit:
    18.10.2011
    Das mag sein, das manche Firmware mit manchen Kernel`s nicht richtig zusammenarbeiten. Muß man wohl ausprobieren.
     
  6. Sascha-Wildfire, 13.04.2012 #6
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Ja, und das kostet ziemlich viel Zeit. Aber ich bin froh, dass jetzt alles einwandfrei funzt.
    Ich glaube, dass ich auch mit den Einstellungen 729 max und 160 min ganz gut liege: echt schnell und trotzdem kein höherer Stromverbrauch (insgesamt) feststellbar.
    Wie hast du denn deine CPU stehen?
     
    Zuletzt bearbeitet: 13.04.2012
  7. Maetzi, 13.04.2012 #7
    Maetzi

    Maetzi Android-Hilfe.de Mitglied

    Beiträge:
    142
    Erhaltene Danke:
    15
    Registriert seit:
    18.10.2011
    Meine CPU steht auf 264-691 Mhz.
     
  8. Sascha-Wildfire, 13.04.2012 #8
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Da du mich jetzt neugierig gemacht hast, hab ich nochmal gegoogelt.... Und folgendes herausgefunden bzw. gelesen:
    "Note: Only nFinity mod change 2+ has the wifi hotspot fixed for Sense ROM. Other kernels may has the infamous wifi hotspot issues."

    Also ich hab jetzt die Version 2.6.32.36-n (die in Verbindung mit der o.g. Aussage verlinkt war) draufgeklatscht und nun funzt alles: WiFi und das original Tethering! Unglaublich aber wahr:thumbup:
    Bin begeistert! Vielen Dank also für deine "Anregeung".

    Gruß, Sascha
     
    Zuletzt bearbeitet: 14.04.2012
  9. Maetzi, 13.04.2012 #9
    Maetzi

    Maetzi Android-Hilfe.de Mitglied

    Beiträge:
    142
    Erhaltene Danke:
    15
    Registriert seit:
    18.10.2011
    Freut mich. Zur Zeit will ich gar kein anderes Handy haben, bin mit dem WF sehr zufrieden. Es hat genau die richtige Größe.:cool2:
     
  10. Sascha-Wildfire, 14.04.2012 #10
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Exakt das ist auch meine Meinung!:thumbsup:
     
  11. Sascha-Wildfire, 14.04.2012 #11
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Tja, da hab ich mich wohl etwas zu früh gefreut:
    auch mit diesem Finity-Kernel krieg ich das Tethering nicht ans laufen...

    Es sah zwar so aus, weil er halt den Hotspot aufbaut und bereitstellt (keine "Fehler"-Meldung), jedoch krieg ich keine Verbindung zu meinem Netbook. Da kann ich machen was ich will.
    Na ja, dacht ich, dann machst halt wieder die Barnacle-App drauf für's Tethering... Aber noch nicht mal mit der krieg ich mit dem Infinty-Kernel eine funktionierende Verbindung. Es wird zwar eine aufgebaut (nach ziemlich langer Zeit), aber es werden keine Daten übertragen. Und das trotz richtiger Einstellungen:(

    Dann hab ich - ohne was an Barnacle zu verändern - wieder den HCDR-Kernel v.4.2mc2 geflasht (der bei der selben CPU-Einstellung meines Erachtens ohnehin ne ganze Ecke schneller arbeitet), und siehe da, Tethering funzt sofort und baut innnerhalb von wenigen Sekunden eine perfekt funktionierende Hotspot-Verbindung auf....

    Mit anderen Worten: der HCDR-Kernel bleibt jetzt drauf. Bin damit echt zufrieden (unter Froyo Sense wohlgemerkt - für alle, die hier unten erst angefangen haben zu lesen).

    Gruß
    Sascha
     
    Zuletzt bearbeitet: 15.04.2012
  12. Sascha-Wildfire, 15.04.2012 #12
    Sascha-Wildfire

    Sascha-Wildfire Threadstarter Erfahrener Benutzer

    Beiträge:
    169
    Erhaltene Danke:
    21
    Registriert seit:
    29.12.2011
    Nach zwei "Einfrierungen" des Systems hab ich auf 710 Mhz runtergeschraubt (also auf den Wert, der ja eigentlich immer so als Max-Wert empfohlen wird). Seitdem läuft alles supi und gefühlt genauso schnell wie mit 729...
    Mann, macht das Spaß, mein "neues" Wildfire:thumbsup:
     
    Zuletzt bearbeitet: 15.04.2012

Diese Seite empfehlen