1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Media Dateien (Bilder, Videos) verschwinden von der SD Karte nach jedem Restart

Dieses Thema im Forum "Foto und Multimedia" wurde erstellt von mpolino, 30.10.2011.

Ist das beschriebene Problem auch bei euch reproduzierbar?

  1. Ja

    3 Stimme(n)
    42.9%
  2. Nein

    4 Stimme(n)
    57.1%
  1. mpolino, 30.10.2011 #1
    mpolino

    mpolino Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Hallo zusammen,

    zum o.g. Phänomen existieren zwar schon zig Foren Beiträge (hier und überall sonst) und sogar an Google gemeldete Bugs/Issues, aber ich habe noch keine dauerhafte Lösung des Problems gefunden. Daher möchte ich dieses Thema hier noch mal zusammenfassend ansprechen. Evtl. hilft die Gemeinschaft hier weiter.

    Zum Problem. Wie schon oben geschrieben, verschwinden bei mir Media Dateien (Bilder, Videos) von der Micro SD Karte nach jedem Restart. Das Problem scheint (nach dem, was ich bisher gelesen habe) Geräte-, ROM-, und Android-Version-unabhängig zu sein. Es gibt Meldungen dazu von Samsung Galaxy-, HTC-, usw. -Besitzern mit unterschiedlichsten ROMs und SD Karten.
    Bei mir geht es um gerootete Hannspree's Hannspad mit HannsTitan 0.4 (Android 2.2.2) und einer 2GB SanDisk MicroSD Karte, um etwas konkreter zu sein.

    Bei meiner Recherche bisher hatte ich folgende Vorschläge/Vermutungen gefunden bzw. ausprobiert:

    • Die SD Karte ist kaputt
      Kann ich eigentlich ausschließen, da es ziemlich unwahrscheinlich ist, dass ausgerechnet die Bilder oder Videos reproduzierbar verschwinden, alles andere aber davon nicht betroffen ist.
    • Die Dateien sind nicht wirklich verschwunden, nur von Galery o.ä. ausgeblendet und können z.B. am PC (per USB oder in einem Kartenleser) oder mit einem DateiManager (Astro, Ghost Commander, ES, etc.) wieder gefunden werden
      Stimmt in meinem Fall nicht. Weg ist weg. Evtl. könnte man durch irgendwelche Recovery Tools (Recuva, etc.) die Bilder wiederherstellen, aber darum geht's mir gar nicht.
    • SDRescan o.ä. hilft
      Das stimmt, wenn die Dateien nicht komplett weg sind. Trifft also in meinem (und bei vielen anderen Betroffenen) nicht zu.
    • QuickPic statt Galery nehmen
      Ich habe die original Galery in die Quarantäne mit App Quarantine (ROOT) verschoben, und hoffe, dass die Anwendung nicht mehr ausgeführt wird. Trotzdem verschwinden die Dateien.
    • nomedia Datei hilft gegen das Löschen
      Das stimmt auch. Die Bilder verschwinden nicht aus den Verzeichnissen, in denen die Datei .nomedia vorhanden ist. Aber das kann nicht der Sinn der Sache sein, da diese Verzeichnisse vom MediaScanner ignoriert, und hiermit erst gar nicht in QuickPic & Co. angezeigt werden.
    Wie gesagt, das Problem ist sehr leicht reproduzierbar (es sind bestimmt andere Wege möglich, aber so habe ich es gemacht):

    • Die MicroSD Karte im Kartenleser am PC oder aber mit einem DateiManager im Tablett direkt mit beliebigen Bilder/Videos beschreiben
      Dabei ist es egal, in welche Verzeichnisse die Dateien kommen: Sobald keine .nomedia Datei im Verzeichnis vorhanden ist, werden die überall gefunden und anschließend nach dem Restart gelöscht.
    • Ins Tablett eingesteckt, werden die Dateien sofort erkannt und im z.B. QuickPic angezeigt. Auch die Dateimanager (s. o.) zeigen alle Dateien.
    • Restart durchführen (egal ob "soft" durch "Restart now" oder "Ausschalten" oder "hard" durch längeres drücken des Buttons)
      Wenn man ganz schnell nach dem Neustart QuickPic aufmacht, sieht man übrigens noch kurz einige Bilder. Nach Paar Sekunden verschwinden die aber schon komplett.
    Ich habe das mit ca. 10 Bilder versucht, die ich über diverse Ordner auf der MicroSD verstreut habe. In anderen Berichten ließt man z.B. von 70-80% Schwund bei 400 Fotos. Die Zahlen unterscheiden sich immer, gemeinsam haben die Beiträge nur, dass bei größerer Anzahl von Bildern die nicht alle gleich verschwinden, sondern irgendwie "schleichend", nach und nach gelöscht werden. Den Verdacht auf böswillige Freundinnen oder Kobolde, die in der Dunkelheit ihr Unwesen treiben, kann man wohl meistens ausschließen.

    Mit diversen Tools (What's up, LogCat, OS Monitor, etc.) habe ich versucht die System Logs auszulesen. Ich sehe dort, dass die SD Karte gemountet wird. Wenn ich mit einem Dateimanager etwas drauf kopiere, sehe ich das ebenfalls in den Logs. Aber keine Spur vom Löschen. Entweder sind die Tools nicht geeignet, oder ich schaue mir die falschen Logs an, oder es wird irgendwie anders geloggt, so dass ich es gar nicht finde.

    In einem der Beiträge habe ich einen Hinweis gefunden, dass beim Linux das Mounten eines Devices/Verzeichnisses an einem MountPoint den Inhalt des dort zuvor gemounteten Devices u.U. überschreiben kann. Passiert hier vielleicht so etwas?

    Gibt es vielleicht ein App, mit dem man die Dateizugriffe überwachen/loggen kann? Evtl. könnte ein geschickter Android-Entwickler so etwas schnell programmieren? Mich würde interessieren, welcher Prozess fürs Löschen zuständig ist.

    Ist das Problem so wie ich es beschrieben habe auch bei euch reproduzierbar? Oder zumindest bei einigen von euch...

    Hat jemand sonst noch irgendeine Idee, wie man das analysieren/debuggen kann?

    Und natürlich die spannendste Frage: Hat jemand schon das Problem erfolgreich und dauerhaft lösen können?

    Hoffe auf eine rege Diskussion in diesem klasse Forum und bin gespannt, was dabei rauskommt.

    Schöne Grüße,
    Michael
     
  2. mpolino, 03.11.2011 #2
    mpolino

    mpolino Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Da bin ich wieder.
    Ich habe gehofft, zumindest Paar Anregungen zu bekommen. Können die Experten hier im Forum nichts mit meinen Ausführungen anfangen? Oder ist der Text zu lang zum Lesen?
     
  3. mpolino, 28.11.2011 #3
    mpolino

    mpolino Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Habe mal eine Umfrage hinzugefügt, in der Hoffnung, dass sich doch noch jemand meldet...
     
  4. theflo, 28.11.2011 #4
    theflo

    theflo Erfahrener Benutzer

    Beiträge:
    217
    Erhaltene Danke:
    26
    Registriert seit:
    03.10.2010
    Hast du schon andere SD-Karten ausprobiert?
    Oder auch einmal die SD-Karte (im Handy) neu formatiert?
     
  5. TimoBeil, 28.11.2011 #5
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,867
    Erhaltene Danke:
    3,530
    Registriert seit:
    20.09.2010
    mpolino bedankt sich.
  6. mpolino, 29.11.2011 #6
    mpolino

    mpolino Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Danke erstmal für eure Antworten.

    Eine andere SD-Karte habe ich nicht ausprobiert, da ich leider keine habe. Aber, wie ich schon sagte, es ist ziemlich unwahrscheinlich, dass ausgerechnet die Bilder oder Videos reproduzierbar verschwinden, alles andere aber davon nicht betroffen ist. Daher würde ich eine kaputte Karte eigentlich ausschließen.
    Die Karte im Tablett neu zu formatieren wäre eine Möglichkeit. Allerdings bin ich mir da etwas unschlüssig, wie ich das machen soll. Wenn ich auf Einstellungen -> SD-Karte & Telefonspeicher gehe, sehe ich 3 Sektionen:

    1. SD-Karte
      Gesamtspeicher 13.06 GB
      Verfügbarer Speicher 11.98 GB
      Trennung...
      SD-Karte formatieren
    2. Interner Telefonspeicher: /mnt/sdcard2
      Gesamtspeicher 1.89 GB
      Verfügbarer Speicher 1.69 GB
    3. Interner Telefonspeicher
      Gesamtspeicher 1.84 GB
      Verfügbarer Speicher 1.40 GB
    Die Anzeige finde ich etwas irreführend. Bei 1. gehe ich eigentlich von dem eigentlichen internen Tablett-Speicher aus, weil meine MicroSD nur 2GB hat. Daher kann die nur 2 oder 3 sein. Eher 2 wegen "/mnt/sdcard2". Was dann die 3 ist weiß ich nicht. Evtl. irgendeine User- oder App-Partition des Tabletts.
    Das würde bedeuten, dass ich die SD-Card gar nicht im Tablett formatieren kann? Oder sehe ich da was falsch?

    Dann habe ich noch zumindest ein ROM mit diesem Bug entdeckt. Und meiner scheint hartnäckiger zu sein, da mir der Tipp von Arcelor leider nichts gebracht hat: Auch nach der Installation von Rescan Media Root ist das beschriebene Problem immer noch da. Oder soll man im Tool etwas besonderes beachten? Ich habe es einfach gestartet, die Meldung "Everything worked fine. You can quit now." bekommen, Tool verlassen und neu gestartet. Die Bilder auf der Karte, die drin war, waren weg nach dem Neustart.

    Heißt für mich: Immer noch keine Lösung in Sicht...
     
  7. TimoBeil, 29.11.2011 #7
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,867
    Erhaltene Danke:
    3,530
    Registriert seit:
    20.09.2010
    Die App ist etwas unübersichtlich aufgebaut. Ich hatte mich anfangs auch gewundert, dass der Mediascan gar nicht wie gewünscht unterdrückt wird. Erst später hatte ich gemerkt, dass man im Menü einen entsprechenden Haken setzen muss. Dann mit dem Zurück-Button die App verlassen und schon ist Ruhe mit der nervigen Scannerei.
     
    mpolino bedankt sich.
  8. mpolino, 29.11.2011 #8
    mpolino

    mpolino Threadstarter Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Eigentlich wollte ich schon schlaffen gehen, aber das muss ich unbedingt noch ausprobieren!

    EDIT: Das hilft tatsächlich!!! Die Bilder sind jetzt auch nach dem Restart noch da. Ein Haken war das nicht in der App, eher ein Button. Aber egal. QuickPic wird wohl einen eigenen Scanner haben, da die Bilder auf der Karte automatisch gefunden werden. Ist schon komisch alles.
    Vielen Dank an dieser Stelle an Timo und Arcelor!!!!

    Wenn mir jemand noch die (OT-)Fragen nach der richtigen Zuordnung der diversen Speicher-Anzeigen beantworten könnte...
     
    Zuletzt bearbeitet: 29.11.2011
  9. TimoBeil, 29.11.2011 #9
    TimoBeil

    TimoBeil Ehrenmitglied

    Beiträge:
    5,867
    Erhaltene Danke:
    3,530
    Registriert seit:
    20.09.2010
    Ich will jetzt nicht besserwisserisch wirken, aber ich glaube der Button, von dem du sprichst wirkt nur einmalig. Hast du bei geöffneter App mal die Menütaste gedrückt? Dort sind 3 Checkboxen, die erste davon unterbindet nachhaltig den Mediascan. Dann noch 2x zurück drücken und gut ist's (die Verzögerung beim 2. Zurück ist beschrieben und gewollt).
     
  10. herby68, 23.06.2015 #10
    herby68

    herby68 Android-Experte

    Beiträge:
    772
    Erhaltene Danke:
    143
    Registriert seit:
    11.02.2011
    Phone:
    Samsung Note 7 , ZTE AXON
    seit 2 Tagen zeigt mir meine Gallery app nicht mehr alle meine Bilder im Kamera Ordner, da fehlen locker 200 Stück?
    Quickpic hingegen zeigt alles korrekt an, das ich mir mal testweise installiert habe.
    Jemand ne Idee?
    hab mir sd card scanner aus dem playstore geladen und durchlaufen lassen.
    Problem besteht weiterhin.
    der filemanager zeigt mir ebenfalls an , das meine Bilder im Kamera Ordner sind.
     

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. dateien auf sd karte verschwunden

    ,
  2. wenn man Bilder löscht von Gerät Speicher verschwinde die von sd Karte

    ,
  3. Daten auf sd Karte verschwunden

    ,
  4. micro sd dateien verschwinden,
  5. sd karte bilder verschwunden,
  6. microsd bilder weg,
  7. dateien verschwinden android,
  8. verschwinden von dateien android,
  9. s2 videos verschwunden von sd karte,
  10. micro sd karte fotos verschwunden