1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

phonegap hat neue Dateinamen

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von G.., 07.03.2012.

  1. G.., 07.03.2012 #1
    G..

    G.. Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    07.03.2012
    Hallo,

    man möge mich jetzt verurteilen aber ich bin offenbar nicht fähig mit der Anleitung auf phonegap klar zu kommen.

    Es beginnt damit die FAQ Get Started Guide « PhoneGap wohl auf die Version 1.0 gemünzt ist. Derzeit ist aber nur Version 1.5 Downloadbar. Und hier beginnt das Spielchen. Denn nun heißen die Dateien vollkommen anders es wird von phonegap.js gesprochen. Denn jetzt heißen sie im Androidvereichnis cordova-1.5.0.js .

    Leider ziehen sich die Probleme weiter durch. Und es ist keine Anleitung zu finden die sich auf die aktuelle 1.5 bezieht. Habt ihr hier einen Ansatz?

    Dateien siehe Screenshot
    Die Console meldet:
    Code:
    [2012-03-07 21:22:43 - Unexpected error while launching logcat. Try reselecting the device.] device not found
    com.android.ddmlib.AdbCommandRejectedException: device not found
        at com.android.ddmlib.AdbHelper.setDevice(AdbHelper.java:736)
        at com.android.ddmlib.AdbHelper.executeRemoteCommand(AdbHelper.java:373)
        at com.android.ddmlib.Device.executeShellCommand(Device.java:372)
        at com.android.ddmuilib.logcat.LogCatReceiver$1.run(LogCatReceiver.java:100)
        at java.lang.Thread.run(Unknown Source)
    Dich habe noch folgende Fehlermeldung. Kann damit jemand etwas anfangen?

    screenshot1.png screenshot2.png
     
    Zuletzt bearbeitet: 08.03.2012
  2. Fonsi, 08.03.2012 #2
    Fonsi

    Fonsi Erfahrener Benutzer

    Beiträge:
    178
    Erhaltene Danke:
    15
    Registriert seit:
    08.07.2011
    Ich kenn mich mit PhoneGap nicht aus, aber auf dem ersten Screenshot importierst du "com.phonegrap.*"? :-D
     
  3. G.., 08.03.2012 #3
    G..

    G.. Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    07.03.2012
    Hi,

    oh ja da hat jemand die Postings zusammengefasst. Der Fehler ist bereits behoben. Nun gibt es nur noch die Fehlermeldungen wie Sie hier zu sehen sind. also bei

    PHP:
    public class Beispiel1Activity extends DroidGap {
        
    /** Called when the activity is first created. */
        
    @Override
        
    public void onCreate(Bundle savedInstanceState) {
            
    super.onCreate(savedInstanceState);
            
    super.loadUrl("file:///android_asset/www/index.html");
        }
    }
     
  4. nicos, 08.03.2012 #4
    nicos

    nicos Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    1
    Registriert seit:
    08.03.2012
    Ich kenn mich auch nicht mit PhoneGap aus, interessiere mich aber dafür (nur so als Warnung das ich vermutlich keine tiefgreifenderen Fragen beantworten kann).

    Die Anleitung scheint dem Umzug des Projekts zur Apache Foundation (dort heisst das dann Apache Cordova) hinterherzuhinken.

    Imports aus den Beispielen sind dementsprechend zu ändern von com.phonegap. zu org.apache.cordova.

    Oder - wenn in Eclipse alles richtig eingerichtet ist - man lässt sich von Eclipse mittel "Organize Imports" (Strg-Shift-O) helfen und das automatisch korrigieren.

    (wenn das jetzt noch dein verbleibendes Problem ist - so richtig verstehe ich nicht welches verbleibende Problem du mit deinem letzten Post meinst)
     
    G.. bedankt sich.
  5. G.., 08.03.2012 #5
    G..

    G.. Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    07.03.2012
    :w00t00: Toll genau das war es die Imigration zu Apache ist die Ursache. Jetzt sind die Fehler weg *TOP*

    Danke Danke
     

Diese Seite empfehlen