1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Problem beim Rooten von hboot 1.00

Dieses Thema im Forum "Root / Hacking / Modding für HTC Legend" wurde erstellt von oliverS13, 26.12.2010.

  1. oliverS13, 26.12.2010 #1
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    Hallo!

    Ich habe ein Problem beim rooten meines HTC Legends.
    Wenn ich den HOWTO von BlaY0 befolge ([HOWTO] Update HBOOT to 1.00 keeping your Legend rooted - xda-developers),komme ich bei folgendem Punkt nicht mehr weiter:

    Wenn ich die flash_image und misc1-2.img Datein nach /data/local/ verschieben sollte:

    bekomme ich folgende Meldung:

    Ähnliche Meldunge bekomme ich auch bei dem Befehl :
    Vielleicht habe ich nicht die Berechtigung auf diesen Sektor des Telefonspeichers zuzugreifen. Obwohl ich mir sicher bin das ich bereits Superuser-Rechte habe. Jedenfals habe ich auch Schritt für Schritt befolgt, soweit ich es beurteilen kann.

    Bitte um Hilfe!
     
    Zuletzt bearbeitet: 26.12.2010
  2. titan, 27.12.2010 #2
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Hallo!

    Ich habe das ganze vor 4 Tagen genauso gemacht.

    Ich vermute ganz stark, dass du den Command Prompt nicht von der richtigen Stelle aus gestartet hast.

    Die einfachste Lösung ist, einfacj diese Datein in den Tools Ordner vom Android SDK zu kopieren, in welchem sich auch die ADB befindet.

    mfg

    titan
     
  3. oliverS13, 27.12.2010 #3
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    Danke für die prompte Antwort titan !

    Naja ich habe die flash_image und und misc1-2.img Datein im Toolsordner vom Android STK eingefügt.

    Dann gebe ich folgende Befehle ein:

    Es folgen wie zuvor auf die 2 letzten Befehle die Meldung
    wobei manche andere Befehel über den adb server wie zB
    funktionieren, mir das aber leider nichts hilft.
    Das sieht dann ungefähr so aus: ADB.PNG
    Ich habe mein Legend auch bestimmt schon im Softroot Modus.
    Vielleich liegt es daran das der adb server die beiden Dateien einfach nicht findet ?

    Bitte um Hilfe!
     
    Zuletzt bearbeitet: 27.12.2010
  4. titan, 27.12.2010 #4
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Ich glaube ich kenne dein Problem.

    Schaue bitte mal nach, ob in dem Toolsordner eine ADB.exe vorhanden ist.

    Wenn nicht liegt genau dort das Problem, da ADB seit neustem nicht mehr standardmäßig im SDK enthalten ist.

    Ich kann dir das ganze aber irgendwo uploaden, wenn du willst.

    mfg

    titan
     
  5. oliverS13, 27.12.2010 #5
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    Danke. Aber das dürfte nicht notwendig sein.
    Trotzedm herzliche dank.

    Ich glaube es dürfte alles in Ordnung damit sein. ADB und andere benötigte Datein sind dort wo sie sein sollten oder ?
    -> Aufzeichnen.PNG

    Hast du vielleicht irgendeine anderen Befehle eingegeben.
    Oder bei VIONary+ etwas anderes gemacht als den Temproot ausgeführt.

    Ich stehe leider gerade ziemlich auf durchzug, also bin ich für jede Hilfe dankbar!

    MFG Oliver !
     
  6. titan, 27.12.2010 #6
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    USB Debugging ist sicherlich auch aktiviert, nehme ich an?

    mfg

    titan
     
  7. oliverS13, 27.12.2010 #7
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    Jah.

    MFG oliverS13
     
  8. titan, 27.12.2010 #8
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Gib mal

    adb devices als command ein und sag mal was er ausgibt.

    mfg

    titan
     
  9. oliverS13, 27.12.2010 #9
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    Aufzeichnen.PNG

    MFG oliverS13
     
  10. titan, 27.12.2010 #10
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Okay, dann ist mit ADB soweit eigentlich alles in Ordnung.

    Ich habe auch nur Temproot mit Visionary r13 gemacht.

    In der Anleitung steht ja eigentlich, das für das SU Ding ein Command Prompt gemacht werden soll. Danach soll zum pushen ein neuer Command Prompt geöffnet werden (wahrscheinlich dann im Ordner wo die Dateien sind). Ich hatte damals auch alles im selben Ordner und hab trotzdem 2 Command Prompts geöffnet.

    Probier das doch mal.

    mfg

    titan
     
    oliverS13 bedankt sich.
  11. oliverS13, 27.12.2010 #11
    oliverS13

    oliverS13 Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    26.12.2010
    Phone:
    HTC Legend
    viele dank!

    das war die lösung des problems !

    MFG oliverS13
     
  12. titan, 27.12.2010 #12
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Jop.

    Ich hab auch schön 5 Stunden drangehangen bevor alles 100 % geklappt hat.

    Naja, cool das jetzt alles geht.

    mfg

    titan
     
  13. titan, 27.12.2010 #13
    titan

    titan Android-Experte

    Beiträge:
    505
    Erhaltene Danke:
    79
    Registriert seit:
    09.06.2010
    Phone:
    LG G2
    Ja, das kann sein. Ich habe schon öfters von Problemen mit dem NAND Lock des Legend gehört.

    Wenn der Rest des Rootens geklappt hat, mache es so wie ich:

    Lade dir die folgende Datei :MEGAUPLOAD - The leading online storage and file delivery service

    Damit kannst du per ADB die Standard Recovery nutzen, indem du die recovery-windows.bat ausführst.

    Geht allerdings nur mit USB Kabel und PC.

    mfg

    titan
     
  14. Droid_Dustin, 31.01.2011 #14
    Droid_Dustin

    Droid_Dustin Android-Experte

    Beiträge:
    539
    Erhaltene Danke:
    159
    Registriert seit:
    16.01.2011
    Phone:
    Samsung Galaxy S6 edge+
    Glaubt ihr, das funktioniert auch mit einem HTC Gratia?
     

Diese Seite empfehlen