1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Root für das Play

Dieses Thema im Forum "Root / Custom-ROMs / Modding für Sony Ericsson Xperia Play" wurde erstellt von Dexxmor, 06.05.2012.

  1. Dexxmor, 06.05.2012 #1
    Dexxmor

    Dexxmor Threadstarter Android-Ikone

    Beiträge:
    5,616
    Erhaltene Danke:
    1,159
    Registriert seit:
    29.07.2011
    Tablet:
    Samsung Galaxy Note 8.0
    Da mir aufgefallen ist, das es hier sogut wie keine Rootanleitung gibt (bzw lauter unterschiedliche) hier eine, die ab der 42er Firmware gehen wird.
    (Quelle: [HOW-TO][zergRush Root] Root w/ v2.2.x-2.3.x (NOT ICS 4.x or GB after 11/2011) - xda-developers)
    Nehmt entweder den Zergrush Exploit oder SuperOneClick. Die ADB Treiber bekommt ihr vom Android SDK oder mithilfe der Treiber im Flashtool (/drivers). Diese Root Methode funktioniert nicht! ab der 62er Firmware, da müsst ihr einen Downgrade machen.

    Für ICS, schaut hier nach.

    MfG
    Dexxmor

    Sollte ich was übersehen haben, eine PM an mich.
    Hier der Download Link für Linux Zergrush
     
  2. bratmaxe100, 06.05.2012 #2
    bratmaxe100

    bratmaxe100 Android-Experte

    Beiträge:
    566
    Erhaltene Danke:
    106
    Registriert seit:
    15.01.2012
    Ich versteh die Leute hier auch nicht wenn die so ein riesen Wert auf Root legen sollen sie doch einfach ihren Bootloader unlocken (andere Leute wären glücklich wenn sie das mit Ihrem Handy machen könnten) und dann einen Custom Kernel oder Rom nehmen.
     
  3. Flo95, 06.05.2012 #3
    Flo95

    Flo95 Ehrenmitglied

    Beiträge:
    3,740
    Erhaltene Danke:
    787
    Registriert seit:
    29.01.2012
    Phone:
    Samsung Galaxy S7 EDGE
    Tablet:
    Apple iPad Air
    Diese Methode ist aber deutlich unkomplizierter, schneller und ohne Garantieverlust (viele Leute wollen diese behalten).

    PS: Endlich Android Guru :D
     
    Zuletzt bearbeitet: 06.05.2012
  4. iGott, 18.05.2012 #4
    iGott

    iGott Erfahrener Benutzer

    Beiträge:
    175
    Erhaltene Danke:
    7
    Registriert seit:
    12.10.2011
    Hey :)
    Hab versucht mein Play zu rooten, aber es klappt nicht mit SuperOneClick :/
    BootLoader ist Unlockt warum auch immer.
    Naja vielleicht hat jemand ne Idee wieso es nicht geht und mit den ganzen Anleitungen kann ich irgendwie nix anfangen :/

    Lg Jan :)
     
  5. bratmaxe100, 18.05.2012 #5
    bratmaxe100

    bratmaxe100 Android-Experte

    Beiträge:
    566
    Erhaltene Danke:
    106
    Registriert seit:
    15.01.2012
  6. Simon 1337, 21.05.2012 #6
    Simon 1337

    Simon 1337 Android-Experte

    Beiträge:
    464
    Erhaltene Danke:
    54
    Registriert seit:
    27.02.2012
    @ igott
    Woher weißt du dass der bootloader unlock ist ?

    gesendet von meinem LT18i
     
  7. Dexxmor, 22.05.2012 #7
    Dexxmor

    Dexxmor Threadstarter Android-Ikone

    Beiträge:
    5,616
    Erhaltene Danke:
    1,159
    Registriert seit:
    29.07.2011
    Tablet:
    Samsung Galaxy Note 8.0
    Bei offenem Bootloader langt es, einen Preroot Kernel zu flashen.
     
  8. power-hardy, 09.09.2012 #8
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    Hallo Community !^^

    Ich hab seit 1 Jahr mein xperia play und wollte es nun rooten.
    Leider hab ich keine Ahnung wie das geht ^^

    Es wär Klasse wenn jemand ne Anleitung in Deutsch hat :)

    Mfg
     
  9. noob_fl, 09.09.2012 #9
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    alzo

    unabhängig von der Firmware ist es am sinnvollsten einfach mal den Bootloader zu knacken damit du frei bist

    dazu... brauchen wir zuerst ein paar treiber auf deinem Computer
    -fastboot package: Multiupload.nl - upload your files to multiple file hosting sites!
    -32/64bit drivers: Multiupload.nl - upload your files to multiple file hosting sites!

    entpacke das zeugs einfach mal, dann stöpselst du dein handy einmal fastboot (menütaste gedrückt halte (oder welche es beim Play auch immer ist) und USB anstöspeln... dann sollte der Windowinstallationsassistent kommen, da klickst du alles weg was mit im internet suchen oder von CD zu tun hat und wählst die Option dass du den Ordner selber suchst, und suchst dann den Driver ordner denn du soeben gedownlaodet hast und wartest bis die treiber installiert sind

    is das so, dann startest du mal den Computer neu, dein Handy startest du ganz normal

    dann öffnest du die Telefonapp auf deinem Handy und gibst *#06# ein und du bekommst die IMEI nummer... die schreibst du am besten mal auf (und streichst die letzte stelle, denn die brauchen wir nicht)

    als nächstes gehst du auf

    Unlocking the boot loader | Sony Xperia

    die seite, liest alles nochmals durch und klickst dann weiter und weiter und wieter bis du die IMEI eingeben musst und die email... das machst du dann auch und du kriegst eine Nummer zurückausgegeben... die nummer speicherst du dir... dann kannst du die Website wieder verlassen

    dann schaltest du dein Handy aus, und stöpselst es wieder Fastboot an deinen computer an

    dann öffnest du die eingabeaufforderung und navigierst in ihr in den fastbootordner (wie man mit der Eingabeaufforderung navigiert weisst du doch hoffentlich oder? als cd.. und cd usw?)

    im fastbootordner angekommen tipselst du nun ein

    fastboot.exe -i 0x0fce oem unlock 0xKEY

    wobei du anstatt KEY die Nummer eingibst die du bekommen hast

    das dauert ein paar minuten... irgendwann solltest du ne antwort kriegen... kriegst du keine, kannst du nach spätestens 5 Minuten das handy abstöpseln und booten

    sind alle deine einstellungen gelöscht, hats geklappt

    so als nächstes brauchst du einen prerootet kernel (denn musst du dir selber suchen)

    gefunden kopierst du den ebenfalls in deinen fastbootordern, stöpselst dein Handy wieder fastboot an, und gibst mit der eingabeaufforderung

    fastboot flash boot kernelname.img (oder elf) ein

    nachdem das geschehen ist kannst du dein Handy booten und du hast root :)
     
    Zuletzt bearbeitet: 09.09.2012
  10. power-hardy, 09.09.2012 #10
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    1. Problem:
    Bei mir passiert am PC null.
    Es kommt nur ein Ton(dödüm) und sonst passiert irgendwie nichts.

    Bei meinem Handy leuchtet die Sperrtaste blau :winki:
     
  11. noob_fl, 09.09.2012 #11
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    d.h. die fastboottreiber sind schon installiert, weiter also zum nächsten schritt ;)
     
    power-hardy bedankt sich.
  12. power-hardy, 09.09.2012 #12
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    Welche Eingabeaufforderung ?
    Bei mir bleibt das Display schwarz und die Sperrtaste läuchtet blau:winki:

    mfg
     
  13. noob_fl, 09.09.2012 #13
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    windows eingabeaufforderung (auf dem Computer, nicht auf dem Handy ;) )

    startbutton -> ausführen -> cmd -> enter

    dann öffnet sich die eingabeaufforderung

    dort dann mit cd.. (ein ordner höher) und cd ordernahme in den fastbootordner navigieren (wo der ist weist du, ich nicht)

    wenn du den Pfad genau weisst kannst du auch gleich

    cd c:\ordnernanme\ordnername\fastboot

    eingeben

    und dort dann den fastboot.exe befehl in meiner anleitung eintippselns ;)
     
  14. power-hardy, 09.09.2012 #14
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    Ich habs mittlerweile selber geschafft ,aber Danke!:D

    Also sind dann alle Apps ect weg ?
     
  15. noob_fl, 09.09.2012 #15
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    jap, alles weg ;)

    aber ist ja kein ding, auch bezahlbare apps werden ja vom Google Playstore gespeichert und du kannst sie wieder downlaoden ;)
     
  16. power-hardy, 09.09.2012 #16
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012


    Ich hab mein Handy nun Neugestartet und man sieh da alle Apps sind noch da:thumbdn:
    Hast du eine Idee was ich falsch mache ?:o
     
    Zuletzt bearbeitet: 09.09.2012
  17. noob_fl, 09.09.2012 #17
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    hm... du kriegst keine fehlermeldung ala "waiting for device" oder so?

    unter umständen ist dein Bootloder schon geunlockt gewesen *confused*

    versuch mal dies

    such dir einen Customkernel für das play als img oder als elf file

    kopiere ihn in den Fastbootordner auf deinem computer

    stöpsel dein Handy fastboot an, mit der eingabeaufforderung wieder in den Fastbootordern und gibt dann dort

    fastboot flash boot kernelname.img

    der halt kernelname.elf

    ein

    wenn es klappt, dann hast du einen geunlockten bootloader ;)
     
  18. power-hardy, 09.09.2012 #18
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    Doch das steht bei mir^^
     
  19. noob_fl, 09.09.2012 #19
    noob_fl

    noob_fl Android-Lexikon

    Beiträge:
    1,573
    Erhaltene Danke:
    392
    Registriert seit:
    07.09.2012
    Tablet:
    Nexus 7 (2012)
    hm, dann sind deine fastboottreiber doch nicht sauber installiert

    versuch mal dies

    starte deinen Computer neu, dann schliesse das Handy in den fastbootmodus an

    und dann wartest du ein bischen (du kannst auch unten rechts in der Windowsstaatusleiste gucken ob windows irgendwas anderes anzeigt, ein Symbol mit einer Platine oder sowas... fahr auch mal mit der Maus drüber ob da ev irgendwas von neue Hardware gefunden oder sowas steht... ;)

    je nach dem, wie schnell/lahm dein Windows ist, kann es 2 - 3 minuten dauern bis der installationsasystent startet
     
  20. power-hardy, 09.09.2012 #20
    power-hardy

    power-hardy Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2012
    ok.....

    mfg

    Der ursprüngliche Beitrag von 19:45 Uhr wurde um 20:05 Uhr ergänzt:

    Leider passiert nix :(
    Ich werds morgen nochmal probieren....muss jetzt zur Arbeit
     

Diese Seite empfehlen