1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

SD-Karte manchmal plötzlich nur noch "read only" gemounted

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von Chocnut, 10.03.2011.

  1. Chocnut, 10.03.2011 #1
    Chocnut

    Chocnut Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Hallo,

    Ich lurke hier schon lange rum, habe dankbar an den HowTos zum Modden des Steins partizipiert. Vielen Dank für die nützlichen Tipps.

    Nur jetzt habe ich ein etwas nerviges Problem.
    Manchmal, wie aus heiterem Himmel, ist meine sdcard nur noch read-only gemounted. Das ist dann zwar kein Problem. Mit dem RootExplorer einfach wieder r/w mounten und dann gehts wieder. Aber nerven tut es eben doch.

    Zum Environment:
    Der Stein läuft mit dem vorletzten CM7, so gut wie ohne Probleme. Die sdcard ist einen Monat alt, 16GB class 6 von A-Data.

    Überraschende, eventuell gehäufte, FC treten nicht auf, die auf einen sdcard Fehler hinweisen könnten. Eine Überprüfung über den Speicherkarten-Zugriff mit dem Festplattendienstprogramm am Mac brachte keine Hinweise.

    Ich habe auch mal im Milestone CM7 message board, wie auch im CM Issue Tracker und in deren Foren nachgeschaut, ob es vielleicht ein CM7 Problem ist, doch dergleichen scheint nicht bekannt zu sein.

    Der Stein ist, wie bei CM üblich, gerootet, aber sonst habe ich eigentlich nur ziemlich weit verbreitete Apps drauf laufen. Also irgendeien dubiose App, die Murks macht, glaube ich nicht zu haben.

    Auch die Forumssuche hier brachte nichts Richtiges. Ein generelles Googlen brachte nur schwere sdcard defekte mit wirklich üblen Lese/Schreibefehlern/gar nicht erkennen etc. Aber wie oben beschrieben scheint (fast) alles zu tun, alles in Ordnung zu sein, nur eben plötzlich ist die Karte nur noch read only. Meistens merke ich es erst, wenn Programme nörgeln, dass sie nicht auf die Karte schreiben können.

    Was könnte das sein und wie behebe ich das?
    Wäre toll, wenn mir da jemand was sagen könnte.

    Viele Grüße,
    Chocnut.
     
  2. k1l, 10.03.2011 #2
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    also generell muckt das Milestone mit vielen SD-Cards, vor allem den großen.

    schmeiss mal nen logger an (osmonitor, logcat) und schau, was z.b. dmesg zu sagen hat, wenn der effekt wieder auftritt.
     
  3. -FuFu-, 10.03.2011 #3
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    gehört in den rootbereich.... bitte nächste mal das richtige Unterforum wählen
     
  4. Chocnut, 10.03.2011 #4
    Chocnut

    Chocnut Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Oha, rootbereich, sorry. Das ist wohl ein Fehler meinerseits.
    Ich werde das mit dem Systemlogger mal versuchen und sehen, was dabei herauskommt.
     
  5. Jackthecrack, 10.03.2011 #5
    Jackthecrack

    Jackthecrack Erfahrener Benutzer

    Beiträge:
    214
    Erhaltene Danke:
    13
    Registriert seit:
    14.07.2010
    Ich hatte auch öfter probleme mit meiner sd-karte.endlose lesevorgänge, langsame zugriffszeiten etc. Komischerweise hat ein trick dann funktioniert, der sehr billig ist: die fehler traten bei mir nicht mehr auf, als ich die karte nicht voll eingeschoben hatte. Versuch einfach mal die karte bei eingelegtem akku bis zum anschlag beim akku wieder herrauszuziehen.also so, dass die karte nicht bis zum anschlag im einschubschacht steckt.die kontakte sind beim stein (vielleicht nicht alle) nähmlich nicht so top verarbeitet und da kommt es dann häufiger zu schreib- und lesefehlern.
     
  6. Sakaschi, 11.03.2011 #6
    Sakaschi

    Sakaschi Android-Ikone

    Beiträge:
    7,008
    Erhaltene Danke:
    4,098
    Registriert seit:
    24.04.2010
    oder sd karte auf den stein formatieren. das hatte bei meiner 32gb sd karte geholfen^^
     
  7. Chocnut, 11.03.2011 #7
    Chocnut

    Chocnut Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Das habe ich am Anfang gemacht.

    Inzwischen ist das Problem nicht wieder aufgetaucht.
    Ich habe auch im Log nachgeschaut, da es inzwischen aber nicht aufgetreten ist, war da nichts zu finden. Bin mir auch nicht ganz sicher, wonach ich da suchen soll, den das Log ist ja nicht gerade wenig. Vold oder Usb<x> könnte es sein. Ein Root Prozess, wie RootExplorer, macht das ganze aber wohl direkt mit mount, denn dessen remount (r/w <-> r/o) ist im Systemlog nicht zu sehen.
    Sobald es aber auftritt, werde ich mich auf die Suche machen.

    C.
     
  8. Chocnut, 17.03.2011 #8
    Chocnut

    Chocnut Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Ich habe jetzt weiter geforscht. Nach dem Backup mit Titanium-Backup tritt das Problem auf. Weitere Forschung hat ergeben, dass die Backups nicht korrekt waren und ein Löschen dieser und einem neuen Backup trat es nicht mehr auf. Deshalb schätze ich, dass es wohl tatsächlich ein Hardwareproblem ist, d.h. die SDcard nicht fehlerfrei ist. Schade, dass Titanium-Backup etwaige Fehler nicht meldet.
     
    Zuletzt bearbeitet: 17.03.2011
  9. k1l, 18.03.2011 #9
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    das ist ein normales verhalten von einem linux. wenn es etwas probleme macht erstmal r/o mounten, damits nicht zu datenverlust kommt.
     
    Chocnut bedankt sich.
  10. Chocnut, 18.03.2011 #10
    Chocnut

    Chocnut Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Aha, alles klar. Also wirklich ein Hardwareproblem. Vielen Dank für die Info, das wusste ich nicht.
     

Diese Seite empfehlen