1. Wir haben diesmal 2 Gewinnspiele zeitgleich für euch - Gewinne einmal ein UMI Plus E - Beim 2ten könnt ihr ein Nomu S30 gewinnen!
  1. UWdus, 04.02.2011 #1
    UWdus

    UWdus Threadstarter Android-Lexikon

    Mal eine Frage...

    Im UK-ROM werkelt eine Swype-Tastatur mit der Versionsnummer 2.21.63.16585.1234 vor sich hin und im Orange-ROM mit der Nr. 2.23.65.17456.
    Jetzt hat mir ein lieber User hier die neuere Version zukommen lassen und ich habe sie mittels Root-Explorer installiert (APK gestartet - Abfrage ob ich Systemdatei ersetzen möchte - kurze Zeit später positive Fertigmeldung der Installation). Aber auch nach einem Neustart habe ich immer noch die Swype-Tastatur mit der UK-Versionsnr.? Hat jemand einen Tipp? Muss ich die Swype.apk im System austauschen?
     
  2. rznag, 04.02.2011 #2
    rznag

    rznag Fortgeschrittenes Mitglied

    Deinstallier erstmal das swype.apk unter /system/app
    Dann entfernst noch die libswype... unter /system/lib
    Dann swype neu installieren und es sollte gehn.
    So musste man vorgehen wenn man die Beta über eine andere Version installieren wollte.
     
    UWdus bedankt sich.
  3. UWdus, 04.02.2011 #3
    UWdus

    UWdus Threadstarter Android-Lexikon

    Was meinst du genau mit deinstallieren? Ich habe sie jetzt mal umbenannt und die Lib auch, danach die "neue" installiert und nix passiert (keine neue Swype.apk in /system/app) Habe jetzt die "neue" Swype.apk in /system/app kopiert und die lib* wieder umbenannt - reboote gerade...
     
  4. UWdus, 04.02.2011 #4
    UWdus

    UWdus Threadstarter Android-Lexikon

    Höh??? Obwohl umbenannt und die neue ins /system/app kopiert, zeigt er mir immer noch die Versionnr. der Swype-Version vom UK-ROM... Zieht er sich die aus der lib*.so? Dann müßte ich meinen edlen Spender mal nach selbiger fragen ;)
     
  5. rznag, 04.02.2011 #5
    rznag

    rznag Fortgeschrittenes Mitglied

    Ich meinte mit deinstallieren einfach löschen. Umbennen tuts natürlich auch. Hauptsache die Dateien sind nicht mehr korrekt vom System erkennbar.
    Vielleicht brauchst zusätzlich zur polnischen swype.apk aber auch noch die Lib aus der Polenversion, lad ich Dir mal eben hoch.
    War auch nur ein Lösungsansatz, weil es bei der Beta so funktioniert hat.
    Sonst probier mal die Daten und Cache von Swype entweder in den Einstellungen -> Anwendungen oder mit Titanium zu löschen.
    Und ich glaub dann gehen mir auch die Ideen aus. :huh:
    Aber wenns jetzt noch nicht geht, vielleicht gleich mit der anderen lib.
     
    UWdus bedankt sich.
  6. rznag, 04.02.2011 #6
    rznag

    rznag Fortgeschrittenes Mitglied

    UWdus bedankt sich.
  7. Basshamster, 04.02.2011 #7
    Basshamster

    Basshamster Android-Experte

    Kurzes Einklicken meinerseits: Ist die Swype-Tastatur (Froyo PL) endlich schwarz? Sonst nehm ich gleich die beta... ;)
     
  8. rznag, 04.02.2011 #8
    rznag

    rznag Fortgeschrittenes Mitglied

    Nein, ist nicht schwarz. Direkt mal gucken ob man das ändern kann.

    Edit: Ne, kann man auch nicht ändern. Ist einfach langweilig grau.
     
  9. UWdus, 04.02.2011 #9
    UWdus

    UWdus Threadstarter Android-Lexikon

    Geschafft...

    Hatte noch das hier gefunden:

    Nach dem 2. Reboot (also nach der Installation) wurde ich aber direkt mit einer Swype-Fehlermeldung noch auf dem Lockscreen begrüßt...

    Habe dann in die Verzeichnisse /system/app und system/lib geschaut und wieder nix da...
    Dann die bereits installierte APK in /system/app kopiert und deine libswypecore.so in /system/lib - et voila :)

    Danke dir und ein schönes Wochenende!!!
     

Diese Seite empfehlen