1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

USB-Host Modus (OTG) mit HC 3.1 möglich?

Dieses Thema im Forum "Motorola Xoom Forum" wurde erstellt von deb10042, 19.08.2011.

  1. deb10042, 19.08.2011 #1
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    Hallo!

    Mein Xoom (EU, 3G + WiFi) habe ich mittels OTA-Update auf die Version 3.1 gebracht und mittlerweile auch erfolgreich gerootet.

    Gibt es eigentlich eine Möglichkeit, nun auch den USB-Host Modus nutzen zu können? (Dachte eigentlich, dass der in 3.1 dabei sein sollte, aber geht nicht...)

    Hat von Euch jemand herausgefunden, wie das mit dem Stock-ROM geht?

    Danke! :smile:
     
  2. Lupus, 19.08.2011 #2
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
  3. deb10042, 19.08.2011 #3
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    Der ist aber offenbar nur für HC 3.2
    Außerdem scheint mir fraglich, ob er für europäische Modelle mit 3G geht.
    Ich würde mir da lieber etwas wünschen, das näher am Stock ROM ist.
     
  4. Lupus, 19.08.2011 #4
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
  5. L-29, 20.08.2011 #5
    L-29

    L-29 Gast

    kannst du mir sagen,was ich da step by step machen muss?
     
  6. atamiga, 21.08.2011 #6
    atamiga

    atamiga Android-Guru

    Beiträge:
    2,058
    Erhaltene Danke:
    195
    Registriert seit:
    14.08.2011
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    Geht nicht mal bei den Amis. Die haben inzwischen 3.2
    Also habe ich Tiamat installiert. Das ist die Version 3.2. Jetzt geht es. Mit ein wenig gefrickel habe ich jetzt auch erfolgreich eine 2TB angeschlossen.

    Gruß Michael



     
  7. L-29, 21.08.2011 #7
    L-29

    L-29 Gast

    wenn ich die app runter laden bzw installieren will
    kommt das diese nicht mit meinen Geräten kompatibel iss??
     
  8. Lupus, 21.08.2011 #8
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
    Dann brauchste wohl doch den passenden Kernel, ohne das gehts wohl nicht. BigRushMods hier gibt es die 1.4.4 , kannst du ganz normal in recovery flashen, Daten und so bleiben erhalten. Dein ROM bleibt euch weiterhin die 3.1 EU Version, nur der Kernel ist anders.
     
  9. L-29, 21.08.2011 #9
    L-29

    L-29 Gast

    Zuletzt von einem Moderator bearbeitet: 21.08.2011
  10. deb10042, 21.08.2011 #10
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    dazu musst Du CWR Clock Work Recovery installieren. Wie? - bitte einfach mal Suche benutzen, dann findest Du passende Anleitungen.
     
  11. deb10042, 21.08.2011 #11
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    Habe jetzt auf mein gerootetes 3.1 (EU) den Tiamat Kernel 1.4.4 drauf gemacht. Läuft zwar alles, aber einen OTG-Modus gibt's damit auch nicht. Selbst mit der von Dir genannten Anwendung tut sich da garnichts. Ich kann damit zwar meinen USB-Stick nach Drücken des "mounten"-Buttons kurz zum linken bringen, danach taucht aber nirgendwo das OTG-Verzeichnis auf. Auch mit der Kamera funktioniert's leider nicht :mad2:

    Warum funzt der Kram nur bei manchen Usern und bei anderen nicht?
     
  12. atamiga, 21.08.2011 #12
    atamiga

    atamiga Android-Guru

    Beiträge:
    2,058
    Erhaltene Danke:
    195
    Registriert seit:
    14.08.2011
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    Hallo,


    ich habe Tiamat 2.1 drauf. Alles bis aus die Kamera geht.


     
  13. Lupus, 21.08.2011 #13
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
    USB Gerät (Stick oder externe HDD, is egal geht beides) einstecken

    mit der App den mount Pfad setzen und merken

    dann mit nem dateimanager (Total Commander, oder ähnliche) zum besagten Pfad navigieren und schon solltest du alle Dateien sehen.
     
  14. deb10042, 22.08.2011 #14
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    Genau so mache ich es, aber die App scheint bereits das Mounten nicht richtig zu machen. Der gezeigte "Balken" des USB-Sticks (oder Kamera) bleibt immer komplett grau, anstatt den Füllstand der Daten anzuzeigen. Wenn ich dann mit einem Dateimanager in den gemounteten Pfad wechsle, gibt es dort kein "USB"- oder "OTG"-Verzeichnis.
     
  15. atamiga, 22.08.2011 #15
    atamiga

    atamiga Android-Guru

    Beiträge:
    2,058
    Erhaltene Danke:
    195
    Registriert seit:
    14.08.2011
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    Saum dir hier das komplette Image runter:


    [ROM] Team Tiamat Xoom Rom 2.1 Hammerhead - xda-developers

    Dann geht es

     
  16. deb10042, 22.08.2011 #16
    deb10042

    deb10042 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    123
    Erhaltene Danke:
    5
    Registriert seit:
    15.08.2011
    Nee, Du, lass ma' stecken!
    Deswegen hatte ich ja weiter oben extra geschrieben, dass ich so nahe wie möglich am Stock-ROM bleiben möchte.
    Das "Hammerhead" hatte ich bereits vor einiger Zeit mal ausprobiert. Es hat mir noch zu viele Unzulänglichkeiten und ist nicht richtig stabil (siehe auch die diversen Beiträge, die es dazu hier und an anderen Stellen gibt).
    Danke für den Tipp, aber ich warte lieber, bis es eine einfachere Lösung gibt.
     
  17. atamiga, 22.08.2011 #17
    atamiga

    atamiga Android-Guru

    Beiträge:
    2,058
    Erhaltene Danke:
    195
    Registriert seit:
    14.08.2011
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    es läuft bei mir ohne Probleme. Auch bei einem Kollegen. Es geht alles....


     
  18. Lupus, 22.08.2011 #18
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
    Vielleicht liegt es am Kabel? Ich weiß grade nicht ob man testen kann, ob das Kabel wirklich ein OTG Kabel ist.
     
  19. atamiga, 22.08.2011 #19
    atamiga

    atamiga Android-Guru

    Beiträge:
    2,058
    Erhaltene Danke:
    195
    Registriert seit:
    14.08.2011
    Phone:
    Sony Xperia Z
    Tablet:
    Sony Xperia Tablet Z2
    Mit Android 3.1 habe ich es auch nicht hingekommen. Erst mit Tiamat ging es. Mein Kabel war nicht schuld.


     
  20. L-29, 22.08.2011 #20
    L-29

    L-29 Gast

    ein einfacher Link als Hilfe hätte es auch getan!!!!!!!!!
     

Diese Seite empfehlen