1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

VoIP Nur mit schlechter Qualität?!

Dieses Thema im Forum "HTC Hero / T-Mobile G2 Touch Forum" wurde erstellt von Chris0504, 04.01.2010.

  1. Chris0504, 04.01.2010 #1
    Chris0504

    Chris0504 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    43
    Registriert seit:
    04.12.2009
    Phone:
    HTC Desire
    Hallo Community,

    Leider muss ich zur Zeit 2 Simkarten benutzen, da ich keinen zusammenhängenden Datentarif mit Vertrag habe, sondern eine O2 UMTS-Karte und eine normale x tra Card.
    Aus diesem Grund würde ich gerne VoIP in Betracht ziehen.
    Jedoch hatte ich, wie ich es das letzte mal ausprobiert habe, sehr schlechte Qualität.Sprich: Wenn ich etwas gesagt habe, kam es erst ca. 10 Sekunden dannach beim anderen Gesprächspartner an.

    Also zur meiner Frage :D:

    Gibt es eine Möglichkeit bessere Gesprächsqualität zu erreichen?

    Danke im vorraus!!!

    lg chris
     
  2. colt, 04.01.2010 #2
    colt

    colt Android-Hilfe.de Mitglied

    Beiträge:
    56
    Erhaltene Danke:
    6
    Registriert seit:
    19.10.2009
    Moin........
    Na ja....... is doch logisch, dass Telefonprovider das nicht sooo gerne sehen ;)
    Daher sind häufig die entsprechenden Ports beim Provider gesperrt.

    Tschues
    Colt
     
  3. Chris0504, 04.01.2010 #3
    Chris0504

    Chris0504 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    43
    Registriert seit:
    04.12.2009
    Phone:
    HTC Desire
    Ok.

    Danke für die Auskunft.

    lg chris
     
  4. Stockfisch, 04.01.2010 #4
    Stockfisch

    Stockfisch Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    4
    Registriert seit:
    18.09.2009
    Das ist nicht ganz richtig. O2 hat die Nutzung von VoIP in seinen Datenflats zugelassen. Je nach Verbindungsqualität kann es trotzdem zu Verbindungsabbrüchen bzw. Echos, ect. kommen. Gerade bei allem unter UMTS ist es eher schlecht. Probier es einfach nochmal. Bei Sipgate gibt es kostenlose Accounts mit Festnetznummer und mit sipdroid eine passende App dazu.
     
  5. Chris0504, 04.01.2010 #5
    Chris0504

    Chris0504 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    359
    Erhaltene Danke:
    43
    Registriert seit:
    04.12.2009
    Phone:
    HTC Desire
    Bin bereits bei Sipgate angemeldet.Jedoch habe ich sehr schlechte Gesprächsqualität trotz HSDPA.
     
  6. zinnni76, 05.01.2010 #6
    zinnni76

    zinnni76 Erfahrener Benutzer

    Beiträge:
    184
    Erhaltene Danke:
    8
    Registriert seit:
    11.09.2009
    Hallo habe Sipdroid (neuste Version und bin auch bei Sipgate angemeldet) und Aldi Talk fürs Inet (Flatrate) auf meinem Hero.Mein Problem nun, ich kann angerufen werden aber nicht selber anrufen.Habe alles richtig eingegeben und bei meinen Hero ist oben links auch ein grüner Punkt.
    Was muß ich noch einstellen damit ich auch selber Anrufen kann??
    Vielen Dank
     
  7. Stockfisch, 05.01.2010 #7
    Stockfisch

    Stockfisch Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    4
    Registriert seit:
    18.09.2009
    Bei Aldi Talk kann es durchaus an blockierten Ports liegen (weiß ich aber nicht). Ich weiß aber nichts von weiteren Einstellungen, die nötig sind.

    Hast du Geld auf deinem Sipgate-Konto bzw. versuchst du ein kostenloses Ziel anzurufen?
     
  8. zinnni76, 05.01.2010 #8
    zinnni76

    zinnni76 Erfahrener Benutzer

    Beiträge:
    184
    Erhaltene Danke:
    8
    Registriert seit:
    11.09.2009
    Also ich habe das kostenlose Konto bei Sipgate d.h. ich bezahle weiterhin nur günstiger. Ja es könnte an den Ports liegen...Kann man das denn durch andere Ports umgehen? Über Wlan gehts allerdings auch nicht.Kann nur angerufen werden. Ich schätze mal über Wlan muß ich erst den Router einrichten aber will ja auch nicht darüber anrufen. Halt nur über Alditalk
     
  9. dereulenspiegel, 05.01.2010 #9
    dereulenspiegel

    dereulenspiegel Android-Hilfe.de Mitglied

    Beiträge:
    105
    Erhaltene Danke:
    4
    Registriert seit:
    16.08.2009
    Also E-Plus (also auch AldiTalk) vergibt an seine Datenfunkteilnehmer keine echten öffentlichen IP-Adressen. Stattdessen bekommt jedes Mobilfunkgerät eine Adresse aus einem privaten Adressraum und nach außen hin wird alles geNATet. Ist also im Prinzip so ähnlich wie zu Hause hinter einem Router. Für SIP müsste man jetzt Ports freigeben. Natürlich kann man jetzt schlecht bei E-Plus anrufen, dass die Ports freischalten sollen. Es gibt aber noch eine andere Möglichkeit: STUN. Mit dieser Technik kann man quasi "Löcher" in NAT-basierte Firewalls schießen (sehr sehr vereinfacht ausgedrückt). Sowohl Clientsoftware als auch Server müssen das können. Vielleicht helfden den E-Plus-Kunden diese Infos bzw. Stichwörter ja erstmal weiter.
     
  10. Stockfisch, 05.01.2010 #10
    Stockfisch

    Stockfisch Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    4
    Registriert seit:
    18.09.2009
    Also das NAT-Problem sollte es eigentlich nicht sein, da eine Verbindung von innen heraus eigentlich möglich sein sollte. Es ist nur schwierig, ein Gerät zu erreichen, das hinter einer NAT versteckt ist. Aber angerufen werden geht ja.
     
  11. zinnni76, 05.01.2010 #11
    zinnni76

    zinnni76 Erfahrener Benutzer

    Beiträge:
    184
    Erhaltene Danke:
    8
    Registriert seit:
    11.09.2009
    Also was würdet ihr mmir jetzt empfehlen?bzw wo kann ich denn nachlesen was ich machen muß damit ich auch anrufen kann
     
  12. Stockfisch, 06.01.2010 #12
    Stockfisch

    Stockfisch Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    4
    Registriert seit:
    18.09.2009
    Naja, du kannst versuchen PBxes einzurichten (auch wenn ich dazu keinen klugen Link hab). Aber da meine Fragen von weiter oben nicht beantwortet wurden, stelle ich sie einfach nochmal:

    Wo wolltest du denn anrufen? Hast du Geld auf deinem Sipgate Konto?

    Grüße
    Martin
     
  13. zinnni76, 06.01.2010 #13
    zinnni76

    zinnni76 Erfahrener Benutzer

    Beiträge:
    184
    Erhaltene Danke:
    8
    Registriert seit:
    11.09.2009
    ich wollte aufs festnetz anrufen da ich ja auch angerufen werden kann...und nein habe kein geld auf meinem sip konto...aber wie gesagt ich müßte wenns gehen würde und es am geld liegt ja ein feedback bekommen aber bei mir ist nichts.wenn ich eine nummer wähle bricht der sofort ab
     
  14. mc.ulla, 06.01.2010 #14
    mc.ulla

    mc.ulla Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    05.01.2010
    Phone:
    HTC Hero
    Tach zusammen, also ich bin bei T-Mobile und habe Sipdroid und PBXes auf Sipgate laufen. Per EDGE oder UMTS funktioniert das ganze überhaupt nicht. Ich bekommen immer Paketverluste am Handy angezeigt (Sipdroid Client). Verbindung bricht zusammen.Hat das irgendjemand schon zum laufen bekommen ? Über WLAN ist das Ergebnis einigermassen befriedigend.
     
    Zuletzt bearbeitet: 06.01.2010
  15. meshua, 09.01.2010 #15
    meshua

    meshua Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    22.10.2009
    Hi,

    hast du schon einmal die Komprimierung (GSM Codec) bei Sipdroid aktiviert:

    Settings -> Call Options -> Voice Compression -> Always Try. Die Gegenstelle muss dies auch unterstützen (PBXes kann es natuerlich).

    Gruesse, meshua
     
  16. mc.ulla, 09.01.2010 #16
    mc.ulla

    mc.ulla Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    05.01.2010
    Phone:
    HTC Hero
    Hallo meshua, danke für den Tip. Hat leider nichts gebracht, ich habe nach ca. 3 Sek Paketverluste von 90%. Wie soll da eine Kommunikation möglich sein, wenn 90% der Daten verworfen werden ? Das klingt so, als würde es bei allen anderen laufen. Hab ich nur die Probleme ?Komisch:eek:
     
  17. meshua, 09.01.2010 #17
    meshua

    meshua Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    22.10.2009
    Selbst über eine (zugegeben sehr gute) EDGE-Verbindung halten sich die Drop-outs mit aktiver Compression in Grenzen.

    Was eventuell auch helfen kann: statt TCP probehalber UDP verwenden (zu finden in den Einstellungen für die VoiP-Gegenstelle, weniger Protokolloverhead als bei TCP).

    Grüße, meshua.
     
  18. mc.ulla, 10.01.2010 #18
    mc.ulla

    mc.ulla Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    05.01.2010
    Phone:
    HTC Hero
    Hallo meshua, ich habe das mal probiert auf udp umzustellen, das bringt aber auch nichts. Kummunikation ist nicht möglich. Zumal der Akku sehr schnell alle wird. Die Packetverluste gehen da auch gegen 90%, es dauert etwas länger. Also irgenwie reicht die Bandbreite der umts/edge nicht aus, um eine saubere Übertragung zu gewährleisten. Schade :(

    Ich bin mit meinem Latein am Ende :confused:

    Trotzdem Danke :D
     
  19. derHaifisch, 05.02.2010 #19
    derHaifisch

    derHaifisch Android-Lexikon

    Beiträge:
    1,640
    Erhaltene Danke:
    254
    Registriert seit:
    09.12.2009
    Das klingt nach meinem Problem mit T-Mobile.
    VOIP scheint wirklich gesperrt zu sein.
    Keiner eine Idee, wie ich diese Sperrung umgehen kann?
     
  20. Melkor, 05.02.2010 #20
    Melkor

    Melkor Super-Moderator Team-Mitglied

    Beiträge:
    17,590
    Erhaltene Danke:
    3,892
    Registriert seit:
    24.06.2009
    Phone:
    Ulefone Power + Wiko Darknight
    Tablet:
    Archos G9 Tablet, Odys Wintab 9 plus 3G
    Wearable:
    Xiaomi MiBand
    Tunneln per VPN zu ner Fritzbox oder entsprechendem VPN Service
     

Diese Seite empfehlen