1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Wie roote ich ein neues Tablet?

Dieses Thema im Forum "Weitere Hersteller allgemein" wurde erstellt von renewehle, 06.08.2012.

  1. renewehle, 06.08.2012 #1
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Hallo,

    ich habe eine Frage zum neuen Toshiba Tablet (welches in Dtl unter dem Begriff AT270 gekannt ist). Das meine ist ein japanisches Geraet und daher ist die Bezeichung Regza AT570, sollte aber nichts zur Sache tun.

    Die Frage ist, wie rootet man ein neues Tablet? Gibt es ein "Universalwerkzeug" dafuer, oder wie funktioniert das so in der Regel?

    Vielen Dank fuer die Erlaeuterungen.
     
  2. mula125, 07.08.2012 #2
    mula125

    mula125 Android-Lexikon

    Beiträge:
    1,455
    Erhaltene Danke:
    276
    Registriert seit:
    13.02.2010
    Das kommt drauf an was für eine Firmware Version du hast!? 2.3.3/ 3.2 oder 4.0!? Dann kannste nach den Tools googeln oder hier im Forum unter Toshiba Tabs suchen.

    Edit: Wie ich dass gelesen habe handelt es sich um das neue Tab mit 7.7" und Amoled Display mit Android 4.0.4.

    Zuerst brauchst du die nötigen USB Treiber vom Tab für dein Win PC. Da kannste mal nach dem Tool "Pda.net" suchen.

    Danach kannste den script hier nehmen: http://www.4shared.com/rar/kPibyW7T/Cube_Root_for_ICS_403.html

    Die vorgehensweise müsste die änliche sein wie bei den anderen ICS Tablets. Da kannste hier meine Anleitung befolgen.

    http://www.android-hilfe.de/showthread.php?t=261076 Root Anleitung für das Freelander PD10 Deluxe

    Wie immer alles auf eigene gefahr!

    Gesendet von meinem GT-I9100 mit der Android-Hilfe.de App
     
    Zuletzt bearbeitet: 07.08.2012
  3. renewehle, 08.08.2012 #3
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Es ist richtig, es handelt sich um das neue Geraet, allerdings habe ich die 4.0.3 Version installiert.

    Wie auch immer, ich konnte danke der Anleitung zumindest die Treiber korrekt installieren und habe daher mittels Explorer einen Zugriff auf das interne und externe Laufwerk, aber eben nur als MTP. Scheinbar ist ein voller Zugriff als Laufwerk nicht mehr moeglich.

    Aber ich haenge bei dem Cube Root Script. Wenn ich es starte kommt in der CMD nur folgendes:

    Code:
    remount failed: Operation not permitted
    rooting please wait...
    failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file system
    failed to copy 'su' to '/system/bin/su': Read-only file system
    Unable to chmod /system/bin/su: No such file or directory
    rm failed for /system/xbin/su, No such file or directory
    done
    Drücken Sie eine beliebige Taste . . .
    
    Gibt es weitere Moeglichkeiten?
     
  4. mula125, 08.08.2012 #4
    mula125

    mula125 Android-Lexikon

    Beiträge:
    1,455
    Erhaltene Danke:
    276
    Registriert seit:
    13.02.2010
    Es it eigetlich egal ob es 4.0.3 oder 4.0.4 ist, der Vorgang beim rooten ist der gleiche.

    Dein Tab wurde jetzt vom PC erkannt und installiert aber nur um es als ein externes Laufwerk zu betreiben. Jetzt müssen noch die adb Treiber für das Tab instlliert werden damit du auf das systeminere zugreifen kannst.

    Wird das Tab vom Pda.net tool erkannt? Ist der Debug-Modus bei dir aktiviert?

    Wenn du den Debug-Modus deativierst kannst du ganznorman auf die int.SD und die ext.SD zugreifen. Der Debug-Modus ist nur dafür da damit du über ein Terminal drauf zugreifen kannst (z.B. cmd)

    Gesendet von meinem GT-9100 mit der Android-Hilfe.de App
     
    Zuletzt bearbeitet: 08.08.2012
  5. renewehle, 08.08.2012 #5
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Ich habe die Software von Pda.net installiert und er sagt mir, dass ich die App auf dem Geraet installieren soll. Da gibt es auch eine Tablet App, aber damit kann ich nur WLAN und Bluetooth auswaehlen. Eine andere App wird mir auch nicht als Download angeboten.

    Den Debug-Modus hatte ich eingeschaltet.

    Gibt es noch eine alternative zur Pda.net Software? Ich dachte die ist nur fuer die Treiber da.
     
  6. mula125, 08.08.2012 #6
    mula125

    mula125 Android-Lexikon

    Beiträge:
    1,455
    Erhaltene Danke:
    276
    Registriert seit:
    13.02.2010
    Du brauchst die pda.net app aus dem Martet nicht. Das tool ist so zu sagen ein universal tool für den Debug-Modus.

    Google mal nach adb Treibern für dein Tab, eventuel gibts welche vom Herstaller direkt.

    Meldet Pda.net unten rechts bei der Uhr im PC dass ein Gerät erkannt wird?

    Gesendet von meinem GT-I9100 mit der Android-Hilfe.de App
     
  7. renewehle, 08.08.2012 #7
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Das Programm ist in der Taskleiste und da steht "PDAnet is ready to Connet."

    Wenn ich mittels Doppelklick Verbinden moechte, kommt eine Box mit der Meldung: Please start PdaNet on your phone and enable USB Tether Mode.
     
  8. mula125, 08.08.2012 #8
    mula125

    mula125 Android-Lexikon

    Beiträge:
    1,455
    Erhaltene Danke:
    276
    Registriert seit:
    13.02.2010
    Ok, dein Tab wird vom Pda.net erkannt. Das ist schon mal gut. :thumbup: Jetzt musst du ein script finden mit dem es geht. Probier den script mal, hab den mal hochgeladen:

    http://db.tt/kFKpodFt

    Lass aber beim modden das Display mal an und stell das Display timeout auf 30min.

    Gesendet von meinem GT-9100 mit der Android-Hilfe.de App
     
  9. renewehle, 09.08.2012 #9
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Wenn ich das Script starte und im Auswahlmenu den Punkt 1 auswaehle, kommt wieder nur diese Meldung:

    Code:
    Running Connection Test
     - Make sure you have only one device listed. (EX: 0123456789ABCDEF)
    '
    * daemon not running. starting it now *
    * daemon started successfully *
    List of devices attached
    
    Done.
    Drücken Sie eine beliebige Taste . . .
    
    Er scheint das Geraet nicht zu finden, aber warum?

    Der ursprüngliche Beitrag von 03:27 Uhr wurde um 04:40 Uhr ergänzt:

    Ich habe es jetzt noch anders gemacht.

    Zuerst habe ich das Android SDK installiert. Wenn ich mittels CMD den Aufruf
    Code:
    adb devices
    gestartet habe, konnte er mein Geraet finden!

    Aus dem Grund habe ich die Dateien von dem Tasselhof-RootScript-MOD genommen und in das SDK Verzeichnis kopiert, dabei die bestehenden Dateien NICHT ueberschrieben. Jetzt konnte ich das Script starten und den Root Vorgang abschliesen.

    Ob ich wirklich Root habe, werden wir bald sehen :)
     
  10. renewehle, 09.08.2012 #10
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Zu frueh gefreut, es hat leider nicht geklappt.

    Er bekommt zwar die GeraeteID nun angezeigt, wenn ich aber den Menupunkt 2 im Script starte. (Verify Tablet is ROOT Capable (with this script)), dann erhalte ich diese Info:

    Code:
    Verifying ADB can access ROOT
    '
    adbd cannot run as root in production builds
    '
    **********************************************************
    If you see: "adbd cannot run as root in production builds"
     - this script WILL NOT work
    '
    If you see: "restarting adbd as root"
     - proceed to option 3
    '
    If you see: "adbd is already running as root"
     - proceed to option 3
    **********************************************************
    '
    Done.
    Drücken Sie eine beliebige Taste . . .
    Er kann demnach leider weiterhin das Rooten nicht ausfuehren.
     
  11. mula125, 09.08.2012 #11
    mula125

    mula125 Android-Lexikon

    Beiträge:
    1,455
    Erhaltene Danke:
    276
    Registriert seit:
    13.02.2010
    Hmm... da bin ich auch grad überfragt. Dann muss es eine andere Möglichkeit geben!? Bin grad mit meinem Latein am ende..:(

    Gesendet von meinem GT-I9100 mit der Android-Hilfe.de App
     
  12. renewehle, 20.08.2012 #12
    renewehle

    renewehle Threadstarter Neuer Benutzer

    Beiträge:
    19
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2010
    Hast Du sonst noch Ideen oder Anregungen zum Testen? Ich bin weiter bereit Risiko einzugehen :)
     

Diese Seite empfehlen