1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Wireless Tether for Root Users - Nun für Samsung Galaxy

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy" wurde erstellt von harry_m, 02.10.2009.

  1. harry_m, 02.10.2009 #1
    harry_m

    harry_m Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    13
    Registriert seit:
    21.09.2009
    Hallo!

    "Wireless Tether for Root Users" ist nun auch für das Samsung Galaxy erhältlich:

    Downloads - android-wifi-tether - Project Hosting on Google Code

    Es MUSS ein Kernel mit netfilter/iptables-Support installiert sein!
    Funktioniert natürlich nur auf gerooteten Geräten (su-Binary in /system/bin/su).
    Mehrere Custom-ROMs bringen schon alles mit was nötig dazu ist.


    Besonderen Dank geht hier auch an Modaco und Drakaz - ohne die das nicht möglich gewesen wäre (ich selbst besitze kein Galaxy).

    Viel Spaß!

    Und nicht vergessen ... unterstützt Opensource-Software! ;)

    Harry
     
    Zuletzt bearbeitet: 02.10.2009
    simi19273, Melkor und Gregor haben sich bedankt.
  2. Gregor, 02.10.2009 #2
    Gregor

    Gregor Fortgeschrittenes Mitglied

    Beiträge:
    442
    Erhaltene Danke:
    56
    Registriert seit:
    31.07.2009
    Hallo Harry,

    damit das funktioniert, müsste das Galaxy doch mit ad-hoc Netzwerken zusammenarbeiten. Sehe ich das richtig?
    Ich würde gerne mein Handy die Leitung meines verkabelten Rechners nutzen lassen, deshalb die Frage.

    lg
     
  3. harry_m, 02.10.2009 #3
    harry_m

    harry_m Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    13
    Registriert seit:
    21.09.2009
    Nun ja, ohne Root-Rechte geht vermutlich einmal gar nichts!

    Du willst also mit deinem Galaxy einem Ad-Hoc-Netzwerk beitreten? Prinzipiell würde ich schon sagen, dass das mit einem gerooteten Gerät funktioniert. Für das G1 gibt es einen Client dafür:

    http://moss.csc.ncsu.edu/~mueller/rt/rt09/readings/projects/g3/

    Prinzipiell bring man so das Galaxy in den Ad-Hoc-Modus - so oder so ähnlich:

    * Zuerst Wifi über Settings deaktivieren.

    * Wifi-Kernel-Modul neu laden (unbedingt das busybox insmod verwenden):
    Code:
    insmod /system/libmodules/bcm4325.ko firmware_path=/etc/rtecdc.bin nvram_path=/etc/nvram.txt
    
    * Etwas warten, bis das Interface hochkommt. (das busybox ifconfig verwenden, sonst siehst du es nicht.)

    * Mit iwconfig konfigurieren (dazu gibt es sicher eine Anleitung im Internetz).

    Code:
    iwconfig eth0 mode ad-hoc
    usw.
    
    Hier ist ein Beitrag, der mir auch geholfen hat:
    http://www.android-hilfe.de/root-hacking-modding-fuer-samsung-galaxy/6522-ad-hoc-wifi-4.html

    Und ja ... wie gesagt ... ist natürlich alles nur "Hören-Sagen" - habe ja selbst kein Galaxy ;-)

    Viel Glück.
     
  4. Gregor, 02.10.2009 #4
    Gregor

    Gregor Fortgeschrittenes Mitglied

    Beiträge:
    442
    Erhaltene Danke:
    56
    Registriert seit:
    31.07.2009
    Hallo Harry,

    zunächst mal vielen Dank für die gute Arbeit. Ich habe zwar root, aber bisher nur das normale rom drauf. Kann dein Prog also mangels netfilter bisher nicht probieren. Mache mich da aber am WE mal ran. (Bin Linux Neuling, aber learning by doing hilft ja Wunder)

    Ich gebe dann gerne mal Rückmeldung.

    Leider haben die meisten Leute ja ein Infrastructure Netzwerk stehen und brauchen also keine AdHoc Lösung. Deswegen interessieren sich wohl nicht viele dafür. (Nen Router ist ja billig)
    Ich kann hier auf der Arbeit aber nicht einfach nen Router ins Netzwerk einhängen.
     
  5. scobby, 02.10.2009 #5
    scobby

    scobby Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    9
    Registriert seit:
    08.09.2009
    Phone:
    HTC Desire
    Also bei mir lief es, hatte das Modaco Rom drauf (mit netfilter und swap)
    musste nur iptables-binary nach /bin/system kopieren dann lief es. Musste nix mit insmod oder iwconfig inner console rumfummeln.
    Einfach Wireless Teather starten, root rechte erlauben und auf dieses Wlan Symbol klickn.
    lg scobby
     
  6. harry_m, 02.10.2009 #6
    harry_m

    harry_m Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    13
    Registriert seit:
    21.09.2009
    Also ... das nachträgliche Installieren der iptables-binary ist nicht mehr notwendig. Wird jetzt von dem Programm erledigt.
     
  7. Tom1968, 03.10.2009 #7
    Tom1968

    Tom1968 Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    21.08.2009
    funktioniert ja super nur frag ich mich grad
    wie bekomm ich das dann wieder ausgeschalten
    selbst wenn das telefon aus ist
    zeigts mir das galaxytether network an
     
  8. harry_m, 03.10.2009 #8
    harry_m

    harry_m Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    13
    Registriert seit:
    21.09.2009
    Naja, da solltest du ja schon selbst die Ursache dieses Problems eingrenzen können. Manche Betriebsysteme (oder auch Wlan-Konfigurationswerkzeuge) zeigen Ad-Hoc-Netzwerke immernoch an, obwohl es die gar nicht mehr gibt.

    Beispiel: Verwende ich das Zero-Config-Tool von WinXP auf meinem Laptop, dann habe ich dasselbe Problem. Habe ich das Intel-eingene Tool in Verwendung, dann verschwinden plötzlich auch die Ad-Hoc-Netzwerke wieder.

    Beschwerden nimmt gerne der Hersteller deines Betriebsystems und/oder Treibers entgegen.
     
    Tom1968 bedankt sich.
  9. Tom1968, 03.10.2009 #9
    Tom1968

    Tom1968 Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    21.08.2009
    da ich mit windows bordmitteln arbeit
    kann das durchaus die ursache sein
    werd mich da mal damit befassen
     
  10. weby, 07.10.2009 #10
    weby

    weby Fortgeschrittenes Mitglied

    Beiträge:
    338
    Erhaltene Danke:
    31
    Registriert seit:
    24.08.2009
    Phone:
    HTC Sensation
    Wo ist der Fehler ?

    Habs Modaco drauf und das App installiert (1.60), mit dem Netbook kann ich auch aufs Galaxy verbinden, nur komme ich nicht ins Internet

    Wenn ich mit dem G1 Wlan´s scanne finde ich das Galaxy gar nicht.

    Was mache ich falsch ?

    LG. Weby
     
  11. zaga, 07.10.2009 #11
    zaga

    zaga Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    26.08.2009
    Hallo @all,

    also ich frage mich auch was ich falsch mache. Ich habe extra Modaco´ROM installiert und "Wireless Theter" läuft, startet auch ohne Probs. Allerdings steht unten wo die Verbindungsgeschwindigkeit stehen müsste jeweils 0,0. Im Router wo ich den Access Point Modus aktiviert habe, kann ich die MAC Adresse von meinem Galaxy sehen. Das steht bei verbundenen Clienten.

    Aber irgendeine verbindung weder ins Netz noch zum Galaxy habe ich nicht hinbekommen. Als Vetrag habe ich den Complete Tarif mit Internet Flat von T-Mobile.

    Es wäre echt super wenn jemand mir einen Zaunpfahl reichen könnte.

    Das Forum ist trotz allem der Hit und danke auch dafür an alle die dazu beitragen
     
  12. ADie, 18.10.2009 #12
    ADie

    ADie Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    18.09.2009
    Jau, genau des hab ich auch. Allerdings musst Du einfach mal einen Blick ins log werfen. Da steht, dass er die Datei /system/lib/modules/wlan.ko nicht finden kann.

    Und die such ich jetzt auch. Falls jemand weiß, wo man die herbekommen kann, bitte ich um Nachricht.
     
  13. herrgrins, 18.10.2009 #13
    herrgrins

    herrgrins Erfahrener Benutzer

    Beiträge:
    195
    Erhaltene Danke:
    11
    Registriert seit:
    24.07.2009
    Hi!
    ich habe ja das GalaxyHero drauf und habs heute mal probiert.
    Also das wifi tethering geht ohne Probleme. Anklicken,kurz warten und schon kann ich am Pc ins Internet.Der Datenzähler läuft auch mit.
    Eine Verschlüsselung habe ich aber nocht nicht probiert.

    mfg
     
    zaga bedankt sich.
  14. rotateh, 18.10.2009 #14
    rotateh

    rotateh Android-Experte

    Beiträge:
    504
    Erhaltene Danke:
    21
    Registriert seit:
    30.07.2009
    hab galaxo getestet ... mit verschlüsselung ... alles kein problem läuft ohne probleme ... click and surf
     
  15. zaga, 18.10.2009 #15
    zaga

    zaga Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    26.08.2009
    Hallo @all, mit dem neuen Galaxo-Rom klappt es jetzt bei mir auch. Ebenfalls ohne verschlüsselung. Hatte noch nicht die Gelegenheit. Aber eigentlich sowie so sinnlos für mich da ich nur UMTS auf dem Balkon habe (müsste das Telefon irgendwie auf dem Balkon positionieren) und in der Wohnung DSL schneller ist. Aber hauptsache ist es klappt :).

    Was allerdings noch viel wichtiger ist und es im Moment nicht benutzbar macht (für mich) ist das keine Ports weitergelitet/freigeschaltet werden können.


    mfg zaga
     
  16. tobi56, 19.10.2009 #16
    tobi56

    tobi56 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    1
    Registriert seit:
    29.07.2009
    sollte mit eins zwei iptables einträgen hinzukriegen sein.. ist allerdings wahrscheinlich völlig nutzlos, da die meisten Netzbetreiber ihren Telefonen keine öffentlichen IP's geben sondern NATten
     
    zaga bedankt sich.
  17. zaga, 20.10.2009 #17
    zaga

    zaga Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    26.08.2009
    Ganz verstanden habe ich das jetzt nicht ? Wenn ich über Was-ist-meine-Ip schaue kommt irgendeine 83.xxx.xxx.xxx nummer die sieht aber ziemlich wie eine Ip aus ? Oder habe ich garkeine Ahnung ?
     
  18. rotateh, 20.10.2009 #18
    rotateh

    rotateh Android-Experte

    Beiträge:
    504
    Erhaltene Danke:
    21
    Registriert seit:
    30.07.2009
    "NATen" is so zuverstehen das das mobilfunknetzwerk wie ein router fungiert ... d.h. es werden wahrscheinlich eh nicht alle ports freigegeben... du hast nach außen natürlich ne normale ip addresse bist aber nur teil des "funknetzwerkes" vom provider
     
  19. zaga, 20.10.2009 #19
    zaga

    zaga Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    26.08.2009
    OK, danke für deine Antwort/Hilfe. Gibt es denn eine Möglichkeit zu prüfen/sehen welche Portbereich das ist. Kann irgendwo her herausfinden ob und welche Ports bei T-Mobile unbenutzbar sind ? Unter "google" habe ich irgendwie nichts gefunden.
     
  20. ADie, 26.10.2009 #20
    ADie

    ADie Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    18.09.2009
    Ich will hier nicht mobben, aber da werden zwei Dinge durcheinandergeworfen. NAT heißt Network ADDRESS translation und hat mit Portweiterleitung erstmal nichts zu tun. Richtig ist, dass u.U. der source port für outgoing packets verändert wird, isbesondere wenn der Router von mehreren Clients für ausgehenden Datenverkehr genutzt wird. Nur wenn mehrere Clients Datenpalete mit demselben source port senden, muss man den souce port überhaupt verändern.

    Portweiterleitung braucht man normalweise nur für eingehende Verbindungen, z.B. um alle Datenpakete mit dem destination port 80 auf einen Webserver zu lenken.

    Und was zaga haben will, geht wahrscheinlich gar nicht. Ich nehme mal an, dass es ihn stört, dass er bestimmte Datenpakete von T-Möbel gar nicht bekommt, z.B. Alles was mit Instant Messaging zu tun hat. Aber das wird ihm sowieso vom T-Möbel-Router schon gar nicht zugestellt, also gibts auch nix, was er auf seinem Android-Handy weiterleiten könnte.

    Da hilft nur eins: Wechsel zu einem Anbieter, der solche schmutzigen Tricks nicht macht, z.B. O2.
     

Diese Seite empfehlen