1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

WLAN VNC dauerhaft

Dieses Thema im Forum "Android Allgemein" wurde erstellt von guenter49xx, 28.01.2012.

  1. guenter49xx, 28.01.2012 #1
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Hallo,
    würde ein Android-Tablet gern als Monitor zu meiner Haussteuerung verwenden. Das funktioniert auch recht gut. Leider schaltet irgendetwas nach ca. einer Stunde die Verbindung ab. Fehlermeldung:
    "VNC connection failed! null"
    Die zugänglichen Energieoptionen habe ich dauerhaft eingestellt.
    Ich bin mir auch nicht sicher, ob ANDROID oder VNC die Ursache ist.
    Wenn ich das gleiche über einen Laptop versuche, bleibt die Verbindung bestehen.
    Freue mich über jede gute Idee
    Gruß
    Günter
     
  2. DeAndi, 28.01.2012 #2
    DeAndi

    DeAndi Android-Lexikon

    Beiträge:
    1,201
    Erhaltene Danke:
    135
    Registriert seit:
    30.09.2011
    probiere es mal mit einer statischen IP.
    Manche Device haben Probleme mit der Lease Time des DHCP.
     
  3. guenter49xx, 28.01.2012 #3
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Hallo DeAndi,
    danke für die schnelle Antwort. Zwei Anmerkungen dazu.
    Den Begriff "Lease Time" kann ich nicht einordnen. Vielleicht habe ich das Problem aber auch zu oberflächlich beschrieben.
    Meine Verbindung besteht innerhalb des LAN; also nicht über das WWW. Der VNC Client in meinem Android-Tablet spricht den VNC-Server auf einem PC im LAN unter XP mit dem DSN an.
    Muss ich deinen Beitrag so verstehen, dass ich dem Android-Device eine feste IP geben soll? Wo kann man die einstellen? Bei der WLAN-Konfiguration hab ich dazu noch nichts gesehen.
     
  4. mizch, 28.01.2012 #4
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Lease Time: Deine Adresse wird über DHCP vergeben, der Router teilt Dir (Deinem Handy) eine IP-Adresse zu. Dazu gehört eine bestimmte Gültigkeitsdauer, die Lease Time. Es ist Sache des Handys, die zu erneuern (und das tut es auch), somit brauchst Du oder VNC sich nicht darum zu kümmern.

    Zusammenfassend: Weder wird die Lease Time im unteren Stundenbereich liegen (so dass sich daraus der von Dir geschilderte Abbruch nach einer Stunde ergäbe) noch bekäme die Anwendungsschicht (wie VNC) in diesem Fall etwas mit, weil sich das Handy schon selbst darum kümmern würde. Die Lease Time ist nicht Dein Problem.
     
  5. DeAndi, 28.01.2012 #5
    DeAndi

    DeAndi Android-Lexikon

    Beiträge:
    1,201
    Erhaltene Danke:
    135
    Registriert seit:
    30.09.2011
    Dein statische IP Adresse wird in den Wlan Einstellenlungen eingestellt, indem du auf deinen AP drückst bis ein Kontexmenu kommt. Netzwerk ändern und da die Statische Adresse einfügst.
     
    Zuletzt bearbeitet: 28.01.2012
  6. mizch, 28.01.2012 #6
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Schon richtig. Nur läuft die Lease Time normalerweise nicht ab, sondern wird vom DHCP-Client im Fon automatisch verlängert (zur Halbzeit), solange Verbindung besteht - was Dir unbekannt zu sein scheint, sonst wäre Deine Antwort sinnlos.

    Der VNC und jede andere Verbindung hat mit der Lease Time nichts zu schaffen und bekommt nichts davon mit. Aber das schrieb ich schon.
     
  7. DeAndi, 28.01.2012 #7
    DeAndi

    DeAndi Android-Lexikon

    Beiträge:
    1,201
    Erhaltene Danke:
    135
    Registriert seit:
    30.09.2011
    Bleib locker und entkrampff dich wieder, wir wollen helfen und hier kein Ring frei geben.
    Ich weiß schon von was ich schreibe, hab aber keine Lust mich mit dir zu brügeln, sorry such dir jemand anderer !
     
  8. mizch, 28.01.2012 #8
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Was ist jetzt das? Ich habe begründet, warum es die Lease Time nicht sein kann. Würde es Dir was ausmachen, einfach bei der Sache zu bleiben? Das jetzt ist doch unnötig.
     
  9. DeAndi, 28.01.2012 #9
    DeAndi

    DeAndi Android-Lexikon

    Beiträge:
    1,201
    Erhaltene Danke:
    135
    Registriert seit:
    30.09.2011
    @mizch
    schaue dir folgenden Link mal an und da den Abschnitt DHCP-Refresh,
    Dynamic Host Configuration Protocol.

    Das bedeutet das wen die Lease Time im Router auf unendlich gestellt wird es keine Probleme mit DHCP geben kann (bei manchen Device ein Problem).

    Das ganze kann natürlich umgangen werden wen man eine Statische IP vergibt, da DHCP für das Device außen vor ist.

    Bevor man die Statische IP vergibt sollte man fest stellen in welchem Range der DHCP die Adressen vergiebt.

    @guenter49xx
    welchen Router (Herstellername und Typ) verwendest du ?
     
  10. mizch, 28.01.2012 #10
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Ich erspare es den Lesern, meine Antwort in fett zu geben. Lies mal den Abschnitt DHCP-Refresh durch (im selben Link) und Du wirst meine Angaben bestätigt finden. Es gibt auch keine Probleme, wenn die Lease Time nicht auf unendlich gestellt wird (das ist eh neu), denn sie wird zur Halbzeit erneuert.
     
  11. DeAndi, 28.01.2012 #11
    DeAndi

    DeAndi Android-Lexikon

    Beiträge:
    1,201
    Erhaltene Danke:
    135
    Registriert seit:
    30.09.2011
    Hmm ich glaube du hast irgendwie ein großes Problem !
    Ich klinke mich hiermit aus auf so ein Nivau muss ich mich nicht begeben.
    Ich habe dazu alles geschrieben !
     
  12. guenter49xx, 29.01.2012 #12
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Hallo euch beiden,
    bin ja erschlagen von so viel Interesse. Werde jeder Spur nachgehen.
    Mein Router ist eine FritzBoxFon 7270.
    Habe es nicht geschafft, die IP an meinen Devices
    1. Samsung Galaxy S2, Android 2.3
    2. Archos 7, Android 1.6
    die IP einzustellen.
    Bekomme die IP zwar angezeigt, komm aber nicht in einen Änderungsdialog.
    Bei kurzem Druck auf den AP kommt die Anzeige mit der Auswahlmöglichkeit Entfernen und Abbruch.
    Bei langem Tastendruck nur die Auswahl Entfernen und Abbruch.

    Bei weitern Tests ist mir aufgefallen, das die Zeit bis zur Fehlermeldung sich durch Tastendrücke im VNC-Bildschirm verlängert.
    Das heißt, die Stunde zählt erst ab der letzten Aktivität.
    Vielleicht macht das eine Aussage zur Ursache?
     
  13. guenter49xx, 29.01.2012 #13
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Hab den Dialog zur statischen IP nun doch gefunden und teste gerade die Stunde, melde mich danach wieder.
     
  14. maniac103, 29.01.2012 #14
    maniac103

    maniac103 Android-Lexikon

    Beiträge:
    1,237
    Erhaltene Danke:
    1,157
    Registriert seit:
    24.01.2011
    Wenn DHCP das Problem wäre, dann ginge gar kein Netzwerk. Zur Lease Time hat mizch schon alles gesagt. Ich glaube eher an einen Inactivity-Timer im VNC-Server, auch angesichts des Fehlerbildes.

    Sent from my Defy
     
  15. guenter49xx, 29.01.2012 #15
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Leider tritt der Fehler auch bei fester IP auf. Schade, werde aber weiter alles testen. Es gibt ja die Pferde die vor der Apotheke k......
    Zu der Idee von maniac103 habe ich zu Beginn schon einen Test beschrieben:
    "Wenn ich das gleiche über einen Laptop versuche, bleibt die Verbindung bestehen."
    Trotzdem Danke.
    Inactivity-Timer scheint aber die richtige Spur zu sein, nur muss das dann eine Funktion im Client (Android-Device) sein.
     
  16. mizch, 29.01.2012 #16
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Das war auch nicht anders zu erwarten. Ich denke auch, dass VNC in ein Inaktivitäts-Timeout läuft.
     
  17. guenter49xx, 29.01.2012 #17
    guenter49xx

    guenter49xx Threadstarter Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    28.01.2012
    Hallo maniac103 auch wenn ich deinen Tip, wegen dem Test mit dem Laptop, nicht so ernst genommen habe, wollte ich doch allen Hinweisen nachgehen.
    Habe dann auch beim VNC-Server unter Connection die Option:
    Disconnect idle Clients after (seconds): 3600 gefunden. Diese Stunde kam mir dann doch sehr verdächtig vor. Habe den Wert auf 0 gesetzt.
    Bisher sind keine Unterbrechungen mehr erfolgt.
    Danke nochmal allen, die sich an der Diskussion beteiligt haben.
    Gruß
    Günter
     

Diese Seite empfehlen