USB Debugging Mode

  • 10 Antworten
  • Neuester Beitrag
Diskutiere USB Debugging Mode im a-rival PAD Forum im Bereich Weitere Hersteller.
D

DieLinde

Neues Mitglied
Hallo,
ich hab mir das 83er Pad von meiner Freundin ausgeliehen, um ein bisschen rumzuprogrammieren. Das wäre auch noch nicht das Problem, das Problem ist dass das Gerät nicht als mögliche Debug Device erkannt wird:

Nun habe ich folgende Anleitung gefunden (Google-Market installieren Thread):

1. Geraetemanager oeffnen (wenn das "Android Eclair" noch/schon drin ist -> rauswerfen)
2. Oben auf "Aktion" -> "Legacyhardware hinzufuegen"
3. Dann manuell das Verzeichnis mit den Google-USB-Treibern auswaehlen (wo auch immer das SDK installiert wurde, das Verzeichnis heisst "...\google_usb_driver\".
4. Auf der Liste der verfuegbaren Geraete nehmen wir dann "ADB Testing Interface". Bestaetigen bis ihr wieder im Geraetemanager seid. Da erscheint nun immer noch ein gelbes Ausrufezeichen!
5. Jetzt das Pad anstecken. Wenn er nach einem Treiber fragt, gehen wir wieder in das google-usb-driver-Verzeichnis und waehlen wieder das "ADB Testing Interface" aus!
6. Und nun sollte ein weiterer EIntrag "ADB Testing Interface" ohne Fehlermeldung erscheinen. Wenn das nicht gleich so sein sollte, einfach das Pad ein paarmal aus- und einstecken. Beim zweiten Mal hatte ich dann einen connect. Darauf achten, dass auf dem Pad das "USB-Debugging" aktiviert ist!
Mein Problem liegt jetzt schon zwischen 2 und 3. Die "Android Eclair"-Treiber deinstallier ich. Dann geh ich auf Legacyhardware, nur dann muss ich erst eine Device auswählen. Das sieht so aus:



Das nächste was kommt ist:


Und zum Schluss sieht mein Manager so aus:

Das unbekannte Gerät war vorher noch nicht da.

Was ich jetzt genau wissen will ist, was ich in diesem Schritt von 2 auf 3 genau machen muss.

Danke schonmal fürs durchlesen

Linde
 
Metschwein

Metschwein

Stammgast
Hi Linde,
kanst ja mal die von OnDroid in post #109 beschriebene vorgehensweise probieren.
 
D

DieLinde

Neues Mitglied
Grüß Gott Metschwein,

ich hab mir den Post nochmal angesehen aber ich komm dabei auch nicht weiter, as Problem ist dieser kleine Absatz:

Man muss das zip-Archive entpacken und dann den Ordner mit dem Treiber manuell auswählen. Den Rest erledigt Windows. Ich weiß nicht, ob die Treiberinstallation notwendig ist, aber es ist schöner keine Fragezeichen im Geräte-Manager zu haben ;-)
Ich hab die Treiber für Windows auf dem PC, aber wo soll ich "den Ordner mit dem Treiber manuell auswählen".

Nur noch kurz, das mit USB-Sticks und so weiter funktioniert einwandfrei, darauf kann ich zugreifen. Problem ist bloß mein Eclipse erkennt das Tablet nicht..

Edit:
Danke auch an Elchpad
Die Treiber hab ich auch drauf:


Grüße
Linde
 
Elchpad83

Elchpad83

Stammgast
Hast Du auch unter Einstellungen->Anwendungen->Entwicklung->USB-Debugging angehakt ?

Gruß
Elchpad83
 
D

DieLinde

Neues Mitglied
ja USB-Debugging ist eingeschaltet!
 
Elchpad83

Elchpad83

Stammgast
Zieh mal das USB-Kabel vom aktuellen Anschluss am PC ab und stecks in einen anderen Port, dann müssten sich die USB-Treiber automatisch installieren...

Gruß Elchpad83
 
D

DieLinde

Neues Mitglied
hmm anderer Anschluss, ich kann drauf zugreifen, hab es also als Wechseldatenträge im Computer, aber in Eclipse das gleiche Bild
 
Elchpad83

Elchpad83

Stammgast
Also beim SDK kann ich Dir jetzt direkt nicht weiterhelfen.....

Schau doch mal auf der Android-Seite (oben über den Link), da ist es erklärt

und falls Du die Treiber nochmal suchst:

C:\....\android-sdk_r09-windows\android-sdk-windows\google-usb_driver

Gruß Elchpad83

und viel Spaß beim rumprogrammieren.....:cool2:

edit: hier ist die Einführung: http://developer.android.com/guide/developing/index.html
 
Zuletzt bearbeitet:
D

DieLinde

Neues Mitglied
ok, danke trotzdem, sollte ich noch eine Lösung finden werde ich sie hier posten!
Falls noch jemand Vorschläge hat, wäre ich auch dankbar!
 
D

DieLinde

Neues Mitglied
So nochmal eine Rückmeldung und Entschuldigung schonaml für den Doppelpost.

Ich habe jetzt auf meinem Laptop alles installiert und dieser läuft unter Windows 7 32-Bit.. Ich habe die Treiber installiert und alles hat funktioniert. Auch debuggen konnte ich auf dem APAD ohne Probleme.

Wieder auf meinem Desktop-PC(Windows7 64Bit) angelangt habe ich Eclipse neu installiert SDK und Plugin neu installiert und wollte die Treiber für das Android Eclair Gerät auch per Update installieren, aber es kommt immer der Fehler, das keine Treiber gefunden wurden.


Das heißt für mich, ich habe die falschen Treiber.
Ich habe die Treiber von diesem Link von OnDroid.

Weiß jemand ob es da andere für Windows 7(64Bit) gibt? Die von Google funktionieren leider auch nicht.

Grüße

Linde