1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. ladyanne, 26.02.2012 #1
    ladyanne

    ladyanne Threadstarter Neuer Benutzer

    Hallo,
    seit Tagen versuche ich eine .apk mithilfe von Eclipse auf einem Emulator zu installieren. In die cmd.exe gebe ich die entsprechenden Anweisungen ein, die .apk liegt im selben Ordner wie die abd. Die Verbindung klappt auch, allerdings erscheint nach der Eingabe der zu ladenden Datei ein ellenlanger Debug-Bericht, mit dem ich nichts anfangen kann. Zur besseren Verständigung habe ich einen Screenshot angehängt. Kann mir da jemand weiterhelfen?
    Im Emulator habe ich natürlich die unbekannten Quellen zugelassen.
    Wenn ich dieselbe Datei in YouWave öffne, erscheint der Hinweis "Shoot the Apple has ARM native code and is not supported". Kann es daran liegen?
    Es wäre schön, wenn mir jemand helfen könnte.
    Danke -ladyanne
     

    Anhänge:

  2. snowman2, 26.02.2012 #2
    snowman2

    snowman2 Erfahrener Benutzer

    Ich wüde sagen, du machst da was gundlegend falsch.

    Ich muss nichts mit cmd.exe oder DOS-Prompt machen. Ich klicke einfach nur in Eclipse auf das Icon-Run und es wird automatisch der Emulator gestartet und meine App gestartet.

    Schau dir nohmal eine Tutorial zum installieren vom Android SDK und Eclipse an. Wenn du danach vorgehst sollte es bei dir auch so klappen.
     
  3. sixi, 27.02.2012 #3
    sixi

    sixi Erfahrener Benutzer

    :laugh: das ist kein "ellenlanger Debugbericht" sondern die Ausgabe, welche Befehle bzw. Parameter es für ADB gibt :)

    adb -e install meine.apk
    installiert die APK im Emulator. Oder aber du installierst es direkt aus Eclipse heraus, wie snowman2 sagt ;)
     
  4. ladyanne, 27.02.2012 #4
    ladyanne

    ladyanne Threadstarter Neuer Benutzer

    Hallo,
    ich konnte das Problem teilweise lösen.
    Wenn über Adobe Air eine Android-App für einen Emulator entwickelt wird, muss bei den Android-Einstellungen "für Emulator" angeklickt werden, sonst geht gar nichts.
    Ich habe nun dort eine kleine App gemacht, die nach der Installation (über cmd) im Emulator erscheint.
    Es gibt jetzt aber ein neues Problem, dafür mache ich aber einen neuen Thread auf.
    Euch Beiden trotzdem herzlichen Dank.
    ladyanne
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Android App mit Raspberry Pi über Bluetooth verbinden Android App Entwicklung Samstag um 14:20 Uhr
[OFFEN] APP Baukasten oder individuell? Android App Entwicklung 10.11.2017
[OFFEN] Feedback Text für die App auf Server Hochladen Android App Entwicklung 28.10.2017
[OFFEN] Android app selber entwickeln mit Bluetooth Android App Entwicklung 13.10.2017
[ERLEDIGET] App über href starten Android App Entwicklung 28.09.2017
[OFFEN] Kostenpflichtige App für Beta-Test hochladen Android App Entwicklung 13.09.2017
[OFFEN] App startet nicht... Android App Entwicklung 10.09.2017
[OFFEN] Sind Notifications in einer Webview App möglich? Android App Entwicklung 10.09.2017
[OFFEN] Möchte eine App für Entrümpelungen entwickeln. Android App Entwicklung 08.09.2017
Du betrachtest das Thema "App nicht im Emulator" im Forum "Android App Entwicklung",