Emulator startet AVD nicht

  • 4 Antworten
  • Neuester Beitrag
Diskutiere Emulator startet AVD nicht im Android App Entwicklung im Bereich Betriebssysteme & Apps.
W

WasserDragoon

Fortgeschrittenes Mitglied
Hallo zusammen,

habe nun dank Anleitung auf YouTube gefunden, wie man ein Custom ROM im Emulator zum Laufen bekommen sollte: YouTube - Custom rom on emulator

Nun habe ich das nach dieser Anleitung gemacht (in Anbetracht, dass ich Linux Ubuntu 10.10 statt Windows XP verwende). Also ein Nandroid Backup gemacht, die system.img in das entsprechende Verzeichnis kopiert und die AVD mit emulator -avd sgs gestartet (Tools-Ordner der SDK befindet sich in $PATH).

Nun taucht der Emulator auf, habe mich schon gefreut. Der Unterstrich hinter dem Schriftzug "ANDROID" blinkt eine Weile, ist dann weg und es passiert nichts mehr... Warte nun schon seit ca. 4-5 Minuten.

Was läuft da nun falsch? Eclipse lass ich übrigens nicht nebenher laufen, die AVD habe ich über tools/android erstellen lassen - Dafür brauch ich ja schließlich kein Eclipse...

Mit freundlichen Grüßen
Danny.

EDIT: Sorry, hab einige Daten vergessen mit anzugeben. Es handelt sich um mein Samsung Galaxy S I9000 mit Android 2.2.1 (im AVD Manager wurde beim Erstellen der AVD Android 2.2 ausgewählt - liegt es vielleicht daran?)

EDIT2: Okay, die Mühe scheint unnötig zu sein. ClockworkMod scheint ein für den Emulator unbrauchbares/inkompatibles System-Image zu erstellen. Ich werde die Änderungen, die ich machen will einfach mit vorigen Backups direkt auf dem Smartphone machen.
 
Zuletzt bearbeitet von einem Moderator:
ramdroid

ramdroid

Stammgast
Kann mir nicht vorstellen dass das funktioniert, da das System Image ja für das entsprechende Gerät kompiliert wurde.

Du kannst aber den Quellcode selbst kompilieren und als Ziel den Emulator angeben. Am Schluß die system.img in das entsprechende Verzeichnis kopieren. Hatte das auch irgendwann mal probiert und mit einer kleiner Veränderung getestet --> hat auch funktioniert.

Auf die gleiche Weise könnte man z.B. auch ein CyanogenMod im Emulator laufen lassen.
 
W

WasserDragoon

Fortgeschrittenes Mitglied
Danke für die Antwort.
Ich denke ich werde das die Tage mal testen...
Kannst du mir evtl. zum selbst kompilieren nähere Informationen geben?

Weiß jemand zufällig welche Dateien ich in der TouchWiz30Launcher.apk bearbeiten muss, um die Hintergrundtransparenz der App-Liste (Die bei Klick auf Menü unten rechts) zu ändern? Und eventuell, um die hässlichen iPhone-like Umrandungen zu entfernen?

Habe die apk mittel apktools bereits dekodiert...
 
Zuletzt bearbeitet:
W

WasserDragoon

Fortgeschrittenes Mitglied
Ich bin da etwas überfordert muss ich sagen, ich möchte mein Kitchen ROM lauffähig machen, nicht CM7 ;-)
Ich denke ich benötige nur eine vom Emulator unterstützte system.img meines Handysystems.

EDIT: Ich hab mich übrigens gegen einen Emulator entschieden, da mir die Geschwindigkeit einfach nicht ausreicht.
Da gehts doch leichter von der Hand mal eben das Kabel an PC/Laptop anzuschließen und die gemoddete APK draufspielen.

Fragt sich nun nur noch welche Datei/Zeile whatever ich bearbeiten muss, um die Hintergrundtransparenz des Menüs zu ändern und möglichst noch diese hässlichen iPhone mäßigen Umrandungen der Apps zu entfernen...

Sonst bin ich mit dem TW Launcher mehr als zufrieden und möchte deshalb nicht wechseln (mir sagen die von mir getesteten Launcher auch nicht zu)
 
Zuletzt bearbeitet:
Ähnliche Themen - Emulator startet AVD nicht Antworten Datum
10